Synthetixio/synthetix 软件分析报告

基础信息

项目名称:Synthetixio/synthetix

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1757301403352604672/1757301403621040128

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Axios 拒绝服务漏洞 拒绝服务 MPS-2021-30688 CVE-2021-3749 高危
marked 存在拒绝服务漏洞 ReDoS MPS-2021-37038 CVE-2022-21680 高危
marked 存在拒绝服务漏洞 过度严格的正则表达式 MPS-2021-37039 CVE-2022-21681 高危
adm-zip 路径遍历 MPS-2022-13529 高危
marked ReDoS MPS-2022-13864 中危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
follow-redirects 输入验证不恰当 MPS-2023-5153 CVE-2023-26159 高危
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
get-func-name 安全漏洞 ReDoS MPS-cyhe-l36p CVE-2023-43646 高危
tough-cookie 原型污染 MPS-esyq-56vx 中危
undici 信息泄露漏洞 MPS-g6am-4ry2 CVE-2023-45143 低危
browserify-sign 密码学签名的验证不恰当 MPS-gimb-o69n CVE-2023-46234 中危
protobuf.js 安全漏洞 原型污染 MPS-ql7z-axpv CVE-2023-36665 严重
Axios XSRF-TOKEN CSRF漏洞 侵犯隐私 MPS-v3q7-sjd2 CVE-2023-45857 高危
OpenZeppelin 安全漏洞 完整性检查值验证不恰当 MPS-xcrp-ys1b CVE-2023-34459 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
follow-redirects 1.15.2 1.15.4 间接依赖 强烈建议修复
axios 0.21.2 1.6.0 间接依赖 建议修复
protobufjs 6.11.4 7.2.4 间接依赖 建议修复
get-func-name 2.0.0 2.0.1 间接依赖 建议修复
adm-zip 0.4.16 0.5.2 间接依赖 建议修复
tough-cookie 2.5.0 4.1.3 间接依赖 建议修复
undici 5.20.0 5.26.2 间接依赖 可选修复
request 2.88.2 间接依赖 可选修复
browserify-sign 4.2.1 4.2.2 间接依赖 可选修复
marked 0.7.0 4.0.10 间接依赖 可选修复
openzeppelin-solidity 4.8.1 直接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 725
Apache-2.0 23
ISC 71
BSD-2-Clause 23
MPL-2.0 10
Unlicense 3
BSD 2
BSD-3-Clause 39
LGPL-3.0 23
CC0-1.0 3
CC-BY-3.0 1
CC-BY-4.0 1
GPL-3.0 1
0BSD 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
@ethersproject/abi 5.7.0 间接依赖 npm
source-map-support 0.5.21 间接依赖 npm
@ethersproject/sha2 5.7.0 间接依赖 npm
eslint-config-prettier 3.6.0 直接依赖 npm
cacheable-request 7.0.2 间接依赖 npm
buffer 5.7.1 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
@xtuc/long 4.2.2 间接依赖 npm
pkg-dir 5.0.0 间接依赖 npm
it-peekable 1.0.3 间接依赖 npm
electron-to-chromium 1.4.301 间接依赖 npm
find-up 2.1.0 间接依赖 npm
strip-bom 3.0.0 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
webpack-merge 5.8.0 间接依赖 npm
multiformats 9.9.0 间接依赖 npm
css-what 5.1.0 间接依赖 npm
has-bigints 1.0.2 间接依赖 npm
flatted 2.0.2 间接依赖 npm
immediate 3.2.3 间接依赖 npm
randomfill 1.0.4 间接依赖 npm
spawn-command 0.0.2-1 间接依赖 npm
mnemonist 0.38.5 间接依赖 npm
is-ip 3.1.0 间接依赖 npm
create-hmac 1.1.7 间接依赖 npm
through 2.3.8 间接依赖 npm
redeyed 2.1.1 间接依赖 npm
regexpp 3.2.0 间接依赖 npm
ethashjs 0.0.8 间接依赖 npm
chai 4.3.7 间接依赖 npm
retimer 3.0.0 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
varint 5.0.2 间接依赖 npm
envinfo 7.8.1 间接依赖 npm
ansi-escapes 4.3.2 间接依赖 npm
is-binary-path 2.1.0 间接依赖 npm
run-parallel 1.2.0 间接依赖 npm
lodash.isequal 4.5.0 间接依赖 npm
load-json-file 1.1.0 直接依赖 npm
proxy-from-env 1.1.0 直接依赖 npm
node-addon-api 2.0.2 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
interface-store 2.0.2 间接依赖 npm
strip-final-newline 2.0.0 间接依赖 npm
jest-docblock 21.2.0 间接依赖 npm
parse5-htmlparser2-tree-adapter 7.0.0 间接依赖 npm
highlightjs-solidity 2.0.6 间接依赖 npm
scrypt-js 3.0.1 间接依赖 npm
big-integer 1.6.36 间接依赖 npm
detect-indent 5.0.0 间接依赖 npm
browserify-des 1.0.2 间接依赖 npm
@gnosis.pm/safe-core-sdk-types 0.1.1 间接依赖 npm
@ensdomains/address-encoder 0.1.9 间接依赖 npm
verror 1.10.0 间接依赖 npm
eslint-plugin-import 2.22.0 直接依赖 npm
ms 2.1.3 间接依赖 npm
rimraf 2.6.3 间接依赖 npm
level 8.0.0 间接依赖 npm
uglify-js 3.15.2 间接依赖 npm
enhanced-resolve 5.12.0 间接依赖 npm
function.prototype.name 1.1.5 间接依赖 npm
renderkid 2.0.7 间接依赖 npm
strip-eof 1.0.0 直接依赖 npm
balanced-match 1.0.2 间接依赖 npm
request 2.88.2 间接依赖 npm
prettier 1.19.1 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
jsbn 0.1.1 间接依赖 npm
pbkdf2 3.1.2 间接依赖 npm
@sentry/hub 5.30.0 间接依赖 npm
busboy 1.6.0 间接依赖 npm
@types/bignumber.js 5.0.0 间接依赖 npm
is-string 1.0.7 间接依赖 npm
openzeppelin-solidity-2.3.0 npm:openzeppelin-solidity@2.3.0 直接依赖 npm
minimalistic-crypto-utils 1.0.1 间接依赖 npm
detect-port 1.3.0 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
is-regex 1.1.4 间接依赖 npm
tough-cookie 2.5.0 间接依赖 npm
is-electron 2.2.2 间接依赖 npm
multibase 0.6.1 间接依赖 npm
async 3.2.3 间接依赖 npm
solhint 3.3.7 直接依赖 npm
flat-cache 2.0.1 间接依赖 npm
recursive-readdir 2.2.3 间接依赖 npm
web3-utils 1.10.0 间接依赖 npm
browserslist 4.21.5 间接依赖 npm
ethereumjs-blockchain 4.0.4 间接依赖 npm
@nomiclabs/hardhat-web3 2.0.0 直接依赖 npm
ip-regex 4.3.0 间接依赖 npm
prepend-http 2.0.0 间接依赖 npm
eslint-config-standard 12.0.0 直接依赖 npm
at-least-node 1.0.0 间接依赖 npm
define-properties 1.1.4 间接依赖 npm
asn1 0.2.6 间接依赖 npm
browserify-cipher 1.0.1 间接依赖 npm
pinkie 2.0.4 间接依赖 npm
@types/eslint-scope 3.7.4 间接依赖 npm
web3-core-requestmanager 1.10.0 间接依赖 npm
@webassemblyjs/helper-buffer 1.11.1 间接依赖 npm
cli-table3 0.5.1 间接依赖 npm
mute-stream 0.0.7 间接依赖 npm
merkle-patricia-tree 3.0.0 间接依赖 npm
highlight.js 10.7.3 间接依赖 npm
timeout-abort-controller 3.0.0 间接依赖 npm
@nodelib/fs.scandir 2.1.5 间接依赖 npm
randombytes 2.1.0 间接依赖 npm
indent-string 4.0.0 间接依赖 npm
schema-utils 3.1.1 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
dir-to-object 2.0.0 间接依赖 npm
graceful-fs 4.2.9 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
responselike 2.0.1 间接依赖 npm
it-map 1.0.6 间接依赖 npm
parse5 7.1.1 间接依赖 npm
buffer-xor 2.0.2 间接依赖 npm
optionator 0.9.1 间接依赖 npm
@jridgewell/gen-mapping 0.3.2 间接依赖 npm
obliterator 2.0.2 间接依赖 npm
des.js 1.0.1 间接依赖 npm
@sentry/node 5.30.0 间接依赖 npm
inherits 2.0.4 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
@gnosis.pm/safe-service-client 1.1.0 直接依赖 npm
extsprintf 1.3.0 间接依赖 npm
lodash.truncate 4.4.2 直接依赖 npm
solc 0.5.16 间接依赖 npm
electron-fetch 1.9.1 间接依赖 npm
@webassemblyjs/helper-api-error 1.11.1 间接依赖 npm
chrome-trace-event 1.0.3 间接依赖 npm
clone-deep 4.0.1 间接依赖 npm
core-js-pure 3.21.1 间接依赖 npm
@ethereumjs/tx 3.5.2 间接依赖 npm
shelljs 0.8.5 间接依赖 npm
hmac-drbg 1.0.1 间接依赖 npm
esquery 1.4.0 间接依赖 npm
object.assign 4.1.4 间接依赖 npm
@chainlink/contracts-0.0.10 npm:@chainlink/contracts@0.0.10 直接依赖 npm
minimist 1.2.6 间接依赖 npm
concat-stream 1.6.2 间接依赖 npm
eventemitter3 4.0.4 间接依赖 npm
npm-run-path 4.0.1 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
@ethersproject/rlp 5.7.0 间接依赖 npm
@sentry/minimal 5.30.0 间接依赖 npm
sha3 2.1.4 间接依赖 npm
aes-js 3.0.0 间接依赖 npm
p-fifo 1.0.0 间接依赖 npm
sisteransi 1.0.5 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
@xtuc/ieee754 1.2.0 间接依赖 npm
lru_map 0.3.3 间接依赖 npm
progress 2.0.3 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
md5 2.3.0 间接依赖 npm
ultron 1.1.1 直接依赖 npm
ansi-regex 3.0.1 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
miller-rabin 4.0.1 间接依赖 npm
invert-kv 1.0.0 间接依赖 npm
@ipld/dag-pb 2.1.18 间接依赖 npm
@ethersproject/basex 5.7.0 间接依赖 npm
css-select 4.2.1 间接依赖 npm
rlp 2.2.7 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
@eth-optimism/contracts 0.3.4 直接依赖 npm
regexp.prototype.flags 1.4.3 间接依赖 npm
@solidity-parser/parser 0.14.1 间接依赖 npm
@sindresorhus/is 4.6.0 间接依赖 npm
array-union 2.1.0 间接依赖 npm
ipfs-utils 9.0.14 间接依赖 npm
path-key 3.1.1 间接依赖 npm
array-uniq 1.0.3 间接依赖 npm
utf8 3.0.0 间接依赖 npm
ajv 6.12.6 间接依赖 npm
recursive-fs 1.1.2 间接依赖 npm
@synthetixio/wei 2.74.1 间接依赖 npm
@truffle/abi-utils 1.0.2 间接依赖 npm
@scure/bip39 1.1.0 直接依赖 npm
typedarray 0.0.6 间接依赖 npm
flat 5.0.2 间接依赖 npm
ethereumjs-abi 0.6.8 间接依赖 npm
@nomicfoundation/solidity-analyzer-darwin-arm64 0.1.0 间接依赖 npm
find-versions 4.0.0 间接依赖 npm
glob-to-regexp 0.4.1 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
@szmarczak/http-timer 5.0.1 间接依赖 npm
web3-providers-http 1.10.0 间接依赖 npm
import-fresh 3.3.0 间接依赖 npm
object.getownpropertydescriptors 2.1.3 间接依赖 npm
interface-datastore 6.1.1 间接依赖 npm
mri 1.2.0 间接依赖 npm
web3-core 1.10.0 间接依赖 npm
compare-versions 3.6.0 间接依赖 npm
fs-extra 9.0.1 间接依赖 npm
@webassemblyjs/helper-numbers 1.11.1 间接依赖 npm
is-bigint 1.0.4 间接依赖 npm
browserify-rsa 4.1.0 间接依赖 npm
is-ci 2.0.0 直接依赖 npm
web3-eth-ens 1.10.0 间接依赖 npm
ltgt 2.2.1 间接依赖 npm
read-pkg 4.0.1 间接依赖 npm
xhr-request 1.1.0 间接依赖 npm
create-ecdh 4.0.4 间接依赖 npm
cbor 5.2.0 间接依赖 npm
@gnosis.pm/safe-deployments 1.10.0 间接依赖 npm
@webassemblyjs/helper-wasm-bytecode 1.11.1 间接依赖 npm
object.values 1.1.5 间接依赖 npm
fp-ts 1.19.3 间接依赖 npm
@ensdomains/ens 0.4.5 间接依赖 npm
public-encrypt 4.0.3 间接依赖 npm
enquirer 2.3.6 间接依赖 npm
source-map 0.2.0 间接依赖 npm
@ipld/dag-json 8.0.11 间接依赖 npm
http-errors 2.0.0 间接依赖 npm
caseless 0.12.0 间接依赖 npm
debug 4.3.4 间接依赖 npm
level-packager 4.0.1 间接依赖 npm
dotenv 6.2.0 直接依赖 npm
acorn-jsx 5.3.2 间接依赖 npm
caller-path 2.0.0 直接依赖 npm
is-callable 1.2.7 间接依赖 npm
picocolors 1.0.0 间接依赖 npm
https-proxy-agent 5.0.0 间接依赖 npm
http-response-object 3.0.2 间接依赖 npm
terser-webpack-plugin 5.3.6 间接依赖 npm
domutils 2.8.0 间接依赖 npm
@types/responselike 1.0.0 间接依赖 npm
change-case 3.0.2 间接依赖 npm
get-port 3.2.0 间接依赖 npm
tsort 0.0.1 间接依赖 npm
@ensdomains/ensjs 2.1.0 间接依赖 npm
@ethersproject/bignumber 5.7.0 间接依赖 npm
hardhat-interact 0.2.3 直接依赖 npm
array-includes 3.1.4 间接依赖 npm
keccak 3.0.2 间接依赖 npm
create-hash 1.2.0 间接依赖 npm
escalade 3.1.1 间接依赖 npm
bech32 1.1.4 间接依赖 npm
fake-merkle-patricia-tree 1.0.1 间接依赖 npm
@uniswap/token-lists 1.0.0-beta.27 直接依赖 npm
depd 2.0.0 间接依赖 npm
mocha 10.2.0 间接依赖 npm
ajv-keywords 3.5.2 间接依赖 npm
inquirer-list-search-prompt 1.0.2 直接依赖 npm
tmp 0.0.33 间接依赖 npm
is-boolean-object 1.1.2 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
is-number-object 1.0.7 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
@nomicfoundation/solidity-analyzer 0.1.0 间接依赖 npm
abbrev 1.0.9 间接依赖 npm
esrecurse 4.3.0 间接依赖 npm
web3-eth-abi 1.7.4 间接依赖 npm
@codechecks/client 0.1.12 直接依赖 npm
call-bind 1.0.2 间接依赖 npm
@nodelib/fs.walk 1.2.8 间接依赖 npm
@nomicfoundation/solidity-analyzer-win32-ia32-msvc 0.1.0 间接依赖 npm
ieee754 1.2.1 间接依赖 npm
mcl-wasm 0.7.9 间接依赖 npm
require-from-string 2.0.2 间接依赖 npm
@protobufjs/utf8 1.1.0 间接依赖 npm
evp_bytestokey 1.0.3 间接依赖 npm
@protobufjs/eventemitter 1.1.0 间接依赖 npm
eslint-plugin-es 3.0.1 间接依赖 npm
crypt 0.0.2 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
ini 1.3.8 间接依赖 npm
astral-regex 1.0.0 间接依赖 npm
cipher-base 1.0.4 间接依赖 npm
web3-eth-iban 1.7.4 间接依赖 npm
encoding-down 5.0.4 间接依赖 npm
bufio 1.2.0 间接依赖 npm
global-modules 2.0.0 间接依赖 npm
@types/long 4.0.2 间接依赖 npm
stealthy-require 1.1.1 间接依赖 npm
browserify-sign 4.2.1 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
callsites 3.1.0 间接依赖 npm
ethereum-bloom-filters 1.0.10 间接依赖 npm
yallist 3.1.1 间接依赖 npm
cheerio 1.0.0-rc.12 间接依赖 npm
@types/estree 0.0.51 间接依赖 npm
has-tostringtag 1.0.0 间接依赖 npm
http2-wrapper 2.2.0 间接依赖 npm
wide-align 1.1.3 直接依赖 npm
assertion-error 1.1.0 间接依赖 npm
ws 7.4.6 间接依赖 npm
spdx-exceptions 2.3.0 间接依赖 npm
onetime 5.1.2 间接依赖 npm
eslint-utils 2.1.0 间接依赖 npm
yargs-parser 13.1.2 间接依赖 npm
yargs 13.3.2 间接依赖 npm
wrap-ansi 5.1.0 间接依赖 npm
util 0.12.5 间接依赖 npm
regenerator-runtime 0.13.9 间接依赖 npm
@types/json5 0.0.29 间接依赖 npm
amdefine 1.0.1 间接依赖 npm
ghost-testrpc 0.0.2 间接依赖 npm
estraverse 4.3.0 间接依赖 npm
os-locale 1.4.0 直接依赖 npm
web3-core-method 1.10.0 间接依赖 npm
jest-worker 27.5.1 间接依赖 npm
nofilter 1.0.4 间接依赖 npm
prompts 2.4.2 间接依赖 npm
any-signal 3.0.1 间接依赖 npm
isobject 3.0.1 间接依赖 npm
signal-exit 3.0.7 间接依赖 npm
node-releases 2.0.10 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
@usecannon/builder 2.1.2 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
@ethersproject/networks 5.7.1 间接依赖 npm
deferred-leveldown 4.0.2 间接依赖 npm
blakejs 1.1.1 间接依赖 npm
tsconfig-paths 3.12.0 间接依赖 npm
minimalistic-assert 1.0.1 间接依赖 npm
watchpack 2.4.0 间接依赖 npm
@ethersproject/logger 5.7.0 间接依赖 npm
@webassemblyjs/wasm-gen 1.11.1 间接依赖 npm
@protobufjs/float 1.0.2 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
lru-cache 5.1.1 间接依赖 npm
dom-converter 0.2.0 间接依赖 npm
@babel/runtime 7.17.2 间接依赖 npm
printj 1.3.1 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
chardet 0.7.0 间接依赖 npm
web3-core-subscriptions 1.10.0 间接依赖 npm
markdown-table 1.1.3 间接依赖 npm
whatwg-url 5.0.0 间接依赖 npm
level-supports 1.0.1 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
globals 12.4.0 间接依赖 npm
@types/lru-cache 5.1.1 间接依赖 npm
type-check 0.4.0 间接依赖 npm
@nomicfoundation/ethereumjs-ethash 2.0.0 间接依赖 npm
@babel/highlight 7.16.10 间接依赖 npm
levn 0.4.1 间接依赖 npm
json-schema 0.4.0 间接依赖 npm
extend 3.0.2 间接依赖 npm
async-eventemitter 0.2.4 间接依赖 npm
@ethersproject/signing-key 5.7.0 间接依赖 npm
untildify 4.0.0 间接依赖 npm
semver 7.5.2 间接依赖 npm
inquirer 6.5.2 直接依赖 npm
it-glob 1.0.2 间接依赖 npm
normalize-package-data 2.5.0 间接依赖 npm
bs58 4.0.1 间接依赖 npm
eslint-visitor-keys 1.3.0 间接依赖 npm
web3-net 1.10.0 间接依赖 npm
@truffle/codec 0.17.2 间接依赖 npm
ethers 5.7.2 间接依赖 npm
handlebars 4.7.7 间接依赖 npm
caniuse-lite 1.0.30001454 间接依赖 npm
ci-info 2.0.0 间接依赖 npm
catering 2.1.1 间接依赖 npm
cacheable-lookup 6.1.0 间接依赖 npm
table 5.4.6 间接依赖 npm
loader-runner 4.3.0 间接依赖 npm
to-readable-stream 1.0.0 直接依赖 npm
env-paths 2.2.1 间接依赖 npm
parse-json 5.2.0 间接依赖 npm
pify 3.0.0 间接依赖 npm
serialize-javascript 6.0.1 间接依赖 npm
ast-parents 0.0.1 间接依赖 npm
p-cancelable 3.0.0 间接依赖 npm
memorystream 0.3.1 间接依赖 npm
@webassemblyjs/wasm-edit 1.11.1 间接依赖 npm
@nomiclabs/ethereumjs-vm 4.2.2 直接依赖 npm
eth-gas-reporter 0.2.25 间接依赖 npm
ethereum-ens 0.8.0 间接依赖 npm
@protobufjs/pool 1.1.0 间接依赖 npm
esprima 4.0.1 间接依赖 npm
cids 0.7.5 间接依赖 npm
is-symbol 1.0.4 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
code-point-at 1.1.0 直接依赖 npm
log-symbols 4.1.0 间接依赖 npm
base64-js 1.5.1 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
yocto-queue 0.1.0 直接依赖 npm
@ethersproject/base64 5.7.0 间接依赖 npm
ethereum-cryptography 0.1.3 间接依赖 npm
tree-kill 1.2.2 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
node-gyp-build 4.3.0 间接依赖 npm
@nomicfoundation/ethereumjs-rlp 4.0.0 间接依赖 npm
@jridgewell/source-map 0.3.2 间接依赖 npm
@protobufjs/aspromise 1.1.2 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
read-pkg-up 2.0.0 间接依赖 npm
semaphore 1.1.0 间接依赖 npm
ipfs-unixfs 6.0.9 间接依赖 npm
@types/qs 6.9.7 间接依赖 npm
@truffle/contract-schema 3.4.15 间接依赖 npm
@iarna/toml 3.0.0 间接依赖 npm
semver-regex 3.1.4 间接依赖 npm
@truffle/interface-adapter 0.5.35 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
web3 1.10.0 间接依赖 npm
arg 4.1.3 间接依赖 npm
@nomicfoundation/ethereumjs-evm 1.0.0 间接依赖 npm
blob-to-it 1.0.4 间接依赖 npm
concurrently 5.2.0 直接依赖 npm
bigint-crypto-utils 3.1.8 间接依赖 npm
multiaddr-to-uri 8.0.0 间接依赖 npm
event-target-shim 5.0.1 间接依赖 npm
ethereumjs-block 2.2.2 间接依赖 npm
har-schema 2.0.0 间接依赖 npm
is-buffer 1.1.6 间接依赖 npm
ethereumjs-tx 2.1.2 间接依赖 npm
emoji-regex 9.2.2 间接依赖 npm
@types/concat-stream 1.6.1 间接依赖 npm
date-fns 2.28.0 间接依赖 npm
@nomiclabs/hardhat-truffle5 2.0.7 直接依赖 npm
request-promise-core 1.1.4 间接依赖 npm
crypto-browserify 3.12.0 直接依赖 npm
@nomicfoundation/ethereumjs-block 4.0.0 间接依赖 npm
crc-32 1.2.1 间接依赖 npm
eslint-scope 5.1.1 间接依赖 npm
tapable 2.2.1 间接依赖 npm
antlr4ts 0.5.0-alpha.4 间接依赖 npm
webpack-cli 5.0.1 直接依赖 npm
@ethersproject/hash 5.7.0 间接依赖 npm
domelementtype 2.3.0 间接依赖 npm
node-environment-flags 1.0.6 直接依赖 npm
is-ipfs 0.6.3 间接依赖 npm
bcrypt-pbkdf 1.0.2 间接依赖 npm
yargs-unparser 2.0.0 间接依赖 npm
@protobufjs/codegen 2.0.4 间接依赖 npm
es-module-lexer 0.9.3 间接依赖 npm
underscore 1.13.2 间接依赖 npm
write 1.0.3 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
@nomiclabs/truffle-contract 4.5.10 间接依赖 npm
xhr2-cookies 1.1.0 直接依赖 npm
@nomicfoundation/solidity-analyzer-freebsd-x64 0.1.0 间接依赖 npm
oauth-sign 0.9.0 间接依赖 npm
hash.js 1.1.7 间接依赖 npm
minimatch 3.1.2 间接依赖 npm
functions-have-names 1.2.3 间接依赖 npm
yn 3.1.1 间接依赖 npm
rechoir 0.6.2 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
url-join 4.0.1 间接依赖 npm
@types/pbkdf2 3.1.0 间接依赖 npm
@ethersproject/json-wallets 5.7.0 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
abi-decoder 2.3.0 直接依赖 npm
@protobufjs/base64 1.1.2 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
@types/levelup 4.3.3 直接依赖 npm
parse-cache-control 1.0.1 间接依赖 npm
uuid 8.3.2 间接依赖 npm
eslint-plugin-promise 4.3.1 直接依赖 npm
@types/bn.js 5.1.1 间接依赖 npm
cli-width 2.2.1 间接依赖 npm
req-cwd 2.0.0 间接依赖 npm
has 1.0.3 间接依赖 npm
anymatch 3.1.2 间接依赖 npm
type-detect 4.0.8 间接依赖 npm
domhandler 4.3.0 间接依赖 npm
is-weakref 1.0.2 间接依赖 npm
opencollective-postinstall 2.0.3 间接依赖 npm
strip-indent 2.0.0 间接依赖 npm
tslib 2.5.0 间接依赖 npm
secp256k1 4.0.3 间接依赖 npm
get-stream 5.2.0 间接依赖 npm
death 1.1.0 间接依赖 npm
slice-ansi 2.1.0 间接依赖 npm
get-intrinsic 1.1.3 间接依赖 npm
fastest-levenshtein 1.0.16 间接依赖 npm
make-error 1.3.6 间接依赖 npm
qs 6.11.0 间接依赖 npm
eth-ens-namehash 2.0.8 间接依赖 npm
which-boxed-primitive 1.0.2 间接依赖 npm
queue-microtask 1.2.3 间接依赖 npm
xmlhttprequest 1.8.0 直接依赖 npm
globby 10.0.2 间接依赖 npm
it-all 1.0.6 间接依赖 npm
promise 8.1.0 间接依赖 npm
memdown 3.0.0 间接依赖 npm
charenc 0.0.2 间接依赖 npm
cosmiconfig 7.0.1 间接依赖 npm
xtend 4.0.2 间接依赖 npm
p-map 4.0.0 间接依赖 npm
http-basic 8.1.3 间接依赖 npm
@types/eslint 8.21.1 间接依赖 npm
deep-is 0.1.4 间接依赖 npm
ipfs-http-client 56.0.3 间接依赖 npm
ansicolors 0.3.2 间接依赖 npm
@discoveryjs/json-ext 0.5.7 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
fast-diff 1.2.0 间接依赖 npm
ethereumjs-account 3.0.0 间接依赖 npm
ripemd160 2.0.2 间接依赖 npm
it-to-stream 1.0.0 间接依赖 npm
@types/chai 4.2.18 间接依赖 npm
json5 2.2.3 间接依赖 npm
wordwrap 1.0.0 间接依赖 npm
camelcase 4.1.0 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
sshpk 1.17.0 间接依赖 npm
espree 7.3.1 间接依赖 npm
@ethersproject/random 5.7.0 间接依赖 npm
caller-callsite 2.0.0 间接依赖 npm
statuses 2.0.1 间接依赖 npm
process-nextick-args 2.0.1 直接依赖 npm
for-each 0.3.3 间接依赖 npm
rustbn.js 0.2.0 间接依赖 npm
@ethersproject/hdnode 5.7.0 间接依赖 npm
@pinata/sdk 1.1.26 直接依赖 npm
testrpc 0.0.1 间接依赖 npm
browser-level 1.0.1 间接依赖 npm
util.promisify 1.1.1 间接依赖 npm
eslint-plugin-node 11.1.0 直接依赖 npm
picomatch 2.3.1 间接依赖 npm
figures 2.0.0 间接依赖 npm
stream-to-it 0.2.4 间接依赖 npm
@webassemblyjs/leb128 1.11.1 间接依赖 npm
pump 3.0.0 间接依赖 npm
cookiejar 2.1.4 间接依赖 npm
@webassemblyjs/floating-point-hex-parser 1.11.1 间接依赖 npm
universalify 1.0.0 间接依赖 npm
is-unicode-supported 0.1.0 间接依赖 npm
browser-stdout 1.3.1 间接依赖 npm
lines-and-columns 1.2.4 间接依赖 npm
lodash.clonedeep 4.5.0 直接依赖 npm
spdx-license-ids 3.0.11 间接依赖 npm
safe-regex-test 1.0.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
async-limiter 1.0.1 直接依赖 npm
axios 0.21.2 间接依赖 npm
file-entry-cache 5.0.1 间接依赖 npm
jsprim 1.4.2 间接依赖 npm
@types/form-data 0.0.33 间接依赖 npm
merge2 1.4.1 间接依赖 npm
@ethersproject/address 5.7.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
utila 0.4.0 间接依赖 npm
it-last 1.0.6 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
@ethersproject/constants 5.7.0 间接依赖 npm
@ethersproject/bytes 5.7.0 间接依赖 npm
err-code 3.0.1 间接依赖 npm
form-data-encoder 1.7.1 间接依赖 npm
pathval 1.1.1 间接依赖 npm
webpack-sources 3.2.3 间接依赖 npm
@nomicfoundation/solidity-analyzer-linux-arm64-gnu 0.1.0 间接依赖 npm
@nomicfoundation/ethereumjs-blockchain 6.0.0 间接依赖 npm
@sentry/core 5.30.0 间接依赖 npm
p-finally 1.0.0 直接依赖 npm
ecc-jsbn 0.1.2 间接依赖 npm
is-hex-prefixed 1.0.0 间接依赖 npm
is-shared-array-buffer 1.0.2 间接依赖 npm
webpack 5.76.0 直接依赖 npm
web3-providers-ipc 1.10.0 间接依赖 npm
streamsearch 1.1.0 间接依赖 npm
ts-essentials 1.0.4 间接依赖 npm
nopt 3.0.6 间接依赖 npm
cardinal 2.1.1 间接依赖 npm
eslint-plugin-standard 4.1.0 直接依赖 npm
which-pm-runs 1.1.0 间接依赖 npm
shallow-clone 3.0.1 间接依赖 npm
setprototypeof 1.2.0 间接依赖 npm
abort-controller 3.0.0 间接依赖 npm
@truffle/blockchain-utils 0.1.8 间接依赖 npm
glob 7.2.0 间接依赖 npm
@nomicfoundation/ethereumjs-vm 6.0.0 间接依赖 npm
@types/json-schema 7.0.11 间接依赖 npm
ts-node 8.10.2 间接依赖 npm
@defi-wonderland/smock 2.3.4 直接依赖 npm
has-property-descriptors 1.0.0 间接依赖 npm
node-emoji 1.11.0 间接依赖 npm
@protobufjs/inquire 1.1.0 间接依赖 npm
level-iterator-stream 3.0.1 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
asn1.js 5.4.1 间接依赖 npm
bluebird 3.7.2 间接依赖 npm
mocha-junit-reporter 2.2.0 直接依赖 npm
es-abstract 1.20.4 间接依赖 npm
@ethersproject/solidity 5.7.0 间接依赖 npm
events 3.3.0 间接依赖 npm
@webassemblyjs/ast 1.11.1 间接依赖 npm
require-main-filename 2.0.0 间接依赖 npm
js-levenshtein 1.1.6 直接依赖 npm
psl 1.8.0 间接依赖 npm
diffie-hellman 5.0.3 间接依赖 npm
tunnel-agent 0.6.0 间接依赖 npm
run-async 2.4.1 间接依赖 npm
check-error 1.0.2 间接依赖 npm
ethereumjs-common 1.5.2 间接依赖 npm
jsonfile 6.1.0 间接依赖 npm
tildify 2.0.0 间接依赖 npm
array.prototype.flat 1.2.5 间接依赖 npm
xml 1.0.1 间接依赖 npm
content-hash 2.5.2 间接依赖 npm
htmlparser2 6.1.0 间接依赖 npm
@ipld/dag-cbor 7.0.3 间接依赖 npm
parse-duration 1.0.2 间接依赖 npm
color-name 1.1.3 间接依赖 npm
buffer-from 1.1.2 间接依赖 npm
level-ws 1.0.0 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
io-ts 1.10.4 间接依赖 npm
resolve 1.22.0 间接依赖 npm
ignore 4.0.6 间接依赖 npm
number-to-bn 1.7.0 间接依赖 npm
agent-base 6.0.2 间接依赖 npm
@truffle/compile-common 0.9.7 间接依赖 npm
@webassemblyjs/utf8 1.11.1 间接依赖 npm
@nomicfoundation/ethereumjs-trie 5.0.0 间接依赖 npm
hardhat-gas-reporter 1.0.9 直接依赖 npm
uint8arrays 3.1.1 间接依赖 npm
@noble/hashes 1.1.2 间接依赖 npm
multimatch 4.0.0 间接依赖 npm
is-directory 0.3.1 直接依赖 npm
@ethersproject/abstract-signer 5.7.0 间接依赖 npm
is-utf8 0.2.1 直接依赖 npm
array-differ 3.0.0 间接依赖 npm
ethjs-unit 0.1.6 间接依赖 npm
mustache 4.2.0 直接依赖 npm
bytes 3.1.2 间接依赖 npm
terser 5.16.3 间接依赖 npm
string.prototype.trimend 1.0.5 间接依赖 npm
resolve-cwd 3.0.0 间接依赖 npm
p-locate 2.0.0 间接依赖 npm
url-parse-lax 3.0.0 直接依赖 npm
@nomicfoundation/solidity-analyzer-win32-arm64-msvc 0.1.0 间接依赖 npm
@ethersproject/contracts 5.7.0 间接依赖 npm
big.js 6.2.1 间接依赖 npm
@webassemblyjs/wast-printer 1.11.1 间接依赖 npm
v8-compile-cache 2.3.0 间接依赖 npm
readdirp 3.6.0 间接依赖 npm
@jridgewell/sourcemap-codec 1.4.14 间接依赖 npm
get-iterator 1.0.2 间接依赖 npm
@webassemblyjs/ieee754 1.11.1 间接依赖 npm
native-fetch 3.0.0 间接依赖 npm
sync-request 6.1.0 间接依赖 npm
json-parse-better-errors 1.0.2 直接依赖 npm
dag-jose 1.0.0 间接依赖 npm
has-symbols 1.0.3 间接依赖 npm
browserify-aes 1.2.0 间接依赖 npm
@truffle/contract 4.6.28 间接依赖 npm
shebang-command 2.0.0 间接依赖 npm
hosted-git-info 2.8.9 间接依赖 npm
@nomicfoundation/solidity-analyzer-darwin-x64 0.1.0 间接依赖 npm
side-channel 1.0.4 间接依赖 npm
sc-istanbul 0.4.6 间接依赖 npm
memory-level 1.0.0 间接依赖 npm
ansi-colors 4.1.1 间接依赖 npm
acorn 7.4.1 间接依赖 npm
level-mem 3.0.1 间接依赖 npm
klaw 1.3.1 直接依赖 npm
multihashes 0.4.21 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
@webassemblyjs/wasm-parser 1.11.1 间接依赖 npm
aggregate-error 3.1.0 间接依赖 npm
run-parallel-limit 1.1.0 间接依赖 npm
performance-now 2.1.0 间接依赖 npm
restore-cursor 2.0.0 间接依赖 npm
class-is 1.1.0 间接依赖 npm
napi-macros 2.0.0 间接依赖 npm
@sentry/utils 5.30.0 间接依赖 npm
kleur 3.0.3 间接依赖 npm
y18n 4.0.3 间接依赖 npm
string_decoder 1.3.0 间接依赖 npm
eslint-plugin-prettier 2.7.0 直接依赖 npm
string-width 2.1.1 间接依赖 npm
@sentry/tracing 5.30.0 间接依赖 npm
@webassemblyjs/helper-wasm-section 1.11.1 间接依赖 npm
binary-extensions 2.2.0 间接依赖 npm
it-first 1.0.7 间接依赖 npm
cli-cursor 2.1.0 间接依赖 npm
@ethersproject/providers 5.7.2 间接依赖 npm
adm-zip 0.4.16 间接依赖 npm
brorand 1.1.0 间接依赖 npm
arrify 2.0.1 间接依赖 npm
ipfs-core-types 0.10.3 间接依赖 npm
hardhat-cannon 2.1.2 直接依赖 npm
fs-readdir-recursive 1.1.0 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
isarray 1.0.0 直接依赖 npm
chokidar 3.5.3 间接依赖 npm
undici 5.20.0 间接依赖 npm
is-plain-obj 2.1.0 间接依赖 npm
@metamask/eth-sig-util 4.0.1 间接依赖 npm
webidl-conversions 3.0.1 间接依赖 npm
then-request 6.0.2 间接依赖 npm
solidity-coverage 0.7.22 直接依赖 npm
locate-path 2.0.0 间接依赖 npm
js-sha3 0.8.0 间接依赖 npm
get-symbol-description 1.0.0 间接依赖 npm
request-promise-native 1.0.9 间接依赖 npm
punycode 2.1.0 间接依赖 npm
@noble/secp256k1 1.6.3 间接依赖 npm
react-native-fetch-api 3.0.0 间接依赖 npm
abstract-level 1.0.3 间接依赖 npm
safe-buffer 5.2.1 间接依赖 npm
aws-sign2 0.7.0 间接依赖 npm
nano-base32 1.0.1 间接依赖 npm
solidity-comments-extractor 0.0.4 间接依赖 npm
mafmt 7.1.0 间接依赖 npm
@nomicfoundation/solidity-analyzer-linux-arm64-musl 0.1.0 间接依赖 npm
tr46 0.0.3 间接依赖 npm
aws4 1.11.0 间接依赖 npm
eslint-plugin-no-only-tests 2.6.0 直接依赖 npm
text-table 0.2.0 间接依赖 npm
ethjs-util 0.1.6 间接依赖 npm
@babel/code-frame 7.16.7 间接依赖 npm
pretty-error 2.1.2 直接依赖 npm
nice-try 1.0.5 直接依赖 npm
eslint-plugin-havven 1.1.0 直接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
strip-json-comments 3.1.1 间接依赖 npm
@eth-optimism/core-utils 0.12.0 间接依赖 npm
@types/minimatch 3.0.5 间接依赖 npm
nth-check 2.0.1 间接依赖 npm
internal-slot 1.0.3 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
hash-base 3.1.0 间接依赖 npm
workerpool 6.2.1 间接依赖 npm
sync-rpc 1.3.6 间接依赖 npm
immutable 4.0.0 间接依赖 npm
receptacle 1.3.2 间接依赖 npm
base-path-converter 1.0.2 间接依赖 npm
@nomicfoundation/ethereumjs-tx 4.0.0 间接依赖 npm
@nomiclabs/hardhat-ethers 2.2.2 直接依赖 npm
prelude-ls 1.2.1 间接依赖 npm
mime-db 1.51.0 间接依赖 npm
lcid 1.0.0 间接依赖 npm
braces 3.0.2 间接依赖 npm
mkdirp 0.5.5 间接依赖 npm
lowercase-keys 3.0.0 间接依赖 npm
@jridgewell/set-array 1.1.2 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
@nomicfoundation/ethereumjs-statemanager 1.0.0 间接依赖 npm
entities 2.2.0 间接依赖 npm
@nomicfoundation/ethereumjs-common 3.0.0 间接依赖 npm
neo-async 2.6.2 间接依赖 npm
@ethersproject/properties 5.7.0 间接依赖 npm
pretty-quick 2.0.2 直接依赖 npm
@types/parse-json 4.0.0 间接依赖 npm
base-x 3.0.9 间接依赖 npm
path-type 4.0.0 间接依赖 npm
type-fest 0.8.1 间接依赖 npm
combined-stream 1.0.8 间接依赖 npm
browser-readablestream-to-it 1.0.3 间接依赖 npm
solidifier 2.2.3 直接依赖 npm
flow-stoplight 1.0.0 间接依赖 npm
fastq 1.13.0 间接依赖 npm
elliptic 6.5.4 间接依赖 npm
cliui 5.0.0 间接依赖 npm
readable-stream 3.6.0 间接依赖 npm
jsonschema 1.4.0 间接依赖 npm
assert-plus 1.0.0 间接依赖 npm
escodegen 1.8.1 间接依赖 npm
har-validator 5.1.5 间接依赖 npm
get-stdin 6.0.0 间接依赖 npm
external-editor 3.1.0 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
eslint-module-utils 2.7.3 间接依赖 npm
inflight 1.0.6 间接依赖 npm
eslint 7.6.0 间接依赖 npm
getpass 0.1.7 间接依赖 npm
@ethersproject/web 5.7.1 间接依赖 npm
word-wrap 1.2.5 间接依赖 npm
exit-on-epipe 1.0.1 间接依赖 npm
p-limit 1.3.0 间接依赖 npm
eslint-import-resolver-node 0.3.6 间接依赖 npm
@usecannon/cli 2.1.2 间接依赖 npm
@nomicfoundation/solidity-analyzer-linux-x64-musl 0.1.0 间接依赖 npm
he 1.2.0 间接依赖 npm
spdx-expression-parse 3.0.1 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
abstract-leveldown 5.0.0 间接依赖 npm
fast-fifo 1.1.0 间接依赖 npm
crypto-addr-codec 0.1.7 间接依赖 npm
@webassemblyjs/wasm-opt 1.11.1 间接依赖 npm
multicodec 0.5.7 间接依赖 npm
strip-hex-prefix 1.0.0 间接依赖 npm
is-number 7.0.0 间接依赖 npm
levelup 3.1.1 间接依赖 npm
nanoid 3.3.4 间接依赖 npm
number-is-nan 1.0.1 直接依赖 npm
p-defer 3.0.0 间接依赖 npm
long 4.0.0 间接依赖 npm
typescript 4.6.2 直接依赖 npm
req-from 2.0.0 间接依赖 npm
@protobufjs/path 1.1.2 间接依赖 npm
eth-lib 0.1.29 间接依赖 npm
contains-path 0.1.0 间接依赖 npm
classic-level 1.2.0 间接依赖 npm
fsevents 2.3.2 间接依赖 npm
@ethersproject/units 5.7.0 间接依赖 npm
web3-eth 1.10.0 间接依赖 npm
idna-uts46-hx 2.3.1 间接依赖 npm
web3-providers-ws 1.10.0 间接依赖 npm
which 2.0.2 间接依赖 npm
lodash.uniq 4.5.0 直接依赖 npm
sha.js 2.4.11 间接依赖 npm
is-stream 2.0.1 间接依赖 npm
reusify 1.0.4 间接依赖 npm
@ensdomains/resolver 0.2.4 间接依赖 npm
md5.js 1.3.5 间接依赖 npm
pako 1.0.11 间接依赖 npm
lodash.isequalwith 4.4.0 间接依赖 npm
@nomicfoundation/solidity-analyzer-win32-x64-msvc 0.1.0 间接依赖 npm
micromatch 4.0.4 间接依赖 npm
human-signals 1.1.1 间接依赖 npm
growl 1.10.5 直接依赖 npm
level-errors 2.0.1 间接依赖 npm
module-error 1.0.2 间接依赖 npm
please-upgrade-node 3.2.0 间接依赖 npm
multiaddr 7.5.0 间接依赖 npm
unpipe 1.0.0 间接依赖 npm
@gnosis.pm/safe-core-sdk 1.3.0 直接依赖 npm
web3-shh 1.10.0 间接依赖 npm
@babel/helper-validator-identifier 7.16.7 间接依赖 npm
antlr4 4.7.1 间接依赖 npm
bn.js 4.11.8 间接依赖 npm
@nomicfoundation/solidity-analyzer-linux-x64-gnu 0.1.0 间接依赖 npm
slash 3.0.0 间接依赖 npm
checkpoint-store 1.1.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
marked 0.7.0 间接依赖 npm
decompress-response 6.0.0 间接依赖 npm
window-size 0.2.0 直接依赖 npm
http-signature 1.2.0 间接依赖 npm
supports-hyperlinks 1.0.1 间接依赖 npm
boolbase 1.0.0 间接依赖 npm
ipfs-core-utils 0.14.3 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
mkdirp-promise 5.0.1 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
raw-body 2.5.1 间接依赖 npm
web3-eth-contract 1.10.0 间接依赖 npm
@ethersproject/abstract-provider 5.7.0 间接依赖 npm
stacktrace-parser 0.1.10 间接依赖 npm
@ethereumjs/common 2.6.5 间接依赖 npm
follow-redirects 1.15.2 间接依赖 npm
fast-glob 3.2.11 间接依赖 npm
prettier-plugin-solidity 1.0.0-beta.6 直接依赖 npm
end-of-stream 1.4.4 间接依赖 npm
husky 4.3.8 直接依赖 npm
asap 2.0.6 间接依赖 npm
string.prototype.trimstart 1.0.5 间接依赖 npm
diff 4.0.2 间接依赖 npm
import-local 3.1.0 间接依赖 npm
colors 1.4.0 间接依赖 npm
form-data 2.5.1 间接依赖 npm
ripemd160-min 0.0.6 间接依赖 npm
@scure/base 1.1.1 间接依赖 npm
which-module 2.0.0 间接依赖 npm
isstream 0.1.2 间接依赖 npm
swarm-js 0.1.42 间接依赖 npm
glob-parent 5.1.2 间接依赖 npm
@ethersproject/wordlists 5.7.0 间接依赖 npm
rxjs 6.6.7 间接依赖 npm
wait-port 0.2.9 直接依赖 npm
@types/glob 7.2.0 间接依赖 npm
is-negative-zero 2.0.2 间接依赖 npm
@types/node 17.0.21 间接依赖 npm
bignumber.js 7.2.1 间接依赖 npm
semaphore-async-await 1.5.1 直接依赖 npm
iso-url 1.2.1 间接依赖 npm
@types/level-errors 3.0.0 间接依赖 npm
@types/cacheable-request 6.0.2 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
fast-check 3.1.1 间接依赖 npm
@ethersproject/wallet 5.7.0 间接依赖 npm
argparse 1.0.10 间接依赖 npm
mime-types 2.1.34 间接依赖 npm
is-date-object 1.0.5 间接依赖 npm
openzeppelin-solidity 4.8.1 直接依赖 npm
deep-eql 4.1.3 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
commander 8.1.0 间接依赖 npm
clean-stack 2.2.0 间接依赖 npm
@types/async-eventemitter 0.2.1 间接依赖 npm
@ethersproject/pbkdf2 5.7.0 间接依赖 npm
cheerio-select 2.1.0 间接依赖 npm
interpret 1.4.0 间接依赖 npm
lodash.assign 4.2.0 直接依赖 npm
@ethersproject/keccak256 5.7.0 间接依赖 npm
loupe 2.3.6 间接依赖 npm
web3-bzz 1.10.0 间接依赖 npm
web3-eth-accounts 1.10.0 间接依赖 npm
sha1 1.1.1 间接依赖 npm
update-browserslist-db 1.0.10 间接依赖 npm
got 12.1.0 间接依赖 npm
ethereumjs-util 7.1.5 间接依赖 npm
p-try 1.0.0 间接依赖 npm
unbox-primitive 1.0.2 间接依赖 npm
colorette 2.0.19 间接依赖 npm
web3-eth-personal 1.10.0 间接依赖 npm
execa 4.1.0 间接依赖 npm
level-codec 9.0.2 间接依赖 npm
@jridgewell/resolve-uri 3.1.0 间接依赖 npm
@truffle/provider 0.2.64 间接依赖 npm
@truffle/debug-utils 6.0.56 间接依赖 npm
request-promise 4.2.6 间接依赖 npm
web3-core-promievent 1.7.4 间接依赖 npm
protobufjs 6.11.4 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
parse-asn1 5.1.6 间接依赖 npm
merge-options 3.0.4 间接依赖 npm
isexe 2.0.0 间接依赖 npm
dom-serializer 1.3.2 间接依赖 npm
object-inspect 1.12.2 间接依赖 npm
@types/secp256k1 4.0.3 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
@nomiclabs/hardhat-etherscan 3.1.0 直接依赖 npm
js-yaml 3.14.1 间接依赖 npm
level-transcoder 1.0.1 间接依赖 npm
cborg 1.10.0 间接依赖 npm
lodash 4.17.21 间接依赖 npm
solidity-parser-antlr 0.4.11 直接依赖 npm
@scure/bip32 1.1.0 直接依赖 npm
yaml 1.10.2 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
marked-terminal 3.3.0 间接依赖 npm
esutils 2.0.3 间接依赖 npm
cli-table 0.3.11 间接依赖 npm
duplexer3 0.1.5 直接依赖 npm
setimmediate 1.0.5 间接依赖 npm
tar 4.4.19 间接依赖 npm
dir-glob 3.0.1 间接依赖 npm
hardhat 2.12.7 直接依赖 npm
@jridgewell/trace-mapping 0.3.17 间接依赖 npm
once 1.4.0 间接依赖 npm
encoding 0.1.13 间接依赖 npm
mock-fs 4.14.0 间接依赖 npm
@nomicfoundation/ethereumjs-util 8.0.0 间接依赖 npm
bs58check 2.1.2 间接依赖 npm
strip-ansi 4.0.0 间接依赖 npm
tweetnacl-util 0.15.1 间接依赖 npm
global-prefix 3.0.0 间接依赖 npm
command-exists 1.2.9 间接依赖 npm
chalk 2.4.2 间接依赖 npm
@protobufjs/fetch 1.1.0 间接依赖 npm
is-core-module 2.8.1 间接依赖 npm
address 1.1.2 间接依赖 npm
@ethersproject/transactions 5.7.0 间接依赖 npm
@ethersproject/strings 5.7.0 间接依赖 npm
spdx-correct 3.1.1 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
path-is-inside 1.0.2 直接依赖 npm
dns-over-http-resolver 1.2.3 直接依赖 npm
bigint-mod-arith 3.1.2 间接依赖 npm
@types/abstract-leveldown 7.2.0 间接依赖 npm
es-to-primitive 1.2.1 间接依赖 npm
@trufflesuite/chromafi 3.0.0 间接依赖 npm
tweetnacl 1.0.3 间接依赖 npm
@sentry/types 5.30.0 间接依赖 npm
level-concat-iterator 2.0.1 直接依赖 npm
toidentifier 1.0.1 间接依赖 npm
web3-core-helpers 1.7.4 间接依赖 npm
semver-compare 1.0.0 间接依赖 npm
get-func-name 2.0.0 间接依赖 npm
@truffle/error 0.1.1 间接依赖 npm
cookie 0.4.2 间接依赖 npm
doctrine 3.0.0 间接依赖 npm
node-fetch 2.6.12 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
wildcard 2.0.0 间接依赖 npm
(0)
上一篇 2024年2月13日
下一篇 2024年2月13日

相关推荐

  • xsonorg/xson 软件分析报告

    基础信息 项目名称:xsonorg/xson 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720001395016990720/1720001395079905280 此报告由Murphysec提供 漏洞列表 …

    软件分析 2023年11月2日
    0
  • bbodi/rustarok 软件分析报告

    基础信息 项目名称:bbodi/rustarok 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716265575817986048/1716265575943815168 此报告由Murphysec提供 漏洞列…

    软件分析 2023年10月23日
    0
  • app-generator/admin-dashboards 软件分析报告

    基础信息 项目名称:app-generator/admin-dashboards 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721948929648824320/1721948930655457280 此报告…

    软件分析 2023年11月8日
    0
  • arl/gitmux 软件分析报告

    基础信息 项目名称:arl/gitmux 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716038421494677504/1716038421742141440 此报告由Murphysec提供 漏洞列表 暂无…

    软件分析 2023年10月23日
    0
  • hackiftekhar/IQMediaPickerController 软件分析报告

    基础信息 项目名称:hackiftekhar/IQMediaPickerController 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721255926329053184/17264777657455288…

    软件分析 2023年11月20日
    0