release-it/release-it 软件分析报告

基础信息

项目名称:release-it/release-it

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1744530056954224640/1744530057281380352

此报告由Murphysec提供

漏洞列表

暂无

缺陷组件

暂无

许可证风险

许可证类型 相关组件 许可证风险
MIT 292
Apache-2.0 3
ISC 30
BSD-2-Clause 7
0BSD 1
BSD-3-Clause 2
Unlicense 1
Python-2.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
safer-buffer 2.1.2 间接依赖 npm
has-symbols 1.0.3 间接依赖 npm
es-get-iterator 1.1.3 间接依赖 npm
get-uri 6.0.2 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
has-proto 1.0.1 间接依赖 npm
cli-cursor 3.1.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
chalk 2.4.2 间接依赖 npm
unique-string 3.0.0 间接依赖 npm
node-fetch 3.3.2 间接依赖 npm
braces 3.0.2 间接依赖 npm
lodash.isstring 4.0.1 间接依赖 npm
open 9.1.0 间接依赖 npm
is-symbol 1.0.4 间接依赖 npm
new-github-release-url 2.0.0 间接依赖 npm
rxjs 7.8.1 间接依赖 npm
regexp.prototype.flags 1.5.1 间接依赖 npm
formdata-polyfill 4.0.10 间接依赖 npm
quick-lru 5.1.1 间接依赖 npm
execa 5.1.1 间接依赖 npm
keyv 4.5.4 间接依赖 npm
es-abstract 1.22.3 间接依赖 npm
iterate-iterator 1.0.2 间接依赖 npm
is-interactive 2.0.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
is-obj 2.0.0 间接依赖 npm
@pnpm/network.ca-file 1.0.2 间接依赖 npm
@types/http-cache-semantics 4.0.4 间接依赖 npm
@szmarczak/http-timer 5.0.1 间接依赖 npm
proto-list 1.2.4 间接依赖 npm
git-up 7.0.0 间接依赖 npm
windows-release 5.1.1 间接依赖 npm
chalk 5.3.0 间接依赖 npm
set-function-name 2.0.1 间接依赖 npm
reusify 1.0.4 间接依赖 npm
@sindresorhus/merge-streams 1.0.0 间接依赖 npm
global-dirs 3.0.1 间接依赖 npm
wcwidth 1.0.1 间接依赖 npm
slash 5.1.0 间接依赖 npm
@octokit/auth-token 4.0.0 间接依赖 npm
js-yaml 4.1.0 间接依赖 npm
functions-have-names 1.2.3 间接依赖 npm
minimatch 3.1.2 间接依赖 npm
lodash 4.17.21 间接依赖 npm
inflight 1.0.6 间接依赖 npm
is-regex 1.1.4 间接依赖 npm
issue-parser 6.0.0 间接依赖 npm
typed-array-byte-length 1.0.0 间接依赖 npm
default-browser 4.0.0 间接依赖 npm
retry 0.13.1 间接依赖 npm
array-buffer-byte-length 1.0.0 间接依赖 npm
data-uri-to-buffer 6.0.1 间接依赖 npm
is-inside-container 1.0.0 间接依赖 npm
responselike 3.0.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
update-notifier 7.0.0 间接依赖 npm
is-path-inside 3.0.3 间接依赖 npm
onetime 5.1.2 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
object.assign 4.1.4 间接依赖 npm
@babel/helper-validator-identifier 7.22.20 间接依赖 npm
tmp 0.0.33 间接依赖 npm
mimic-response 3.1.0 间接依赖 npm
decompress-response 6.0.0 间接依赖 npm
path-key 4.0.0 间接依赖 npm
type-fest 2.19.0 间接依赖 npm
strip-final-newline 3.0.0 间接依赖 npm
lru-cache 7.18.3 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
escape-string-regexp 5.0.0 间接依赖 npm
parse-path 7.0.0 间接依赖 npm
is-set 2.0.2 间接依赖 npm
execa 7.2.0 间接依赖 npm
@pnpm/config.env-replace 1.1.0 间接依赖 npm
strip-ansi 6.0.1 间接依赖 npm
internal-slot 1.0.6 间接依赖 npm
run-applescript 5.0.0 间接依赖 npm
string-width 5.1.2 间接依赖 npm
protocols 2.0.1 间接依赖 npm
@octokit/request-error 5.0.1 间接依赖 npm
define-properties 1.2.1 间接依赖 npm
define-lazy-prop 3.0.0 间接依赖 npm
esprima 4.0.1 间接依赖 npm
@babel/code-frame 7.22.13 间接依赖 npm
inherits 2.0.4 间接依赖 npm
cacheable-lookup 7.0.0 间接依赖 npm
fastq 1.15.0 间接依赖 npm
which-boxed-primitive 1.0.2 间接依赖 npm
proxy-agent 6.3.1 间接依赖 npm
@babel/highlight 7.22.20 间接依赖 npm
for-each 0.3.3 间接依赖 npm
stop-iteration-iterator 1.0.0 间接依赖 npm
env-paths 2.2.1 间接依赖 npm
is-array-buffer 3.0.2 间接依赖 npm
has-flag 4.0.0 间接依赖 npm
resolve-alpn 1.2.1 间接依赖 npm
is-installed-globally 0.4.0 间接依赖 npm
wrap-ansi 8.1.0 间接依赖 npm
registry-url 6.0.1 间接依赖 npm
path-key 3.1.1 间接依赖 npm
@ljharb/through 2.3.11 间接依赖 npm
set-function-length 1.1.1 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
inquirer 9.2.12 间接依赖 npm
run-parallel 1.2.0 间接依赖 npm
is-stream 3.0.0 间接依赖 npm
typedarray-to-buffer 3.1.5 间接依赖 npm
get-intrinsic 1.2.2 间接依赖 npm
proxy-from-env 1.1.0 间接依赖 npm
semver-diff 4.0.0 间接依赖 npm
es-to-primitive 1.2.1 间接依赖 npm
ini 2.0.0 间接依赖 npm
lines-and-columns 1.2.4 间接依赖 npm
has-tostringtag 1.0.0 间接依赖 npm
normalize-url 8.0.0 间接依赖 npm
http2-wrapper 2.2.1 间接依赖 npm
@nodelib/fs.walk 1.2.8 间接依赖 npm
cacheable-request 10.2.14 间接依赖 npm
wildcard-match 5.1.2 间接依赖 npm
default-browser-id 3.0.0 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
defer-to-connect 2.0.1 间接依赖 npm
safe-array-concat 1.0.1 间接依赖 npm
@octokit/endpoint 9.0.2 间接依赖 npm
@octokit/request 8.1.5 间接依赖 npm
jsonfile 4.0.0 间接依赖 npm
mute-stream 1.0.0 间接依赖 npm
ignore 5.2.4 间接依赖 npm
@octokit/types 12.2.0 间接依赖 npm
micromatch 4.0.5 间接依赖 npm
ast-types 0.13.4 间接依赖 npm
lodash.capitalize 4.2.1 间接依赖 npm
typed-array-buffer 1.0.0 间接依赖 npm
node-domexception 1.0.0 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
estraverse 5.3.0 间接依赖 npm
@iarna/toml 2.2.5 间接依赖 npm
import-lazy 4.0.0 间接依赖 npm
is-weakref 1.0.2 间接依赖 npm
is-ci 3.0.1 间接依赖 npm
basic-ftp 5.0.3 间接依赖 npm
base64-js 1.5.1 间接依赖 npm
glob 7.2.3 间接依赖 npm
lodash.uniqby 4.7.0 间接依赖 npm
figures 5.0.0 间接依赖 npm
tslib 2.6.2 间接依赖 npm
is-string 1.0.7 间接依赖 npm
lru-cache 6.0.0 间接依赖 npm
is-in-ci 0.1.0 间接依赖 npm
signal-exit 4.1.0 间接依赖 npm
unicorn-magic 0.1.0 间接依赖 npm
yargs-parser 21.1.1 间接依赖 npm
ansi-styles 4.3.0 间接依赖 npm
ansi-align 3.0.1 间接依赖 npm
boxen 7.1.1 间接依赖 npm
ini 1.3.8 间接依赖 npm
cli-spinners 2.9.1 间接依赖 npm
arraybuffer.prototype.slice 1.0.2 间接依赖 npm
configstore 6.0.0 间接依赖 npm
json-buffer 3.0.1 间接依赖 npm
color-name 1.1.3 间接依赖 npm
mimic-response 4.0.0 间接依赖 npm
type-fest 0.21.3 间接依赖 npm
is-arguments 1.1.1 间接依赖 npm
call-bind 1.0.5 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
supports-color 7.2.0 间接依赖 npm
es-set-tostringtag 2.0.2 间接依赖 npm
string-width 4.2.3 间接依赖 npm
ansi-escapes 4.3.2 间接依赖 npm
balanced-match 1.0.2 间接依赖 npm
function-bind 1.1.2 间接依赖 npm
mime-db 1.52.0 间接依赖 npm
ora 7.0.1 间接依赖 npm
is-map 2.0.2 间接依赖 npm
string.prototype.trimend 1.0.7 间接依赖 npm
write-file-atomic 3.0.3 间接依赖 npm
is-docker 3.0.0 间接依赖 npm
strip-ansi 7.1.0 间接依赖 npm
fetch-blob 3.2.0 间接依赖 npm
import-fresh 3.3.0 间接依赖 npm
dot-prop 6.0.1 间接依赖 npm
macos-release 3.2.0 间接依赖 npm
universal-user-agent 6.0.1 间接依赖 npm
hasown 2.0.0 间接依赖 npm
unbox-primitive 1.0.2 间接依赖 npm
available-typed-arrays 1.0.5 间接依赖 npm
side-channel 1.0.4 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
get-symbol-description 1.0.0 间接依赖 npm
lodash.escaperegexp 4.1.2 间接依赖 npm
ip 2.0.0 间接依赖 npm
graceful-fs 4.2.10 间接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
es-array-method-boxes-properly 1.0.0 间接依赖 npm
yallist 4.0.0 间接依赖 npm
onetime 6.0.0 间接依赖 npm
restore-cursor 3.1.0 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
glob-parent 5.1.2 间接依赖 npm
fs-extra 8.1.0 间接依赖 npm
debug 4.3.4 间接依赖 npm
external-editor 3.1.0 间接依赖 npm
object-inspect 1.13.1 间接依赖 npm
package-json 8.1.1 间接依赖 npm
escodegen 2.1.0 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
buffer 6.0.3 间接依赖 npm
safe-regex-test 1.0.0 间接依赖 npm
semver 7.5.4 间接依赖 npm
typed-array-length 1.0.4 间接依赖 npm
@octokit/core 5.0.1 间接依赖 npm
deep-extend 0.6.0 间接依赖 npm
ci-info 3.9.0 间接依赖 npm
url-join 5.0.0 间接依赖 npm
bplist-parser 0.2.0 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
is-unicode-supported 1.3.0 间接依赖 npm
eastasianwidth 0.2.0 间接依赖 npm
callsites 3.1.0 间接依赖 npm
@octokit/plugin-request-log 4.0.0 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
log-symbols 5.1.0 间接依赖 npm
before-after-hook 2.2.3 间接依赖 npm
once 1.4.0 间接依赖 npm
pac-resolver 7.0.0 间接依赖 npm
wrap-ansi 6.2.0 间接依赖 npm
globalthis 1.0.3 间接依赖 npm
mime-types 2.1.35 间接依赖 npm
safe-buffer 5.2.1 间接依赖 npm
parse-json 5.2.0 间接依赖 npm
p-cancelable 3.0.0 间接依赖 npm
is-negative-zero 2.0.2 间接依赖 npm
get-stream 6.0.1 间接依赖 npm
npm-run-path 5.1.0 间接依赖 npm
data-uri-to-buffer 4.0.1 间接依赖 npm
define-data-property 1.1.1 间接依赖 npm
got 13.0.0 间接依赖 npm
escape-goat 4.0.0 间接依赖 npm
strip-json-comments 2.0.1 间接依赖 npm
form-data-encoder 2.1.4 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
latest-version 7.0.0 间接依赖 npm
is-npm 6.0.0 间接依赖 npm
cli-boxes 3.0.0 间接依赖 npm
defaults 1.0.4 间接依赖 npm
string_decoder 1.3.0 间接依赖 npm
string.prototype.trimstart 1.0.7 间接依赖 npm
which-typed-array 1.1.13 间接依赖 npm
get-stream 8.0.1 间接依赖 npm
bl 5.1.0 间接依赖 npm
ip 1.1.8 间接依赖 npm
is-boolean-object 1.1.2 间接依赖 npm
function.prototype.name 1.1.6 间接依赖 npm
config-chain 1.1.13 间接依赖 npm
is-bigint 1.0.4 间接依赖 npm
has-bigints 1.0.2 间接依赖 npm
pac-proxy-agent 7.0.1 间接依赖 npm
is-docker 2.2.1 间接依赖 npm
path-type 5.0.0 间接依赖 npm
is-core-module 2.13.1 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
run-async 3.0.0 间接依赖 npm
@pnpm/npm-conf 2.2.2 间接依赖 npm
http-proxy-agent 7.0.0 间接依赖 npm
is-typed-array 1.1.12 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
git-url-parse 13.1.1 间接依赖 npm
iterate-value 1.0.2 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
human-signals 5.0.0 间接依赖 npm
is-date-object 1.0.5 间接依赖 npm
emoji-regex 9.2.2 间接依赖 npm
titleize 3.0.0 间接依赖 npm
string-width 6.1.0 间接依赖 npm
minimist 1.2.8 间接依赖 npm
registry-auth-token 5.0.2 间接依赖 npm
shelljs 0.8.5 间接依赖 npm
parse-url 8.1.0 间接依赖 npm
chardet 0.7.0 间接依赖 npm
ieee754 1.2.1 间接依赖 npm
deprecation 2.3.1 间接依赖 npm
pupa 3.1.0 间接依赖 npm
globby 14.0.0 间接依赖 npm
web-streams-polyfill 3.2.1 间接依赖 npm
stdin-discarder 0.1.0 间接依赖 npm
rc 1.2.8 间接依赖 npm
typed-array-byte-offset 1.0.0 间接依赖 npm
ora 5.4.1 间接依赖 npm
xdg-basedir 5.1.0 间接依赖 npm
@nodelib/fs.scandir 2.1.5 间接依赖 npm
esutils 2.0.3 间接依赖 npm
@octokit/plugin-rest-endpoint-methods 10.1.3 间接依赖 npm
execa 8.0.1 间接依赖 npm
widest-line 4.0.1 间接依赖 npm
graceful-fs 4.2.11 间接依赖 npm
resolve 1.22.8 间接依赖 npm
@tootallnate/quickjs-emscripten 0.23.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
isarray 2.0.5 间接依赖 npm
socks 2.7.1 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
merge2 1.4.1 间接依赖 npm
@octokit/graphql 7.0.2 间接依赖 npm
socks-proxy-agent 8.0.2 间接依赖 npm
http-cache-semantics 4.1.1 间接依赖 npm
bundle-name 3.0.0 间接依赖 npm
https-proxy-agent 7.0.2 间接依赖 npm
cli-width 4.1.0 间接依赖 npm
@octokit/openapi-types 19.0.2 间接依赖 npm
which 2.0.2 间接依赖 npm
smart-buffer 4.2.0 间接依赖 npm
has-property-descriptors 1.0.1 间接依赖 npm
@octokit/rest 20.0.2 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
@sindresorhus/is 5.6.0 间接依赖 npm
async-retry 1.3.3 间接依赖 npm
is-plain-object 5.0.0 间接依赖 npm
rechoir 0.6.2 间接依赖 npm
os-name 5.1.0 间接依赖 npm
is-number 7.0.0 间接依赖 npm
clone 1.0.4 间接依赖 npm
cli-cursor 4.0.0 间接依赖 npm
@octokit/plugin-paginate-rest 9.1.3 间接依赖 npm
is-ssh 1.4.0 间接依赖 npm
ms 2.1.2 间接依赖 npm
got 12.6.1 间接依赖 npm
ansi-regex 5.0.1 间接依赖 npm
ansi-regex 6.0.1 间接依赖 npm
netmask 2.0.2 间接依赖 npm
is-number-object 1.0.7 间接依赖 npm
chalk 4.1.2 间接依赖 npm
shebang-command 2.0.0 间接依赖 npm
big-integer 1.6.51 间接依赖 npm
queue-microtask 1.2.3 间接依赖 npm
mimic-fn 4.0.0 间接依赖 npm
degenerator 5.0.1 间接依赖 npm
ansi-styles 6.2.1 间接依赖 npm
camelcase 7.0.1 间接依赖 npm
signal-exit 3.0.7 间接依赖 npm
string.prototype.trim 1.2.8 间接依赖 npm
is-callable 1.2.7 间接依赖 npm
lodash.isplainobject 4.0.6 间接依赖 npm
fast-glob 3.3.2 间接依赖 npm
picomatch 2.3.1 间接依赖 npm
readable-stream 3.6.2 间接依赖 npm
is-wsl 2.2.0 间接依赖 npm
gopd 1.0.1 间接依赖 npm
lowercase-keys 3.0.0 间接依赖 npm
is-shared-array-buffer 1.0.2 间接依赖 npm
agent-base 7.1.0 间接依赖 npm
argparse 2.0.1 间接依赖 npm
universalify 0.1.2 间接依赖 npm
untildify 4.0.0 间接依赖 npm
interpret 1.4.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
promise.allsettled 1.0.7 间接依赖 npm
cosmiconfig 9.0.0 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
array.prototype.map 1.0.6 间接依赖 npm
(0)
上一篇 2024年1月9日
下一篇 2024年1月9日

相关推荐

  • discord-net/Discord.Net 软件分析报告

    基础信息 项目名称:discord-net/Discord.Net 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721135788179062784/1729382119754387456 此报告由Murphy…

    软件分析 2023年11月28日
    0
  • bbrks/go-blurhash 软件分析报告

    基础信息 项目名称:bbrks/go-blurhash 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716267261937451008/1716267262021337089 此报告由Murphysec提供 …

    软件分析 2023年10月23日
    0
  • ckeditor-for-wordpress/ckeditor-for-wordpress 软件分析报告

    基础信息 项目名称:ckeditor-for-wordpress/ckeditor-for-wordpress 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716701005756366848/17167010…

    软件分析 2023年10月24日
    0
  • AR-js-org/AR.js 软件分析报告

    基础信息 项目名称:AR-js-org/AR.js 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716003421018521600/1716003421467312128 此报告由Murphysec提供 漏洞…

    软件分析 2023年10月23日
    0
  • derekp7/snebu 软件分析报告

    基础信息 项目名称:derekp7/snebu 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717123154974654464/1717123155905789952 此报告由Murphysec提供 漏洞列表…

    软件分析 2023年10月25日
    0