kennethreitz/bake 软件分析报告

基础信息

项目名称:kennethreitz/bake

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1719411141397757952/1729848581978284032

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
jQuery 跨站脚本漏洞 XSS MPS-2020-15461 CVE-2020-11023 中危
jQuery 跨站脚本漏洞 XSS MPS-2020-15462 CVE-2020-11022 中危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
nth-check 正则表达式拒绝服务漏洞 ReDoS MPS-2021-31847 CVE-2021-3803 高危
json-schema 安全漏洞 原型污染 MPS-2021-34478 CVE-2021-3918 严重
org.webjars.bower:underscore 代码注入漏洞 代码注入 MPS-2021-3658 CVE-2021-23358 高危
Markdown-It 正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-37028 CVE-2022-21670 中危
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
ejs 代码注入 MPS-2022-13642 中危
markdown-it 拒绝服务 MPS-2022-13854 中危
got 存在打开重定向漏洞 跨站重定向 MPS-2022-19247 CVE-2022-33987 中危
Express 中的 qs 模块存在原型污染漏洞 原型污染 MPS-2022-3967 CVE-2022-24999 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
Github ejs 安全漏洞 注入 MPS-2022-8391 CVE-2022-29078 严重
ejs 存在服务端模板注入漏洞 注入 MPS-2023-10199 CVE-2023-29827 严重
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
tough-cookie 原型污染 MPS-esyq-56vx 中危
Microsoft typed-rest-client 安全漏洞 MPS-m5yq-73ht CVE-2023-30846 高危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
typed-rest-client 1.2.0 1.8.0 间接依赖 建议修复
json-schema 0.2.3 0.4.0 间接依赖 建议修复
glob-parent 3.1.0 5.1.2 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
sphinx 2.2.1 3.0.4 间接依赖 建议修复
ejs 2.7.1 间接依赖 建议修复
underscore 1.8.3 1.12.1 间接依赖 建议修复
minimist 0.0.8 1.2.6 间接依赖 建议修复
nth-check 1.0.2 2.0.1 间接依赖 建议修复
minimist 1.2.0 1.2.6 间接依赖 建议修复
tough-cookie 2.4.3 4.1.3 间接依赖 建议修复
qs 6.5.2 6.5.3 间接依赖 建议修复
semver 5.7.1 7.5.2 间接依赖 可选修复
got 7.1.0 11.8.5 间接依赖 可选修复
markdown-it 8.4.2 12.3.2 间接依赖 可选修复
request 2.88.0 间接依赖 可选修复
semver 6.3.0 7.5.2 间接依赖 可选修复
tslib 1.10.0 间接依赖

许可证风险

许可证类型 相关组件 许可证风险
MIT 230
Apache-2.0 10
BSD-3-Clause 7
BSD-2-Clause 14
ISC 25
Unlicense 1
Apache 1
WTFPL 2
BSD-like 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
array-union 1.0.2 间接依赖 npm
cross-spawn 6.0.5 间接依赖 npm
INDENT_STYLES 间接依赖 pip
p-timeout 1.2.1 间接依赖 npm
linkify-it 2.2.0 间接依赖 npm
denodeify 1.2.1 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
json-schema 0.2.3 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
url-to-options 1.0.1 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
code-point-at 1.1.0 间接依赖 npm
is-glob 4.0.1 间接依赖 npm
buffer-fill 1.0.0 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
bcrypt-pbkdf 1.0.2 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
parse-semver 1.1.1 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
verror 1.10.0 间接依赖 npm
qs 6.5.2 间接依赖 npm
yazl 2.5.1 间接依赖 npm
domhandler 2.4.2 间接依赖 npm
make-dir 1.3.0 间接依赖 npm
dateformat 3.0.3 间接依赖 npm
@nodelib/fs.stat 1.1.3 间接依赖 npm
inquirer 6.5.2 间接依赖 npm
form-data 2.3.3 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
decompress-response 3.3.0 间接依赖 npm
is-retry-allowed 1.2.0 间接依赖 npm
resolve 1.21.0 间接依赖 npm
hosted-git-info 2.8.9 间接依赖 npm
vinyl-file 2.0.0 间接依赖 npm
url-parse-lax 1.0.0 间接依赖 npm
resolve 1.12.0 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
combined-stream 1.0.8 间接依赖 npm
mime 1.6.0 间接依赖 npm
recommonmark 0.6.0 间接依赖 pip
interpret 1.4.0 间接依赖 npm
http-signature 1.2.0 间接依赖 npm
pad-component 0.0.1 间接依赖 npm
clone-buffer 1.0.0 间接依赖 npm
string_decoder 1.3.0 间接依赖 npm
ansi-regex 3.0.0 间接依赖 npm
array-uniq 1.0.3 间接依赖 npm
timed-out 4.0.1 间接依赖 npm
vinyl 2.2.0 间接依赖 npm
oauth-sign 0.9.0 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
which 1.3.1 间接依赖 npm
commondir 1.0.1 间接依赖 npm
is-plain-obj 1.1.0 间接依赖 npm
github-username 4.1.0 间接依赖 npm
jsbn 0.1.1 间接依赖 npm
extsprintf 1.3.0 间接依赖 npm
entities 1.1.2 间接依赖 npm
@types/node 12.7.5 间接依赖 npm
isbinaryfile 3.0.3 间接依赖 npm
parse5 3.0.3 间接依赖 npm
psl 1.4.0 间接依赖 npm
semver 5.7.1 间接依赖 npm
cli-boxes 1.0.0 间接依赖 npm
cheerio 1.0.0-rc.3 间接依赖 npm
vsce 1.66.0 直接依赖 npm
tslib 1.10.0 间接依赖 npm
pretty-bytes 5.3.0 间接依赖 npm
vinyl 1.2.0 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
ajv 6.12.6 间接依赖 npm
pify 3.0.0 间接依赖 npm
tweetnacl 0.14.5 间接依赖 npm
tunnel 0.0.4 间接依赖 npm
semver 6.3.0 间接依赖 npm
p-locate 3.0.0 间接依赖 npm
ejs 2.7.1 间接依赖 npm
merge2 1.3.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
text-table 0.2.0 间接依赖 npm
entities 2.0.0 间接依赖 npm
yosay 2.0.2 间接依赖 npm
argparse 1.0.10 间接依赖 npm
isarray 1.0.0 间接依赖 npm
number-is-nan 1.0.1 间接依赖 npm
get-stream 3.0.0 间接依赖 npm
duplexer3 0.1.4 间接依赖 npm
editions 2.2.0 间接依赖 npm
detect-conflict 1.0.1 间接依赖 npm
readable-stream 3.4.0 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
clone-stats 0.0.1 间接依赖 npm
buffer-alloc 1.2.0 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
strip-ansi 5.2.0 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
generator-code 1.2.6 直接依赖 npm
aws-sign2 0.7.0 间接依赖 npm
path-type 3.0.0 间接依赖 npm
os 0.1.1 间接依赖 npm
color-name 1.1.3 间接依赖 npm
through2 3.0.1 间接依赖 npm
wrap-ansi 2.1.0 间接依赖 npm
didyoumean 1.2.1 间接依赖 npm
tmp 0.0.33 间接依赖 npm
chardet 0.7.0 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
binaryextensions 2.1.2 间接依赖 npm
restore-cursor 2.0.0 间接依赖 npm
once 1.4.0 间接依赖 npm
chalk 1.1.3 间接依赖 npm
htmlparser2 3.10.1 间接依赖 npm
buffer-alloc-unsafe 1.1.0 间接依赖 npm
run-async 2.3.0 间接依赖 npm
commander 2.20.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
tough-cookie 2.4.3 间接依赖 npm
domelementtype 2.0.1 间接依赖 npm
cli-table 0.3.1 间接依赖 npm
uuid 3.3.3 间接依赖 npm
asn1 0.2.4 间接依赖 npm
grouped-queue 0.3.3 间接依赖 npm
dargs 6.1.0 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
balanced-match 1.0.2 间接依赖 npm
extend 3.0.2 间接依赖 npm
glob-parent 3.1.0 间接依赖 npm
figures 2.0.0 间接依赖 npm
har-validator 5.1.3 间接依赖 npm
ansi-regex 4.1.0 间接依赖 npm
ansi-escapes 3.2.0 间接依赖 npm
TaskFilter 间接依赖 pip
sprintf-js 1.0.3 间接依赖 npm
taketalk 1.0.0 间接依赖 npm
isurl 1.0.0 间接依赖 npm
extsprintf 1.4.0 间接依赖 npm
har-schema 2.0.0 间接依赖 npm
deep-extend 0.6.0 间接依赖 npm
read-pkg 3.0.0 间接依赖 npm
debug 3.2.6 间接依赖 npm
DEFAULT_BAKEFILE_NAME 间接依赖 pip
brace-expansion 1.1.11 间接依赖 npm
is-core-module 2.8.1 间接依赖 npm
gh-got 6.0.0 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
mime-types 2.1.24 间接依赖 npm
inflight 1.0.6 间接依赖 npm
dom-serializer 0.2.1 间接依赖 npm
arrify 1.0.1 间接依赖 npm
fast-glob 2.2.7 间接依赖 npm
performance-now 2.1.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
uc.micro 1.0.6 间接依赖 npm
ms 2.1.2 间接依赖 npm
domelementtype 1.3.1 间接依赖 npm
rechoir 0.6.2 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
dom-serializer 0.1.1 间接依赖 npm
fd-slicer 1.1.0 间接依赖 npm
multimatch 2.1.0 间接依赖 npm
scoped-regex 1.0.0 间接依赖 npm
strip-bom-stream 2.0.0 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
punycode 1.4.1 间接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
buffer-crc32 0.2.13 间接依赖 npm
css-what 2.1.3 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
untildify 3.0.3 间接依赖 npm
fast-plist 0.1.2 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
p-cancelable 0.3.0 间接依赖 npm
through 2.3.8 间接依赖 npm
inherits 2.0.4 间接依赖 npm
tunnel-agent 0.6.0 间接依赖 npm
replace-ext 0.0.1 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
request 2.88.0 间接依赖 npm
sphinx 2.2.1 间接依赖 pip
assert-plus 1.0.0 间接依赖 npm
markdown-it 8.4.2 间接依赖 npm
nth-check 1.0.2 间接依赖 npm
is-promise 2.1.0 间接依赖 npm
pify 4.0.1 间接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
slash 1.0.0 间接依赖 npm
sanitize-filename 1.6.3 间接依赖 npm
replace-ext 1.0.0 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
is-scoped 1.0.0 间接依赖 npm
boolbase 1.0.0 间接依赖 npm
has-ansi 2.0.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
diff 3.5.0 间接依赖 npm
colors 1.0.3 间接依赖 npm
rimraf 2.7.1 间接依赖 npm
dir-glob 2.0.0 间接依赖 npm
osenv 0.1.5 间接依赖 npm
minimist 0.0.8 间接依赖 npm
lodash 4.17.21 间接依赖 npm
aws4 1.8.0 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
sshpk 1.16.1 间接依赖 npm
array-differ 1.0.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
got 7.1.0 间接依赖 npm
ignore 3.3.10 间接依赖 npm
glob 7.2.0 间接依赖 npm
clone 1.0.4 间接依赖 npm
string-template 0.2.1 间接依赖 npm
caseless 0.12.0 间接依赖 npm
truncate-utf8-bytes 1.0.2 间接依赖 npm
read 1.0.7 间接依赖 npm
chalk 2.4.2 间接依赖 npm
strip-ansi 4.0.0 间接依赖 npm
cloneable-readable 1.1.3 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
pend 1.2.0 间接依赖 npm
xtend 4.0.2 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
readable-stream 2.3.6 间接依赖 npm
nice-try 1.0.5 间接依赖 npm
textextensions 2.5.0 间接依赖 npm
globby 8.0.2 间接依赖 npm
rxjs 6.5.3 间接依赖 npm
lowercase-keys 1.0.1 间接依赖 npm
p-limit 2.2.1 间接依赖 npm
pify 2.3.0 间接依赖 npm
mute-stream 0.0.7 间接依赖 npm
getpass 0.1.7 间接依赖 npm
path-key 2.0.1 间接依赖 npm
load-json-file 4.0.0 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
log-symbols 2.2.0 间接依赖 npm
async 2.6.4 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
errlop 1.1.2 间接依赖 npm
find-up 3.0.0 间接依赖 npm
locate-path 3.0.0 间接依赖 npm
external-editor 3.1.0 间接依赖 npm
strip-bom 2.0.0 间接依赖 npm
yeoman-generator 3.2.0 间接依赖 npm
mime-db 1.40.0 间接依赖 npm
isstream 0.1.2 间接依赖 npm
css-select 1.2.0 间接依赖 npm
azure-devops-node-api 7.2.0 间接依赖 npm
typed-rest-client 1.2.0 间接依赖 npm
parse-json 4.0.0 间接依赖 npm
get-stdin 4.0.1 间接依赖 npm
mem-fs-editor 5.1.0 间接依赖 npm
istextorbinary 2.5.1 间接依赖 npm
jsprim 1.4.1 间接依赖 npm
string-width 2.1.1 间接依赖 npm
mute-stream 0.0.8 间接依赖 npm
minimist 1.2.0 间接依赖 npm
normalize-package-data 2.5.0 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
@mrmlnc/readdir-enhanced 2.2.1 间接依赖 npm
safe-buffer 5.2.0 间接依赖 npm
url-join 1.1.0 间接依赖 npm
utf8-byte-length 1.0.4 间接依赖 npm
mem-fs 1.1.3 间接依赖 npm
error 7.2.0 间接依赖 npm
strip-bom 3.0.0 间接依赖 npm
read-pkg-up 4.0.0 间接依赖 npm
clone-stats 1.0.0 间接依赖 npm
sax 1.2.4 间接依赖 npm
string-width 1.0.2 间接依赖 npm
cli-cursor 2.1.0 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
yauzl 2.10.0 间接依赖 npm
mdurl 1.0.1 间接依赖 npm
yeoman-environment 2.4.0 间接依赖 npm
graceful-fs 4.2.2 间接依赖 npm
domutils 1.5.1 间接依赖 npm
shelljs 0.8.5 间接依赖 npm
through2 2.0.5 间接依赖 npm
debug 4.1.1 间接依赖 npm
tmp 0.0.29 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
cli-width 2.2.0 间接依赖 npm
read-chunk 3.2.0 间接依赖 npm
underscore 1.8.3 间接依赖 npm
p-try 2.2.0 间接依赖 npm
Bakefile 间接依赖 pip
is-fullwidth-code-point 1.0.0 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
ecc-jsbn 0.1.2 间接依赖 npm
domutils 1.7.0 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
clone 2.1.2 间接依赖 npm
os-homedir 1.0.2 间接依赖 npm
with-open-file 0.1.6 间接依赖 npm
(0)
上一篇 2023年11月29日
下一篇 2023年11月29日

相关推荐

  • doat/DOAutocompleteTextField 软件分析报告

    基础信息 项目名称:doat/DOAutocompleteTextField 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721138991700447232/1725777544927993856 此报告由M…

    软件分析 2023年11月18日
    0
  • hmemcpy/milewski-ctfp-pdf 软件分析报告

    基础信息 项目名称:hmemcpy/milewski-ctfp-pdf 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721258893735657472/1728267833395601408 此报告由Murp…

    软件分析 2023年11月25日
    0
  • shopizer-ecommerce/shopizer 软件分析报告

    基础信息 项目名称:shopizer-ecommerce/shopizer 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1762238399485476864/1762238399523225600 此报告由Mu…

    软件分析 2024年2月27日
    0
  • appwilldev/AWVersionAgent 软件分析报告

    基础信息 项目名称:appwilldev/AWVersionAgent 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720686664753790976/1720686665340993536 此报告由Murp…

    软件分析 2023年11月4日
    0
  • wolfSSL/wolfssl 软件分析报告

    基础信息 项目名称:wolfSSL/wolfssl 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1724618962782085120/1724618964292034560 此报告由Murphysec提供 漏洞…

    软件分析 2023年11月15日
    0