jeff-collins/ment.io 软件分析报告

基础信息

项目名称:jeff-collins/ment.io

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1719050898395234304/1726751507934044160

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Hoek 访问控制错误漏洞 MAID MPS-2018-3882 CVE-2018-3728 高危
npm CLI 任意文件写入漏洞 UNIX符号链接跟随 MPS-2019-16248 CVE-2019-16775 中危
npm CLI 路径遍历漏洞 路径遍历 MPS-2019-16249 CVE-2019-16776 高危
npm CLI node_modules二进制文件覆盖漏洞 权限管理不当 MPS-2019-16250 CVE-2019-16777 中危
kind-of 存在注入漏洞 将资源暴露给错误范围 MPS-2019-17164 CVE-2019-20149 高危
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
handlebars 代码注入漏洞 代码注入 MPS-2020-13732 CVE-2019-20920 高危
handlebars 安全漏洞 不可达退出条件的循环(无限循环) MPS-2020-13734 CVE-2019-20922 高危
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
Yargs Y18n 输入原型污染漏洞 动态确定对象属性修改的控制不恰当 MPS-2020-17543 CVE-2020-7774 严重
Ini 拒绝服务 MPS-2020-17544 CVE-2020-7788 高危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
yargs-parser 原型污染漏洞 特权定义了不安全动作 MPS-2020-4006 CVE-2020-7608 中危
websocket-extensions 拒绝服务 MPS-2020-8041 CVE-2020-7662 高危
websocket-extensions 拒绝服务漏洞 拒绝服务 MPS-2020-8042 CVE-2020-7663 高危
npm CLI 日志信息泄露漏洞 日志敏感信息泄露 MPS-2020-9965 CVE-2020-15095 中危
Socketio Engineio 资源管理错误漏洞 拒绝服务 MPS-2021-0191 CVE-2020-36048 高危
Socketio Engineio 资源管理错误漏洞 拒绝服务 MPS-2021-0192 CVE-2020-36049 高危
Socketio Socket.io CORS漏洞 源验证错误 MPS-2021-0652 CVE-2020-28481 中危
yeikos js.merge 原型污染 MPS-2021-1900 CVE-2020-28499 严重
UIkarma 打开重定向漏洞 跨站重定向 MPS-2021-19534 CVE-2021-23495 中危
jsonpointer 使用不兼容类型访问资源(类型混淆) MPS-2021-19846 CVE-2021-23807 严重
requests 代码注入漏洞 代码注入 MPS-2021-2418 CVE-2020-28502 高危
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Ruy Adorno hosted-git-info 正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-3400 CVE-2021-23362 中危
Async 原型污染漏洞 原型污染 MPS-2021-34434 CVE-2021-43138 高危
Takayuki Sato copy-props 安全漏洞 原型污染 MPS-2021-3446 CVE-2020-28503 严重
json-schema 安全漏洞 原型污染 MPS-2021-34478 CVE-2021-3918 严重
log4js-node 存在信息泄露漏洞 缺省权限不正确 MPS-2021-37062 CVE-2022-21704 中危
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
handlebars 远程代码执行 (RCE) 漏洞 代码注入 MPS-2021-4548 CVE-2021-23369 严重
Dan DeFelippi node-XMLHttpRequest 信任管理问题漏洞 证书验证不恰当 MPS-2021-5338 CVE-2021-31597 严重
npm path-parse 安全漏洞 拒绝服务 MPS-2021-6165 CVE-2021-23343 高危
handlebars 原型污染 MPS-2021-6180 CVE-2021-23383 严重
ws 存在拒绝服务漏洞 拒绝服务 MPS-2021-7109 CVE-2021-32640 中危
trim-newlines 存在拒绝服务漏洞 拒绝服务 MPS-2021-7398 CVE-2021-33623 高危
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
shelljs 权限管理不当 MPS-2022-0508 CVE-2022-0144 高危
follow-redirects 侵犯隐私 MPS-2022-0815 CVE-2022-0155 中危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13732 高危
handlebars 存在代码注入漏洞 代码注入 MPS-2022-13733 高危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13734 严重
handlebars 拒绝服务 MPS-2022-13735 中危
http-proxy 拒绝服务 MPS-2022-13767 中危
is-my-json-valid 存在拒绝服务漏洞 拒绝服务 MPS-2022-13795 高危
is-my-json-valid 代码注入 MPS-2022-13796 高危
istanbul-reports 通过 window.opener 访问使用指向不受信任目标的 Web 链接 MPS-2022-13797 中危
jsonpointer 拒绝服务 MPS-2022-13815 严重
js-yaml 存在拒绝服务漏洞 拒绝服务 MPS-2022-13820 中危
js-yaml 代码注入 MPS-2022-13822 高危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
merge 拒绝服务 MPS-2022-13875 高危
uglify-js ReDoS MPS-2022-14112 中危
Karma 跨站脚本漏洞 XSS MPS-2022-2997 CVE-2022-0437 中危
follow-redirects 未授权敏感信息泄露 MPS-2022-3636 CVE-2022-0536 中危
Express 中的 qs 模块存在原型污染漏洞 原型污染 MPS-2022-3967 CVE-2022-24999 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
decode-uri-component 拒绝服务 MPS-2022-56259 CVE-2022-38900 高危
Socketio Engine.IO拒绝服务漏洞 未捕获的异常 MPS-2022-58577 CVE-2022-41940 中危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
hawk 资源管理错误漏洞 拒绝服务 MPS-2022-8568 CVE-2022-29167 高危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
fsevents 安全漏洞 代码注入 MPS-2ipy-muq0 CVE-2023-45311 严重
Babel 插件任意代码执行漏洞漏洞【Poc公开】 不完整的黑名单 MPS-avb9-j50z CVE-2023-45133 严重
tough-cookie 原型污染 MPS-esyq-56vx 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
xmlhttprequest-ssl 1.5.5 1.6.2 间接依赖 强烈建议修复
@babel/traverse 7.6.3 7.23.2 间接依赖 建议修复
websocket-extensions 0.1.3 0.1.4 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
hawk 3.1.3 9.0.1 间接依赖 建议修复
js-yaml 3.6.1 3.13.1 间接依赖 建议修复
merge 1.2.1 2.1.1 间接依赖 建议修复
json-schema 0.2.3 0.4.0 间接依赖 建议修复
path-parse 1.0.6 1.0.7 间接依赖 建议修复
copy-props 2.0.4 2.0.5 直接依赖 建议修复
express 4.17.1 4.17.3 直接依赖 建议修复
shelljs 0.3.0 0.8.5 间接依赖 建议修复
jsonpointer 4.0.1 5.0.0 间接依赖 建议修复
is-my-json-valid 2.20.0 2.20.3 间接依赖 建议修复
y18n 3.2.1 3.2.2 间接依赖 建议修复
handlebars 4.4.3 4.7.7 间接依赖 建议修复
npm 6.12.0 6.14.6 直接依赖 建议修复
hoek 2.16.3 4.2.1 间接依赖 建议修复
tough-cookie 2.3.4 4.1.3 间接依赖 建议修复
socket.io-parser 3.2.0 3.3.2 间接依赖 建议修复
engine.io 3.2.1 6.4.2 间接依赖 建议修复
lodash 4.17.15 4.17.21 间接依赖 建议修复
glob-parent 3.1.0 5.1.2 间接依赖 建议修复
qs 6.7.0 6.7.3 间接依赖 建议修复
minimist 1.2.0 1.2.6 间接依赖 建议修复
trim-newlines 1.0.0 3.0.1 间接依赖 建议修复
decode-uri-component 0.2.0 0.2.1 间接依赖 建议修复
ini 1.3.5 1.3.6 间接依赖 建议修复
async 2.6.3 2.6.4 间接依赖 可选修复
lodash.template 3.6.2 间接依赖 可选修复
kind-of 6.0.2 6.0.3 间接依赖 可选修复
log4js 4.5.1 6.4.0 间接依赖 可选修复
fsevents 1.2.9 1.2.11 间接依赖 可选修复
uglify-js 3.6.2 3.14.3 间接依赖 可选修复
karma 4.4.0 6.3.16 直接依赖 可选修复
ajv 6.10.2 6.12.3 直接依赖 可选修复
ws 3.3.3 5.2.3 间接依赖 可选修复
request 2.79.0 间接依赖 可选修复
yargs-parser 5.0.0 5.0.1 间接依赖 可选修复
semver 4.3.6 7.5.2 间接依赖 可选修复
hosted-git-info 2.8.5 2.8.9 间接依赖 可选修复
follow-redirects 1.9.0 1.14.8 间接依赖 可选修复
istanbul-reports 2.2.6 3.1.3 间接依赖 可选修复
http-proxy 1.18.0 1.18.1 间接依赖 可选修复
socket.io 2.1.1 2.4.0 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 513
Apache-2.0 13
ISC 45
BSD-2-Clause 12
BSD-3-Clause 18
自定义许可证 1
BSD 1
CC-BY-3.0 1
CC0 1
BSD-like 1
CC0-1.0 1
Unlicense 1
Artistic-2.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
requires-port 1.0.0 间接依赖 npm
union-value 1.0.1 间接依赖 npm
htmlparser2 3.8.3 间接依赖 npm
object-component 0.0.3 间接依赖 npm
object.defaults 1.1.0 间接依赖 npm
strip-indent 1.0.1 间接依赖 npm
snapdragon-util 3.0.1 间接依赖 npm
clone 1.0.4 间接依赖 npm
duplexify 3.7.1 间接依赖 npm
ipaddr.js 1.9.0 间接依赖 npm
concat-stream 1.6.2 间接依赖 npm
@babel/parser 7.6.4 间接依赖 npm
isarray 0.0.1 间接依赖 npm
eventemitter3 4.0.0 间接依赖 npm
ordered-ast-traverse 0.1.1 间接依赖 npm
lodash._basecopy 3.0.1 间接依赖 npm
unique-stream 2.3.1 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
date-now 0.1.4 间接依赖 npm
cache-base 1.0.1 间接依赖 npm
path-parse 1.0.6 间接依赖 npm
karma-script-launcher 0.1.0 直接依赖 npm
backo2 1.0.2 间接依赖 npm
progress 1.1.8 间接依赖 npm
to-fast-properties 2.0.0 间接依赖 npm
phantomjs-prebuilt 2.1.16 间接依赖 npm
is-extendable 0.1.1 间接依赖 npm
stringstream 0.0.6 间接依赖 npm
lodash._reunescapedhtml 2.4.1 直接依赖 npm
once 1.3.3 间接依赖 npm
lodash.assign 4.2.0 间接依赖 npm
type-is 1.6.18 间接依赖 npm
liftoff 3.1.0 直接依赖 npm
methods 1.1.2 间接依赖 npm
json-schema 0.2.3 间接依赖 npm
punycode 1.4.1 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
gulp-bump 3.1.3 直接依赖 npm
body-parser 1.19.0 间接依赖 npm
domelementtype 1.3.1 间接依赖 npm
yargs-parser 5.0.0 间接依赖 npm
lcid 1.0.0 间接依赖 npm
interpret 1.2.0 直接依赖 npm
load-json-file 1.1.0 间接依赖 npm
to-absolute-glob 2.0.2 间接依赖 npm
boom 2.10.1 间接依赖 npm
fast-deep-equal 2.0.1 间接依赖 npm
tmp 0.0.33 间接依赖 npm
stream-exhaust 1.0.2 间接依赖 npm
express 4.17.1 直接依赖 npm
ret 0.1.15 间接依赖 npm
append-buffer 1.0.2 间接依赖 npm
cookie 0.4.0 间接依赖 npm
extract-zip 1.6.7 间接依赖 npm
lodash._htmlescapes 2.4.1 间接依赖 npm
open 7.0.0 直接依赖 npm
body 5.1.0 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
component-emitter 1.3.0 间接依赖 npm
split-string 3.1.0 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
default-compare 1.0.0 间接依赖 npm
caseless 0.11.0 间接依赖 npm
array-differ 1.0.0 直接依赖 npm
esprima 2.7.3 间接依赖 npm
deep-is 0.1.3 间接依赖 npm
is-absolute 1.0.0 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
inherits 2.0.4 间接依赖 npm
bcrypt-pbkdf 1.0.2 间接依赖 npm
get-value 2.0.6 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
performance-now 2.1.0 直接依赖 npm
oauth-sign 0.8.2 间接依赖 npm
mute-stdout 1.0.1 直接依赖 npm
http-proxy 1.18.0 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
duplexer2 0.0.2 间接依赖 npm
ws 3.3.3 间接依赖 npm
stream-shift 1.0.0 间接依赖 npm
object-keys 0.4.0 间接依赖 npm
ajv 6.10.2 直接依赖 npm
es6-promise 4.2.8 间接依赖 npm
extglob 2.0.4 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
request 2.79.0 间接依赖 npm
undertaker-registry 1.0.1 间接依赖 npm
nopt 3.0.6 间接依赖 npm
jsonpointer 4.0.1 间接依赖 npm
hoek 2.16.3 间接依赖 npm
extend 3.0.2 间接依赖 npm
better-assert 1.0.2 间接依赖 npm
lodash.isobject 2.4.1 间接依赖 npm
string-width 1.0.2 间接依赖 npm
snapdragon-node 2.1.1 间接依赖 npm
raw-body 2.4.0 间接依赖 npm
karma-phantomjs-launcher 1.0.4 直接依赖 npm
is-descriptor 0.1.6 间接依赖 npm
path-dirname 1.0.2 间接依赖 npm
beeper 1.1.1 直接依赖 npm
expand-tilde 2.0.2 间接依赖 npm
aws-sign2 0.6.0 间接依赖 npm
wordwrap 0.0.3 间接依赖 npm
has-symbols 1.0.0 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
buffer-alloc-unsafe 1.1.0 间接依赖 npm
lodash._reevaluate 3.0.0 间接依赖 npm
gulp 4.0.2 直接依赖 npm
chokidar 2.1.8 间接依赖 npm
unpipe 1.0.0 间接依赖 npm
after 0.8.2 间接依赖 npm
connect-livereload 0.4.1 直接依赖 npm
undertaker 1.2.1 间接依赖 npm
socket.io 2.1.1 间接依赖 npm
uri-js 4.2.2 间接依赖 npm
lodash._objecttypes 2.4.1 间接依赖 npm
is-fullwidth-code-point 1.0.0 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
xmlhttprequest-ssl 1.5.5 间接依赖 npm
setprototypeof 1.1.1 间接依赖 npm
lodash.restparam 3.6.1 间接依赖 npm
code-point-at 1.1.0 间接依赖 npm
typedarray 0.0.6 间接依赖 npm
loud-rejection 1.6.0 间接依赖 npm
global-prefix 1.0.2 间接依赖 npm
forwarded 0.1.2 间接依赖 npm
esutils 2.0.3 间接依赖 npm
safe-regex 1.1.0 间接依赖 npm
invert-kv 1.0.0 间接依赖 npm
is-data-descriptor 0.1.4 间接依赖 npm
yauzl 2.4.1 间接依赖 npm
copy-props 2.0.4 直接依赖 npm
bach 1.2.0 间接依赖 npm
date-format 2.1.0 间接依赖 npm
color-convert 1.9.3 直接依赖 npm
js-tokens 4.0.0 间接依赖 npm
type-check 0.3.2 间接依赖 npm
is-unc-path 1.0.0 间接依赖 npm
pify 2.3.0 间接依赖 npm
ansi-gray 0.1.1 间接依赖 npm
global-modules 1.0.0 间接依赖 npm
glob-watcher 5.0.3 间接依赖 npm
has-flag 1.0.0 直接依赖 npm
lodash._basetostring 3.0.1 间接依赖 npm
parse-filepath 1.0.2 间接依赖 npm
ng-annotate 0.13.0 间接依赖 npm
tough-cookie 2.3.4 间接依赖 npm
universalify 0.1.2 间接依赖 npm
jsbn 0.1.1 间接依赖 npm
on-finished 2.3.0 间接依赖 npm
readdirp 2.2.1 间接依赖 npm
cookie-signature 1.0.6 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
mime-types 2.1.24 间接依赖 npm
base64-arraybuffer 0.1.5 间接依赖 npm
is-relative 1.0.0 间接依赖 npm
arr-union 3.1.0 间接依赖 npm
sshpk 1.16.1 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
http-parser-js 0.4.10 间接依赖 npm
continuable-cache 0.3.1 间接依赖 npm
domutils 1.5.1 间接依赖 npm
arr-map 2.0.2 间接依赖 npm
static-extend 0.1.2 间接依赖 npm
readable-stream 1.1.14 间接依赖 npm
plugin-error 1.0.1 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
to-array 0.1.4 间接依赖 npm
to-object-path 0.3.0 间接依赖 npm
vinyl 0.5.3 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
is-my-ip-valid 1.0.0 间接依赖 npm
map-obj 1.0.1 间接依赖 npm
is-number 3.0.0 间接依赖 npm
stack-trace 0.0.10 间接依赖 npm
buffer-equal 1.0.0 间接依赖 npm
karma-threshold-reporter 0.1.15 直接依赖 npm
blob 0.0.5 间接依赖 npm
resolve-dir 1.0.1 间接依赖 npm
define-property 2.0.2 间接依赖 npm
ordered-read-streams 1.0.1 间接依赖 npm
through 2.3.8 间接依赖 npm
lodash.isarray 3.0.4 间接依赖 npm
istanbul 0.4.5 间接依赖 npm
estraverse 1.9.3 间接依赖 npm
flush-write-stream 1.1.1 间接依赖 npm
es6-iterator 2.0.3 间接依赖 npm
has-ansi 2.0.0 间接依赖 npm
get-stdin 4.0.1 间接依赖 npm
socket.io-parser 3.2.0 间接依赖 npm
is-binary-path 1.0.1 间接依赖 npm
streamroller 1.0.6 间接依赖 npm
hosted-git-info 2.8.5 间接依赖 npm
indent-string 2.1.0 间接依赖 npm
detect-file 1.0.0 间接依赖 npm
fs-mkdirp-stream 1.0.0 间接依赖 npm
lodash.keys 3.1.2 间接依赖 npm
qjobs 1.2.0 间接依赖 npm
wrap-ansi 2.1.0 间接依赖 npm
spdx-exceptions 2.2.0 间接依赖 npm
sparkles 1.0.1 间接依赖 npm
decode-uri-component 0.2.0 间接依赖 npm
lodash._isiterateecall 3.0.9 间接依赖 npm
negotiator 0.6.2 间接依赖 npm
rechoir 0.6.2 间接依赖 npm
use 3.1.1 间接依赖 npm
graceful-fs 4.2.2 间接依赖 npm
gulp-header 2.0.7 间接依赖 npm
component-bind 1.0.0 间接依赖 npm
alter 0.2.0 间接依赖 npm
is-my-json-valid 2.20.0 间接依赖 npm
pend 1.2.0 间接依赖 npm
lodash 4.17.15 间接依赖 npm
ansi-cyan 0.1.1 直接依赖 npm
lodash._escapestringchar 2.4.1 直接依赖 npm
lodash._isnative 2.4.1 直接依赖 npm
through2 2.0.5 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
string-template 0.2.1 间接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
har-validator 2.0.6 间接依赖 npm
@babel/helper-function-name 7.1.0 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
event-stream 3.0.20 间接依赖 npm
binary-extensions 1.13.1 间接依赖 npm
lodash._getnative 3.9.1 间接依赖 npm
isbinaryfile 3.0.3 间接依赖 npm
audit 0.0.6 直接依赖 npm
generate-function 2.3.1 间接依赖 npm
matchdep 2.0.0 直接依赖 npm
gulp-ng-annotate 0.3.6 直接依赖 npm
lcov-parse 0.0.10 间接依赖 npm
make-error 1.3.5 间接依赖 npm
homedir-polyfill 1.0.3 间接依赖 npm
di 0.0.1 间接依赖 npm
component-inherit 0.0.3 间接依赖 npm
@babel/helper-get-function-arity 7.0.0 间接依赖 npm
map-cache 0.2.2 间接依赖 npm
through2-filter 3.0.0 间接依赖 npm
extsprintf 1.3.0 间接依赖 npm
camelcase 2.1.1 间接依赖 npm
posix-character-classes 0.1.1 间接依赖 npm
jsonfile 4.0.0 间接依赖 npm
colors 1.4.0 间接依赖 npm
async-done 1.3.2 间接依赖 npm
source-map-url 0.4.0 间接依赖 npm
read-pkg 1.1.0 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
buffer-fill 1.0.0 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
cloneable-readable 1.1.3 直接依赖 npm
uuid 3.3.3 间接依赖 npm
semver-greatest-satisfied-range 1.1.0 直接依赖 npm
unc-path-regex 0.1.2 间接依赖 npm
gulp-util 2.2.20 间接依赖 npm
lodash._reinterpolate 3.0.0 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
bower 1.8.8 直接依赖 npm
istanbul-lib-coverage 2.0.5 间接依赖 npm
assert-plus 0.2.0 间接依赖 npm
path-type 1.1.0 间接依赖 npm
es5-ext 0.10.51 间接依赖 npm
split 0.2.10 间接依赖 npm
void-elements 2.0.1 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
fsevents 1.2.9 间接依赖 npm
nan 2.14.0 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
karma-firefox-launcher 0.1.7 直接依赖 npm
kew 0.7.0 间接依赖 npm
d 1.0.1 间接依赖 npm
merge 1.2.1 间接依赖 npm
socket.io-adapter 1.1.1 间接依赖 npm
fined 1.2.0 间接依赖 npm
flatted 2.0.1 间接依赖 npm
map-stream 0.0.7 间接依赖 npm
exit 0.1.2 间接依赖 npm
lodash.values 2.4.1 直接依赖 npm
asynckit 0.4.0 间接依赖 npm
collection-visit 1.0.0 间接依赖 npm
bump-regex 3.1.1 间接依赖 npm
from 0.1.7 间接依赖 npm
end-of-stream 1.4.4 间接依赖 npm
lodash.defaults 2.4.1 直接依赖 npm
make-dir 2.1.0 间接依赖 npm
send 0.17.1 间接依赖 npm
shelljs 0.3.0 间接依赖 npm
gulp-coveralls 0.1.4 直接依赖 npm
tiny-lr 1.1.1 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
has-cors 1.1.0 间接依赖 npm
gulp-wrap 0.15.0 直接依赖 npm
array-uniq 1.0.3 直接依赖 npm
ms 2.0.0 间接依赖 npm
media-typer 0.3.0 间接依赖 npm
trim-newlines 1.0.0 间接依赖 npm
node.extend 2.0.2 间接依赖 npm
cliui 3.2.0 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
unset-value 1.0.0 间接依赖 npm
next-tick 1.0.0 间接依赖 npm
@babel/highlight 7.5.0 间接依赖 npm
color-name 1.1.3 间接依赖 npm
engine.io-parser 2.1.3 间接依赖 npm
connect 3.7.0 间接依赖 npm
useragent 2.3.0 间接依赖 npm
custom-event 1.0.1 间接依赖 npm
array-slice 1.1.0 间接依赖 npm
ordered-esprima-props 1.0.0 间接依赖 npm
gulp-concat 2.6.1 间接依赖 npm
jsesc 2.5.2 间接依赖 npm
encodeurl 1.0.2 间接依赖 npm
utils-merge 1.0.1 间接依赖 npm
istanbul-lib-report 2.0.8 间接依赖 npm
expand-brackets 2.1.4 间接依赖 npm
entities 1.0.0 间接依赖 npm
just-debounce 1.0.0 间接依赖 npm
jasmine-reporters 0.4.1 直接依赖 npm
is-negated-glob 1.0.0 间接依赖 npm
source-map 0.5.7 间接依赖 npm
class-utils 0.3.6 间接依赖 npm
vinyl-fs 3.0.3 间接依赖 npm
array-sort 1.0.0 直接依赖 npm
ecc-jsbn 0.1.2 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
atob 2.1.2 间接依赖 npm
spdx-expression-parse 3.0.0 间接依赖 npm
object.reduce 1.0.1 间接依赖 npm
simple-fmt 0.1.0 间接依赖 npm
jshint 2.10.2 直接依赖 npm
throttleit 1.0.0 间接依赖 npm
object-assign 3.0.0 间接依赖 npm
lodash.templatesettings 3.1.1 间接依赖 npm
mixin-deep 1.3.2 间接依赖 npm
dom-serializer 0.2.1 间接依赖 npm
base 0.11.2 间接依赖 npm
etag 1.8.1 间接依赖 npm
jshint-stylish 0.2.0 直接依赖 npm
sntp 1.0.9 间接依赖 npm
glob-stream 6.1.0 间接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
pump 2.0.1 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
repeat-string 1.6.1 间接依赖 npm
is-property 1.0.2 间接依赖 npm
follow-redirects 1.9.0 间接依赖 npm
require-main-filename 1.0.1 间接依赖 npm
is-accessor-descriptor 0.1.6 间接依赖 npm
generate-object-property 1.2.0 间接依赖 npm
domhandler 2.3.0 间接依赖 npm
socket.io-client 2.1.1 间接依赖 npm
psl 1.4.0 直接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
ansi-colors 1.1.0 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
yargs 7.1.0 直接依赖 npm
redent 1.0.0 间接依赖 npm
is 3.3.0 间接依赖 npm
console-browserify 1.1.0 间接依赖 npm
array-initial 1.1.0 间接依赖 npm
find-up 1.1.2 间接依赖 npm
which-module 1.0.0 间接依赖 npm
source-map-resolve 0.5.2 间接依赖 npm
arr-filter 1.1.2 间接依赖 npm
accepts 1.3.7 间接依赖 npm
lodash.isarguments 3.1.0 间接依赖 npm
for-in 1.0.2 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
is-buffer 1.1.6 间接依赖 npm
stringset 0.2.1 间接依赖 npm
prelude-ls 1.1.2 间接依赖 npm
fill-range 4.0.0 间接依赖 npm
es6-weak-map 2.0.3 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
meow 3.7.0 直接依赖 npm
xmlbuilder 0.4.2 间接依赖 npm
now-and-later 2.0.1 间接依赖 npm
ee-first 1.1.1 间接依赖 npm
os-locale 1.4.0 间接依赖 npm
xtend 4.0.2 间接依赖 npm
pumpify 1.5.1 间接依赖 npm
camelcase-keys 2.1.0 间接依赖 npm
tryit 1.0.3 间接依赖 npm
spdx-license-ids 3.0.5 间接依赖 npm
nanomatch 1.2.13 间接依赖 npm
glogg 1.0.2 间接依赖 npm
buffer-alloc 1.2.0 间接依赖 npm
es6-symbol 3.1.2 间接依赖 npm
combined-stream 1.0.8 间接依赖 npm
async-each 1.0.3 间接依赖 npm
istanbul-reports 2.2.6 间接依赖 npm
karma-junit-reporter 0.2.2 直接依赖 npm
has-color 0.1.7 直接依赖 npm
verror 1.10.0 间接依赖 npm
cryptiles 2.0.5 间接依赖 npm
chalk 1.1.3 间接依赖 npm
object.map 1.0.1 间接依赖 npm
klaw 1.3.1 直接依赖 npm
http-signature 1.1.1 间接依赖 npm
commander 2.20.3 间接依赖 npm
to-through 2.0.0 间接依赖 npm
istanbul-lib-instrument 3.3.0 间接依赖 npm
toidentifier 1.0.0 间接依赖 npm
remove-bom-stream 1.2.0 间接依赖 npm
karma 4.4.0 直接依赖 npm
bluebird 3.7.1 间接依赖 npm
log-driver 1.2.5 间接依赖 npm
kind-of 6.0.2 间接依赖 npm
bufferstreams 1.0.1 间接依赖 npm
statuses 1.5.0 间接依赖 npm
karma-chrome-launcher 0.1.12 直接依赖 npm
array-each 1.0.1 间接依赖 npm
pretty-hrtime 1.0.3 直接依赖 npm
debug 2.6.9 间接依赖 npm
qs 6.7.0 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
lodash.escape 3.2.0 间接依赖 npm
stream-combiner 0.0.4 间接依赖 npm
pinkie 2.0.4 间接依赖 npm
@babel/types 7.6.3 间接依赖 npm
engine.io-client 3.2.1 间接依赖 npm
pascalcase 0.1.1 间接依赖 npm
indexof 0.0.1 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
gulplog 1.0.0 间接依赖 npm
range-parser 1.2.1 间接依赖 npm
fs-extra 7.0.1 间接依赖 npm
lodash.template 3.6.2 间接依赖 npm
http-errors 1.7.2 间接依赖 npm
bytes 3.1.0 间接依赖 npm
ansi-red 0.1.1 直接依赖 npm
mime-db 1.40.0 间接依赖 npm
har-schema 2.0.0 直接依赖 npm
fast-json-stable-stringify 2.0.0 间接依赖 npm
string_decoder 0.10.31 间接依赖 npm
coveralls 2.13.3 间接依赖 npm
resolve 1.12.0 间接依赖 npm
asn1 0.2.4 间接依赖 npm
gulp-angular-templatecache 3.0.0 直接依赖 npm
escape-html 1.0.3 间接依赖 npm
@babel/code-frame 7.5.5 间接依赖 npm
vinyl-bufferstream 1.0.1 间接依赖 npm
uglify-js 3.6.2 间接依赖 npm
vary 1.1.2 间接依赖 npm
archy 1.0.0 间接依赖 npm
cli 1.0.1 间接依赖 npm
time-stamp 1.1.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
serve-static 1.14.1 间接依赖 npm
lodash.clonedeep 4.5.0 间接依赖 npm
globals 11.12.0 间接依赖 npm
finalhandler 1.1.2 间接依赖 npm
lodash._escapehtmlchar 2.4.1 直接依赖 npm
rfdc 1.1.4 间接依赖 npm
define-properties 1.1.3 间接依赖 npm
value-or-function 3.0.0 间接依赖 npm
resolve-options 1.1.0 间接依赖 npm
form-data 2.1.4 间接依赖 npm
path-exists 2.1.0 间接依赖 npm
amdefine 1.0.1 直接依赖 npm
isstream 0.1.2 间接依赖 npm
lodash._shimkeys 2.4.1 直接依赖 npm
strip-json-comments 1.0.4 间接依赖 npm
request-progress 2.0.1 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
glob 7.1.4 间接依赖 npm
has-binary2 1.0.3 间接依赖 npm
merge-descriptors 1.0.1 间接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
argparse 1.0.10 间接依赖 npm
inflight 1.0.6 间接依赖 npm
@babel/traverse 7.6.3 间接依赖 npm
parse-json 2.2.0 间接依赖 npm
array-find-index 1.0.2 间接依赖 npm
get-caller-file 1.0.3 间接依赖 npm
which 1.3.1 间接依赖 npm
each-props 1.3.2 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
for-own 1.0.0 间接依赖 npm
getpass 0.1.7 间接依赖 npm
engine.io 3.2.1 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
object.assign 4.1.0 间接依赖 npm
stable 0.1.8 间接依赖 npm
currently-unhandled 0.4.1 间接依赖 npm
normalize-path 2.1.1 间接依赖 npm
hawk 3.1.3 间接依赖 npm
number-is-nan 1.0.1 间接依赖 npm
lead 1.0.0 间接依赖 npm
v8flags 3.1.3 直接依赖 npm
content-disposition 0.5.3 间接依赖 npm
text-table 0.2.0 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
parseuri 0.0.5 间接依赖 npm
tweetnacl 0.14.5 间接依赖 npm
lodash._reescape 3.0.0 间接依赖 npm
tryor 0.1.2 间接依赖 npm
findup-sync 3.0.0 间接依赖 npm
js-yaml 3.6.1 间接依赖 npm
base64id 1.0.0 间接依赖 npm
async-settle 1.0.0 间接依赖 npm
karma-jasmine 0.1.6 直接依赖 npm
make-error-cause 1.2.2 间接依赖 npm
spdx-correct 3.1.0 间接依赖 npm
dom-serialize 2.2.1 间接依赖 npm
mime 1.6.0 间接依赖 npm
parseurl 1.3.3 间接依赖 npm
path-root-regex 0.1.2 间接依赖 npm
flagged-respawn 1.0.1 间接依赖 npm
vinyl-sourcemaps-apply 0.1.4 间接依赖 npm
parse-passwd 1.0.0 间接依赖 npm
array-last 1.3.0 间接依赖 npm
upath 1.2.0 间接依赖 npm
has 1.0.3 间接依赖 npm
util-deprecate 1.0.2 直接依赖 npm
decamelize 1.2.0 间接依赖 npm
fancy-log 1.3.3 间接依赖 npm
websocket-extensions 0.1.3 间接依赖 npm
safe-json-parse 1.0.1 间接依赖 npm
gulp-footer 2.0.2 间接依赖 npm
parseqs 0.0.5 间接依赖 npm
lazystream 1.0.0 间接依赖 npm
aws4 1.8.0 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
concat-with-sourcemaps 1.1.0 间接依赖 npm
clone-buffer 1.0.0 直接依赖 npm
has-gulplog 0.1.0 间接依赖 npm
optimist 0.6.1 间接依赖 npm
proxy-addr 2.0.5 间接依赖 npm
ultron 1.1.1 间接依赖 npm
urix 0.1.0 间接依赖 npm
jsprim 1.4.1 间接依赖 npm
lodash._root 3.0.1 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
semver 4.3.6 间接依赖 npm
y18n 3.2.1 间接依赖 npm
livereload-js 2.4.0 间接依赖 npm
is-finite 1.0.2 间接依赖 npm
type 1.2.0 间接依赖 npm
consolidate 0.15.1 间接依赖 npm
has-value 1.0.0 间接依赖 npm
replace-homedir 1.0.0 直接依赖 npm
faye-websocket 0.10.0 间接依赖 npm
gulp-karma 0.0.5 直接依赖 npm
@babel/helper-split-export-declaration 7.4.4 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
rcfinder 0.1.9 间接依赖 npm
clone-stats 0.0.1 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
is-utf8 0.2.1 间接依赖 npm
rimraf 2.7.1 间接依赖 npm
plugin-log 0.1.0 间接依赖 npm
optionator 0.8.2 间接依赖 npm
gulp-uglify 3.0.2 直接依赖 npm
neo-async 2.6.1 间接依赖 npm
last-run 1.1.1 间接依赖 npm
ansi-wrap 0.1.0 间接依赖 npm
content-type 1.0.4 间接依赖 npm
karma-coverage 2.0.1 直接依赖 npm
websocket-driver 0.7.3 间接依赖 npm
simple-is 0.2.0 间接依赖 npm
destroy 1.0.4 间接依赖 npm
replace-ext 0.0.1 间接依赖 npm
snapdragon 0.8.2 间接依赖 npm
isobject 3.0.1 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
default-resolution 2.0.0 间接依赖 npm
make-iterator 1.0.1 间接依赖 npm
async-limiter 1.0.1 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
is-glob 4.0.1 间接依赖 npm
fs-readfile-promise 3.0.1 间接依赖 npm
vinyl-sourcemap 1.1.0 间接依赖 npm
@babel/generator 7.6.4 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
fresh 0.5.2 间接依赖 npm
braces 2.3.2 间接依赖 npm
read-pkg-up 1.0.1 间接依赖 npm
log4js 4.5.1 间接依赖 npm
levn 0.3.0 间接依赖 npm
is-wsl 2.1.1 间接依赖 npm
gulp-livereload 4.0.2 直接依赖 npm
pause-stream 0.0.11 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
abbrev 1.0.9 间接依赖 npm
ent 2.2.0 间接依赖 npm
remove-bom-buffer 3.0.0 间接依赖 npm
array-flatten 1.1.1 间接依赖 npm
rcloader 0.2.2 间接依赖 npm
duplexer 0.1.1 间接依赖 npm
is-valid-glob 1.0.0 间接依赖 npm
tunnel-agent 0.4.3 间接依赖 npm
handlebars 4.4.3 间接依赖 npm
async 2.6.3 间接依赖 npm
parse-node-version 1.0.1 间接依赖 npm
hasha 2.2.0 间接依赖 npm
repeating 2.0.1 间接依赖 npm
assign-symbols 1.0.0 间接依赖 npm
repeat-element 1.1.3 间接依赖 npm
yeast 0.1.2 间接依赖 npm
sver-compat 1.5.0 间接依赖 npm
to-regex-range 2.1.1 间接依赖 npm
normalize-package-data 2.5.0 间接依赖 npm
glob-parent 3.1.0 间接依赖 npm
istanbul-lib-source-maps 3.0.6 间接依赖 npm
minimist 1.2.0 间接依赖 npm
picomatch 2.0.7 直接依赖 npm
error 7.2.0 间接依赖 npm
resolve-url 0.2.1 间接依赖 npm
depd 1.1.2 间接依赖 npm
@babel/template 7.6.0 间接依赖 npm
stringmap 0.2.2 间接依赖 npm
path-root 0.1.1 间接依赖 npm
yallist 2.1.2 间接依赖 npm
lodash._basevalues 3.0.0 间接依赖 npm
npm 6.12.0 直接依赖 npm
color-support 1.1.3 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
fd-slicer 1.0.1 间接依赖 npm
convert-source-map 0.4.1 间接依赖 npm
gulp-jshint 2.1.0 直接依赖 npm
array-unique 0.3.2 间接依赖 npm
lru-cache 4.1.5 间接依赖 npm
escodegen 1.8.1 间接依赖 npm
ini 1.3.5 间接依赖 npm
set-value 2.0.1 间接依赖 npm
acorn 0.9.0 间接依赖 npm
dateformat 2.2.0 间接依赖 npm
multipipe 0.1.2 间接依赖 npm
path-to-regexp 0.1.7 间接依赖 npm
collection-map 1.0.0 间接依赖 npm
arraybuffer.slice 0.0.7 间接依赖 npm
callsite 1.0.0 间接依赖 npm
(0)
上一篇 2023年11月21日
下一篇 2023年11月21日

相关推荐

  • Chris911/iStats 软件分析报告

    基础信息 项目名称:Chris911/iStats 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716656266784931840/1716656267288248320 此报告由Murphysec提供 漏洞…

    软件分析 2023年10月24日
    0
  • apiiro/combobulator 软件分析报告

    基础信息 项目名称:apiiro/combobulator 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715963880584904704/1715963880635236352 此报告由Murphysec提…

    软件分析 2023年10月23日
    0
  • topiam/eiam 软件分析报告

    基础信息 项目名称:topiam/eiam 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715402134693658624/1715402134735601664 此报告由Murphysec提供 漏洞列表 漏…

    软件分析 2023年10月23日
    0
  • eixom/php-jsonlite 软件分析报告

    基础信息 项目名称:eixom/php-jsonlite 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717413346981756928/1717413347115974656 此报告由Murphysec提供…

    软件分析 2023年10月26日
    0
  • Yalantis/Context-Menu.Android 软件分析报告

    基础信息 项目名称:Yalantis/Context-Menu.Android 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720116633516167168/1720116633558110208 此报告由…

    软件分析 2023年11月3日
    0