yhjor/mongoose-plugin-cache 软件分析报告

基础信息

项目名称:yhjor/mongoose-plugin-cache

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1721663059028938752/1721663059066687488

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
mixin-deep 参数注入漏洞 参数注入或修改 MPS-2019-10507 CVE-2019-10746 严重
set-value 存在拒绝服务漏洞 拒绝服务 MPS-2019-10508 CVE-2019-10747 中危
Automattic Mongoose 输入验证错误漏洞 未授权敏感信息泄露 MPS-2019-12917 CVE-2019-17426 严重
handlebars 原型污染漏洞 原型污染 MPS-2019-16888 CVE-2019-19919 严重
kind-of 存在注入漏洞 将资源暴露给错误范围 MPS-2019-17164 CVE-2019-20149 高危
lodash 原型污染漏洞 拒绝服务 MPS-2019-8636 CVE-2019-10744 严重
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
codecov-node 操作系统命令注入漏洞 OS命令注入 MPS-2020-10705 CVE-2020-15123 严重
npm bl 内存泄露漏洞 越界读取 MPS-2020-12199 CVE-2020-8244 中危
Codecov NodeJs Uploader 注入漏洞 注入 MPS-2020-1229 CVE-2020-7596 高危
handlebars 代码注入漏洞 代码注入 MPS-2020-13732 CVE-2019-20920 高危
handlebars 安全漏洞 不可达退出条件的循环(无限循环) MPS-2020-13734 CVE-2019-20922 高危
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
Mquery 安全漏洞 拒绝服务 MPS-2020-17265 CVE-2020-35149 中危
Yargs Y18n 输入原型污染漏洞 动态确定对象属性修改的控制不恰当 MPS-2020-17543 CVE-2020-7774 严重
Ini 拒绝服务 MPS-2020-17544 CVE-2020-7788 高危
Mikaelbr Node-notifier 操作系统命令注入漏洞 OS命令注入 MPS-2020-17637 CVE-2020-7789 中危
codecov-node npm module 操作系统命令注入漏洞 OS命令注入 MPS-2020-2560 CVE-2020-7597 高危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
yargs-parser 原型污染漏洞 特权定义了不安全动作 MPS-2020-4006 CVE-2020-7608 中危
BSON 序列化绕过漏洞 反序列化 MPS-2020-4726 CVE-2020-7610 严重
js-bson 反序列化 MPS-2020-4759 CVE-2019-2391 中危
decompress package 路径遍历漏洞 路径遍历 MPS-2020-6640 CVE-2020-12265 严重
node-tar 路径遍历漏洞 路径遍历 MPS-2021-11547 CVE-2021-32804 高危
node-tar 路径遍历漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-11548 CVE-2021-32803 高危
yeikos js.merge 原型污染 MPS-2021-1900 CVE-2020-28499 严重
mpath module 安全漏洞 使用不兼容类型访问资源(类型混淆) MPS-2021-19477 CVE-2021-23438 严重
set-value 原型污染漏洞 使用不兼容类型访问资源(类型混淆) MPS-2021-19479 CVE-2021-23440 严重
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28486 CVE-2021-37701 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28488 CVE-2021-37712 高危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-28489 CVE-2021-37713 高危
nodejs 正则表达式漏洞 拒绝服务 MPS-2021-31423 CVE-2021-3777 高危
prompts 正则表达式拒绝服务漏洞 ReDoS MPS-2021-32909 中危
Async 原型污染漏洞 原型污染 MPS-2021-34434 CVE-2021-43138 高危
json-schema 安全漏洞 原型污染 MPS-2021-34478 CVE-2021-3918 严重
braces 拒绝服务 MPS-2021-3692 CVE-2018-1109 中危
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
handlebars 远程代码执行 (RCE) 漏洞 代码注入 MPS-2021-4548 CVE-2021-23369 严重
node-redis 正则表达式拒绝服务 (ReDoS) 拒绝服务 MPS-2021-5152 CVE-2021-29469 高危
npm path-parse 安全漏洞 拒绝服务 MPS-2021-6165 CVE-2021-23343 高危
handlebars 原型污染 MPS-2021-6180 CVE-2021-23383 严重
ws 存在拒绝服务漏洞 拒绝服务 MPS-2021-7109 CVE-2021-32640 中危
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
mem 拒绝服务 MPS-2022-12990 中危
acorn 存在拒绝服务漏洞 拒绝服务 MPS-2022-13525 高危
handlebars 存在原型污染漏洞 MAID MPS-2022-13730 高危
handlebars 存在原型污染漏洞 MAID MPS-2022-13731 高危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13732 高危
handlebars 存在代码注入漏洞 代码注入 MPS-2022-13733 高危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13734 严重
handlebars 拒绝服务 MPS-2022-13735 中危
https-proxy-agent 存在中间人攻击漏洞 中间人攻击 MPS-2022-13770 中危
istanbul-reports 通过 window.opener 访问使用指向不受信任目标的 Web 链接 MPS-2022-13797 中危
js-yaml 存在拒绝服务漏洞 拒绝服务 MPS-2022-13820 中危
js-yaml 代码注入 MPS-2022-13822 高危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
merge 拒绝服务 MPS-2022-13875 高危
mongodb 存在拒绝服务漏洞 拒绝服务 MPS-2022-13888 高危
mongoose 存在原型污染漏洞 原型污染 MPS-2022-13891 中危
mquery 存在原型污染漏洞 原型污染 MPS-2022-13896 高危
tar 正则表达式拒绝服务漏洞 拒绝服务 MPS-2022-14081 低危
uglify-js ReDoS MPS-2022-14112 中危
Automattic Mongoose 安全漏洞 原型污染 MPS-2022-3209 CVE-2022-24304 高危
Express 中的 qs 模块存在原型污染漏洞 原型污染 MPS-2022-3967 CVE-2022-24999 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
Automattic Mongoose 安全漏洞 原型污染 MPS-2022-52708 CVE-2022-2564 严重
nwsapi 拒绝服务 拒绝服务 MPS-2022-54623 中危
decode-uri-component 拒绝服务 MPS-2022-56259 CVE-2022-38900 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
Tauri 原型污染漏洞 原型污染 MPS-2022-65568 CVE-2022-46175 高危
needle 存在Authorization请求头泄露漏洞 未授权敏感信息泄露 MPS-2022-7866 中危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
fsevents 安全漏洞 代码注入 MPS-2ipy-muq0 CVE-2023-45311 严重
tough-cookie 原型污染 MPS-esyq-56vx 中危
Automattic Mongoose 安全漏洞 原型污染 MPS-rkw8-631m CVE-2023-3696 严重

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
minimist 1.2.0 1.2.6 间接依赖 建议修复
set-value 2.0.0 2.0.1 间接依赖 建议修复
decompress 4.2.0 4.2.1 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
mongoose 5.3.12 5.13.20 直接依赖 建议修复
bson 1.1.0 1.1.4 间接依赖 建议修复
merge 1.2.1 2.1.1 间接依赖 建议修复
tough-cookie 2.5.0 4.1.3 间接依赖 建议修复
ini 1.3.5 1.3.6 间接依赖 建议修复
mongodb 3.1.10 3.1.13 直接依赖 建议修复
tar 4.4.8 4.4.18 间接依赖 建议修复
y18n 3.2.1 3.2.2 间接依赖 建议修复
decompress-tar 4.1.1 间接依赖 建议修复
mongoose 5.4.1 5.13.20 直接依赖 建议修复
path-parse 1.0.6 1.0.7 间接依赖 建议修复
tough-cookie 2.4.3 4.1.3 间接依赖 建议修复
json-schema 0.2.3 0.4.0 间接依赖 建议修复
mpath 0.5.1 0.8.4 间接依赖 建议修复
json5 2.1.0 2.2.2 间接依赖 建议修复
mongodb 3.1.9 3.1.13 间接依赖 建议修复
handlebars 4.0.12 4.7.7 间接依赖 建议修复
acorn 6.0.4 6.4.1 间接依赖 建议修复
json5 0.5.1 1.0.2 间接依赖 建议修复
redis 2.8.0 3.1.1 直接依赖 建议修复
mquery 3.2.0 3.2.5 间接依赖 建议修复
qs 6.5.2 6.5.3 间接依赖 建议修复
acorn 5.7.3 5.7.4 间接依赖 建议修复
mixin-deep 1.3.1 1.3.2 间接依赖 建议修复
codecov 3.1.0 3.7.1 直接依赖 建议修复
tmpl 1.0.4 1.0.5 间接依赖 建议修复
glob-parent 2.0.0 5.1.2 间接依赖 建议修复
js-yaml 3.12.0 3.13.1 间接依赖 建议修复
decode-uri-component 0.2.0 0.2.1 间接依赖 建议修复
minimist 0.0.8 1.2.6 间接依赖 建议修复
lodash 4.17.11 4.17.21 间接依赖 建议修复
uglify-js 3.4.9 3.14.3 直接依赖 可选修复
braces 1.8.5 2.3.1 间接依赖 可选修复
istanbul-reports 1.5.1 3.1.3 间接依赖 可选修复
prompts 0.1.14 2.4.2 直接依赖 可选修复
yargs-parser 10.1.0 13.1.2 间接依赖 可选修复
mem 1.1.0 4.0.0 间接依赖 可选修复
fsevents 1.2.4 1.2.11 直接依赖 可选修复
https-proxy-agent 2.2.1 2.2.3 间接依赖 可选修复
async 2.6.1 2.6.4 间接依赖 可选修复
node-notifier 5.3.0 5.4.5 直接依赖 可选修复
ws 5.2.2 5.2.3 间接依赖 可选修复
needle 2.2.4 3.1.0 间接依赖 可选修复
ajv 6.6.2 6.12.3 间接依赖 可选修复
semver 5.6.0 7.5.2 间接依赖 可选修复
kind-of 6.0.2 6.0.3 间接依赖 可选修复
request 2.88.0 间接依赖 可选修复
yargs-parser 9.0.2 13.1.2 间接依赖 可选修复
nwsapi 2.0.9 2.2.1 间接依赖 可选修复
bl 1.2.2 1.2.3 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 441
BSD-3-Clause 21
BSD-2-Clause 10
ISC 54
Apache-2.0 25
WTFPL 1
自定义许可证 1
Unlicense 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
babel-template 6.26.0 间接依赖 npm
source-map 0.6.1 间接依赖 npm
has-value 1.0.0 间接依赖 npm
escodegen 1.11.0 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
istanbul-lib-hook 1.2.2 间接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
read-pkg-up 1.0.1 间接依赖 npm
preserve 0.2.0 间接依赖 npm
posix-character-classes 0.1.1 直接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
es-abstract 1.12.0 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
is-primitive 2.0.0 间接依赖 npm
has-values 1.0.0 间接依赖 npm
glob-parent 2.0.0 间接依赖 npm
uglify-js 3.4.9 直接依赖 npm
async-limiter 1.0.0 间接依赖 npm
p-locate 2.0.0 间接依赖 npm
@types/node 10.12.18 间接依赖 npm
mongoose 5.4.1 直接依赖 npm
chalk 1.1.3 间接依赖 npm
to-regex-range 2.1.1 直接依赖 npm
bson 1.1.0 间接依赖 npm
har-schema 2.0.0 间接依赖 npm
buffer-crc32 0.2.13 间接依赖 npm
abab 2.0.0 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
md5-file 4.0.0 间接依赖 npm
double-ended-queue 2.1.0-0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
os-locale 2.1.0 间接依赖 npm
uri-js 4.2.2 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
jest-worker 23.2.0 间接依赖 npm
path-parse 1.0.6 间接依赖 npm
parse5 4.0.0 间接依赖 npm
buffer 3.6.0 间接依赖 npm
expand-brackets 0.1.5 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
is-extglob 1.0.0 间接依赖 npm
caseless 0.12.0 间接依赖 npm
domexception 1.0.1 间接依赖 npm
p-locate 3.0.0 间接依赖 npm
merge 1.2.1 间接依赖 npm
yauzl 2.10.0 间接依赖 npm
babel-code-frame 6.26.0 间接依赖 npm
uuid 3.3.2 间接依赖 npm
snapdragon 0.8.2 间接依赖 npm
dedent 0.7.0 间接依赖 npm
bs-logger 0.2.6 间接依赖 npm
whatwg-url 7.0.0 间接依赖 npm
whatwg-mimetype 2.2.0 间接依赖 npm
babel-preset-jest 23.2.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
set-value 2.0.0 间接依赖 npm
invariant 2.2.4 间接依赖 npm
babel-core 6.26.3 间接依赖 npm
@types/redis 2.8.7 直接依赖 npm
object-keys 1.0.12 间接依赖 npm
nan 2.11.1 间接依赖 npm
rc 1.2.8 间接依赖 npm
read-pkg 1.1.0 间接依赖 npm
is-glob 2.0.1 间接依赖 npm
mongodb-core 3.1.9 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
ieee754 1.1.12 间接依赖 npm
psl 1.1.29 间接依赖 npm
realpath-native 1.0.2 间接依赖 npm
mime-types 2.1.21 间接依赖 npm
wrap-ansi 2.1.0 间接依赖 npm
merge-stream 1.0.1 间接依赖 npm
acorn-globals 4.3.0 间接依赖 npm
redis-mock 0.33.0 直接依赖 npm
esprima 3.1.3 间接依赖 npm
base64-js 0.0.8 间接依赖 npm
repeat-string 1.6.1 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
strip-json-comments 2.0.1 间接依赖 npm
babel-helpers 6.24.1 间接依赖 npm
babel-jest 23.6.0 间接依赖 npm
source-map-support 0.5.9 间接依赖 npm
yargs-parser 10.1.0 间接依赖 npm
locate-path 2.0.0 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
delegates 1.0.0 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
nanomatch 1.2.13 直接依赖 npm
for-own 0.1.5 间接依赖 npm
unset-value 1.0.0 间接依赖 npm
jest-get-type 22.4.3 间接依赖 npm
@babel/highlight 7.0.0 间接依赖 npm
collection-visit 1.0.0 间接依赖 npm
bluebird 3.5.3 直接依赖 npm
minimist 0.0.8 间接依赖 npm
ansi-escapes 3.1.0 间接依赖 npm
tar-stream 1.6.2 间接依赖 npm
source-map-url 0.4.0 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
resolve 1.1.7 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
tslib 1.9.3 间接依赖 npm
has-ansi 2.0.0 直接依赖 npm
get-stream 2.3.1 间接依赖 npm
jsesc 1.3.0 间接依赖 npm
braces 2.3.2 间接依赖 npm
write-file-atomic 2.3.0 间接依赖 npm
@types/mongodb 3.1.18 间接依赖 npm
istanbul-reports 1.5.1 间接依赖 npm
mongodb-core 3.1.8 间接依赖 npm
node-notifier 5.3.0 直接依赖 npm
resolve 1.9.0 间接依赖 npm
walker 1.0.7 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
mpath 0.5.1 间接依赖 npm
babel-plugin-istanbul 4.1.6 间接依赖 npm
istanbul-lib-instrument 1.10.2 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
npm-packlist 1.1.12 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
sparse-bitfield 3.0.3 间接依赖 npm
fileset 2.0.3 间接依赖 npm
symbol-tree 3.2.2 间接依赖 npm
has-unicode 2.0.1 间接依赖 npm
js-yaml 3.12.0 间接依赖 npm
ws 5.2.2 间接依赖 npm
debug 4.1.0 间接依赖 npm
detect-indent 4.0.0 间接依赖 npm
object-copy 0.1.0 间接依赖 npm
buffer-alloc-unsafe 1.1.0 间接依赖 npm
mongodb 3.1.10 直接依赖 npm
jest-matcher-utils 23.6.0 间接依赖 npm
throat 4.1.0 间接依赖 npm
getpass 0.1.7 间接依赖 npm
jest-cli 23.6.0 间接依赖 npm
decompress-targz 4.1.1 间接依赖 npm
istanbul-lib-report 1.1.5 间接依赖 npm
ignore-walk 3.0.1 间接依赖 npm
decompress-tarbz2 4.1.1 间接依赖 npm
graceful-fs 4.1.15 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
istanbul-lib-coverage 1.2.1 间接依赖 npm
console-control-strings 1.1.0 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
builtin-modules 1.1.1 间接依赖 npm
expand-range 1.8.2 间接依赖 npm
fb-watchman 2.0.0 间接依赖 npm
append-transform 0.4.0 间接依赖 npm
ret 0.1.15 间接依赖 npm
regenerator-runtime 0.12.1 间接依赖 npm
isstream 0.1.2 间接依赖 npm
babel-register 6.26.0 间接依赖 npm
growly 1.3.0 间接依赖 npm
filename-regex 2.0.1 间接依赖 npm
acorn 5.7.3 间接依赖 npm
class-utils 0.3.6 间接依赖 npm
jsbn 0.1.1 间接依赖 npm
pify 2.3.0 间接依赖 npm
color-name 1.1.3 间接依赖 npm
find-up 3.0.0 间接依赖 npm
ansi-regex 3.0.0 间接依赖 npm
debug 2.6.9 间接依赖 npm
istanbul-api 1.3.7 直接依赖 npm
locate-path 3.0.0 间接依赖 npm
babel-plugin-jest-hoist 23.2.0 间接依赖 npm
es6-promise 4.2.5 间接依赖 npm
argparse 1.0.10 间接依赖 npm
is-number 2.1.0 间接依赖 npm
stealthy-require 1.1.1 间接依赖 npm
arrify 1.0.1 间接依赖 npm
cssstyle 1.1.1 间接依赖 npm
array-unique 0.3.2 间接依赖 npm
seek-bzip 1.0.5 间接依赖 npm
ajv 6.6.2 间接依赖 npm
psl 1.1.31 间接依赖 npm
ms 2.1.1 间接依赖 npm
define-properties 1.1.3 间接依赖 npm
decompress-tar 4.1.1 间接依赖 npm
stack-utils 1.0.2 间接依赖 npm
get-port 4.0.0 间接依赖 npm
https-proxy-agent 2.2.1 间接依赖 npm
fsevents 1.2.4 直接依赖 npm
mongodb-memory-server 2.6.0 直接依赖 npm
object.getownpropertydescriptors 2.0.3 间接依赖 npm
ms 2.0.0 间接依赖 npm
jest-resolve-dependencies 23.6.0 直接依赖 npm
end-of-stream 1.4.1 间接依赖 npm
estraverse 4.2.0 间接依赖 npm
find-up 2.1.0 间接依赖 npm
decompress 4.2.0 间接依赖 npm
xtend 4.0.1 间接依赖 npm
@types/mongodb 3.1.14 间接依赖 npm
needle 2.2.4 间接依赖 npm
jest-environment-jsdom 23.4.0 间接依赖 npm
istanbul-lib-source-maps 1.2.6 间接依赖 npm
lcid 1.0.0 间接依赖 npm
babel-messages 6.23.0 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
glob-base 0.3.0 间接依赖 npm
tslint-config-prettier 1.15.0 直接依赖 npm
codecov 3.1.0 直接依赖 npm
tough-cookie 2.4.3 间接依赖 npm
file-type 3.9.0 间接依赖 npm
redis-parser 2.6.0 间接依赖 npm
buffer-alloc 1.2.0 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
which-module 2.0.0 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
sisteransi 0.1.1 间接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
jest-environment-node 23.4.0 间接依赖 npm
urlgrey 0.4.4 间接依赖 npm
left-pad 1.3.0 间接依赖 npm
semver 5.6.0 间接依赖 npm
regex-cache 0.4.4 间接依赖 npm
use 3.1.1 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
nwsapi 2.0.9 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
detect-newline 2.1.0 间接依赖 npm
is-data-descriptor 0.1.4 间接依赖 npm
extsprintf 1.3.0 间接依赖 npm
isarray 1.0.0 间接依赖 npm
pretty-format 23.6.0 间接依赖 npm
tslint-config-prettier 1.17.0 直接依赖 npm
commander 2.19.0 间接依赖 npm
@types/bson 1.0.11 间接依赖 npm
cliui 4.1.0 间接依赖 npm
bluebird 3.5.1 间接依赖 npm
yallist 3.0.3 间接依赖 npm
are-we-there-yet 1.1.5 间接依赖 npm
split-string 3.1.0 间接依赖 npm
@types/jest 23.3.7 直接依赖 npm
json-schema 0.2.3 间接依赖 npm
array-unique 0.2.1 间接依赖 npm
code-point-at 1.1.0 直接依赖 npm
to-object-path 0.3.0 间接依赖 npm
wordwrap 0.0.3 间接依赖 npm
watch 0.18.0 间接依赖 npm
babel-runtime 6.26.0 间接依赖 npm
jsprim 1.4.1 间接依赖 npm
memory-pager 1.1.0 间接依赖 npm
is-fullwidth-code-point 1.0.0 间接依赖 npm
performance-now 2.1.0 间接依赖 npm
@types/redis 2.8.10 直接依赖 npm
redis-mock 0.41.0 直接依赖 npm
buffer-fill 1.0.0 间接依赖 npm
trim-right 1.0.1 间接依赖 npm
optionator 0.8.2 间接依赖 npm
strip-dirs 2.1.0 间接依赖 npm
@types/jest 23.3.10 直接依赖 npm
lockfile 1.0.4 间接依赖 npm
sliced 1.0.1 间接依赖 npm
getos 3.1.0 间接依赖 npm
inherits 2.0.3 间接依赖 npm
which 1.3.1 间接依赖 npm
fast-json-stable-stringify 2.0.0 间接依赖 npm
sshpk 1.16.0 间接依赖 npm
har-validator 5.1.3 间接依赖 npm
os-homedir 1.0.2 间接依赖 npm
redis-commands 1.4.0 间接依赖 npm
debug 4.1.1 间接依赖 npm
commander 2.8.1 间接依赖 npm
get-stream 3.0.0 间接依赖 npm
strip-ansi 4.0.0 间接依赖 npm
resolve-cwd 2.0.0 间接依赖 npm
diff 3.5.0 间接依赖 npm
to-buffer 1.1.1 间接依赖 npm
gauge 2.7.4 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
cssom 0.3.4 间接依赖 npm
decode-uri-component 0.2.0 间接依赖 npm
assign-symbols 1.0.0 间接依赖 npm
browser-process-hrtime 0.1.3 间接依赖 npm
jest-regex-util 23.3.0 间接依赖 npm
pend 1.2.0 间接依赖 npm
mimic-fn 1.2.0 间接依赖 npm
pinkie 2.0.4 间接依赖 npm
mongoose 5.3.12 直接依赖 npm
@babel/runtime 7.1.5 间接依赖 npm
component-emitter 1.2.1 间接依赖 npm
process-nextick-args 2.0.0 间接依赖 npm
babel-types 6.26.0 间接依赖 npm
co 4.6.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
convert-source-map 1.6.0 间接依赖 npm
kleur 2.0.2 间接依赖 npm
get-value 2.0.6 间接依赖 npm
@babel/code-frame 7.0.0 间接依赖 npm
prettier 1.15.3 直接依赖 npm
jest-util 23.4.0 间接依赖 npm
deep-extend 0.6.0 间接依赖 npm
@babel/runtime 7.2.0 间接依赖 npm
jest-snapshot 23.6.0 间接依赖 npm
jest-changed-files 23.4.2 直接依赖 npm
core-js 2.5.7 间接依赖 npm
import-local 1.0.0 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
execa 0.7.0 间接依赖 npm
source-map 0.5.7 间接依赖 npm
ts-jest 23.10.5 直接依赖 npm
babel-plugin-syntax-object-rest-spread 6.13.0 间接依赖 npm
browser-resolve 1.11.3 间接依赖 npm
jest-each 23.6.0 间接依赖 npm
strip-bom 2.0.0 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
redis 2.8.0 直接依赖 npm
jest-leak-detector 23.6.0 间接依赖 npm
minimist 1.2.0 间接依赖 npm
inflight 1.0.6 间接依赖 npm
chalk 2.4.1 间接依赖 npm
jest-resolve 23.6.0 间接依赖 npm
optimist 0.6.1 间接依赖 npm
mongodb-memory-server 2.9.1 直接依赖 npm
rimraf 2.6.2 直接依赖 npm
is-utf8 0.2.1 间接依赖 npm
wide-align 1.1.3 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
isexe 2.0.0 间接依赖 npm
through 2.3.8 间接依赖 npm
makeerror 1.0.11 间接依赖 npm
snapdragon-node 2.1.1 直接依赖 npm
ecc-jsbn 0.1.2 间接依赖 npm
make-dir 1.3.0 间接依赖 npm
cache-base 1.0.1 间接依赖 npm
prettier 1.14.3 直接依赖 npm
pkg-dir 3.0.0 间接依赖 npm
regenerator-runtime 0.11.1 间接依赖 npm
lodash.keyby 4.6.0 直接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
sax 1.2.4 间接依赖 npm
get-port 4.1.0 间接依赖 npm
acorn-walk 6.1.1 间接依赖 npm
expect 23.6.0 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
fast-deep-equal 2.0.1 间接依赖 npm
whatwg-url 6.5.0 间接依赖 npm
urix 0.1.0 间接依赖 npm
babylon 6.18.0 间接依赖 npm
jest-serializer 23.0.1 间接依赖 npm
get-caller-file 1.0.3 间接依赖 npm
minipass 2.3.5 间接依赖 npm
graceful-readlink 1.0.1 直接依赖 npm
node-pre-gyp 0.10.3 间接依赖 npm
invert-kv 1.0.0 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
jsdom 11.12.0 间接依赖 npm
@types/mongoose 5.2.19 直接依赖 npm
esutils 2.0.2 间接依赖 npm
array-equal 1.0.0 间接依赖 npm
resolve-from 3.0.0 间接依赖 npm
detect-libc 1.0.3 间接依赖 npm
pn 1.1.0 间接依赖 npm
nan 2.12.1 间接依赖 npm
mongodb 3.1.9 间接依赖 npm
string-width 1.0.2 间接依赖 npm
camelcase 4.1.0 间接依赖 npm
file-type 5.2.0 间接依赖 npm
aws-sign2 0.7.0 间接依赖 npm
jest-validate 23.6.0 间接依赖 npm
require-main-filename 1.0.1 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
jest-config 23.6.0 间接依赖 npm
string-length 2.0.0 间接依赖 npm
sane 2.5.2 间接依赖 npm
commander 2.17.1 间接依赖 npm
slash 1.0.0 间接依赖 npm
exit 0.1.2 间接依赖 npm
decompress-unzip 4.0.1 间接依赖 npm
jest-docblock 23.2.0 间接依赖 npm
jest-jasmine2 23.6.0 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
is-dotfile 1.0.3 间接依赖 npm
debug 3.1.0 间接依赖 npm
strip-eof 1.0.0 间接依赖 npm
nopt 4.0.1 间接依赖 npm
ci-info 1.6.0 间接依赖 npm
tough-cookie 2.5.0 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
default-require-extensions 1.0.0 间接依赖 npm
home-or-tmp 2.0.0 间接依赖 npm
is-descriptor 0.1.6 间接依赖 npm
once 1.4.0 间接依赖 npm
is-finite 1.0.2 间接依赖 npm
readable-stream 2.3.6 间接依赖 npm
leven 2.1.0 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
micromatch 2.3.11 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
mixin-deep 1.3.1 间接依赖 npm
kind-of 3.2.2 间接依赖 npm
map-cache 0.2.2 间接依赖 npm
object-visit 1.0.1 间接依赖 npm
whatwg-encoding 1.0.5 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
cross-spawn 5.1.0 间接依赖 npm
request 2.88.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
npm-bundled 1.0.5 间接依赖 npm
oauth-sign 0.9.0 间接依赖 npm
astral-regex 1.0.0 间接依赖 npm
data-urls 1.1.0 间接依赖 npm
to-fast-properties 1.0.3 间接依赖 npm
ts-jest 23.10.4 直接依赖 npm
punycode 1.4.1 间接依赖 npm
async 2.6.1 间接依赖 npm
@types/mongoose 5.3.5 直接依赖 npm
jest-mock 23.2.0 间接依赖 npm
asn1 0.2.4 间接依赖 npm
kareem 2.3.0 间接依赖 npm
arr-diff 2.0.0 间接依赖 npm
is-posix-bracket 0.1.1 间接依赖 npm
bcrypt-pbkdf 1.0.2 间接依赖 npm
pascalcase 0.1.1 间接依赖 npm
is-natural-number 4.0.1 间接依赖 npm
loose-envify 1.4.0 间接依赖 npm
acorn 6.0.4 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
extglob 0.3.2 间接依赖 npm
resolve-url 0.2.1 间接依赖 npm
minizlib 1.2.1 间接依赖 npm
argv 0.0.2 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
resolve-from 2.0.0 间接依赖 npm
agent-base 4.2.1 间接依赖 npm
mem 1.1.0 间接依赖 npm
debug 3.2.6 间接依赖 npm
assert-plus 1.0.0 间接依赖 npm
fs-minipass 1.2.5 间接依赖 npm
kind-of 6.0.2 间接依赖 npm
html-encoding-sniffer 1.0.2 间接依赖 npm
extglob 2.0.4 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
string-width 2.1.1 间接依赖 npm
safe-regex 1.1.0 间接依赖 npm
shellwords 0.1.1 间接依赖 npm
strip-bom 3.0.0 间接依赖 npm
yargs 11.1.0 间接依赖 npm
whatwg-mimetype 2.3.0 间接依赖 npm
lodash.sortby 4.7.0 间接依赖 npm
supports-color 3.2.3 间接依赖 npm
pkg-dir 2.0.0 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
glob 7.1.3 间接依赖 npm
tr46 1.0.1 间接依赖 npm
json5 0.5.1 间接依赖 npm
make-error 1.3.5 间接依赖 npm
capture-exit 1.2.0 间接依赖 npm
commondir 1.0.1 间接依赖 npm
mongoose-legacy-pluralize 1.0.2 间接依赖 npm
is-extendable 0.1.1 间接依赖 npm
lodash.get 4.4.2 间接依赖 npm
globals 9.18.0 间接依赖 npm
private 0.1.8 间接依赖 npm
mime-db 1.37.0 间接依赖 npm
tslint 5.12.0 直接依赖 npm
getos 3.1.1 间接依赖 npm
memory-pager 1.4.0 间接依赖 npm
request-promise-native 1.0.5 间接依赖 npm
isobject 2.1.0 间接依赖 npm
ini 1.3.5 间接依赖 npm
extsprintf 1.4.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
lodash 4.17.11 间接依赖 npm
js-tokens 3.0.2 间接依赖 npm
snapdragon-util 3.0.1 间接依赖 npm
bser 2.0.0 间接依赖 npm
aws4 1.8.0 间接依赖 npm
y18n 3.2.1 间接依赖 npm
tmp 0.0.33 间接依赖 npm
tsutils 2.29.0 间接依赖 npm
jest 23.6.0 直接依赖 npm
tar 4.4.8 间接依赖 npm
osenv 0.1.5 间接依赖 npm
npm-run-path 2.0.2 间接依赖 npm
typescript 3.2.2 直接依赖 npm
for-in 1.0.2 间接依赖 npm
atob 2.1.2 间接依赖 npm
aproba 1.2.0 间接依赖 npm
esprima 4.0.1 间接依赖 npm
w3c-hr-time 1.0.1 间接依赖 npm
es6-promisify 5.0.0 间接依赖 npm
babel-generator 6.26.1 间接依赖 npm
unbzip2-stream 1.3.1 间接依赖 npm
object.omit 2.0.1 间接依赖 npm
tweetnacl 0.14.5 间接依赖 npm
tslint 5.11.0 直接依赖 npm
handlebars 4.0.12 间接依赖 npm
abbrev 1.1.1 间接依赖 npm
@types/node 10.12.0 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
braces 1.8.5 间接依赖 npm
verror 1.10.0 间接依赖 npm
prompts 0.1.14 直接依赖 npm
regexp-clone 0.0.1 间接依赖 npm
fill-range 2.2.4 间接依赖 npm
callsites 2.0.0 间接依赖 npm
fd-slicer 1.1.0 间接依赖 npm
exec-sh 0.2.2 间接依赖 npm
mquery 3.2.0 间接依赖 npm
extend 3.0.2 间接依赖 npm
form-data 2.3.3 间接依赖 npm
bluebird 3.5.2 间接依赖 npm
source-map-support 0.4.18 间接依赖 npm
jest-diff 23.6.0 间接依赖 npm
chownr 1.1.1 间接依赖 npm
test-exclude 4.2.3 间接依赖 npm
typescript 3.1.3 直接依赖 npm
repeat-element 1.1.3 间接依赖 npm
file-type 6.2.0 间接依赖 npm
static-extend 0.1.2 间接依赖 npm
arr-union 3.1.0 间接依赖 npm
util.promisify 1.0.0 间接依赖 npm
pify 3.0.0 间接依赖 npm
map-visit 1.0.0 间接依赖 npm
has-flag 1.0.0 间接依赖 npm
http-signature 1.2.0 间接依赖 npm
fs-constants 1.0.0 间接依赖 npm
is-ci 1.2.1 间接依赖 npm
rsvp 3.6.2 间接依赖 npm
saslprep 1.0.2 直接依赖 npm
is-equal-shallow 0.1.3 间接依赖 npm
request-promise-core 1.1.1 间接依赖 npm
qs 6.5.2 间接依赖 npm
json5 2.1.0 间接依赖 npm
babel-traverse 6.26.0 间接依赖 npm
union-value 1.0.0 间接依赖 npm
node-int64 0.4.0 间接依赖 npm
is-buffer 1.1.6 间接依赖 npm
core-js 2.6.1 间接依赖 npm
jest-message-util 23.4.0 间接依赖 npm
is-accessor-descriptor 0.1.6 间接依赖 npm
tunnel-agent 0.6.0 间接依赖 npm
pluralize 7.0.0 直接依赖 npm
bl 1.2.2 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
npmlog 4.1.2 间接依赖 npm
webidl-conversions 4.0.2 间接依赖 npm
find-cache-dir 2.0.0 间接依赖 npm
combined-stream 1.0.7 间接依赖 npm
jest-runner 23.6.0 直接依赖 npm
yargs-parser 9.0.2 间接依赖 npm
xml-name-validator 3.0.0 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
repeating 2.0.1 间接依赖 npm
normalize-path 2.1.1 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
base 0.11.2 间接依赖 npm
require_optional 1.0.1 间接依赖 npm
jest-runtime 23.6.0 间接依赖 npm
is-generator-fn 1.0.0 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
tmpl 1.0.4 间接依赖 npm
jest-haste-map 23.6.0 间接依赖 npm
define-property 2.0.2 间接依赖 npm
jest-watcher 23.4.0 直接依赖 npm
parse-glob 3.0.4 间接依赖 npm
source-map-resolve 0.5.2 间接依赖 npm
(0)
上一篇 2023年11月7日
下一篇 2023年11月7日

相关推荐

  • beele/homebridge-unifi-protect-camera-motion 软件分析报告

    基础信息 项目名称:beele/homebridge-unifi-protect-camera-motion 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1727517396765728768/172751739…

    软件分析 2023年11月23日
    0
  • alibaba/Sentinel 软件分析报告

    基础信息 项目名称:alibaba/Sentinel 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715695909533958144/1715695909575901184 此报告由Murphysec提供 漏…

    软件分析 2023年10月23日
    0
  • AnyChart/AnyChart 软件分析报告

    基础信息 项目名称:AnyChart/AnyChart 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1725002413754507264/1725002414433984512 此报告由Murphysec提供 …

    软件分析 2023年11月16日
    0
  • CStanKonrad/long_llama 软件分析报告

    基础信息 项目名称:CStanKonrad/long_llama 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721116345076023296/1727776229790539776 此报告由Murphys…

    软件分析 2023年11月24日
    0
  • google/fruit 软件分析报告

    基础信息 项目名称:google/fruit 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721234800034971648/1729615394846494720 此报告由Murphysec提供 漏洞列表 …

    软件分析 2023年11月29日
    0