eneserdogan/trino 软件分析报告

基础信息

项目名称:eneserdogan/trino

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1717452409864503296/1772839038016294912

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Joyent Node.js tough-cookie模块安全漏洞 拒绝服务 MPS-2017-11145 CVE-2017-15010 高危
brace-expansion 安全漏洞 拒绝服务 MPS-2018-1167 CVE-2017-18077 高危
Hoek 访问控制错误漏洞 MAID MPS-2018-3882 CVE-2018-3728 高危
Growl 安全漏洞 OS命令注入 MPS-2018-7026 CVE-2017-16042 严重
debug 模块拒绝服务漏洞 拒绝服务 MPS-2018-7210 CVE-2017-16137 中危
mime模块拒绝服务漏洞 拒绝服务 MPS-2018-7211 CVE-2017-16138 高危
lodash node 拒绝服务漏洞 拒绝服务 MPS-2018-7315 CVE-2018-3721 中危
lodash 存在拒绝服务漏洞 拒绝服务 MPS-2019-1228 CVE-2018-16487 中危
extend module [*, 2.0.2)、[3.0.0, 3.0.2) 原型污染漏洞 注入 MPS-2019-1232 CVE-2018-16492 严重
lodash 不加限制或调节的资源分配 MPS-2019-8123 CVE-2019-1010266 中危
lodash 原型污染漏洞 拒绝服务 MPS-2019-8636 CVE-2019-10744 严重
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Async 原型污染漏洞 原型污染 MPS-2021-34434 CVE-2021-43138 高危
json-schema 安全漏洞 原型污染 MPS-2021-34478 CVE-2021-3918 严重
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
slugify 存在拒绝服务漏洞 拒绝服务 MPS-2022-13097 中危
is-my-json-valid 存在拒绝服务漏洞 拒绝服务 MPS-2022-13795 高危
is-my-json-valid 代码注入 MPS-2022-13796 高危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
mocha 不正确的正则表达式 MPS-2022-13886 中危
Express 中的 qs 模块存在原型污染漏洞 原型污染 MPS-2022-3967 CVE-2022-24999 高危
mocha ReDoS 漏洞 ReDoS MPS-2022-54598 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
hawk 资源管理错误漏洞 拒绝服务 MPS-2022-8568 CVE-2022-29167 高危
vercel ms 安全漏洞 ReDoS MPS-2023-0304 CVE-2017-20162 中危
debug 安全漏洞 ReDoS MPS-2023-0646 CVE-2017-20165 高危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
tough-cookie 原型污染 MPS-esyq-56vx 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
growl 1.9.2 1.10.0 间接依赖 强烈建议修复
hawk 3.1.3 9.0.1 间接依赖 建议修复
lodash 3.10.1 4.17.21 间接依赖 建议修复
brace-expansion 1.1.6 1.1.7 间接依赖 建议修复
debug 2.2.0 2.6.9 间接依赖 建议修复
mocha 3.2.0 直接依赖 建议修复
lodash 4.17.4 4.17.21 间接依赖 建议修复
mime 1.3.4 1.4.1 间接依赖 建议修复
minimist 0.0.8 1.2.6 间接依赖 建议修复
hoek 2.16.3 4.2.1 间接依赖 建议修复
qs 6.4.0 6.4.1 间接依赖 建议修复
qs 6.3.2 6.3.3 间接依赖 建议修复
extend 3.0.0 3.0.2 间接依赖 建议修复
tough-cookie 2.3.2 4.1.3 间接依赖 建议修复
minimatch 3.0.3 3.0.5 间接依赖 建议修复
json-schema 0.2.3 0.4.0 间接依赖 建议修复
minimist 1.2.0 1.2.6 间接依赖 建议修复
is-my-json-valid 2.20.0 2.20.3 间接依赖 建议修复
request 2.76.0 间接依赖 可选修复
request 2.81.0 间接依赖 可选修复
ms 0.7.1 2.0.0 间接依赖 可选修复
ajv 4.11.5 6.12.3 间接依赖 可选修复
slugify 1.1.0 1.3.1 直接依赖 可选修复
async 2.1.5 2.6.4 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 155
ISC 22
Apache-2.0 12
BSD-3-Clause 10
Unlicense 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
xtend 4.0.1 间接依赖 npm
through2 2.0.3 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
lodash._basecopy 3.0.1 间接依赖 npm
once 1.3.3 间接依赖 npm
readable-stream 2.2.6 间接依赖 npm
mocha 3.2.0 直接依赖 npm
exit-hook 1.1.1 间接依赖 npm
has-flag 1.0.0 间接依赖 npm
type-detect 1.0.0 间接依赖 npm
is-stream-ended 0.1.0 间接依赖 npm
lru-cache 4.0.2 间接依赖 npm
uuid 3.0.1 间接依赖 npm
@google-cloud/translate 0.7.0 直接依赖 npm
is-stream 1.1.0 间接依赖 npm
ansi-escapes 1.4.0 间接依赖 npm
concat-stream 1.6.0 间接依赖 npm
npm-run-path 2.0.2 间接依赖 npm
string-width 1.0.2 间接依赖 npm
code-point-at 1.1.0 间接依赖 npm
boom 2.10.1 间接依赖 npm
stringstream 0.0.6 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
minimist 0.0.8 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
lodash.isarray 3.0.4 间接依赖 npm
in-publish 2.0.0 间接依赖 npm
mime-types 2.1.14 间接依赖 npm
propprop 0.3.1 间接依赖 npm
isstream 0.1.2 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
glob 7.0.5 间接依赖 npm
core-js 2.4.1 间接依赖 npm
is-fullwidth-code-point 1.0.0 间接依赖 npm
request 2.81.0 间接依赖 npm
ecc-jsbn 0.1.2 间接依赖 npm
lodash 4.17.4 间接依赖 npm
type-detect 0.1.1 间接依赖 npm
diff 1.4.0 间接依赖 npm
clipboardy 1.0.2 直接依赖 npm
jsbn 0.1.1 间接依赖 npm
ajv 4.11.5 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
mime-db 1.26.0 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
google-p12-pem 0.1.1 间接依赖 npm
qs 6.3.2 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
form-data 2.1.2 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
sshpk 1.16.1 间接依赖 npm
once 1.4.0 间接依赖 npm
inherits 2.0.3 间接依赖 npm
aws-sign2 0.6.0 间接依赖 npm
chalk 1.1.3 间接依赖 npm
stream-events 1.0.1 间接依赖 npm
object-assign 3.0.0 间接依赖 npm
assert-plus 0.2.0 间接依赖 npm
minimatch 3.0.3 间接依赖 npm
isarray 1.0.0 间接依赖 npm
html-tags 1.1.1 间接依赖 npm
execa 0.6.3 间接依赖 npm
lodash.noop 3.0.1 间接依赖 npm
lodash.create 3.1.1 间接依赖 npm
hoek 2.16.3 间接依赖 npm
retry-request 1.3.2 间接依赖 npm
balanced-match 0.4.2 间接依赖 npm
mute-stream 0.0.5 间接依赖 npm
assertion-error 1.0.2 间接依赖 npm
node-uuid 1.4.8 间接依赖 npm
punycode 1.4.1 间接依赖 npm
is 3.2.1 间接依赖 npm
oauth-sign 0.8.2 间接依赖 npm
onetime 2.0.1 间接依赖 npm
typedarray 0.0.6 间接依赖 npm
google-auto-auth 0.5.4 间接依赖 npm
jwa 1.1.5 间接依赖 npm
stream-shift 1.0.0 间接依赖 npm
async 1.5.2 间接依赖 npm
minimist 1.2.0 间接依赖 npm
path-key 2.0.1 间接依赖 npm
strip-eof 1.0.0 间接依赖 npm
number-is-nan 1.0.1 间接依赖 npm
onetime 1.1.0 间接依赖 npm
ora 1.1.0 直接依赖 npm
cli-cursor 1.0.2 间接依赖 npm
sntp 1.0.9 间接依赖 npm
split-array-stream 1.0.0 间接依赖 npm
har-schema 1.0.5 间接依赖 npm
mimic-fn 1.1.0 间接依赖 npm
lodash.isarguments 3.1.0 间接依赖 npm
performance-now 0.2.0 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
array-uniq 1.0.3 间接依赖 npm
run-async 0.1.0 间接依赖 npm
deep-eql 0.1.3 间接依赖 npm
isexe 2.0.0 间接依赖 npm
process-nextick-args 1.0.7 间接依赖 npm
base64url 2.0.0 间接依赖 npm
node-localstorage 0.6.0 间接依赖 npm
which 1.2.14 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
cross-spawn 5.1.0 间接依赖 npm
supports-color 3.1.2 间接依赖 npm
lodash 3.10.1 间接依赖 npm
vorpal 1.11.4 直接依赖 npm
chai 3.5.0 直接依赖 npm
tunnel-agent 0.4.3 间接依赖 npm
assert-plus 1.0.0 间接依赖 npm
bcrypt-pbkdf 1.0.2 间接依赖 npm
lodash.keys 3.1.2 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
readline2 1.0.1 间接依赖 npm
lodash._basecreate 3.0.3 间接依赖 npm
babel-runtime 6.23.0 间接依赖 npm
is-html 1.1.0 间接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
google-auth-library 0.10.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
lodash._baseassign 3.2.0 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
hawk 3.1.3 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
cli-width 1.1.1 间接依赖 npm
lodash._getnative 3.9.1 间接依赖 npm
inquirer 0.11.0 间接依赖 npm
mime 1.3.4 间接依赖 npm
lodash._isiterateecall 3.0.9 间接依赖 npm
gtoken 1.2.2 间接依赖 npm
@google-cloud/common 0.12.2 间接依赖 npm
methmeth 1.1.0 间接依赖 npm
log-update 1.0.2 间接依赖 npm
graceful-readlink 1.0.1 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
ms 0.7.1 间接依赖 npm
cryptiles 2.0.5 间接依赖 npm
tweetnacl 0.14.5 间接依赖 npm
extend 3.0.0 间接依赖 npm
get-stream 3.0.0 间接依赖 npm
duplexify 3.5.0 间接依赖 npm
create-error-class 3.0.2 间接依赖 npm
http-signature 1.1.1 间接依赖 npm
cli-spinners 1.0.0 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
har-validator 2.0.6 间接依赖 npm
debug 2.2.0 间接依赖 npm
cli-cursor 2.1.0 间接依赖 npm
string-format-obj 1.1.0 间接依赖 npm
wrap-ansi 2.1.0 间接依赖 npm
stubs 1.1.2 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
qs 6.4.0 间接依赖 npm
brace-expansion 1.1.6 间接依赖 npm
yallist 2.1.2 间接依赖 npm
log-driver 1.2.5 间接依赖 npm
inflight 1.0.6 间接依赖 npm
capture-stack-trace 1.0.0 间接依赖 npm
request 2.76.0 间接依赖 npm
json-schema 0.2.3 间接依赖 npm
getpass 0.1.7 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
modelo 4.2.0 间接依赖 npm
json3 3.3.2 间接依赖 npm
har-validator 4.2.1 间接依赖 npm
regenerator-runtime 0.10.3 间接依赖 npm
figures 1.7.0 间接依赖 npm
caseless 0.12.0 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
safe-buffer 5.0.1 间接依赖 npm
combined-stream 1.0.5 间接依赖 npm
is-my-json-valid 2.20.0 间接依赖 npm
restore-cursor 1.0.1 间接依赖 npm
ent 2.2.0 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
extsprintf 1.0.2 间接依赖 npm
asn1 0.2.4 间接依赖 npm
has-ansi 2.0.0 间接依赖 npm
jsprim 1.4.0 间接依赖 npm
slugify 1.1.0 直接依赖 npm
buffer-shims 1.0.0 间接依赖 npm
aws4 1.6.0 间接依赖 npm
json-stable-stringify 1.0.1 间接依赖 npm
tunnel-agent 0.6.0 间接依赖 npm
tough-cookie 2.3.2 间接依赖 npm
browser-stdout 1.3.0 间接依赖 npm
commander 2.9.0 间接依赖 npm
arrify 1.0.1 间接依赖 npm
string_decoder 0.10.31 间接依赖 npm
jws 3.1.4 间接依赖 npm
end-of-stream 1.0.0 间接依赖 npm
restore-cursor 2.0.0 间接依赖 npm
babel-polyfill 6.23.0 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
verror 1.3.6 间接依赖 npm
caseless 0.11.0 间接依赖 npm
co 4.6.0 间接依赖 npm
rx-lite 3.1.2 间接依赖 npm
async 2.1.5 间接依赖 npm
log-symbols 1.0.2 间接依赖 npm
growl 1.9.2 间接依赖 npm
through 2.3.8 间接依赖 npm
(0)
上一篇 2024年3月18日
下一篇 2024年3月27日

相关推荐

  • scylladb/seastar 软件分析报告

    基础信息 项目名称:scylladb/seastar 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1744214008266272768/1744214019536367616 此报告由Murphysec提供 漏…

    软件分析 2024年1月8日
    0
  • carabina/JCBannerView 软件分析报告

    基础信息 项目名称:carabina/JCBannerView 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716572564989198336/1716572565224079360 此报告由Murphyse…

    软件分析 2023年10月24日
    0
  • esilverberg/ios-image-filters 软件分析报告

    基础信息 项目名称:esilverberg/ios-image-filters 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717512303074394112/1717512303120531456 此报告由…

    软件分析 2023年10月26日
    0
  • dotnet/interactive 软件分析报告

    基础信息 项目名称:dotnet/interactive 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721142320799223808/1722751475246911488 此报告由Murphysec提供…

    软件分析 2023年11月10日
    0
  • blurooo/bobolink 软件分析报告

    基础信息 项目名称:blurooo/bobolink 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716394146062450688/1716394167432429568 此报告由Murphysec提供 漏…

    软件分析 2023年10月23日
    0