Tonejs/Tone.js 软件分析报告

基础信息

项目名称:Tonejs/Tone.js

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1746833139156287488/1765172974314274816

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
socket.io 拒绝服务漏洞 拒绝服务 MPS-15wb-xgoz CVE-2023-32695 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
mocha ReDoS 漏洞 ReDoS MPS-2022-54598 高危
Tauri 原型污染漏洞 原型污染 MPS-2022-65568 CVE-2022-46175 高危
word-wrap 安全漏洞 ReDoS MPS-2023-5109 CVE-2023-26115 高危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
follow-redirects 输入验证不恰当 MPS-2023-5153 CVE-2023-26159 高危
Webpack 安全漏洞 MPS-2023-7721 CVE-2023-28154 严重
Babel 插件任意代码执行漏洞漏洞 不完整的黑名单 MPS-avb9-j50z CVE-2023-45133 严重
Engine.IO 存在拒绝服务漏洞 MPS-b79p-4aco CVE-2023-31125 中危
get-func-name 安全漏洞 ReDoS MPS-cyhe-l36p CVE-2023-43646 高危
tough-cookie 原型污染 MPS-esyq-56vx 中危
browserify-sign 密码学签名的验证不恰当 MPS-gimb-o69n CVE-2023-46234 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
follow-redirects 1.15.1 1.15.4 间接依赖 强烈建议修复
tough-cookie 4.1.2 4.1.3 间接依赖 建议修复
socket.io-parser 4.2.1 4.2.3 间接依赖 建议修复
json5 0.5.1 1.0.2 间接依赖 建议修复
engine.io 6.2.1 6.4.2 间接依赖 建议修复
word-wrap 1.2.3 1.2.4 间接依赖 建议修复
@babel/traverse 7.18.13 7.23.2 间接依赖 建议修复
mocha 9.2.2 直接依赖 建议修复
webpack 5.74.0 5.76.0 直接依赖 建议修复
get-func-name 2.0.0 2.0.1 间接依赖 建议修复
semver 5.7.1 7.5.2 间接依赖 可选修复
browserify-sign 4.2.1 4.2.2 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 587
BSD-2-Clause 21
BSD-3-Clause 20
ISC 36
Apache-2.0 12
BSD 2
CC-BY-3.0 1
CC0-1.0 1
0BSD 1
CC-BY-4.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
shiki 0.12.1 间接依赖 npm
ajv-keywords 3.5.2 间接依赖 npm
estraverse 4.3.0 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
convert-source-map 1.8.0 间接依赖 npm
xtend 4.0.2 间接依赖 npm
is-core-module 2.10.0 间接依赖 npm
browserslist 4.21.3 间接依赖 npm
socket.io-adapter 2.4.0 间接依赖 npm
p-try 2.2.0 直接依赖 npm
enquirer 2.3.6 间接依赖 npm
clone 1.0.4 间接依赖 npm
entities 3.0.1 间接依赖 npm
@webpack-cli/info 1.5.0 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
@babel/core 7.18.13 间接依赖 npm
connect 3.7.0 间接依赖 npm
babel-helper-get-function-arity 6.24.1 间接依赖 npm
check-error 1.0.2 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
os-browserify 0.3.0 间接依赖 npm
ignore-walk 3.0.4 间接依赖 npm
tmp-promise 2.1.1 直接依赖 npm
which 1.3.1 间接依赖 npm
asn1.js 5.4.1 间接依赖 npm
fastq 1.13.0 间接依赖 npm
tsutils 3.21.0 间接依赖 npm
negotiator 0.6.3 间接依赖 npm
http-errors 2.0.0 间接依赖 npm
@socket.io/component-emitter 3.1.0 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
ent 2.2.0 间接依赖 npm
fast-url-parser 1.1.3 间接依赖 npm
fs-extra 8.1.0 间接依赖 npm
@babel/helper-validator-option 7.18.6 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
isarray 1.0.0 直接依赖 npm
fastest-levenshtein 1.0.16 间接依赖 npm
node-fetch 2.6.7 间接依赖 npm
is-string 1.0.7 间接依赖 npm
no-case 3.0.4 间接依赖 npm
clone-deep 4.0.1 间接依赖 npm
loose-envify 1.4.0 间接依赖 npm
minimatch 3.1.2 间接依赖 npm
css-what 6.1.0 间接依赖 npm
has-tostringtag 1.0.0 间接依赖 npm
secure-compare 3.0.1 间接依赖 npm
babel-plugin-syntax-class-properties 6.13.0 间接依赖 npm
babylon 6.18.0 间接依赖 npm
progress 2.0.3 间接依赖 npm
babel-plugin-transform-es2015-computed-properties 6.24.1 间接依赖 npm
babel-plugin-transform-es2015-literals 6.22.0 间接依赖 npm
typedoc 0.23.24 直接依赖 npm
minimalistic-crypto-utils 1.0.1 间接依赖 npm
miller-rabin 4.0.1 间接依赖 npm
@humanwhocodes/config-array 0.5.0 间接依赖 npm
acorn-walk 7.2.0 间接依赖 npm
@types/node 18.7.15 间接依赖 npm
babel-plugin-transform-regenerator 6.26.0 间接依赖 npm
picomatch 2.3.1 间接依赖 npm
@colors/colors 1.5.0 间接依赖 npm
babel-preset-stage-1 6.24.1 间接依赖 npm
minimist 1.2.6 间接依赖 npm
pascal-case 3.1.2 间接依赖 npm
marked 4.2.12 间接依赖 npm
on-finished 2.4.1 间接依赖 npm
babel-plugin-transform-es2015-sticky-regex 6.24.1 间接依赖 npm
tapable 2.2.1 间接依赖 npm
hash-base 3.1.0 间接依赖 npm
vscode-oniguruma 1.7.0 间接依赖 npm
tr46 2.1.0 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
basic-auth 1.1.0 间接依赖 npm
karma 6.4.0 直接依赖 npm
jest-worker 27.5.1 间接依赖 npm
fsevents 2.3.2 间接依赖 npm
destroy 1.2.0 间接依赖 npm
spdx-expression-parse 3.0.1 间接依赖 npm
ansi-colors 4.1.3 间接依赖 npm
has-flag 3.0.0 直接依赖 npm
teeny-request 7.1.1 间接依赖 npm
terser-webpack-plugin 5.3.6 间接依赖 npm
babel-plugin-transform-es2015-block-scoped-functions 6.22.0 间接依赖 npm
dot-case 3.0.4 间接依赖 npm
dom-serialize 2.2.1 间接依赖 npm
babel-plugin-transform-class-properties 6.24.1 间接依赖 npm
is-nan 1.3.2 间接依赖 npm
readable-stream 3.6.0 间接依赖 npm
webpack-merge 5.8.0 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
@babel/helper-function-name 7.18.9 间接依赖 npm
finalhandler 1.1.2 间接依赖 npm
daccord 1.1.0 间接依赖 npm
p-limit 3.1.0 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
pitch-fq 1.0.0 间接依赖 npm
babel-plugin-transform-es2015-for-of 6.23.0 间接依赖 npm
babel-plugin-transform-es2015-duplicate-keys 6.24.1 间接依赖 npm
combine-source-map 0.8.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
range-parser 1.2.1 间接依赖 npm
cssstyle 2.3.0 间接依赖 npm
globals 9.18.0 间接依赖 npm
console-browserify 1.2.0 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
serialize-javascript 6.0.0 间接依赖 npm
eslint-plugin-html 6.2.0 直接依赖 npm
resolve-cwd 3.0.0 间接依赖 npm
@nodelib/fs.scandir 2.1.5 间接依赖 npm
ws 7.5.9 间接依赖 npm
color-name 1.1.3 间接依赖 npm
is-fullwidth-code-point 3.0.0 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
babel-messages 6.23.0 间接依赖 npm
es6-object-assign 1.1.0 间接依赖 npm
word-wrap 1.2.3 间接依赖 npm
statuses 1.5.0 间接依赖 npm
@babel/helper-validator-identifier 7.18.6 间接依赖 npm
loupe 2.3.4 间接依赖 npm
buffer-xor 1.0.3 间接依赖 npm
querystringify 2.2.0 间接依赖 npm
babel-plugin-transform-decorators 6.24.1 间接依赖 npm
rfdc 1.3.0 间接依赖 npm
@discoveryjs/json-ext 0.5.7 间接依赖 npm
hmac-drbg 1.0.1 间接依赖 npm
escalade 3.1.1 间接依赖 npm
pkg-dir 4.2.0 间接依赖 npm
domelementtype 2.3.0 间接依赖 npm
@webassemblyjs/utf8 1.11.1 间接依赖 npm
yargs-parser 20.2.4 间接依赖 npm
domutils 2.8.0 间接依赖 npm
jsdom 16.7.0 直接依赖 npm
notecoord 1.1.0 间接依赖 npm
p-locate 5.0.0 间接依赖 npm
source-map-support 0.4.18 间接依赖 npm
ieee754 1.2.1 间接依赖 npm
content-type 1.0.4 间接依赖 npm
babel-plugin-transform-es2015-shorthand-properties 6.24.1 间接依赖 npm
automation-events 5.0.0 间接依赖 npm
minimalistic-assert 1.0.1 间接依赖 npm
istanbul-lib-source-maps 4.0.1 间接依赖 npm
regexp.prototype.flags 1.4.3 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
is-generator-function 1.0.10 间接依赖 npm
brorand 1.1.0 间接依赖 npm
import-fresh 3.3.0 间接依赖 npm
babel-plugin-syntax-export-extensions 6.13.0 间接依赖 npm
create-hmac 1.1.7 间接依赖 npm
object-inspect 1.12.2 间接依赖 npm
inflight 1.0.6 间接依赖 npm
saxes 5.0.1 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
babel-plugin-syntax-dynamic-import 6.18.0 间接依赖 npm
boolbase 1.0.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
browser-resolve 2.0.0 间接依赖 npm
html-encoding-sniffer 2.0.1 间接依赖 npm
regenerator-transform 0.10.1 间接依赖 npm
mime-db 1.52.0 间接依赖 npm
ms 2.1.2 间接依赖 npm
is-docker 2.2.1 间接依赖 npm
which-boxed-primitive 1.0.2 间接依赖 npm
table 6.8.0 间接依赖 npm
url 0.11.0 间接依赖 npm
spdx-exceptions 2.3.0 间接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
@webassemblyjs/wast-printer 1.11.1 间接依赖 npm
@types/chai 4.3.3 直接依赖 npm
enhanced-resolve 4.5.0 间接依赖 npm
w3c-hr-time 1.0.2 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
custom-event 1.0.1 间接依赖 npm
eslint-plugin-jsdoc 36.1.1 直接依赖 npm
async 3.2.4 间接依赖 npm
js-tokens 3.0.2 间接依赖 npm
process-nextick-args 2.0.1 直接依赖 npm
for-each 0.3.3 间接依赖 npm
babel-plugin-transform-strict-mode 6.24.1 间接依赖 npm
wildcard 2.0.0 间接依赖 npm
chrome-trace-event 1.0.3 间接依赖 npm
plotly.js-dist 1.58.5 间接依赖 npm
babel-plugin-check-es2015-constants 6.22.0 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
ee-first 1.1.1 间接依赖 npm
mime 1.6.0 间接依赖 npm
is-binary-path 2.1.0 间接依赖 npm
find-up 5.0.0 间接依赖 npm
extend 3.0.2 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
yn 3.1.1 间接依赖 npm
babel-helper-optimise-call-expression 6.24.1 间接依赖 npm
stream-http 3.2.0 间接依赖 npm
@babel/parser 7.18.13 间接依赖 npm
media-typer 0.3.0 间接依赖 npm
babel-helper-explode-class 6.24.1 间接依赖 npm
@es-joy/jsdoccomment 0.10.8 间接依赖 npm
regexpu-core 2.0.0 间接依赖 npm
log-symbols 4.1.0 间接依赖 npm
arg 4.1.3 间接依赖 npm
@webpack-cli/serve 1.7.0 间接依赖 npm
which-typed-array 1.1.8 间接依赖 npm
istanbul-lib-instrument 5.2.0 间接依赖 npm
karma-coverage 2.2.0 直接依赖 npm
process 0.11.10 间接依赖 npm
string_decoder 1.3.0 间接依赖 npm
whatwg-url 8.7.0 间接依赖 npm
karma-sourcemap-loader 0.3.8 直接依赖 npm
@babel/helper-string-parser 7.18.10 间接依赖 npm
universalify 0.1.2 间接依赖 npm
esquery 1.4.0 间接依赖 npm
date-format 4.0.13 间接依赖 npm
colorette 2.0.19 间接依赖 npm
@types/eslint 8.4.6 间接依赖 npm
@webassemblyjs/wasm-parser 1.11.1 间接依赖 npm
babel-plugin-transform-object-rest-spread 6.26.0 间接依赖 npm
babel-plugin-transform-es2015-modules-systemjs 6.24.1 间接依赖 npm
tough-cookie 4.1.2 间接依赖 npm
@typescript-eslint/utils 5.36.1 间接依赖 npm
webidl-conversions 6.1.0 间接依赖 npm
regexpp 3.2.0 间接依赖 npm
babel-plugin-transform-es2015-template-literals 6.22.0 间接依赖 npm
inherits 2.0.4 间接依赖 npm
w3c-xmlserializer 2.0.0 间接依赖 npm
requires-port 1.0.0 间接依赖 npm
raw-body 2.5.1 间接依赖 npm
emoji-regex 8.0.0 间接依赖 npm
lru-cache 4.1.5 间接依赖 npm
balanced-match 1.0.2 间接依赖 npm
@webassemblyjs/ieee754 1.11.1 间接依赖 npm
callsites 3.1.0 间接依赖 npm
stream-browserify 3.0.0 间接依赖 npm
abab 2.0.6 间接依赖 npm
lodash.memoize 3.0.4 间接依赖 npm
acorn-jsx 5.3.2 间接依赖 npm
merge2 1.4.1 间接依赖 npm
browser-process-hrtime 1.0.0 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
@jridgewell/set-array 1.1.2 间接依赖 npm
psl 1.9.0 间接依赖 npm
available-typed-arrays 1.0.5 间接依赖 npm
ajv 6.12.6 间接依赖 npm
colors 1.4.0 间接依赖 npm
yallist 2.1.2 间接依赖 npm
@babel/generator 7.18.13 间接依赖 npm
comment-parser 1.2.4 间接依赖 npm
querystring 0.2.0 间接依赖 npm
babel-preset-stage-3 6.24.1 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
browserify-rsa 4.1.0 间接依赖 npm
@babel/helper-module-transforms 7.18.9 间接依赖 npm
has 1.0.3 间接依赖 npm
karma-safari-launcher 1.0.0 直接依赖 npm
vscode-textmate 8.0.0 间接依赖 npm
setprototypeof 1.2.0 间接依赖 npm
source-map 0.5.7 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
@babel/traverse 7.18.13 间接依赖 npm
timers-browserify 2.0.12 间接依赖 npm
crypto-browserify 3.12.0 间接依赖 npm
regenerate 1.4.2 间接依赖 npm
watchpack 2.4.0 间接依赖 npm
buffer-from 1.1.2 直接依赖 npm
flatted 3.2.7 间接依赖 npm
qjobs 1.2.0 间接依赖 npm
terser 5.15.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
@types/cors 2.8.12 间接依赖 npm
once 1.4.0 间接依赖 npm
browserify-des 1.0.2 间接依赖 npm
os-homedir 1.0.2 间接依赖 npm
type-fest 0.20.2 直接依赖 npm
vm-browserify 1.1.2 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
define-properties 1.1.4 间接依赖 npm
espree 7.3.1 间接依赖 npm
babel-plugin-transform-es2015-destructuring 6.23.0 间接依赖 npm
@babel/helpers 7.18.9 间接依赖 npm
home-or-tmp 2.0.0 间接依赖 npm
html-minifier-terser 6.1.0 间接依赖 npm
scientific-notation 1.0.2 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
parse-asn1 5.1.6 间接依赖 npm
stream-events 1.0.5 间接依赖 npm
@webpack-cli/configtest 1.2.0 间接依赖 npm
url-parse 1.5.10 间接依赖 npm
babel-helper-define-map 6.26.0 间接依赖 npm
babel-plugin-transform-es2015-spread 6.22.0 间接依赖 npm
renderkid 3.0.0 间接依赖 npm
deep-is 0.1.4 间接依赖 npm
audiobuffer-to-wav 1.0.0 间接依赖 npm
follow-redirects 1.15.1 间接依赖 npm
binary-extensions 2.2.0 间接依赖 npm
camel-case 4.1.2 间接依赖 npm
is-callable 1.2.4 间接依赖 npm
babel-generator 6.26.1 间接依赖 npm
karma-chrome-launcher 2.2.0 直接依赖 npm
get-func-name 2.0.0 间接依赖 npm
fast-glob 3.2.11 间接依赖 npm
pad 3.2.0 间接依赖 npm
exit 0.1.2 间接依赖 npm
babel-register 6.26.0 间接依赖 npm
picocolors 1.0.0 间接依赖 npm
@humanwhocodes/object-schema 1.2.1 间接依赖 npm
glob 7.2.3 间接依赖 npm
babel-plugin-syntax-decorators 6.13.0 间接依赖 npm
array2d 0.0.5 间接依赖 npm
@jridgewell/source-map 0.3.2 间接依赖 npm
babel-plugin-transform-es2015-modules-amd 6.24.1 间接依赖 npm
vary 1.1.2 间接依赖 npm
fs-access 1.0.1 间接依赖 npm
slash 1.0.0 间接依赖 npm
diffie-hellman 5.0.3 间接依赖 npm
karma-typescript 5.5.3 直接依赖 npm
engine.io 6.2.1 间接依赖 npm
is-negative-zero 2.0.2 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
is-wsl 2.2.0 间接依赖 npm
is-symbol 1.0.4 间接依赖 npm
babel-plugin-transform-class-constructor-call 6.24.1 间接依赖 npm
log4js 6.6.1 间接依赖 npm
@babel/highlight 7.18.6 间接依赖 npm
object.assign 4.1.4 间接依赖 npm
@webassemblyjs/ast 1.11.1 间接依赖 npm
prelude-ls 1.2.1 间接依赖 npm
@babel/helper-compilation-targets 7.18.9 间接依赖 npm
graceful-fs 4.2.10 间接依赖 npm
locate-path 6.0.0 间接依赖 npm
pako 1.0.11 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
babel-plugin-transform-es2015-function-name 6.24.1 间接依赖 npm
domain-browser 4.22.0 间接依赖 npm
http-proxy 1.18.1 间接依赖 npm
memory-fs 0.5.0 间接依赖 npm
babel-plugin-transform-async-to-generator 6.24.1 间接依赖 npm
has-symbols 1.0.3 间接依赖 npm
emojis-list 3.0.0 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
eslint-utils 3.0.0 间接依赖 npm
portfinder 1.0.32 间接依赖 npm
typescript 4.8.2 直接依赖 npm
string.prototype.trimstart 1.0.5 间接依赖 npm
cookie 0.4.2 间接依赖 npm
dom-serializer 1.4.1 间接依赖 npm
dom-converter 0.2.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
@babel/helper-hoist-variables 7.18.6 间接依赖 npm
camelcase 6.3.0 间接依赖 npm
eslint-scope 5.1.1 间接依赖 npm
regenerator-runtime 0.11.1 间接依赖 npm
sha.js 2.4.11 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
get-intrinsic 1.1.2 间接依赖 npm
path-key 3.1.1 直接依赖 npm
strip-json-comments 3.1.1 间接依赖 npm
get-symbol-description 1.0.0 间接依赖 npm
@typescript-eslint/scope-manager 5.36.1 间接依赖 npm
globby 11.1.0 间接依赖 npm
string-width 4.2.3 间接依赖 npm
path-type 4.0.0 间接依赖 npm
ripemd160 2.0.2 间接依赖 npm
@typescript-eslint/eslint-plugin 5.36.1 直接依赖 npm
loader-utils 1.4.2 间接依赖 npm
browserify-cipher 1.0.1 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
@eslint/eslintrc 0.4.3 间接依赖 npm
acorn 7.4.1 间接依赖 npm
to-fast-properties 1.0.3 间接依赖 npm
domexception 2.0.1 间接依赖 npm
evp_bytestokey 1.0.3 间接依赖 npm
side-channel 1.0.4 间接依赖 npm
spdx-license-ids 3.0.12 间接依赖 npm
depd 2.0.0 间接依赖 npm
babel-core 6.26.3 间接依赖 npm
core-js 2.6.12 间接依赖 npm
@types/estree 0.0.51 间接依赖 npm
uuid 8.3.2 间接依赖 npm
doctrine 3.0.0 间接依赖 npm
@types/json-schema 7.0.11 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
esrecurse 4.3.0 间接依赖 npm
fft-windowing 0.1.4 间接依赖 npm
is-shared-array-buffer 1.0.2 间接依赖 npm
yargs-unparser 2.0.0 间接依赖 npm
assert 2.0.0 间接依赖 npm
decimal.js 10.4.0 间接依赖 npm
babel-preset-stage-2 6.24.1 间接依赖 npm
null-check 1.0.0 间接依赖 npm
cliui 7.0.4 间接依赖 npm
util 0.12.4 间接依赖 npm
yargs 17.5.1 间接依赖 npm
babel-types 6.26.0 间接依赖 npm
@typescript-eslint/parser 5.36.1 直接依赖 npm
babel-preset-stage-0 6.24.1 间接依赖 npm
optionator 0.9.1 间接依赖 npm
is-weakref 1.0.2 间接依赖 npm
babel-plugin-transform-export-extensions 6.22.0 间接依赖 npm
cors 2.8.5 间接依赖 npm
ts-loader 7.0.5 直接依赖 npm
base64-js 1.5.1 间接依赖 npm
@webassemblyjs/wasm-edit 1.11.1 间接依赖 npm
istanbul-lib-report 3.0.0 间接依赖 npm
unbox-primitive 1.0.2 间接依赖 npm
@types/html-minifier-terser 6.1.0 间接依赖 npm
corser 2.0.1 间接依赖 npm
micromatch 4.0.5 间接依赖 npm
astral-regex 2.0.0 间接依赖 npm
babel-template 6.26.0 间接依赖 npm
mocha 9.2.2 直接依赖 npm
chai 4.3.6 直接依赖 npm
browserify-zlib 0.2.0 间接依赖 npm
jsonc-parser 3.2.0 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
@types/mocha 5.2.7 直接依赖 npm
core-util-is 1.0.3 直接依赖 npm
big.js 5.2.2 间接依赖 npm
node-releases 2.0.6 间接依赖 npm
babel-helper-call-delegate 6.24.1 间接依赖 npm
cross-spawn 5.1.0 间接依赖 npm
braces 3.0.2 间接依赖 npm
is-unicode-supported 0.1.0 间接依赖 npm
babel-plugin-transform-async-generator-functions 6.24.1 间接依赖 npm
param-case 3.0.4 间接依赖 npm
cipher-base 1.0.4 间接依赖 npm
form-data 3.0.1 间接依赖 npm
update-browserslist-db 1.0.7 间接依赖 npm
@babel/template 7.18.10 间接依赖 npm
babel-plugin-transform-es2015-modules-commonjs 6.26.2 间接依赖 npm
escodegen 2.0.0 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
html-webpack-plugin 5.5.0 直接依赖 npm
xml-name-validator 3.0.0 间接依赖 npm
babel-plugin-transform-es2015-block-scoping 6.26.0 间接依赖 npm
commander 8.3.0 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
ignore 5.2.0 间接依赖 npm
semver 5.7.1 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
md5.js 1.3.5 间接依赖 npm
engine.io-parser 5.0.4 间接依赖 npm
levn 0.4.1 间接依赖 npm
builtin-status-codes 3.0.0 间接依赖 npm
url-join 2.0.5 间接依赖 npm
babel-plugin-syntax-function-bind 6.13.0 间接依赖 npm
@typescript-eslint/typescript-estree 5.36.1 间接依赖 npm
is-arguments 1.1.1 间接依赖 npm
loader-runner 4.3.0 间接依赖 npm
@babel/runtime 7.20.13 间接依赖 npm
debug 4.3.4 间接依赖 npm
argparse 1.0.10 间接依赖 npm
toidentifier 1.0.1 间接依赖 npm
@babel/types 7.18.13 间接依赖 npm
@babel/helper-split-export-declaration 7.18.6 间接依赖 npm
karma-mocha 2.0.1 直接依赖 npm
@types/ua-parser-js 0.7.36 直接依赖 npm
constants-browserify 1.0.0 间接依赖 npm
streamroller 3.1.2 间接依赖 npm
socket.io-parser 4.2.1 间接依赖 npm
babel-runtime 6.26.0 间接依赖 npm
@webassemblyjs/helper-wasm-section 1.11.1 间接依赖 npm
require-from-string 2.0.2 直接依赖 npm
randombytes 2.1.0 间接依赖 npm
cssom 0.4.4 间接依赖 npm
istanbul-reports 3.1.5 间接依赖 npm
qs 6.10.3 间接依赖 npm
es-to-primitive 1.2.1 间接依赖 npm
has-bigints 1.0.2 间接依赖 npm
http-proxy-agent 4.0.1 间接依赖 npm
babel-plugin-transform-do-expressions 6.22.0 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
lodash.truncate 4.4.2 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
trim-right 1.0.1 间接依赖 npm
is-date-object 1.0.5 间接依赖 npm
istanbul-lib-coverage 3.2.0 间接依赖 npm
helmholtz 2.0.2 间接依赖 npm
gensync 1.0.0-beta.2 间接依赖 npm
webpack-cli 4.10.0 直接依赖 npm
@xtuc/long 4.2.2 间接依赖 npm
diff 4.0.2 间接依赖 npm
parse5 6.0.1 间接依赖 npm
elliptic 6.5.4 间接依赖 npm
karma-firefox-launcher 1.3.0 直接依赖 npm
@webassemblyjs/helper-api-error 1.11.1 间接依赖 npm
querystring-es3 0.2.1 间接依赖 npm
esprima 4.0.1 间接依赖 npm
argv 0.0.2 间接依赖 npm
regjsparser 0.1.5 间接依赖 npm
mkdirp 0.5.6 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
browserify-sign 4.2.1 间接依赖 npm
encodeurl 1.0.2 间接依赖 npm
webpack-sources 3.2.3 间接依赖 npm
create-ecdh 4.0.4 间接依赖 npm
babel-plugin-transform-es2015-typeof-symbol 6.23.0 间接依赖 npm
type-detect 4.0.8 间接依赖 npm
schema-utils 3.1.1 间接依赖 npm
pbkdf2 3.1.2 间接依赖 npm
urlgrey 1.0.0 间接依赖 npm
shallow-clone 3.0.1 间接依赖 npm
interval-coords 1.1.1 间接依赖 npm
stubs 3.0.0 间接依赖 npm
mime-types 2.1.35 间接依赖 npm
eslint 7.32.0 直接依赖 npm
void-elements 2.0.1 间接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
yocto-queue 0.1.0 间接依赖 npm
chalk 1.1.3 间接依赖 npm
data-urls 2.0.0 间接依赖 npm
babel-plugin-syntax-trailing-function-commas 6.22.0 间接依赖 npm
accepts 1.3.8 间接依赖 npm
@typescript-eslint/visitor-keys 5.36.1 间接依赖 npm
text-table 0.2.0 间接依赖 npm
browser-stdout 1.3.1 间接依赖 npm
hash.js 1.1.7 间接依赖 npm
webpack 5.74.0 直接依赖 npm
babel-helper-replace-supers 6.24.1 间接依赖 npm
@types/eslint-scope 3.7.4 间接依赖 npm
nth-check 2.1.1 间接依赖 npm
es-module-lexer 0.9.3 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
tslib 2.4.1 间接依赖 npm
tty-browserify 0.0.1 间接依赖 npm
showdown 2.1.0 直接依赖 npm
nwsapi 2.2.2 间接依赖 npm
path-browserify 1.0.1 间接依赖 npm
@ampproject/remapping 2.2.0 间接依赖 npm
jsdoc-type-pratt-parser 1.2.0 间接依赖 npm
clean-css 5.3.1 间接依赖 npm
bytes 3.1.2 间接依赖 npm
glob-to-regexp 0.4.1 间接依赖 npm
karma-spec-reporter 0.0.32 直接依赖 npm
combined-stream 1.0.8 间接依赖 npm
babel-helper-regex 6.26.0 间接依赖 npm
workerpool 6.2.0 间接依赖 npm
babel-plugin-transform-es2015-arrow-functions 6.22.0 间接依赖 npm
tmp 0.2.1 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
babel-plugin-transform-es2015-modules-umd 6.24.1 间接依赖 npm
call-bind 1.0.2 间接依赖 npm
array-union 2.1.0 间接依赖 npm
electron-to-chromium 1.4.241 间接依赖 npm
regjsgen 0.2.0 间接依赖 npm
@typescript-eslint/type-utils 5.36.1 间接依赖 npm
js-yaml 3.14.1 间接依赖 npm
type-is 1.6.18 间接依赖 npm
cross-var 1.1.0 直接依赖 npm
setimmediate 1.0.5 间接依赖 npm
lodash 4.17.21 间接依赖 npm
v8-compile-cache 2.3.0 间接依赖 npm
@babel/code-frame 7.12.11 间接依赖 npm
relateurl 0.2.7 间接依赖 npm
@nodelib/fs.walk 1.2.8 间接依赖 npm
domhandler 4.3.1 间接依赖 npm
has-property-descriptors 1.0.0 间接依赖 npm
is-typed-array 1.1.9 间接依赖 npm
is-plain-obj 2.1.0 间接依赖 npm
@webassemblyjs/helper-buffer 1.11.1 间接依赖 npm
codecov 3.8.3 直接依赖 npm
@typescript-eslint/types 5.36.1 间接依赖 npm
babel-plugin-transform-exponentiation-operator 6.24.1 间接依赖 npm
opener 1.5.2 间接依赖 npm
acorn-globals 6.0.0 间接依赖 npm
readdirp 3.6.0 间接依赖 npm
lower-case 2.0.2 间接依赖 npm
dir-glob 3.0.1 间接依赖 npm
accidental-value 1.0.0 间接依赖 npm
private 0.1.8 间接依赖 npm
babel-plugin-transform-es2015-object-super 6.24.1 间接依赖 npm
htmlparser2 7.2.0 间接依赖 npm
he 1.2.0 间接依赖 npm
xmlchars 2.2.0 间接依赖 npm
utila 0.4.0 间接依赖 npm
@ungap/promise-all-settled 1.1.2 间接依赖 npm
escape-html 1.0.3 间接依赖 npm
@webassemblyjs/floating-point-hex-parser 1.11.1 间接依赖 npm
type-check 0.4.0 间接依赖 npm
union 0.5.0 间接依赖 npm
eslint-visitor-keys 3.3.0 间接依赖 npm
chokidar 3.5.3 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
is-number 7.0.0 间接依赖 npm
@babel/compat-data 7.18.13 间接依赖 npm
@webassemblyjs/leb128 1.11.1 间接依赖 npm
babel-plugin-transform-es2015-parameters 6.24.1 间接依赖 npm
functions-have-names 1.2.3 间接依赖 npm
y18n 5.0.8 间接依赖 npm
flat 5.0.2 间接依赖 npm
isobject 3.0.1 间接依赖 npm
public-encrypt 4.0.3 间接依赖 npm
socket.io 4.5.2 间接依赖 npm
di 0.0.1 间接依赖 npm
utils-merge 1.0.1 间接依赖 npm
dsp.js 1.0.1 间接依赖 npm
@webassemblyjs/helper-numbers 1.11.1 间接依赖 npm
slice-ansi 4.0.0 间接依赖 npm
http-server 13.1.0 直接依赖 npm
caniuse-lite 1.0.30001390 间接依赖 npm
lunr 2.3.9 间接依赖 npm
pathval 1.1.1 间接依赖 npm
whatwg-encoding 1.0.5 间接依赖 npm
parseurl 1.3.3 间接依赖 npm
json5 0.5.1 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
https-browserify 1.0.0 间接依赖 npm
inline-source-map 0.6.2 间接依赖 npm
@babel/helper-simple-access 7.18.6 间接依赖 npm
string.prototype.trimend 1.0.5 间接依赖 npm
@jridgewell/resolve-uri 3.1.0 间接依赖 npm
babel-helper-hoist-variables 6.24.1 间接依赖 npm
repeating 2.0.1 间接依赖 npm
@tootallnate/once 1.1.2 间接依赖 npm
@istanbuljs/schema 0.1.3 间接依赖 npm
babel-plugin-syntax-do-expressions 6.13.0 间接依赖 npm
jsonfile 4.0.0 间接依赖 npm
assertion-error 1.1.0 间接依赖 npm
esutils 2.0.3 间接依赖 npm
@webassemblyjs/helper-wasm-bytecode 1.11.1 间接依赖 npm
invariant 2.2.4 间接依赖 npm
wcwidth 1.0.1 间接依赖 npm
https-proxy-agent 5.0.1 间接依赖 npm
detect-indent 4.0.0 间接依赖 npm
@jridgewell/gen-mapping 0.1.1 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
events 3.3.0 间接依赖 npm
ts-node 8.10.2 直接依赖 npm
create-hash 1.2.0 间接依赖 npm
growl 1.10.5 间接依赖 npm
envinfo 7.8.1 间接依赖 npm
glob-parent 5.1.2 间接依赖 npm
@xtuc/ieee754 1.2.0 间接依赖 npm
neo-async 2.6.2 间接依赖 npm
defaults 1.0.3 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
whatwg-mimetype 2.3.0 间接依赖 npm
file-entry-cache 6.0.1 间接依赖 npm
@types/cookie 0.4.1 间接依赖 npm
@webassemblyjs/wasm-gen 1.11.1 间接依赖 npm
path-exists 4.0.0 间接依赖 npm
@jridgewell/sourcemap-codec 1.4.14 间接依赖 npm
is-regex 1.1.4 间接依赖 npm
resolve 1.22.1 间接依赖 npm
standardized-audio-context 25.3.37 直接依赖 npm
body-parser 1.20.0 间接依赖 npm
regextras 0.8.0 间接依赖 npm
@babel/helper-environment-visitor 7.18.9 间接依赖 npm
symbol-tree 3.2.4 间接依赖 npm
babel-code-frame 6.26.0 间接依赖 npm
css-select 4.3.0 间接依赖 npm
bn.js 5.2.1 间接依赖 npm
jsesc 1.3.0 间接依赖 npm
@jridgewell/trace-mapping 0.3.15 间接依赖 npm
make-dir 3.1.0 间接依赖 npm
prr 1.0.1 间接依赖 npm
pretty-error 4.0.0 间接依赖 npm
deep-eql 3.0.1 间接依赖 npm
make-error 1.3.6 间接依赖 npm
babel-preset-es2015 6.24.1 间接依赖 npm
html-escaper 2.0.2 间接依赖 npm
anymatch 3.1.2 间接依赖 npm
browserify-aes 1.2.0 间接依赖 npm
babel-plugin-transform-function-bind 6.22.0 间接依赖 npm
randomfill 1.0.4 间接依赖 npm
babel-plugin-transform-es2015-classes 6.24.1 间接依赖 npm
errno 0.1.8 间接依赖 npm
@webassemblyjs/wasm-opt 1.11.1 间接依赖 npm
babel-plugin-syntax-class-constructor-call 6.18.0 间接依赖 npm
base64id 2.0.0 间接依赖 npm
is-potential-custom-element-name 1.0.1 间接依赖 npm
isbinaryfile 4.0.10 间接依赖 npm
flat-cache 3.0.4 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
unpipe 1.0.0 间接依赖 npm
function.prototype.name 1.1.5 间接依赖 npm
internal-slot 1.0.3 间接依赖 npm
es-abstract 1.20.2 间接依赖 npm
ua-parser-js 0.7.33 间接依赖 npm
object-is 1.1.5 间接依赖 npm
color-convert 1.9.3 直接依赖 npm
rimraf 3.0.2 间接依赖 npm
agent-base 6.0.2 间接依赖 npm
import-local 3.1.0 间接依赖 npm
eventemitter3 4.0.7 间接依赖 npm
buffer 5.7.1 间接依赖 npm
@babel/helper-module-imports 7.18.6 间接依赖 npm
babel-plugin-transform-es2015-unicode-regex 6.24.1 间接依赖 npm
babel-helpers 6.24.1 间接依赖 npm
decamelize 4.0.0 间接依赖 npm
des.js 1.0.1 间接依赖 npm
has-ansi 2.0.0 间接依赖 npm
teoria 2.5.0 直接依赖 npm
nanoid 3.3.1 间接依赖 npm
babel-helper-function-name 6.24.1 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
@tonejs/plot 0.0.35 直接依赖 npm
babel-traverse 6.26.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
wrap-ansi 7.0.0 间接依赖 npm
(0)
上一篇 2024年3月6日
下一篇 2024年3月6日

相关推荐

  • bing0o/bash_scripting 软件分析报告

    基础信息 项目名称:bing0o/bash_scripting 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1727526943380688896/1727526943636541440 此报告由Murphyse…

    软件分析 2023年11月23日
    0
  • dagraham/etm-tk 软件分析报告

    基础信息 项目名称:dagraham/etm-tk 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717010054179848192/1717010058374152192 此报告由Murphysec提供 漏洞…

    软件分析 2023年10月25日
    0
  • Antondomashnev/ADGraphView 软件分析报告

    基础信息 项目名称:Antondomashnev/ADGraphView 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715865447870103552/1715865448432140288 此报告由Mur…

    软件分析 2023年10月23日
    0
  • dqbd/tiktokenizer 软件分析报告

    基础信息 项目名称:dqbd/tiktokenizer 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1762247833586663424/1762247833624412160 此报告由Murphysec提供 …

    软件分析 2024年2月27日
    0
  • yonyong/springboot-bbs 软件分析报告

    基础信息 项目名称:yonyong/springboot-bbs 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720243365041573888/1720243365360340992 此报告由Murphys…

    软件分析 2023年11月3日
    0