man-group/notebooker 软件分析报告

基础信息

项目名称:man-group/notebooker

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1758444450851467264/1758444450901798912

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Mikaelbr Node-notifier 操作系统命令注入漏洞 OS命令注入 MPS-2020-17637 CVE-2020-7789 中危
yargs-parser 原型污染漏洞 特权定义了不安全动作 MPS-2020-4006 CVE-2020-7608 中危
url-regex 拒绝服务漏洞 拒绝服务 MPS-2020-8260 CVE-2020-7661 高危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Andrey Sitnik postcss 拒绝服务漏洞 拒绝服务 MPS-2021-4549 CVE-2021-23368 中危
postcss 存在正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-5409 CVE-2021-23382 中危
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
js-beautify ReDoS MPS-2022-13810 中危
lodash.set 存在拒绝服务漏洞 拒绝服务 MPS-2022-13843 高危
uglify-js ReDoS MPS-2022-14112 中危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
needle 存在Authorization请求头泄露漏洞 未授权敏感信息泄露 MPS-2022-7866 中危
PostCSS 安全漏洞 注入 MPS-y3tx-jzms CVE-2023-44270 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
glob-parent 5.1.1 5.1.2 间接依赖 建议修复
postcss 7.0.27 8.4.31 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
lodash.set 4.3.2 间接依赖 建议修复
url-regex 3.2.0 间接依赖 建议修复
glob-parent 3.1.0 5.1.2 间接依赖 建议修复
yargs-parser 5.0.0 5.0.1 间接依赖 可选修复
node-notifier 5.4.3 5.4.5 间接依赖 可选修复
js-beautify 1.11.0 1.14.1 间接依赖 可选修复
semver 6.3.1 7.5.2 间接依赖 可选修复
uglify-js 3.9.1 3.14.3 间接依赖 可选修复
lodash.template 4.5.0 间接依赖 可选修复
postcss 6.0.23 8.4.31 间接依赖 可选修复
lodash.template 3.6.2 间接依赖 可选修复
semver 5.7.2 7.5.2 间接依赖 可选修复
needle 2.9.1 3.1.0 直接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 615
ISC 63
BSD-3-Clause 10
BSD 3
BSD-2-Clause 12
Apache-2.0 12
0BSD 1
CC-BY-4.0 1
AGPL-3.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
camelcase 5.3.1 间接依赖 npm
rework-import 2.1.0 间接依赖 npm
array-differ 1.0.0 间接依赖 npm
colorette 1.2.2 间接依赖 npm
type 1.2.0 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
Union 间接依赖 pip
for-own 1.0.0 间接依赖 npm
DEFAULT_MAILFROM_ADDRESS 间接依赖 pip
string-width 2.1.1 间接依赖 npm
resolve 1.17.0 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
word-wrap 1.2.4 间接依赖 npm
postcss 7.0.27 间接依赖 npm
is-string 1.0.6 间接依赖 npm
findup 0.1.5 间接依赖 npm
esquery 1.3.1 间接依赖 npm
array-union 1.0.2 间接依赖 npm
public-encrypt 4.0.3 间接依赖 npm
duplexer2 0.0.2 间接依赖 npm
uglify-js 3.9.1 间接依赖 npm
insert-module-globals 7.2.1 间接依赖 npm
gulp-copy 4.0.1 间接依赖 npm
pump 2.0.1 间接依赖 npm
umd 3.0.3 间接依赖 npm
strip-ansi 5.2.0 间接依赖 npm
nice-try 1.0.5 间接依赖 npm
homedir-polyfill 1.0.3 间接依赖 npm
tty-browserify 0.0.1 间接依赖 npm
is-number 4.0.0 间接依赖 npm
fomantic-ui 2.8.8 直接依赖 npm
chokidar 2.1.8 间接依赖 npm
hash.js 1.1.7 间接依赖 npm
DEFAULT_MONGO_HOST 间接依赖 pip
Mock 间接依赖 pip
safer-buffer 2.1.2 间接依赖 npm
universal-user-agent 4.0.1 间接依赖 npm
cross-spawn 6.0.5 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
binaryextensions 2.2.0 间接依赖 npm
ansi-colors 3.2.4 间接依赖 npm
eslint-utils 1.4.3 间接依赖 npm
glogg 1.0.2 间接依赖 npm
through2-filter 3.0.0 间接依赖 npm
whatwg-url 5.0.0 间接依赖 npm
rxjs 6.5.5 间接依赖 npm
dateutil 间接依赖 pip
brace-expansion 1.1.11 间接依赖 npm
strip-ansi 4.0.0 间接依赖 npm
kind-of 5.1.0 间接依赖 npm
syntax-error 1.4.0 间接依赖 npm
glob-parent 5.1.1 间接依赖 npm
image-size 0.5.5 直接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
make_response 间接依赖 pip
has-flag 3.0.0 间接依赖 npm
rimraf 2.7.1 间接依赖 npm
matchdep 2.0.0 间接依赖 npm
object.map 1.0.1 间接依赖 npm
is-glob 3.1.0 间接依赖 npm
remove-bom-buffer 3.0.0 间接依赖 npm
estraverse 4.3.0 间接依赖 npm
vm-browserify 1.1.2 间接依赖 npm
inquirer 7.1.0 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
semver 6.3.1 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
last-run 1.1.1 间接依赖 npm
yargs 7.1.0 间接依赖 npm
lodash.defaults 3.1.2 间接依赖 npm
safe-buffer 5.2.0 间接依赖 npm
convert-source-map 1.7.0 间接依赖 npm
is-negative-zero 2.0.1 间接依赖 npm
diff 3.5.0 直接依赖 npm
bach 1.2.0 间接依赖 npm
archy 1.0.0 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
now-and-later 2.0.1 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
mute-stdout 1.0.1 间接依赖 npm
is-what 3.14.1 间接依赖 npm
lodash.escape 3.2.0 间接依赖 npm
read-only-stream 2.0.0 间接依赖 npm
espree 6.2.1 间接依赖 npm
debug 4.1.1 间接依赖 npm
through2 3.0.1 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
@octokit/types 2.12.1 间接依赖 npm
elliptic 6.5.4 间接依赖 npm
stream-http 3.2.0 间接依赖 npm
es6-symbol 3.1.3 间接依赖 npm
undertaker-registry 1.0.1 间接依赖 npm
dash-ast 1.0.0 间接依赖 npm
strip-json-comments 2.0.1 间接依赖 npm
needle 2.9.1 直接依赖 npm
expand-tilde 2.0.2 间接依赖 npm
safe-buffer 5.2.1 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
glob 7.1.6 间接依赖 npm
bindings 1.5.0 间接依赖 npm
diffie-hellman 5.0.3 间接依赖 npm
is-arguments 1.1.0 间接依赖 npm
which-boxed-primitive 1.0.2 间接依赖 npm
flush-write-stream 1.1.1 间接依赖 npm
object.defaults 1.1.0 间接依赖 npm
defined 1.0.0 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
subarg 1.0.0 间接依赖 npm
make-dir 2.1.0 直接依赖 npm
esutils 2.0.3 间接依赖 npm
@octokit/request-error 1.2.1 间接依赖 npm
events 3.3.0 间接依赖 npm
ansi-styles 4.2.1 间接依赖 npm
type-fest 0.8.1 间接依赖 npm
extend 3.0.2 间接依赖 npm
replacestream 4.0.3 间接依赖 npm
browser-resolve 2.0.0 间接依赖 npm
commander 2.20.3 间接依赖 npm
path-is-inside 1.0.2 间接依赖 npm
ini 1.3.8 间接依赖 npm
object-assign 3.0.0 间接依赖 npm
is-glob 4.0.1 间接依赖 npm
@babel/code-frame 7.8.3 间接依赖 npm
onetime 5.1.0 间接依赖 npm
miller-rabin 4.0.1 间接依赖 npm
gulp-print 5.0.2 间接依赖 npm
sparkles 1.0.1 间接依赖 npm
strip-bom-stream 3.0.0 间接依赖 npm
ripemd160 2.0.2 间接依赖 npm
esrecurse 4.2.1 间接依赖 npm
lodash._root 3.0.1 间接依赖 npm
call-bind 1.0.2 间接依赖 npm
typedarray 0.0.6 间接依赖 npm
camelcase 3.0.0 间接依赖 npm
@octokit/plugin-rest-endpoint-methods 2.4.0 间接依赖 npm
lodash.keys 2.4.1 间接依赖 npm
signal-exit 3.0.3 间接依赖 npm
ieee754 1.2.1 间接依赖 npm
lodash.keys 3.1.2 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
is-binary-path 1.0.1 间接依赖 npm
just-debounce 1.0.0 间接依赖 npm
stream-browserify 3.0.0 间接依赖 npm
NotebookResultComplete 间接依赖 pip
extglob 2.0.4 间接依赖 npm
ImmutableMultiDict 间接依赖 pip
stream-exhaust 1.0.2 间接依赖 npm
cliui 3.2.0 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
windows-release 3.3.0 间接依赖 npm
is-path-cwd 1.0.0 间接依赖 npm
through2 2.0.5 间接依赖 npm
@octokit/endpoint 6.0.1 间接依赖 npm
shasum-object 1.0.0 间接依赖 npm
tslib 1.11.1 间接依赖 npm
btoa-lite 1.0.0 间接依赖 npm
has-symbols 1.0.2 间接依赖 npm
yallist 2.1.2 间接依赖 npm
gulplog 1.0.0 间接依赖 npm
gulp-if 2.0.2 间接依赖 npm
minimist 1.2.6 间接依赖 npm
async-each 1.0.3 间接依赖 npm
create-ecdh 4.0.4 间接依赖 npm
acorn 7.4.1 间接依赖 npm
browserify 17.0.0 直接依赖 npm
@octokit/plugin-paginate-rest 1.1.2 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
text-table 0.2.0 间接依赖 npm
browserify-des 1.0.2 间接依赖 npm
mute-stream 0.0.7 间接依赖 npm
eslint-visitor-keys 1.1.0 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
supports-color 6.1.0 间接依赖 npm
del 3.0.0 间接依赖 npm
domain-browser 1.2.0 间接依赖 npm
braces 2.3.2 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
jsonparse 1.3.1 间接依赖 npm
ext 1.4.0 间接依赖 npm
isobject 4.0.0 间接依赖 npm
console-browserify 1.2.0 间接依赖 npm
lodash.template 3.6.2 间接依赖 npm
isobject 3.0.1 间接依赖 npm
tslib 2.3.1 间接依赖 npm
node-releases 1.1.72 间接依赖 npm
require-dot-file 0.4.0 间接依赖 npm
js-yaml 3.13.1 间接依赖 npm
url 0.11.0 间接依赖 npm
urix 0.1.0 间接依赖 npm
inherits 2.0.1 间接依赖 npm
buffer-xor 1.0.3 间接依赖 npm
ansi-regex 5.0.0 间接依赖 npm
fs-mkdirp-stream 1.0.0 间接依赖 npm
beeper 1.1.1 间接依赖 npm
binary-extensions 1.13.1 间接依赖 npm
constants-browserify 1.0.0 间接依赖 npm
is-symbol 1.0.4 间接依赖 npm
import-regex 1.1.0 间接依赖 npm
findup-sync 3.0.0 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
source-map-url 0.4.0 间接依赖 npm
pinkie 2.0.4 间接依赖 npm
gulp-flatten 0.4.0 间接依赖 npm
vinyl 2.2.0 间接依赖 npm
each-props 1.3.2 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
ansi-regex 4.1.0 间接依赖 npm
which-module 1.0.0 间接依赖 npm
JSONStream 1.3.5 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
before-after-hook 2.1.0 间接依赖 npm
has-gulplog 0.1.0 间接依赖 npm
next-tick 1.0.0 间接依赖 npm
shellwords 0.1.1 间接依赖 npm
lodash.uniq 4.5.0 间接依赖 npm
cli-table 0.3.1 间接依赖 npm
argparse 1.0.10 间接依赖 npm
lodash._getnative 3.9.1 间接依赖 npm
rtlcss 2.5.0 间接依赖 npm
is-absolute 1.0.0 间接依赖 npm
caniuse-lite 1.0.30001230 间接依赖 npm
append-buffer 1.0.2 间接依赖 npm
better-console 1.0.1 间接依赖 npm
through2 1.1.1 间接依赖 npm
pako 1.0.11 间接依赖 npm
parse-passwd 1.0.0 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
editorconfig 0.15.3 间接依赖 npm
decode-uri-component 0.2.2 间接依赖 npm
is-fullwidth-code-point 3.0.0 间接依赖 npm
fill-range 4.0.0 间接依赖 npm
lodash.defaults 2.4.1 间接依赖 npm
buffer-equal 1.0.0 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
duplexer2 0.1.4 间接依赖 npm
parse-node-version 1.0.1 间接依赖 npm
mkdirp 0.5.5 间接依赖 npm
gulp-debug 4.0.0 间接依赖 npm
acorn-node 1.8.2 间接依赖 npm
brorand 1.1.0 间接依赖 npm
strip-json-comments 3.1.0 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
stream-combiner2 1.1.1 间接依赖 npm
cli-cursor 2.1.0 间接依赖 npm
is-extendable 1.0.1 间接依赖 npm
hash-base 3.1.0 间接依赖 npm
DEFAULT_DATABASE_NAME 间接依赖 pip
crypto-browserify 3.12.0 间接依赖 npm
ms 2.1.2 间接依赖 npm
glob-parent 3.1.0 间接依赖 npm
is-wsl 1.1.0 间接依赖 npm
color-name 1.1.4 间接依赖 npm
es5-ext 0.10.53 间接依赖 npm
figures 2.0.0 间接依赖 npm
callsites 3.1.0 间接依赖 npm
map-stream 0.1.0 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
config-chain 1.1.12 间接依赖 npm
arr-union 3.1.0 间接依赖 npm
esprima 4.0.1 间接依赖 npm
path-dirname 1.0.2 间接依赖 npm
stringify-object 3.3.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
which 1.3.1 间接依赖 npm
liftoff 3.1.0 间接依赖 npm
asn1.js 5.4.1 间接依赖 npm
has-ansi 2.0.0 间接依赖 npm
octokit-pagination-methods 1.1.0 间接依赖 npm
mute-stream 0.0.8 间接依赖 npm
tr46 0.0.3 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
nan 2.14.1 间接依赖 npm
inflight 1.0.6 间接依赖 npm
tildify 1.2.0 间接依赖 npm
globals 12.4.0 间接依赖 npm
os-homedir 1.0.2 间接依赖 npm
mime 1.6.0 直接依赖 npm
globby 2.1.0 间接依赖 npm
stream-shift 1.0.1 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
cli-width 2.2.1 间接依赖 npm
notebooker 间接依赖 pip
once 1.4.0 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
isarray 0.0.1 间接依赖 npm
regexpp 2.0.1 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
universal-user-agent 5.0.0 间接依赖 npm
deep-assign 1.0.0 间接依赖 npm
gulp-less 5.0.0 间接依赖 npm
prr 1.0.1 间接依赖 npm
labeled-stream-splicer 2.0.2 间接依赖 npm
irregular-plurals 2.0.0 间接依赖 npm
color-name 1.1.3 间接依赖 npm
get-imports 1.0.0 间接依赖 npm
unique-stream 2.3.1 间接依赖 npm
string.prototype.trimend 1.0.4 间接依赖 npm
commander 2.1.0 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
get-caller-file 1.0.3 间接依赖 npm
gulp-uglify 3.0.2 间接依赖 npm
@babel/helper-validator-identifier 7.9.5 间接依赖 npm
gulp-cli 2.2.0 间接依赖 npm
lodash._bindcallback 3.0.1 间接依赖 npm
normalize-path 2.1.1 间接依赖 npm
CombinedMultiDict 间接依赖 pip
fined 1.2.0 间接依赖 npm
cipher-base 1.0.4 间接依赖 npm
lodash.isobject 2.4.1 间接依赖 npm
https-browserify 1.0.0 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
read-pkg 1.1.0 间接依赖 npm
globby 6.1.0 间接依赖 npm
CANCEL_MESSAGE 间接依赖 pip
clone-stats 0.0.1 间接依赖 npm
jquery 3.5.0 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
gulp-concat 2.6.1 间接依赖 npm
path-browserify 1.0.1 间接依赖 npm
v8-compile-cache 2.1.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
object-inspect 1.10.3 间接依赖 npm
Enum 间接依赖 pip
colors 1.0.3 间接依赖 npm
ansi-escapes 3.2.0 间接依赖 npm
findup-sync 2.0.0 间接依赖 npm
v8flags 3.1.3 间接依赖 npm
bn.js 4.12.0 间接依赖 npm
is-promise 2.1.0 间接依赖 npm
type-check 0.3.2 间接依赖 npm
is-relative 1.0.0 间接依赖 npm
deep-is 0.1.3 间接依赖 npm
source-map 0.6.1 间接依赖 npm
array-initial 1.1.0 间接依赖 npm
parents 1.0.1 间接依赖 npm
has-flag 4.0.0 间接依赖 npm
eslint-scope 5.0.0 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
wrench-sui 0.0.3 间接依赖 npm
array-uniq 1.0.3 间接依赖 npm
replace-ext 1.0.0 间接依赖 npm
is-nan 1.3.2 间接依赖 npm
color-convert 2.0.1 间接依赖 npm
find-up 1.1.2 间接依赖 npm
available-typed-arrays 1.0.4 间接依赖 npm
progress 2.0.3 间接依赖 npm
os-name 3.1.0 间接依赖 npm
to-absolute-glob 2.0.2 间接依赖 npm
time-stamp 1.1.0 间接依赖 npm
string-width 3.1.0 间接依赖 npm
lodash.templatesettings 3.1.1 间接依赖 npm
onetime 2.0.1 间接依赖 npm
lodash._isiterateecall 3.0.9 间接依赖 npm
detect-file 1.0.0 间接依赖 npm
combine-source-map 0.8.0 间接依赖 npm
get-own-enumerable-property-symbols 3.0.2 间接依赖 npm
Optional 间接依赖 pip
diff 1.0.8 间接依赖 npm
fsevents 1.2.12 直接依赖 npm
color-support 1.1.3 间接依赖 npm
Any 间接依赖 pip
rework-visit 1.0.0 间接依赖 npm
DEFAULT_SERIALIZER 间接依赖 pip
plur 3.1.1 间接依赖 npm
nanomatch 1.2.13 间接依赖 npm
file-entry-cache 5.0.1 间接依赖 npm
randombytes 2.1.0 间接依赖 npm
TEMPLATE_DIR_SEPARATOR 间接依赖 pip
is-obj 1.0.1 间接依赖 npm
flat-cache 2.0.1 间接依赖 npm
url-regex 3.2.0 间接依赖 npm
through2 4.0.2 间接依赖 npm
punycode 1.3.2 间接依赖 npm
detect-indent 6.0.0 间接依赖 npm
querystring-es3 0.2.1 间接依赖 npm
bn.js 5.2.1 间接依赖 npm
glob 7.1.7 间接依赖 npm
has-symbols 1.0.1 间接依赖 npm
browserify-sign 4.2.2 间接依赖 npm
ansi-escapes 4.3.1 间接依赖 npm
replace-ext 2.0.0 间接依赖 npm
default-resolution 2.0.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
timers-browserify 1.4.2 间接依赖 npm
gulp-match 1.1.0 间接依赖 npm
lodash._createassigner 3.1.1 间接依赖 npm
levn 0.3.0 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
string-width 1.0.2 间接依赖 npm
isarray 1.0.0 间接依赖 npm
jquery 3.5.1 直接依赖 npm
@babel/highlight 7.9.0 间接依赖 npm
atob 2.1.2 间接依赖 npm
atob-lite 2.0.0 间接依赖 npm
./notebook_requirements.txt 间接依赖 pip
arr-diff 1.1.0 间接依赖 npm
querystring 0.2.0 间接依赖 npm
module-deps 6.2.3 间接依赖 npm
replace-ext 0.0.1 间接依赖 npm
is-regex 1.1.3 间接依赖 npm
cached-path-relative 1.1.0 间接依赖 npm
resolve-url 0.2.1 间接依赖 npm
gulp-chmod 2.0.0 间接依赖 npm
glob-stream 6.1.0 间接依赖 npm
lodash.set 4.3.2 间接依赖 npm
is-typed-array 1.1.5 间接依赖 npm
which-typed-array 1.1.4 间接依赖 npm
lodash.assign 3.2.0 间接依赖 npm
lodash.memoize 3.0.4 间接依赖 npm
concat-with-sourcemaps 1.1.0 间接依赖 npm
copy-props 2.0.5 间接依赖 npm
async-settle 1.0.0 间接依赖 npm
is-fullwidth-code-point 1.0.0 间接依赖 npm
message 间接依赖 pip
clone 1.0.4 间接依赖 npm
is-valid-glob 1.0.0 间接依赖 npm
browserslist 4.16.6 间接依赖 npm
cron-expression-validator 1.0.18 直接依赖 npm
ternary-stream 2.1.1 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
fast-safe-stringify 2.0.7 间接依赖 npm
require-main-filename 1.0.1 间接依赖 npm
readable-stream 3.6.2 间接依赖 npm
os-locale 1.4.0 间接依赖 npm
array-slice 0.2.3 间接依赖 npm
remove-bom-stream 1.2.0 间接依赖 npm
strip-bom-buf 1.0.0 间接依赖 npm
./notebooker/notebook_templates_example/notebook_requirements.txt 间接依赖 pip
sigmund 1.0.1 间接依赖 npm
clone-buffer 1.0.0 间接依赖 npm
ansi-cyan 0.1.1 间接依赖 npm
lazystream 1.0.0 间接依赖 npm
gulp-dedupe 0.0.2 间接依赖 npm
lodash 4.17.21 间接依赖 npm
AnyStr 间接依赖 pip
rework-plugin-url 1.1.0 间接依赖 npm
es6-iterator 2.0.3 间接依赖 npm
process 0.11.10 间接依赖 npm
lodash._objecttypes 2.4.1 间接依赖 npm
yargs-parser 5.0.0 间接依赖 npm
lodash._reevaluate 3.0.0 间接依赖 npm
arr-filter 1.1.2 间接依赖 npm
rework-plugin-function 1.0.2 间接依赖 npm
acorn-jsx 5.2.0 间接依赖 npm
JobStatus 间接依赖 pip
semver-greatest-satisfied-range 1.1.0 间接依赖 npm
growly 1.3.0 间接依赖 npm
detective 5.2.0 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
readable-stream 1.1.14 间接依赖 npm
strip-ansi 6.0.0 间接依赖 npm
lodash._reescape 3.0.0 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
mkdirp 1.0.4 间接依赖 npm
has 1.0.3 间接依赖 npm
lodash.isarguments 3.1.0 间接依赖 npm
gulp-autoprefixer 6.1.0 间接依赖 npm
simple-concat 1.0.1 间接依赖 npm
vinyl 0.5.3 间接依赖 npm
randomfill 1.0.4 间接依赖 npm
wrap-ansi 2.1.0 间接依赖 npm
create_app 间接依赖 pip
astral-regex 1.0.0 间接依赖 npm
unbox-primitive 1.0.1 间接依赖 npm
object.assign 4.1.0 间接依赖 npm
util 0.12.3 间接依赖 npm
array-sort 1.0.0 间接依赖 npm
browserify-rsa 4.1.0 间接依赖 npm
gulp-replace 1.0.0 间接依赖 npm
readable-stream 2.3.7 间接依赖 npm
datatables 1.10.18 直接依赖 npm
is-path-inside 1.0.1 间接依赖 npm
array-unique 0.3.2 间接依赖 npm
lodash._basecopy 3.0.1 间接依赖 npm
clone-stats 1.0.0 间接依赖 npm
type-fest 0.11.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
stream-splicer 2.0.1 间接依赖 npm
p-map 1.2.0 间接依赖 npm
y18n 3.2.2 间接依赖 npm
ip-regex 1.0.3 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
lodash._baseassign 3.2.0 间接依赖 npm
fancy-log 1.3.3 间接依赖 npm
for-in 1.0.2 间接依赖 npm
plugin-error 1.0.1 间接依赖 npm
table 5.4.6 间接依赖 npm
clone 2.1.2 间接依赖 npm
resolve-dir 1.0.1 间接依赖 npm
nopt 4.0.3 间接依赖 npm
dateformat 2.2.0 间接依赖 npm
graceful-fs 4.2.3 间接依赖 npm
map-stream 0.0.7 间接依赖 npm
unique 间接依赖 pip
pumpify 1.5.1 间接依赖 npm
escalade 3.1.1 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
is-utf8 0.2.1 间接依赖 npm
autoprefixer 9.7.6 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
resolve-options 1.1.0 间接依赖 npm
postcss 6.0.23 间接依赖 npm
gulp-git 2.10.1 间接依赖 npm
pify 4.0.1 间接依赖 npm
gulp-clone 2.0.1 间接依赖 npm
lodash._shimkeys 2.4.1 间接依赖 npm
optionator 0.8.3 间接依赖 npm
js-beautify 1.11.0 间接依赖 npm
sver-compat 1.5.0 间接依赖 npm
lcid 1.0.0 间接依赖 npm
gulp-plumber 1.2.1 间接依赖 npm
pbkdf2 3.1.2 间接依赖 npm
d 1.0.1 间接依赖 npm
acorn-walk 7.2.0 间接依赖 npm
path-platform 0.11.15 间接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
assert 1.5.0 间接依赖 npm
emoji-regex 8.0.0 间接依赖 npm
kind-of 1.1.0 间接依赖 npm
DEFAULT_RESULT_COLLECTION_NAME 间接依赖 pip
multipipe 0.1.2 间接依赖 npm
copy-anything 2.0.3 间接依赖 npm
convert-source-map 1.1.3 间接依赖 npm
chalk 3.0.0 间接依赖 npm
readable-stream 3.6.0 间接依赖 npm
node.extend 2.0.2 间接依赖 npm
lodash._isnative 2.4.1 间接依赖 npm
@types/color-name 1.1.1 间接依赖 npm
xtend 4.0.2 间接依赖 npm
rimraf 2.6.3 间接依赖 npm
find_packages 间接依赖 pip
slice-ansi 2.1.0 间接依赖 npm
array-last 1.3.0 间接依赖 npm
is-negated-glob 1.0.0 间接依赖 npm
read-pkg-up 1.0.1 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
lodash.get 4.4.2 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
pify 2.3.0 间接依赖 npm
stat-mode 0.2.2 间接依赖 npm
clean-css 4.2.3 间接依赖 npm
browser-pack 6.1.0 间接依赖 npm
chardet 0.7.0 间接依赖 npm
luxon 1.28.1 间接依赖 npm
get-value 2.0.6 间接依赖 npm
vinyl-fs 3.0.3 间接依赖 npm
Dict 间接依赖 pip
lodash.restparam 3.6.1 间接依赖 npm
doctrine 3.0.0 间接依赖 npm
patch 间接依赖 pip
inherits 2.0.4 间接依赖 npm
is-plain-object 5.0.0 间接依赖 npm
gulp-notify 3.2.0 间接依赖 npm
vinyl-sourcemaps-apply 0.2.1 间接依赖 npm
gulp-clean-css 4.3.0 间接依赖 npm
arr-map 2.0.2 间接依赖 npm
normalize-range 0.1.2 间接依赖 npm
is-core-module 2.4.0 间接依赖 npm
any-shell-escape 0.1.1 间接依赖 npm
bootstrap-table 1.20.2 直接依赖 npm
natural-compare 1.4.0 间接依赖 npm
semver 5.7.2 间接依赖 npm
md5.js 1.3.5 间接依赖 npm
node-fetch 2.6.7 间接依赖 npm
flagged-respawn 1.0.1 间接依赖 npm
source-map 0.5.7 间接依赖 npm
resolve 1.20.0 间接依赖 npm
eslint 6.8.0 直接依赖 npm
cli-cursor 3.1.0 间接依赖 npm
figures 3.2.0 间接依赖 npm
is-generator-function 1.0.9 间接依赖 npm
make-error 1.3.6 间接依赖 npm
gulp-concat-filenames 1.2.0 间接依赖 npm
Blueprint 间接依赖 pip
repeat-element 1.1.3 间接依赖 npm
abbrev 1.1.1 间接依赖 npm
chalk 2.4.2 间接依赖 npm
get-intrinsic 1.1.1 间接依赖 npm
make-error-cause 1.2.2 间接依赖 npm
parse-asn1 5.1.6 间接依赖 npm
gulp-util 3.0.8 间接依赖 npm
ansi-red 0.1.1 间接依赖 npm
debug 3.2.7 间接依赖 npm
collection-map 1.0.0 间接依赖 npm
restore-cursor 3.1.0 间接依赖 npm
node-notifier 5.4.3 间接依赖 npm
colors 0.6.2 间接依赖 npm
Callable 间接依赖 pip
ansi-colors 1.1.0 间接依赖 npm
yargs-parser 13.1.2 直接依赖 npm
lodash.template 4.5.0 间接依赖 npm
inquirer 6.5.2 间接依赖 npm
deps-sort 2.0.1 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
htmlescape 1.1.1 间接依赖 npm
create-hash 1.2.0 间接依赖 npm
emoji-regex 7.0.3 间接依赖 npm
ajv 6.12.6 间接依赖 npm
pretty-hrtime 1.0.3 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
estraverse 5.1.0 间接依赖 npm
replace-homedir 1.0.0 间接依赖 npm
concat-stream 1.6.2 间接依赖 npm
async-done 1.3.2 间接依赖 npm
restore-cursor 2.0.0 间接依赖 npm
acorn 7.1.1 间接依赖 npm
string.prototype.trimstart 1.0.4 间接依赖 npm
base64-js 1.5.1 间接依赖 npm
gulp-rename 1.4.0 间接依赖 npm
@octokit/rest 16.43.1 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
osenv 0.1.5 间接依赖 npm
glob-watcher 5.0.3 间接依赖 npm
textextensions 2.6.0 间接依赖 npm
ignore 4.0.6 间接依赖 npm
array-each 1.0.1 间接依赖 npm
bn.js 5.2.0 间接依赖 npm
util 0.10.3 间接依赖 npm
end-of-stream 1.4.4 间接依赖 npm
lodash.isarray 3.0.4 间接依赖 npm
code-point-at 1.1.0 间接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
undertaker 1.2.1 间接依赖 npm
browserify-aes 1.2.0 间接依赖 npm
make-iterator 1.0.1 间接依赖 npm
snapdragon 0.8.2 间接依赖 npm
inline-source-map 0.6.2 间接依赖 npm
os-browserify 0.3.0 间接依赖 npm
ansi-regex 3.0.0 间接依赖 npm
SUBMISSION_TIMEOUT 间接依赖 pip
gulp-header 2.0.9 间接依赖 npm
is-buffer 1.1.6 间接依赖 npm
es-to-primitive 1.2.1 间接依赖 npm
default-compare 1.0.0 间接依赖 npm
object.assign 4.1.2 间接依赖 npm
assign-symbols 1.0.0 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
less 4.1.2 间接依赖 npm
des.js 1.0.1 间接依赖 npm
istextorbinary 2.2.1 间接依赖 npm
duplexify 3.7.1 间接依赖 npm
ansi-gray 0.1.1 间接依赖 npm
css 2.2.4 间接依赖 npm
deepmerge 4.2.2 间接依赖 npm
source-map-resolve 0.5.3 间接依赖 npm
evp_bytestokey 1.0.3 间接依赖 npm
@octokit/plugin-request-log 1.0.0 间接依赖 npm
shell-quote 1.7.3 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
readdirp 2.2.1 间接依赖 npm
lodash.templatesettings 4.2.0 间接依赖 npm
glob 5.0.15 间接依赖 npm
interpret 1.2.0 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
is-plain-object 3.0.0 间接依赖 npm
import-fresh 3.2.1 间接依赖 npm
path-key 2.0.1 间接依赖 npm
builtin-status-codes 3.0.0 间接依赖 npm
es6-weak-map 2.0.3 间接依赖 npm
gulp 4.0.2 间接依赖 npm
string_decoder 1.3.0 间接依赖 npm
require-dir 1.2.0 间接依赖 npm
deprecation 2.3.1 间接依赖 npm
lodash._reinterpolate 3.0.0 间接依赖 npm
ansi-wrap 0.1.0 间接依赖 npm
macos-release 2.3.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
convert-source-map 0.3.5 间接依赖 npm
file-uri-to-path 1.0.0 间接依赖 npm
lodash._basetostring 3.0.1 间接依赖 npm
setup_app 间接依赖 pip
fork-stream 0.0.4 间接依赖 npm
List 间接依赖 pip
supports-color 7.1.0 间接依赖 npm
gulp-concat-css 3.1.0 间接依赖 npm
arr-union 2.1.0 间接依赖 npm
webidl-conversions 3.0.1 间接依赖 npm
tmp 0.0.33 间接依赖 npm
get-assigned-identifiers 1.2.0 间接依赖 npm
parse-filepath 1.0.2 间接依赖 npm
@octokit/auth-token 2.4.0 间接依赖 npm
first-chunk-stream 2.0.0 间接依赖 npm
has-bigints 1.0.1 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
external-editor 3.1.0 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
stack-trace 0.0.10 间接依赖 npm
editions 1.3.4 间接依赖 npm
extend-shallow 2.0.1 间接依赖 npm
browserify-zlib 0.2.0 间接依赖 npm
value-or-function 3.0.0 间接依赖 npm
minimalistic-assert 1.0.1 间接依赖 npm
vinyl-sourcemap 1.1.0 间接依赖 npm
extend-shallow 1.1.4 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
cron-parser 3.5.0 直接依赖 npm
flatted 2.0.2 间接依赖 npm
is 3.3.0 间接依赖 npm
define-properties 1.1.3 间接依赖 npm
string_decoder 0.10.31 间接依赖 npm
es-abstract 1.18.2 间接依赖 npm
ordered-read-streams 1.0.1 间接依赖 npm
rechoir 0.6.2 间接依赖 npm
merge-stream 1.0.1 间接依赖 npm
undeclared-identifiers 1.1.3 间接依赖 npm
is-path-in-cwd 1.0.1 间接依赖 npm
write 1.0.3 间接依赖 npm
is-regexp 1.0.0 间接依赖 npm
@octokit/request 5.4.2 间接依赖 npm
flask 间接依赖 pip
errno 0.1.7 直接依赖 npm
sha.js 2.4.11 间接依赖 npm
object.reduce 1.0.1 间接依赖 npm
async 1.5.2 间接依赖 npm
gulp-json-editor 2.5.4 间接依赖 npm
minimalistic-crypto-utils 1.0.1 间接依赖 npm
@octokit/request-error 2.0.0 间接依赖 npm
plugin-error 0.1.2 间接依赖 npm
create-hmac 1.1.7 间接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
cloneable-readable 1.1.3 间接依赖 npm
gulp-rtlcss 1.4.1 间接依赖 npm
is-date-object 1.0.4 间接依赖 npm
define-property 2.0.2 间接依赖 npm
mimic-fn 1.2.0 间接依赖 npm
foreach 2.0.5 间接依赖 npm
lead 1.0.0 间接依赖 npm
setup 间接依赖 pip
num2fraction 1.2.2 间接依赖 npm
punycode 1.4.1 间接依赖 npm
split-string 3.1.0 间接依赖 npm
postcss-value-parser 4.0.3 间接依赖 npm
parse-import 2.0.0 间接依赖 npm
yamljs 0.3.0 间接依赖 npm
to-through 2.0.0 间接依赖 npm
through 2.3.8 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
pify 3.0.0 间接依赖 npm
prelude-ls 1.1.2 间接依赖 npm
snapdragon-node 2.1.1 间接依赖 npm
array-slice 1.1.0 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
encoders 间接依赖 pip
lru-cache 4.1.5 间接依赖 npm
lodash._basevalues 3.0.0 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
run-async 2.4.0 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
NotebookResultError 间接依赖 pip
sax 1.2.4 间接依赖 npm
chalk 1.1.3 间接依赖 npm
execa 1.0.0 间接依赖 npm
mkdirp-classic 0.5.3 间接依赖 npm
is-callable 1.2.3 间接依赖 npm
browserify-cipher 1.0.1 间接依赖 npm
hmac-drbg 1.0.1 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
gulp-tap 1.0.1 间接依赖 npm
@types/node 13.13.2 间接依赖 npm
upath 1.2.0 间接依赖 npm
buffer 5.2.1 间接依赖 npm
electron-to-chromium 1.3.739 间接依赖 npm
string-width 4.2.0 间接依赖 npm
rework 1.0.1 间接依赖 npm
proto-list 1.2.4 间接依赖 npm
mock 间接依赖 pip
(0)
上一篇 2024年2月16日
下一篇 2024年2月16日

相关推荐

  • facebook/proxygen 软件分析报告

    基础信息 项目名称:facebook/proxygen 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721180697174999040/1729402564377530368 此报告由Murphysec提供 …

    软件分析 2023年11月28日
    0
  • alvarotrigo/multiscroll.js 软件分析报告

    基础信息 项目名称:alvarotrigo/multiscroll.js 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720550099398344704/1720550099436093440 此报告由Mur…

    软件分析 2023年11月4日
    0
  • ibraheemdev/modern-unix 软件分析报告

    基础信息 项目名称:ibraheemdev/modern-unix 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721271534323847168/1723881241251897344 此报告由Murphy…

    软件分析 2023年11月13日
    0
  • deeplearning4j/deeplearning4j 软件分析报告

    基础信息 项目名称:deeplearning4j/deeplearning4j 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721129500456062976/1722651584838078464 此报告由…

    软件分析 2023年11月10日
    0
  • swoole/phpy 软件分析报告

    基础信息 项目名称:swoole/phpy 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1733414944379981824/1733414944413536256 此报告由Murphysec提供 漏洞列表 暂…

    软件分析 2023年12月9日
    0