r-spacex/SpaceX-API 软件分析报告

基础信息

项目名称:r-spacex/SpaceX-API

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1756362120648777728/1756362973476610048

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
MongoDB 日志信息泄露漏洞 日志敏感信息泄露 MPS-2021-24103 CVE-2021-32050 高危
http-cache-semantics 安全漏洞 ReDoS MPS-2022-5164 CVE-2022-25881 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
Luxon 存在Redos漏洞 ReDoS MPS-2022-69796 CVE-2023-22467 中危
xml2js 安全漏洞 原型污染 MPS-2023-4673 CVE-2023-0842 中危
word-wrap 安全漏洞 ReDoS MPS-2023-5109 CVE-2023-26115 高危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
Babel 插件任意代码执行漏洞漏洞 不完整的黑名单 MPS-avb9-j50z CVE-2023-45133 严重
tough-cookie 原型污染 MPS-esyq-56vx 中危
Automattic Mongoose 安全漏洞 原型污染 MPS-rkw8-631m CVE-2023-3696 严重

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
@babel/traverse 7.18.13 7.23.2 间接依赖 建议修复
tough-cookie 4.1.2 4.1.3 直接依赖 建议修复
word-wrap 1.2.3 1.2.4 间接依赖 建议修复
mongoose 6.5.3 6.11.3 直接依赖 建议修复
http-cache-semantics 4.1.0 4.1.1 间接依赖 可选修复
luxon 1.28.0 1.28.1 间接依赖 可选修复
semver 7.3.7 7.5.2 间接依赖 可选修复
xml2js 0.4.23 0.5.0 间接依赖 可选修复
mongodb 4.8.1 4.17.0 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 441
ISC 36
BSD-3-Clause 17
BSD-2-Clause 19
0BSD 1
Apache-2.0 15
Unlicense 1
GPL-2.0 1
APACHE-2.0 1
Python-2.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
koa2-cors 2.0.6 直接依赖 npm
pkg-dir 4.2.0 间接依赖 npm
is-symbol 1.0.4 间接依赖 npm
@sinclair/typebox 0.24.28 间接依赖 npm
mime-types 2.1.35 间接依赖 npm
@babel/helper-simple-access 7.18.6 间接依赖 npm
@babel/plugin-syntax-numeric-separator 7.10.4 间接依赖 npm
@humanwhocodes/module-importer 1.0.1 间接依赖 npm
requires-port 1.0.0 间接依赖 npm
buffer 5.7.1 间接依赖 npm
has-tostringtag 1.0.0 间接依赖 npm
define-properties 1.1.4 间接依赖 npm
glob-parent 6.0.2 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
boolbase 1.0.0 间接依赖 npm
object.entries 1.1.5 间接依赖 npm
ignore 5.2.0 间接依赖 npm
object.values 1.1.5 间接依赖 npm
delegates 1.0.0 间接依赖 npm
ylru 1.3.2 间接依赖 npm
tough-cookie 4.1.2 直接依赖 npm
fastq 1.13.0 间接依赖 npm
acorn-jsx 5.3.2 间接依赖 npm
keyv 4.3.2 间接依赖 npm
domelementtype 2.3.0 间接依赖 npm
cacheable-request 7.0.2 间接依赖 npm
find-up 2.1.0 间接依赖 npm
rimraf 3.0.2 间接依赖 npm
which 2.0.2 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
@babel/plugin-syntax-json-strings 7.8.3 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
is-boolean-object 1.1.2 间接依赖 npm
jest-worker 29.0.1 间接依赖 npm
p-limit 1.3.0 间接依赖 npm
esutils 2.0.3 间接依赖 npm
@types/node 18.0.0 间接依赖 npm
end-of-stream 1.4.4 间接依赖 npm
ioredis 5.2.3 直接依赖 npm
compress-brotli 1.3.8 间接依赖 npm
babel-preset-jest 29.0.0 间接依赖 npm
ci-info 3.3.2 间接依赖 npm
is-string 1.0.7 间接依赖 npm
tslib 1.14.1 间接依赖 npm
eslint-plugin-jest 26.8.7 直接依赖 npm
jest-docblock 29.0.0 间接依赖 npm
lodash.defaults 4.2.0 间接依赖 npm
@babel/compat-data 7.18.13 间接依赖 npm
kareem 2.4.1 间接依赖 npm
is-negative-zero 2.0.2 间接依赖 npm
prompts 2.4.2 间接依赖 npm
side-channel 1.0.4 间接依赖 npm
cookies 0.8.0 间接依赖 npm
parse5 7.0.0 间接依赖 npm
@types/prettier 2.7.0 间接依赖 npm
saslprep 1.0.3 间接依赖 npm
js-yaml 4.1.0 间接依赖 npm
eslint 8.23.0 直接依赖 npm
is-fullwidth-code-point 3.0.0 间接依赖 npm
koa-bodyparser 4.3.0 直接依赖 npm
negotiator 0.6.3 间接依赖 npm
get-intrinsic 1.1.2 间接依赖 npm
@babel/types 7.18.13 间接依赖 npm
@typescript-eslint/scope-manager 5.35.1 间接依赖 npm
mongoose 6.5.3 直接依赖 npm
@babel/plugin-syntax-logical-assignment-operators 7.10.4 间接依赖 npm
get-stream 6.0.1 间接依赖 npm
ee-first 1.1.1 间接依赖 npm
inherits 2.0.4 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
@types/whatwg-url 8.2.2 间接依赖 npm
redis-parser 3.0.0 间接依赖 npm
jest-matcher-utils 29.0.1 间接依赖 npm
diff-sequences 29.0.0 间接依赖 npm
@babel/parser 7.18.13 间接依赖 npm
quick-lru 5.1.1 间接依赖 npm
next-tick 1.1.0 间接依赖 npm
is-stream 2.0.1 间接依赖 npm
url-parse 1.5.10 间接依赖 npm
type-fest 0.20.2 间接依赖 npm
confusing-browser-globals 1.0.11 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
grapheme-splitter 1.0.4 间接依赖 npm
querystringify 2.2.0 间接依赖 npm
@jest/globals 29.0.1 间接依赖 npm
balanced-match 1.0.2 间接依赖 npm
form-data-encoder 2.0.1 间接依赖 npm
keygrip 1.1.0 间接依赖 npm
parse-json 5.2.0 间接依赖 npm
@types/graceful-fs 4.1.5 间接依赖 npm
string.prototype.trimstart 1.0.5 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
isexe 2.0.0 间接依赖 npm
raw-body 2.5.1 间接依赖 npm
mongodb 4.8.1 间接依赖 npm
emoji-regex 8.0.0 间接依赖 npm
process-warning 2.0.0 间接依赖 npm
entities 4.3.0 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
tle.js 4.7.1 直接依赖 npm
only 0.0.2 间接依赖 npm
on-finished 2.4.1 间接依赖 npm
inflation 2.0.0 间接依赖 npm
jest-diff 29.0.1 间接依赖 npm
glob 7.2.3 间接依赖 npm
@babel/traverse 7.18.13 间接依赖 npm
ext 1.6.0 间接依赖 npm
http-errors 1.8.1 间接依赖 npm
cacheable-lookup 6.0.4 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
import-local 3.1.0 间接依赖 npm
jest-each 29.0.1 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
smart-buffer 4.2.0 间接依赖 npm
heap 0.2.7 间接依赖 npm
babel-jest 29.0.1 间接依赖 npm
@types/json-buffer 3.0.0 间接依赖 npm
string-width 4.2.3 间接依赖 npm
whatwg-url 11.0.0 间接依赖 npm
@babel/plugin-syntax-class-properties 7.12.13 间接依赖 npm
is-generator-function 1.0.10 间接依赖 npm
estraverse 4.3.0 间接依赖 npm
@babel/helper-split-export-declaration 7.18.6 间接依赖 npm
@jest/console 29.0.1 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
npm-run-path 4.0.1 间接依赖 npm
@babel/plugin-syntax-nullish-coalescing-operator 7.8.3 间接依赖 npm
human-signals 2.1.0 间接依赖 npm
write-file-atomic 4.0.2 间接依赖 npm
ms 2.1.2 间接依赖 npm
cache-content-type 1.0.1 间接依赖 npm
type-is 1.6.18 间接依赖 npm
moment-range 4.0.2 直接依赖 npm
toidentifier 1.0.1 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
import-fresh 3.3.0 间接依赖 npm
istanbul-lib-report 3.0.0 间接依赖 npm
detect-newline 3.1.0 间接依赖 npm
bytes 3.1.2 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
jest-changed-files 29.0.0 间接依赖 npm
yallist 4.0.0 间接依赖 npm
internal-slot 1.0.3 间接依赖 npm
anymatch 3.1.2 间接依赖 npm
@types/istanbul-lib-report 3.0.0 间接依赖 npm
fast-glob 3.2.11 间接依赖 npm
semver 7.3.7 间接依赖 npm
@humanwhocodes/object-schema 1.2.1 间接依赖 npm
yocto-queue 0.1.0 直接依赖 npm
@babel/code-frame 7.18.6 间接依赖 npm
wrap-ansi 7.0.0 间接依赖 npm
v8-to-istanbul 9.0.1 间接依赖 npm
clone-response 1.0.2 间接依赖 npm
inflight 1.0.6 间接依赖 npm
strip-ansi 6.0.1 间接依赖 npm
flat-cache 3.0.4 间接依赖 npm
@ampproject/remapping 2.2.0 间接依赖 npm
@types/yargs 17.0.11 间接依赖 npm
pretty-format 29.0.1 间接依赖 npm
@jest/test-result 29.0.1 间接依赖 npm
@babel/plugin-syntax-jsx 7.18.6 间接依赖 npm
deep-is 0.1.4 间接依赖 npm
lines-and-columns 1.2.4 间接依赖 npm
pino-std-serializers 6.0.0 间接依赖 npm
babel-preset-current-node-syntax 1.0.1 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
ansi-escapes 4.3.2 间接依赖 npm
@szmarczak/http-timer 5.0.1 间接依赖 npm
jest-watcher 29.0.1 间接依赖 npm
@jest/reporters 29.0.1 间接依赖 npm
make-dir 3.1.0 间接依赖 npm
esquery 1.4.0 间接依赖 npm
memory-pager 1.5.0 间接依赖 npm
methods 1.1.2 间接依赖 npm
atomic-sleep 1.0.0 间接依赖 npm
has-symbols 1.0.3 间接依赖 npm
eslint-plugin-import 2.26.0 直接依赖 npm
lodash 4.17.21 直接依赖 npm
expect 29.0.1 间接依赖 npm
@types/responselike 1.0.0 间接依赖 npm
is-bigint 1.0.4 间接依赖 npm
accepts 1.3.8 间接依赖 npm
strip-final-newline 2.0.0 间接依赖 npm
media-typer 0.3.0 间接依赖 npm
real-require 0.1.0 间接依赖 npm
@types/http-cache-semantics 4.0.1 间接依赖 npm
jest-circus 29.0.1 间接依赖 npm
has 1.0.3 间接依赖 npm
jest-snapshot 29.0.1 间接依赖 npm
@babel/helper-environment-visitor 7.18.9 间接依赖 npm
eslint-scope 5.1.1 间接依赖 npm
makeerror 1.0.12 间接依赖 npm
@jest/fake-timers 29.0.1 间接依赖 npm
webidl-conversions 7.0.0 间接依赖 npm
destroy 1.2.0 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
@babel/plugin-syntax-optional-chaining 7.8.3 间接依赖 npm
color-convert 2.0.1 间接依赖 npm
co 4.6.0 间接依赖 npm
jsesc 2.5.2 间接依赖 npm
@jridgewell/gen-mapping 0.1.1 间接依赖 npm
jest-pnp-resolver 1.2.2 间接依赖 npm
fuzzball 2.1.2 直接依赖 npm
@typescript-eslint/eslint-plugin 5.35.1 直接依赖 npm
eslint-utils 3.0.0 间接依赖 npm
@humanwhocodes/gitignore-to-minimatch 1.0.2 间接依赖 npm
is-number-object 1.0.7 间接依赖 npm
resolve.exports 1.1.0 间接依赖 npm
koa-convert 2.0.0 间接依赖 npm
chalk 4.1.2 间接依赖 npm
@bcoe/v8-coverage 0.2.3 间接依赖 npm
@babel/helper-module-transforms 7.18.9 间接依赖 npm
array-includes 3.1.5 间接依赖 npm
slash 3.0.0 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
@jridgewell/resolve-uri 3.1.0 间接依赖 npm
doctrine 3.0.0 间接依赖 npm
jest-resolve 29.0.1 间接依赖 npm
is-generator-fn 2.1.0 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
@babel/plugin-syntax-async-generators 7.8.4 间接依赖 npm
@types/yargs-parser 21.0.0 间接依赖 npm
@babel/helper-validator-option 7.18.6 间接依赖 npm
es6-iterator 2.0.3 间接依赖 npm
yargs 17.5.1 间接依赖 npm
@babel/template 7.18.10 间接依赖 npm
text-table 0.2.0 间接依赖 npm
eslint-import-resolver-node 0.3.6 间接依赖 npm
babel-plugin-istanbul 6.1.1 间接依赖 npm
resolve-cwd 3.0.0 间接依赖 npm
setprototypeof 1.2.0 间接依赖 npm
@babel/helper-hoist-variables 7.18.6 间接依赖 npm
fsevents 2.3.2 间接依赖 npm
parseurl 1.3.3 间接依赖 npm
strip-bom 4.0.0 间接依赖 npm
@babel/helpers 7.18.9 间接依赖 npm
mongoose-paginate-v2 1.7.0 直接依赖 npm
helmet 4.6.0 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
@typescript-eslint/typescript-estree 5.35.1 间接依赖 npm
unpipe 1.0.0 间接依赖 npm
camelcase 5.3.1 间接依赖 npm
deepmerge 4.2.2 间接依赖 npm
espree 9.4.0 间接依赖 npm
standard-as-callback 2.1.0 间接依赖 npm
@types/babel__generator 7.6.4 间接依赖 npm
psl 1.8.0 间接依赖 npm
koa-router 12.0.0 直接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
lodash.isarguments 3.1.0 间接依赖 npm
type-check 0.4.0 间接依赖 npm
sift 16.0.0 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
pino-abstract-transport 1.0.0 间接依赖 npm
execa 5.1.1 间接依赖 npm
responselike 2.0.0 间接依赖 npm
event-target-shim 5.0.1 间接依赖 npm
@ioredis/commands 1.2.0 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
thread-stream 2.0.0 间接依赖 npm
prelude-ls 1.2.1 间接依赖 npm
@jest/schemas 29.0.0 间接依赖 npm
jest-regex-util 29.0.0 间接依赖 npm
escape-string-regexp 4.0.0 间接依赖 npm
encodeurl 1.0.2 间接依赖 npm
@typescript-eslint/type-utils 5.35.1 间接依赖 npm
word-wrap 1.2.3 间接依赖 npm
flatted 3.2.5 间接依赖 npm
tmpl 1.0.5 间接依赖 npm
@humanwhocodes/config-array 0.10.4 间接依赖 npm
minimatch 3.1.2 间接依赖 npm
globby 11.1.0 间接依赖 npm
es-abstract 1.20.1 间接依赖 npm
merge2 1.4.1 间接依赖 npm
@jest/core 29.0.1 间接依赖 npm
terminal-link 2.1.1 间接依赖 npm
@types/stack-utils 2.0.1 间接依赖 npm
path-to-regexp 6.2.1 间接依赖 npm
domutils 3.0.1 间接依赖 npm
@typescript-eslint/visitor-keys 5.35.1 间接依赖 npm
normalize-url 6.1.0 间接依赖 npm
sonic-boom 3.1.0 间接依赖 npm
path-key 3.1.1 间接依赖 npm
function.prototype.name 1.1.5 间接依赖 npm
node-int64 0.4.0 间接依赖 npm
cheerio-select 2.1.0 间接依赖 npm
resolve-alpn 1.2.1 间接依赖 npm
regexp.prototype.flags 1.4.3 间接依赖 npm
readable-stream 4.0.0 间接依赖 npm
is-shared-array-buffer 1.0.2 间接依赖 npm
ansi-regex 5.0.1 间接依赖 npm
universalify 0.2.0 间接依赖 npm
char-regex 1.0.2 间接依赖 npm
quick-format-unescaped 4.0.4 间接依赖 npm
@sinonjs/fake-timers 9.1.2 间接依赖 npm
dir-glob 3.0.1 间接依赖 npm
@sinonjs/commons 1.8.3 间接依赖 npm
cron 2.1.0 直接依赖 npm
debug 4.3.4 间接依赖 npm
copy-to 2.0.1 间接依赖 npm
css-select 5.1.0 间接依赖 npm
setimmediate 1.0.5 间接依赖 npm
http-cache-semantics 4.1.0 间接依赖 npm
nth-check 2.1.1 间接依赖 npm
p-try 1.0.0 间接依赖 npm
tsconfig-paths 3.14.1 间接依赖 npm
@babel/helper-compilation-targets 7.18.9 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
@jest/test-sequencer 29.0.1 间接依赖 npm
acorn 8.8.0 间接依赖 npm
eslint-config-airbnb-base 15.0.0 直接依赖 npm
@jridgewell/trace-mapping 0.3.15 间接依赖 npm
@nodelib/fs.scandir 2.1.5 间接依赖 npm
test-exclude 6.0.0 间接依赖 npm
@jest/expect 29.0.1 间接依赖 npm
eslint-module-utils 2.7.3 间接依赖 npm
shebang-command 2.0.0 间接依赖 npm
jest-resolve-dependencies 29.0.1 间接依赖 npm
koa-helmet 6.1.0 直接依赖 npm
supports-hyperlinks 2.2.0 间接依赖 npm
kleur 3.0.3 间接依赖 npm
satellite.js 4.1.3 间接依赖 npm
etag 1.8.1 间接依赖 npm
object.assign 4.1.2 间接依赖 npm
defer-to-connect 2.0.1 间接依赖 npm
@jest/environment 29.0.1 间接依赖 npm
unbox-primitive 1.0.2 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
@babel/core 7.18.13 间接依赖 npm
sparse-bitfield 3.0.3 间接依赖 npm
jest-util 29.0.1 间接依赖 npm
gensync 1.0.0-beta.2 间接依赖 npm
pump 3.0.0 直接依赖 npm
fresh 0.5.2 间接依赖 npm
bson 4.7.0 间接依赖 npm
denque 2.0.1 间接依赖 npm
fb-watchman 2.0.1 间接依赖 npm
reusify 1.0.4 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
cjs-module-lexer 1.2.2 间接依赖 npm
@typescript-eslint/parser 5.35.1 直接依赖 npm
micromatch 4.0.5 间接依赖 npm
got 12.3.1 直接依赖 npm
walker 1.0.8 间接依赖 npm
source-map-support 0.5.13 间接依赖 npm
tsutils 3.21.0 间接依赖 npm
@babel/plugin-syntax-import-meta 7.10.4 间接依赖 npm
cliui 7.0.4 间接依赖 npm
stack-utils 2.0.5 间接依赖 npm
which-boxed-primitive 1.0.2 间接依赖 npm
object-inspect 1.12.2 间接依赖 npm
babel-plugin-jest-hoist 29.0.0 间接依赖 npm
is-weakref 1.0.2 间接依赖 npm
istanbul-reports 3.1.5 间接依赖 npm
base64-js 1.5.1 间接依赖 npm
to-fast-properties 2.0.0 间接依赖 npm
esprima 4.0.1 直接依赖 npm
signal-exit 3.0.7 间接依赖 npm
@types/webidl-conversions 6.1.1 间接依赖 npm
http2-wrapper 2.1.11 间接依赖 npm
pirates 4.0.5 间接依赖 npm
istanbul-lib-source-maps 4.0.1 间接依赖 npm
sax 1.2.4 间接依赖 npm
lru-cache 6.0.0 间接依赖 npm
once 1.4.0 间接依赖 npm
get-package-type 0.1.0 间接依赖 npm
callsites 3.1.0 间接依赖 npm
optionator 0.9.1 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
buffer-from 1.1.2 间接依赖 npm
@typescript-eslint/utils 5.35.1 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
strip-json-comments 3.1.1 间接依赖 npm
htmlparser2 8.0.1 间接依赖 npm
dom-serializer 2.0.0 间接依赖 npm
@jest/transform 29.0.1 间接依赖 npm
json-buffer 3.0.1 间接依赖 npm
p-locate 2.0.0 间接依赖 npm
lowercase-keys 3.0.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
is-date-object 1.0.5 间接依赖 npm
@istanbuljs/load-nyc-config 1.1.0 间接依赖 npm
d 1.0.1 间接依赖 npm
json5 2.2.1 间接依赖 npm
fast-redact 3.1.1 间接依赖 npm
deep-equal 1.0.1 间接依赖 npm
@babel/helper-function-name 7.18.9 间接依赖 npm
koa-compose 4.1.0 间接依赖 npm
yargs-parser 21.1.1 间接依赖 npm
redis-errors 1.2.0 间接依赖 npm
emittery 0.10.2 间接依赖 npm
cheerio 1.0.0-rc.12 直接依赖 npm
browserslist 4.21.3 间接依赖 npm
abort-controller 3.0.0 间接依赖 npm
http-assert 1.5.0 间接依赖 npm
tsscmp 1.0.6 间接依赖 npm
@types/istanbul-lib-coverage 2.0.4 间接依赖 npm
is-callable 1.2.4 间接依赖 npm
collect-v8-coverage 1.0.1 间接依赖 npm
content-disposition 0.5.4 间接依赖 npm
mongodb-connection-string-url 2.5.3 间接依赖 npm
@babel/helper-module-imports 7.18.6 间接依赖 npm
jest-message-util 29.0.1 间接依赖 npm
minimist 1.2.6 间接依赖 npm
blake3 2.1.7 直接依赖 npm
@babel/helper-validator-identifier 7.18.6 间接依赖 npm
@jridgewell/set-array 1.1.2 间接依赖 npm
ansi-styles 4.3.0 间接依赖 npm
jest-environment-node 29.0.1 间接依赖 npm
qs 6.10.5 间接依赖 npm
picomatch 2.3.1 间接依赖 npm
@babel/plugin-syntax-optional-catch-binding 7.8.3 间接依赖 npm
has-flag 4.0.0 间接依赖 npm
convert-source-map 1.8.0 间接依赖 npm
@babel/helper-string-parser 7.18.10 间接依赖 npm
mongoose-id 0.1.3 直接依赖 npm
koa 2.13.4 直接依赖 npm
xml2js 0.4.23 间接依赖 npm
@types/json5 0.0.29 间接依赖 npm
braces 3.0.2 间接依赖 npm
statuses 1.5.0 间接依赖 npm
path-type 4.0.0 间接依赖 npm
string.prototype.codepointat 0.2.1 间接依赖 npm
luxon 1.28.0 间接依赖 npm
@babel/plugin-syntax-top-level-await 7.14.5 间接依赖 npm
parse5-htmlparser2-tree-adapter 7.0.0 间接依赖 npm
@istanbuljs/schema 0.1.3 间接依赖 npm
socks 2.7.0 间接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
depd 2.0.0 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
@babel/plugin-syntax-typescript 7.18.6 间接依赖 npm
jest-leak-detector 29.0.1 间接依赖 npm
@types/babel__template 7.4.1 间接依赖 npm
@babel/highlight 7.18.6 间接依赖 npm
is-core-module 2.9.0 间接依赖 npm
split2 4.1.0 间接依赖 npm
jest 29.0.1 直接依赖 npm
cluster-key-slot 1.1.0 间接依赖 npm
jest-validate 29.0.1 间接依赖 npm
escape-html 1.0.3 间接依赖 npm
@nodelib/fs.walk 1.2.8 间接依赖 npm
co-body 6.1.0 间接依赖 npm
mpath 0.9.0 间接依赖 npm
html-escaper 2.0.2 间接依赖 npm
resolve 1.22.1 间接依赖 npm
is-regex 1.1.4 间接依赖 npm
decompress-response 6.0.0 间接依赖 npm
@types/istanbul-reports 3.0.1 间接依赖 npm
es5-ext 0.10.61 间接依赖 npm
string-length 4.0.2 间接依赖 npm
react-is 18.2.0 间接依赖 npm
@types/keyv 3.1.4 间接依赖 npm
tr46 3.0.0 间接依赖 npm
@jest/expect-utils 29.0.1 间接依赖 npm
source-map 0.6.1 间接依赖 npm
y18n 5.0.8 间接依赖 npm
string.fromcodepoint 0.2.1 间接依赖 npm
mimic-response 1.0.1 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
jest-cli 29.0.1 间接依赖 npm
file-entry-cache 6.0.1 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
moment 2.29.4 间接依赖 npm
rss-parser 3.12.0 直接依赖 npm
es6-symbol 3.1.3 间接依赖 npm
has-property-descriptors 1.0.0 间接依赖 npm
ieee754 1.2.1 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
jest-runner 29.0.1 间接依赖 npm
globals 13.17.0 间接依赖 npm
xmlbuilder 11.0.1 间接依赖 npm
bser 2.1.1 间接依赖 npm
@jest/source-map 29.0.0 间接依赖 npm
levn 0.4.1 间接依赖 npm
p-cancelable 3.0.0 间接依赖 npm
@jest/types 29.0.1 间接依赖 npm
string.prototype.trimend 1.0.5 间接依赖 npm
domhandler 5.0.3 间接依赖 npm
@types/babel__core 7.1.19 间接依赖 npm
regexpp 3.2.0 间接依赖 npm
@babel/plugin-syntax-object-rest-spread 7.8.3 间接依赖 npm
koa-conditional-get 3.0.0 直接依赖 npm
ip 2.0.0 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
@babel/plugin-syntax-bigint 7.8.3 间接依赖 npm
istanbul-lib-instrument 5.2.0 间接依赖 npm
exit 0.1.2 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
dotenv 16.0.1 直接依赖 npm
escalade 3.1.1 间接依赖 npm
koa-etag 4.0.0 直接依赖 npm
es-shim-unscopables 1.0.0 间接依赖 npm
@sindresorhus/is 5.3.0 间接依赖 npm
jest-get-type 29.0.0 间接依赖 npm
jest-haste-map 29.0.1 间接依赖 npm
@jridgewell/sourcemap-codec 1.4.14 间接依赖 npm
mquery 4.0.3 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
jest-runtime 29.0.1 间接依赖 npm
dedent 0.7.0 间接依赖 npm
pino 8.4.2 直接依赖 npm
@types/babel__traverse 7.18.0 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
on-exit-leak-free 2.1.0 间接依赖 npm
array.prototype.flat 1.3.0 间接依赖 npm
has-bigints 1.0.2 间接依赖 npm
esrecurse 4.3.0 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
@eslint/eslintrc 1.3.1 间接依赖 npm
leven 3.1.0 间接依赖 npm
css-what 6.1.0 间接依赖 npm
jest-mock 29.0.1 间接依赖 npm
argparse 2.0.1 间接依赖 npm
istanbul-lib-coverage 3.2.0 间接依赖 npm
supports-color 7.2.0 间接依赖 npm
onetime 5.1.2 间接依赖 npm
get-symbol-description 1.0.0 间接依赖 npm
content-type 1.0.4 间接依赖 npm
array-union 2.1.0 间接依赖 npm
jest-config 29.0.1 间接依赖 npm
moment-timezone 0.5.37 直接依赖 npm
vary 1.1.2 间接依赖 npm
sisteransi 1.0.5 间接依赖 npm
@babel/helper-plugin-utils 7.18.9 间接依赖 npm
typescript 4.7.4 直接依赖 npm
mime-db 1.52.0 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
@types/cacheable-request 6.0.2 间接依赖 npm
functions-have-names 1.2.3 间接依赖 npm
color-name 1.1.4 间接依赖 npm
@types/json-schema 7.0.11 间接依赖 npm
eslint-visitor-keys 3.3.0 间接依赖 npm
graceful-fs 4.2.10 间接依赖 npm
es-to-primitive 1.2.1 间接依赖 npm
type 1.2.0 间接依赖 npm
safe-stable-stringify 2.3.1 间接依赖 npm
@typescript-eslint/types 5.35.1 间接依赖 npm
ajv 6.12.6 间接依赖 npm
sprintf-js 1.0.3 直接依赖 npm
@babel/generator 7.18.13 间接依赖 npm
run-parallel 1.2.0 间接依赖 npm
locate-path 2.0.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
call-bind 1.0.2 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
(0)
上一篇 2024年2月10日
下一篇 2024年2月11日

相关推荐

  • altrim/ember-cli-tooltipster 软件分析报告

    基础信息 项目名称:altrim/ember-cli-tooltipster 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715741844792197120/1715741844863500288 此报告由M…

    软件分析 2023年10月23日
    0
  • jaredpalmer/formik 软件分析报告

    基础信息 项目名称:jaredpalmer/formik 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721293060028846081/1724082555673595904 此报告由Murphysec提供…

    软件分析 2023年11月13日
    0
  • ebourg/hessian 软件分析报告

    基础信息 项目名称:ebourg/hessian 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721154866176397312/1727879523951140864 此报告由Murphysec提供 漏洞列…

    软件分析 2023年11月24日
    0
  • joshuaferrara/node-csgo 软件分析报告

    基础信息 项目名称:joshuaferrara/node-csgo 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719267292948856832/1719267296417546240 此报告由Murphy…

    软件分析 2023年10月31日
    0
  • d4nyll/smartscroll 软件分析报告

    基础信息 项目名称:d4nyll/smartscroll 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721120231937609728/1725701631087435776 此报告由Murphysec提供…

    软件分析 2023年11月18日
    0