supabase/realtime 软件分析报告

基础信息

项目名称:supabase/realtime

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1746665939430051840/1746665939480383488

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
ZEIT Next.js 安全漏洞 MPS-cl5v-ayrn CVE-2023-46298 高危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
semver 7.3.8 7.5.2 间接依赖 可选修复
next 12.1.0 13.4.20-canary.13 直接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 269
ISC 29
BSD-2-Clause 9
BSD-3-Clause 4
Apache-2.0 10
MPL-2.0 1
GPL-3.0-or-later 1
Python-2.0 1
ODC-By-1.0 1
CC-BY-4.0 1
0BSD 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
eslint-plugin-react-hooks 4.6.0 间接依赖 npm
inflight 1.0.6 间接依赖 npm
eslint 8.11.0 直接依赖 npm
damerau-levenshtein 1.0.8 间接依赖 npm
anymatch 3.1.2 间接依赖 npm
@types/lodash.samplesize 4.2.6 直接依赖 npm
@types/lodash 4.14.180 间接依赖 npm
is-string 1.0.7 间接依赖 npm
acorn 8.7.0 间接依赖 npm
@eslint/eslintrc 1.2.1 间接依赖 npm
detect-node-es 1.1.0 间接依赖 npm
@supabase/gotrue-js 2.3.1 间接依赖 npm
styled-jsx 5.0.0 间接依赖 npm
lodash.castarray 4.4.0 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
esrecurse 4.3.0 间接依赖 npm
is-date-object 1.0.5 间接依赖 npm
safe-regex-test 1.0.0 间接依赖 npm
detective 5.2.0 间接依赖 npm
dlv 1.1.3 间接依赖 npm
@next/swc-linux-x64-musl 12.1.0 间接依赖 npm
hoist-non-react-statics 3.3.2 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
eslint-utils 3.0.0 间接依赖 npm
@types/lodash.clonedeep 4.5.6 直接依赖 npm
is-symbol 1.0.4 间接依赖 npm
node-fetch 2.6.11 间接依赖 npm
@supabase/realtime-js 2.1.0 间接依赖 npm
@supabase/realtime-js 2.7.3 间接依赖 npm
eslint-import-resolver-node 0.3.6 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
@next/eslint-plugin-next 12.3.4 间接依赖 npm
deepmerge 4.2.2 间接依赖 npm
@nodelib/fs.walk 1.2.8 间接依赖 npm
didyoumean 1.2.2 间接依赖 npm
@babel/code-frame 7.16.7 间接依赖 npm
has-property-descriptors 1.0.0 间接依赖 npm
object.fromentries 2.0.6 间接依赖 npm
jsx-ast-utils 3.3.3 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
fastq 1.13.0 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
array.prototype.tosorted 1.1.1 间接依赖 npm
formik 2.2.9 间接依赖 npm
react-is 16.13.1 间接依赖 npm
@next/swc-android-arm64 12.1.0 间接依赖 npm
@typescript-eslint/types 5.44.0 间接依赖 npm
utf-8-validate 5.0.10 间接依赖 npm
eslint-visitor-keys 3.3.0 间接依赖 npm
es6-iterator 2.0.3 间接依赖 npm
ansi-styles 4.3.0 间接依赖 npm
side-channel 1.0.4 间接依赖 npm
@radix-ui/colors 0.1.8 间接依赖 npm
optionator 0.9.1 间接依赖 npm
type 1.2.0 间接依赖 npm
js-yaml 4.1.0 间接依赖 npm
node-gyp-build 4.5.0 间接依赖 npm
shebang-command 2.0.0 间接依赖 npm
react-remove-scroll 2.5.5 直接依赖 npm
binary-extensions 2.2.0 间接依赖 npm
functions-have-names 1.2.3 间接依赖 npm
flat-cache 3.0.4 间接依赖 npm
string.prototype.trimstart 1.0.6 间接依赖 npm
axe-core 4.5.2 间接依赖 npm
is-binary-path 2.1.0 间接依赖 npm
escape-string-regexp 4.0.0 间接依赖 npm
function.prototype.name 1.1.5 间接依赖 npm
inherits 2.0.4 间接依赖 npm
eslint-import-resolver-typescript 2.7.1 间接依赖 npm
get-nonce 1.0.1 间接依赖 npm
eslint-plugin-jsx-a11y 6.6.1 间接依赖 npm
is-regex 1.1.4 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
semver 7.3.8 间接依赖 npm
chokidar 3.5.3 间接依赖 npm
get-symbol-description 1.0.0 间接依赖 npm
define-properties 1.1.4 间接依赖 npm
prelude-ls 1.2.1 间接依赖 npm
@next/swc-win32-x64-msvc 12.1.0 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
lodash.samplesize 4.2.0 直接依赖 npm
@types/react 17.0.41 直接依赖 npm
lilconfig 2.0.5 直接依赖 npm
yallist 4.0.0 间接依赖 npm
object-inspect 1.12.2 间接依赖 npm
node-releases 2.0.2 间接依赖 npm
is-callable 1.2.7 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
lodash 4.17.21 间接依赖 npm
string.prototype.matchall 4.0.8 间接依赖 npm
path-key 3.1.1 间接依赖 npm
webidl-conversions 3.0.1 间接依赖 npm
tailwindcss-radix 1.6.0 间接依赖 npm
mini-svg-data-uri 1.4.4 间接依赖 npm
axobject-query 2.2.0 间接依赖 npm
@supabase/postgrest-js 1.7.1 间接依赖 npm
object-hash 2.2.0 间接依赖 npm
slash 3.0.0 间接依赖 npm
@supabase/functions-js 2.0.0 间接依赖 npm
@radix-ui/popper 0.1.0 直接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
chalk 4.1.2 间接依赖 npm
postcss-js 4.0.0 间接依赖 npm
next 12.1.0 直接依赖 npm
@types/node 20.3.2 间接依赖 npm
acorn-jsx 5.3.2 间接依赖 npm
doctrine 2.1.0 间接依赖 npm
is-core-module 2.11.0 间接依赖 npm
estraverse 5.3.0 间接依赖 npm
lru-cache 6.0.0 间接依赖 npm
get-intrinsic 1.1.3 间接依赖 npm
@mertasan/tailwindcss-variables 2.5.1 间接依赖 npm
es-abstract 1.20.4 间接依赖 npm
which 2.0.2 间接依赖 npm
isexe 2.0.0 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
strip-bom 3.0.0 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
@types/json5 0.0.29 间接依赖 npm
resolve 1.22.0 间接依赖 npm
@next/swc-linux-arm64-musl 12.1.0 间接依赖 npm
eslint-module-utils 2.7.4 间接依赖 npm
quick-lru 5.1.1 间接依赖 npm
@next/swc-darwin-x64 12.1.0 间接依赖 npm
@typescript-eslint/parser 5.44.0 间接依赖 npm
@typescript-eslint/visitor-keys 5.44.0 间接依赖 npm
normalize-range 0.1.2 间接依赖 npm
autoprefixer 10.4.4 间接依赖 npm
cross-fetch 3.1.6 间接依赖 npm
array.prototype.flat 1.3.1 间接依赖 npm
call-bind 1.0.2 间接依赖 npm
yaeti 0.0.6 间接依赖 npm
@types/websocket 1.0.5 间接依赖 npm
@next/swc-linux-arm64-gnu 12.1.0 间接依赖 npm
lines-and-columns 1.2.4 间接依赖 npm
balanced-match 1.0.2 间接依赖 npm
is-weakref 1.0.2 间接依赖 npm
esutils 2.0.3 间接依赖 npm
tr46 0.0.3 间接依赖 npm
reusify 1.0.4 间接依赖 npm
ms 2.1.2 间接依赖 npm
csstype 3.0.11 间接依赖 npm
cross-fetch 3.1.5 间接依赖 npm
@babel/runtime-corejs3 7.20.1 间接依赖 npm
esquery 1.4.0 间接依赖 npm
strip-json-comments 3.1.1 间接依赖 npm
@next/swc-linux-arm-gnueabihf 12.1.0 间接依赖 npm
tailwindcss 3.0.23 间接依赖 npm
fsevents 2.3.2 间接依赖 npm
yaml 1.10.2 间接依赖 npm
@tailwindcss/forms 0.4.1 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
es-to-primitive 1.2.1 间接依赖 npm
which-boxed-primitive 1.0.2 间接依赖 npm
fraction.js 4.2.0 间接依赖 npm
deep-is 0.1.4 间接依赖 npm
regexp.prototype.flags 1.4.3 间接依赖 npm
react 17.0.2 直接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
postcss 8.4.32 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
debug 2.6.9 间接依赖 npm
array-includes 3.1.6 间接依赖 npm
lodash.isplainobject 4.0.6 间接依赖 npm
core-js-pure 3.26.1 间接依赖 npm
es5-ext 0.10.62 间接依赖 npm
@types/parse-json 4.0.0 间接依赖 npm
@babel/runtime 7.20.1 间接依赖 npm
eslint-scope 7.1.1 间接依赖 npm
ansi-regex 5.0.1 间接依赖 npm
word-wrap 1.2.4 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
regexpp 3.2.0 间接依赖 npm
has-flag 4.0.0 间接依赖 npm
node-fetch 2.6.7 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
text-table 0.2.0 间接依赖 npm
minimatch 3.1.2 间接依赖 npm
source-map-js 1.0.2 间接依赖 npm
flatted 3.2.5 间接依赖 npm
@typescript-eslint/typescript-estree 5.44.0 间接依赖 npm
globby 11.1.0 间接依赖 npm
@headlessui/react 1.7.4 间接依赖 npm
typedarray-to-buffer 3.1.5 间接依赖 npm
postcss-nested 5.0.6 间接依赖 npm
tsutils 3.21.0 间接依赖 npm
merge2 1.4.1 间接依赖 npm
import-fresh 3.3.0 间接依赖 npm
ignore 5.2.0 间接依赖 npm
type-fest 0.20.2 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
xtend 4.0.2 间接依赖 npm
@radix-ui/react-presence 0.1.2 直接依赖 npm
typescript 4.6.2 直接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
has-bigints 1.0.2 间接依赖 npm
react-style-singleton 2.2.1 间接依赖 npm
emoji-regex 9.2.2 间接依赖 npm
@types/node 17.0.21 直接依赖 npm
tiny-warning 1.0.3 间接依赖 npm
rimraf 3.0.2 间接依赖 npm
@supabase/postgrest-js 1.1.0 间接依赖 npm
@supabase/ui 0.37.0-alpha.81 直接依赖 npm
escalade 3.1.1 间接依赖 npm
@next/swc-darwin-arm64 12.1.0 间接依赖 npm
file-entry-cache 6.0.1 间接依赖 npm
@types/phoenix 1.5.4 间接依赖 npm
glob 7.2.0 间接依赖 npm
dir-glob 3.0.1 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
@humanwhocodes/config-array 0.9.5 间接依赖 npm
@supabase/storage-js 2.5.1 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
client-only 0.0.1 间接依赖 npm
acorn-walk 7.2.0 间接依赖 npm
argparse 2.0.1 间接依赖 npm
object.assign 4.1.4 间接依赖 npm
parse-json 5.2.0 间接依赖 npm
@tailwindcss/typography 0.5.8 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
array.prototype.flatmap 1.3.1 间接依赖 npm
supports-color 7.2.0 间接依赖 npm
ast-types-flow 0.0.7 间接依赖 npm
react-fast-compare 2.0.4 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
picocolors 1.0.0 间接依赖 npm
braces 3.0.2 间接依赖 npm
debug 4.3.4 间接依赖 npm
language-subtag-registry 0.3.22 间接依赖 npm
type 2.7.2 间接依赖 npm
scheduler 0.20.2 间接依赖 npm
use-sidecar 1.1.2 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
eslint-plugin-react 7.31.11 间接依赖 npm
minimist 1.2.7 间接依赖 npm
strip-ansi 6.0.1 间接依赖 npm
object.hasown 1.1.2 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
lodash.throttle 4.1.1 直接依赖 npm
@types/prop-types 15.7.4 间接依赖 npm
tsconfig-paths 3.14.1 间接依赖 npm
has 1.0.3 间接依赖 npm
once 1.4.0 间接依赖 npm
use-callback-ref 1.3.0 间接依赖 npm
@radix-ui/primitive 0.1.0 直接依赖 npm
levn 0.4.1 间接依赖 npm
json5 1.0.2 间接依赖 npm
@supabase/functions-js 2.1.2 间接依赖 npm
node-gyp-build 4.6.0 间接依赖 npm
aria-hidden 1.2.2 直接依赖 npm
postcss-selector-parser 6.0.10 间接依赖 npm
v8-compile-cache 2.3.0 间接依赖 npm
@supabase/supabase-js 2.1.0 直接依赖 npm
postcss-value-parser 4.2.0 间接依赖 npm
readdirp 3.6.0 间接依赖 npm
ms 2.0.0 间接依赖 npm
callsites 3.1.0 间接依赖 npm
camelcase-css 2.0.1 间接依赖 npm
prop-types 15.8.1 间接依赖 npm
react-dom 17.0.2 直接依赖 npm
espree 9.3.1 间接依赖 npm
micromatch 4.0.4 间接依赖 npm
caniuse-lite 1.0.30001434 间接依赖 npm
lodash.clonedeep 4.5.0 直接依赖 npm
lodash-es 4.17.21 间接依赖 npm
whatwg-url 5.0.0 间接依赖 npm
cosmiconfig 7.0.1 间接依赖 npm
fast-glob 3.2.11 间接依赖 npm
bufferutil 4.0.7 间接依赖 npm
@supabase/supabase-js 2.26.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
color-name 1.1.4 间接依赖 npm
eslint-config-next 12.3.4 直接依赖 npm
array-union 2.1.0 间接依赖 npm
globals 13.13.0 间接依赖 npm
@supabase/gotrue-js 2.34.0 间接依赖 npm
websocket 1.0.34 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
electron-to-chromium 1.4.93 间接依赖 npm
@radix-ui/rect 0.1.1 直接依赖 npm
es-shim-unscopables 1.0.0 间接依赖 npm
@next/swc-win32-ia32-msvc 12.1.0 间接依赖 npm
use-subscription 1.5.1 间接依赖 npm
nanoid 3.3.7 间接依赖 npm
@next/env 12.1.0 间接依赖 npm
is-negative-zero 2.0.2 间接依赖 npm
@types/lodash.throttle 4.1.6 直接依赖 npm
language-tags 1.0.5 间接依赖 npm
next-tick 1.1.0 间接依赖 npm
@nodelib/fs.scandir 2.1.5 间接依赖 npm
object.entries 1.1.6 间接依赖 npm
type-check 0.4.0 间接依赖 npm
color-convert 2.0.1 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
is-shared-array-buffer 1.0.2 间接依赖 npm
es6-symbol 3.1.3 间接依赖 npm
run-parallel 1.2.0 间接依赖 npm
invariant 2.2.4 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
@types/scheduler 0.16.2 间接依赖 npm
react-remove-scroll-bar 2.3.4 间接依赖 npm
@humanwhocodes/object-schema 1.2.1 间接依赖 npm
regenerator-runtime 0.13.11 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
@types/phoenix 1.6.0 间接依赖 npm
@rushstack/eslint-patch 1.2.0 间接依赖 npm
ajv 6.12.6 间接依赖 npm
aria-query 4.2.2 间接依赖 npm
string.prototype.trimend 1.0.6 间接依赖 npm
cssesc 3.0.0 间接依赖 npm
acorn-node 1.8.2 间接依赖 npm
browserslist 4.20.2 间接依赖 npm
@babel/highlight 7.16.10 间接依赖 npm
defined 1.0.0 间接依赖 npm
@typescript-eslint/scope-manager 5.44.0 间接依赖 npm
@next/swc-win32-arm64-msvc 12.1.0 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
d 1.0.1 间接依赖 npm
glob-parent 6.0.2 间接依赖 npm
path-type 4.0.0 间接依赖 npm
arg 5.0.1 间接依赖 npm
internal-slot 1.0.3 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
has-tostringtag 1.0.0 间接依赖 npm
has-symbols 1.0.3 间接依赖 npm
@next/swc-linux-x64-gnu 12.1.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
picomatch 2.3.1 间接依赖 npm
tslib 2.4.1 间接依赖 npm
object.values 1.1.6 间接依赖 npm
unbox-primitive 1.0.2 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
loose-envify 1.4.0 间接依赖 npm
eslint-plugin-import 2.26.0 间接依赖 npm
@supabase/storage-js 2.0.0 间接依赖 npm
ext 1.7.0 间接依赖 npm
(0)
上一篇 2024年1月15日
下一篇 2024年1月15日

相关推荐

  • davidear/blur_comment 软件分析报告

    基础信息 项目名称:davidear/blur_comment 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721126262260367360/1725717820803080192 此报告由Murphyse…

    软件分析 2023年11月18日
    0
  • JosephusPaye/Keen-UI 软件分析报告

    基础信息 项目名称:JosephusPaye/Keen-UI 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721320259272396800/1724293909432979456 此报告由Murphysec…

    软件分析 2023年11月14日
    0
  • grimmer0125/search-github-starred 软件分析报告

    基础信息 项目名称:grimmer0125/search-github-starred 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718371187301335040/1718371187351666688 …

    软件分析 2023年10月29日
    0
  • baidu/puck 软件分析报告

    基础信息 项目名称:baidu/puck 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716215409236819968/1716215409291345920 此报告由Murphysec提供 漏洞列表 漏洞…

    软件分析 2023年10月23日
    0
  • uber/zanzibar 软件分析报告

    基础信息 项目名称:uber/zanzibar 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1754287023004745728/1754287038657888256 此报告由Murphysec提供 漏洞列表…

    软件分析 2024年2月5日
    0