fluid-cloudnative/fluid 软件分析报告

基础信息

项目名称:fluid-cloudnative/fluid

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1721203418768343040/1731643000039100416

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Eclipse Jetty 资源管理错误漏洞 拒绝服务 MPS-0e59-bdsi CVE-2023-36478 高危
Netty 存在 HTTP 请求走私漏洞 HTTP请求走私 MPS-2019-12064 CVE-2019-16869 高危
Red Hat JBoss Enterprise Application Platform 代码问题漏洞 反序列化 MPS-2019-12470 CVE-2019-10202 严重
jackson-mapper-asl XXE MPS-2019-15048 CVE-2019-10172 高危
Kubernetes 输入验证错误漏洞 输入验证不恰当 MPS-2019-15838 CVE-2019-11255 中危
Apache Log4j SocketServer反序列化漏洞 反序列化 MPS-2019-17271 CVE-2019-17571 严重
Eclipse Jetty 权限提升漏洞 权限、特权和访问控制 MPS-2020-15633 CVE-2020-27216 高危
Apache HttpClient URI解析错误漏洞 XSS MPS-2020-17341 CVE-2020-13956 中危
FasterXML jackson-databind 代码问题漏洞 XXE MPS-2020-17358 CVE-2020-25649 高危
Eclipse Jetty HTTP 请求走私漏洞 在释放前未清除敏感信息 MPS-2020-17594 CVE-2020-27218 中危
Apache Log4j2 SmtpAppender证书验证不当漏洞 证书验证不恰当 MPS-2020-6684 CVE-2020-9488 低危
Apache Commons Compress 安存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10550 CVE-2021-35517 高危
Apache Commons Compress 存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10551 CVE-2021-35516 高危
Apache Commons Compress 存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10564 CVE-2021-36090 高危
Apache Commons Compress 无限循环漏洞 不可达退出条件的循环(无限循环) MPS-2021-10565 CVE-2021-35515 高危
netplex json-smart-v 分布式拒绝服务攻击 对因果或异常条件的不恰当检查 MPS-2021-2102 CVE-2021-27568 严重
Eclipse Jetty 拒绝服务 MPS-2021-2571 CVE-2020-27223 中危
Apache Commons Net 未授权敏感信息泄露 MPS-2021-28440 CVE-2021-37533 中危
Apache Log4j2 远程代码执行漏洞 反序列化 MPS-2021-38241 CVE-2021-44228 严重
Apache Log4j2 JDBC Appender远程代码执行漏洞 代码注入 MPS-2021-38327 CVE-2021-44832 中危
Apache Log4j JMSAppender反序列化漏洞 反序列化 MPS-2021-38359 CVE-2021-4104 高危
Eclipse Jetty 资源管理错误漏洞 对异常条件的处理不恰当 MPS-2021-3864 CVE-2021-28165 高危
Apache Log4j2 基于上下文查找的远程代码执行漏洞 反序列化 MPS-2021-38665 CVE-2021-45046 严重
Apache Log4j2 自引用拒绝服务漏洞 未经控制的递归 MPS-2021-38752 CVE-2021-45105 中危
Apache Commons IO 存在路径遍历漏洞 路径遍历 MPS-2021-4531 CVE-2021-29425 中危
json-smart 存在拒绝服务漏洞 越界写入 MPS-2021-7737 CVE-2021-31684 高危
Eclipse Jetty 存在信息泄露漏洞 不充分的会话过期机制 MPS-2021-8884 CVE-2021-34428 低危
commons-codec:commons-codec 存在信息泄露漏洞 未授权敏感信息泄露 MPS-2022-11853 低危
gRPC-Java 缓冲区泄露漏洞 通过发送数据的信息暴露 MPS-2022-12216 中危
com.google.code.gson:gson 存在BigDecimal拒绝服务漏洞 反序列化 MPS-2022-12287 CVE-2022-25647 高危
org.apache.hadoop:hadoop-hdfs XXE MPS-2022-12474 中危
FasterXML Jackson-databind 拒绝服务漏洞 拒绝服务 MPS-2022-12500 中危
Apache Log4j JDBCAppender SQL注入漏洞 SQL注入 MPS-2022-1444 CVE-2022-23305 严重
Apache Log4j Chainsaw反序列化漏洞 反序列化 MPS-2022-1445 CVE-2022-23307 高危
Apache Log4j 反序列化漏洞 反序列化 MPS-2022-1446 CVE-2022-23302 高危
Eclipse Jetty URI注入漏洞 注入 MPS-2022-18060 CVE-2022-2047 低危
Alluxio 安全漏洞 日志输出的转义处理不恰当 MPS-2022-2282 CVE-2022-23848 严重
Apache Hadoop 存在shell命令注入漏洞 参数注入或修改 MPS-2022-4190 CVE-2022-25168 严重
woodstox-core XXE MPS-2022-54303 中危
XStream 缓冲区错误漏洞 输入验证不恰当 MPS-2022-57061 CVE-2022-40156 低危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57062 CVE-2022-40155 高危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57063 CVE-2022-40154 高危
XStream 缓冲区错误漏洞 越界写入 MPS-2022-57065 CVE-2022-40152 高危
FasterXML jackson-databind 小于2.14.0-rc1拒绝服务漏洞 拒绝服务 MPS-2022-58653 CVE-2022-42003 中危
FasterXML jackson-databind 小于2.13.4拒绝服务漏洞 拒绝服务 MPS-2022-58654 CVE-2022-42004 中危
Apache Hadoop 存在路径遍历漏洞 路径遍历 MPS-2022-5920 CVE-2022-26612 严重
FasterXML jackson-databind 拒绝服务漏洞 越界写入 MPS-2022-6242 CVE-2020-36518 高危
Eclipse Jetty 资源管理错误漏洞 拒绝服务 MPS-2023-4997 CVE-2023-26048 中危
Eclipse Jetty 信息泄露漏洞 XSS MPS-2023-4998 CVE-2023-26049 中危
netplex json-smart 安全漏洞 未经控制的递归 MPS-2023-7760 CVE-2023-1370 高危
jackson-databind 拒绝服务漏洞 拒绝服务 MPS-2023-8438 CVE-2021-46877 中危
Eclipse Jetty 安全漏洞 MPS-49ot-3w07 CVE-2023-40167 中危
snappy-java 输入验证错误漏洞 整数溢出或环绕 MPS-8znw-4jmi CVE-2023-34453 高危
Okio 安全漏洞 数值类型间的不正确转换 MPS-a2tx-d4fb CVE-2023-3635 高危
snappy-java 的 compress 方法整数溢出漏洞导致拒绝服务 整数溢出或环绕 MPS-angp-mxl2 CVE-2023-34454 中危
ZooKeeper SASL 身份验证绕过漏洞 通过用户控制密钥绕过授权机制 MPS-bznr-672x CVE-2023-44981 高危
Snappy 安全漏洞 不加限制或调节的资源分配 MPS-s7wb-p03z CVE-2023-43642 高危
amqp-client 拒绝服务漏洞 拒绝服务 MPS-sqnw-9vcz CVE-2023-46120 中危
Snappy 输入验证错误漏洞 不加限制或调节的资源分配 MPS-tnp7-60hk CVE-2023-34455 高危
【存在争议】FasterXML jackson-databind 代码问题漏洞 不加限制或调节的资源分配 MPS-z1bx-p8y2 CVE-2023-35116 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
org.apache.logging.log4j:log4j-core 2.13.3 2.17.1 间接依赖 强烈建议修复
org.xerial.snappy:snappy-java 1.0.5 1.1.10.4 间接依赖 建议修复
net.minidev:json-smart 2.3 2.4.9 间接依赖 建议修复
org.eclipse.jetty:jetty-server 9.4.20.v20190813 9.4.51 间接依赖 建议修复
org.apache.commons:commons-compress 1.19 1.21 间接依赖 建议修复
io.netty:netty 3.10.6.Final 间接依赖 建议修复
org.eclipse.jetty:jetty-http 9.4.20.v20190813 11.0.16 间接依赖 建议修复
com.squareup.okio:okio 1.6.0 3.4.0 间接依赖 建议修复
org.eclipse.jetty:jetty-io 9.4.20.v20190813 9.4.39.v20210325 间接依赖 建议修复
org.apache.zookeeper:zookeeper 3.5.8 3.7.2 间接依赖 建议修复
log4j:log4j 1.2.17 间接依赖 建议修复
com.fasterxml.woodstox:woodstox-core 5.0.3 5.4.0 间接依赖 建议修复
org.codehaus.jackson:jackson-mapper-asl 1.9.13 间接依赖 建议修复
org.eclipse.jetty:jetty-webapp 9.4.20.v20190813 9.4.33.v20201020 间接依赖 建议修复
com.fasterxml.jackson.core:jackson-databind 2.10.3 间接依赖 建议修复
org.alluxio:alluxio-core-common 2.4.1 2.7.3 间接依赖 建议修复
org.apache.hadoop:hadoop-common 3.3.0 3.3.3 间接依赖 建议修复
org.apache.hadoop:hadoop-hdfs 3.3.0 3.3.2 直接依赖 可选修复
commons-net:commons-net 3.6 3.9.0 间接依赖 可选修复
org.apache.httpcomponents:httpclient 4.5.6 4.5.13 间接依赖 可选修复
com.rabbitmq:amqp-client 5.5.3 5.18.0 间接依赖 可选修复
com.google.code.gson:gson 2.2.4 2.8.9 间接依赖 可选修复
k8s.io/kubernetes v1.23.0 直接依赖 可选修复
io.grpc:grpc-core 1.28.1 1.33.0 间接依赖 可选修复
commons-io:commons-io 2.5 2.7 间接依赖 可选修复
commons-codec:commons-codec 1.11 1.13 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
自定义许可证 19
Apache-2.0 155
BSD-3-Clause 25
MIT 26
BSD-2-Clause 3
ISC 1
CDDL-1.1 5
LGPL-2.1 1
MPL-1.1 2
WTFPL 1
GPL-2.0 2

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
com.thoughtworks.paranamer:paranamer 2.3 间接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-core 3.3.0 间接依赖 maven
golang.org/x/text v0.13.0 间接依赖 go
github.com/onsi/gomega v1.27.10 直接依赖 go
org.checkerframework:checker-qual 3.33.0 间接依赖 maven
org.eclipse.jetty:jetty-io 9.4.20.v20190813 间接依赖 maven
org.jline:jline 3.9.0 间接依赖 maven
google.golang.org/grpc v1.40.0 直接依赖 go
github.com/golang/protobuf v1.5.3 间接依赖 go
github.com/smarty/assertions v1.15.0 间接依赖 go
org.apache.curator:curator-client 4.2.0 间接依赖 maven
org.apache.httpcomponents:httpclient 4.5.6 间接依赖 maven
org.alluxio:alluxio-core-client 2.4.1 直接依赖 maven
org.apache.yetus:audience-annotations 0.5.0 间接依赖 maven
github.com/go-openapi/jsonpointer v0.19.5 间接依赖 go
github.com/cespare/xxhash/v2 v2.2.0 间接依赖 go
go.uber.org/zap v1.24.0 直接依赖 go
org.apache.hadoop:hadoop-annotations 3.3.0 间接依赖 maven
github.com/emicklei/go-restful v2.16.0+incompatible 间接依赖 go
sigs.k8s.io/yaml v1.3.0 直接依赖 go
org.eclipse.jetty.websocket:websocket-common 9.4.20.v20190813 间接依赖 maven
com.google.guava:failureaccess 1.0.1 间接依赖 maven
com.fasterxml.jackson.core:jackson-annotations 2.10.3 间接依赖 maven
org.eclipse.jetty:jetty-client 9.4.20.v20190813 间接依赖 maven
github.com/go-logr/logr v1.3.0 直接依赖 go
org.alluxio:alluxio-core-client-fs 2.4.1 间接依赖 maven
com.google.guava:guava 32.0.0-jre 直接依赖 maven
org.ow2.asm:asm 5.0.4 间接依赖 maven
gomodules.xyz/jsonpatch/v2 v2.2.0 间接依赖 go
org.eclipse.jetty:jetty-servlet 9.4.20.v20190813 间接依赖 maven
org.apache.hadoop:hadoop-yarn-common 3.3.0 间接依赖 maven
com.fasterxml.jackson.core:jackson-core 2.10.3 间接依赖 maven
golang.org/x/time v0.3.0 间接依赖 go
io.perfmark:perfmark-api 0.19.0 间接依赖 maven
github.com/PuerkitoBio/purell v1.1.1 间接依赖 go
io.grpc:grpc-stub 1.28.1 间接依赖 maven
github.com/kubernetes-csi/csi-lib-utils v0.9.1 间接依赖 go
github.com/docker/go-units v0.5.0 直接依赖 go
dnsjava:dnsjava 2.1.7 间接依赖 maven
github.com/josharian/intern v1.0.0 间接依赖 go
org.apache.kerby:kerb-util 1.0.1 间接依赖 maven
commons-daemon:commons-daemon 1.0.13 间接依赖 maven
org.apache.hadoop:hadoop-common 3.3.0 间接依赖 maven
org.eclipse.jetty:jetty-util-ajax 9.4.20.v20190813 间接依赖 maven
org.apache.commons:commons-configuration2 2.1.1 间接依赖 maven
javax.annotation:javax.annotation-api 1.3.2 间接依赖 maven
github.com/smartystreets/goconvey v1.8.1 直接依赖 go
com.nimbusds:nimbus-jose-jwt 7.9 间接依赖 maven
github.com/stretchr/testify v1.8.4 直接依赖 go
golang.org/x/term v0.13.0 间接依赖 go
k8s.io/kubernetes v1.23.0 直接依赖 go
gopkg.in/yaml.v2 v2.4.0 直接依赖 go
k8s.io/kube-openapi v0.0.0-20211115234752-e816edb12b65 直接依赖 go
k8s.io/utils v0.0.0-20210930125809-cb0fa318a74b 直接依赖 go
com.fasterxml.jackson.jaxrs:jackson-jaxrs-base 2.10.3 间接依赖 maven
google.golang.org/protobuf v1.30.0 间接依赖 go
github.com/golang/mock v1.6.0 直接依赖 go
org.codehaus.jackson:jackson-mapper-asl 1.9.13 间接依赖 maven
github.com/davecgh/go-spew v1.1.1 间接依赖 go
org.apache.kerby:kerb-crypto 1.0.1 间接依赖 maven
github.com/google/uuid v1.1.2 间接依赖 go
javax.xml.bind:jaxb-api 2.2.11 间接依赖 maven
config 间接依赖 pip
github.com/rogpeppe/go-internal v1.10.0 间接依赖 go
io.grpc:grpc-context 1.28.1 间接依赖 maven
io.dropwizard.metrics:metrics-core 4.1.11 间接依赖 maven
org.eclipse.jetty:jetty-util 9.4.20.v20190813 间接依赖 maven
github.com/pkg/errors v0.9.1 直接依赖 go
io.netty:netty 3.10.6.Final 间接依赖 maven
github.com/gogo/protobuf v1.3.2 间接依赖 go
org.apache.kerby:kerb-server 1.0.1 间接依赖 maven
org.apache.kerby:kerb-admin 1.0.1 间接依赖 maven
github.com/googleapis/gnostic v0.5.5 间接依赖 go
github.com/prometheus/client_golang v1.16.0 直接依赖 go
com.sun.jersey:jersey-server 1.19 间接依赖 maven
github.com/pmezard/go-difflib v1.0.0 间接依赖 go
github.com/container-storage-interface/spec v1.7.0 直接依赖 go
org.apache.hadoop:hadoop-client 3.3.0 直接依赖 maven
org.fusesource.leveldbjni:leveldbjni-all 1.8 间接依赖 maven
github.com/modern-go/concurrent v0.0.0-20180306012644-bacd9c7ef1dd 间接依赖 go
com.google.errorprone:error_prone_annotations 2.18.0 间接依赖 maven
com.squareup.okhttp:okhttp 2.7.5 间接依赖 maven
org.apache.avro:avro 1.7.7 间接依赖 maven
org.apache.kerby:kerby-config 1.0.1 间接依赖 maven
log4j:log4j 1.2.17 间接依赖 maven
com.google.j2objc:j2objc-annotations 2.8 间接依赖 maven
github.com/brahma-adshonor/gohook v1.1.9 直接依赖 go
org.slf4j:slf4j-api 1.7.30 间接依赖 maven
github.com/golang/groupcache v0.0.0-20210331224755-41bb18bfe9da 间接依赖 go
org.apache.logging.log4j:log4j-core 2.13.3 间接依赖 maven
org.eclipse.jetty:jetty-webapp 9.4.20.v20190813 间接依赖 maven
github.com/fsnotify/fsnotify v1.5.1 间接依赖 go
com.sun.jersey:jersey-core 1.19 间接依赖 maven
gopkg.in/inf.v0 v0.9.1 间接依赖 go
k8s.io/api v0.23.0 直接依赖 go
commons-logging:commons-logging 1.1.3 间接依赖 maven
commons-collections:commons-collections 3.2.2 间接依赖 maven
github.com/gopherjs/gopherjs v1.17.2 间接依赖 go
org.apache.hadoop:hadoop-auth 3.3.0 间接依赖 maven
github.com/onsi/ginkgo v1.16.5 直接依赖 go
commons-io:commons-io 2.5 间接依赖 maven
org.alluxio:alluxio-core-client-hdfs 2.4.1 直接依赖 maven
github.com/moby/spdystream v0.2.0 间接依赖 go
io.grpc:grpc-api 1.28.1 间接依赖 maven
net.minidev:accessors-smart 1.2 间接依赖 maven
github.com/PuerkitoBio/urlesc v0.0.0-20170810143723-de5bf2ad4578 间接依赖 go
org.alluxio:alluxio-core-transport 2.4.1 间接依赖 maven
net.minidev:json-smart 2.3 间接依赖 maven
commons-cli:commons-cli 1.2 间接依赖 maven
github.com/prometheus/procfs v0.10.1 间接依赖 go
github.com/google/gofuzz v1.1.0 间接依赖 go
golang.org/x/net v0.17.0 直接依赖 go
k8s.io/component-helpers v0.23.0 直接依赖 go
github.com/go-logr/zapr v1.2.0 间接依赖 go
com.sun.jersey:jersey-servlet 1.19 间接依赖 maven
com.google.protobuf:protobuf-java 3.16.3 直接依赖 maven
org.apache.hadoop:hadoop-hdfs-client 3.3.0 间接依赖 maven
google.golang.org/appengine v1.6.7 间接依赖 go
org.apache.kerby:kerby-pkix 1.0.1 间接依赖 maven
org.apache.kerby:kerb-common 1.0.1 间接依赖 maven
javax.servlet.jsp:jsp-api 2.1 间接依赖 maven
github.com/matttproud/golang_protobuf_extensions v1.0.4 间接依赖 go
org.alluxio:alluxio-core-common 2.4.1 间接依赖 maven
org.apache.zookeeper:zookeeper-jute 3.5.8 间接依赖 maven
org.apache.hadoop.thirdparty:hadoop-shaded-protobuf_3_7 1.0.0 间接依赖 maven
org.apache.curator:curator-recipes 4.2.0 间接依赖 maven
org.apache.kerby:kerb-simplekdc 1.0.1 间接依赖 maven
github.com/felixge/fgprof v0.9.3 直接依赖 go
org.apache.zookeeper:zookeeper 3.5.8 间接依赖 maven
org.apache.logging.log4j:log4j-api 2.13.3 间接依赖 maven
com.google.code.findbugs:jsr305 3.0.2 间接依赖 maven
com.google.code.gson:gson 2.2.4 间接依赖 maven
cloud.google.com/go v0.81.0 间接依赖 go
io.dropwizard.metrics:metrics-graphite 4.1.11 间接依赖 maven
org.eclipse.jetty:jetty-xml 9.4.20.v20190813 间接依赖 maven
gopkg.in/tomb.v1 v1.0.0-20141024135613-dd632973f1e7 间接依赖 go
commons-net:commons-net 3.6 间接依赖 maven
com.google.guava:listenablefuture 9999.0-empty-to-avoid-conflict-with-guava 间接依赖 maven
org.apache.httpcomponents:httpcore 4.4.10 间接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-jobclient 3.3.0 间接依赖 maven
org.javassist:javassist 3.26.0-GA 间接依赖 maven
com.squareup.okio:okio 1.6.0 间接依赖 maven
golang.org/x/sys v0.13.0 间接依赖 go
com.fasterxml.woodstox:woodstox-core 5.0.3 间接依赖 maven
com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider 2.10.3 间接依赖 maven
org.apache.hadoop:hadoop-hdfs 3.3.0 直接依赖 maven
org.apache.kerby:kerby-asn1 1.0.1 间接依赖 maven
org.eclipse.jetty:jetty-http 9.4.20.v20190813 间接依赖 maven
org.eclipse.jetty:jetty-security 9.4.20.v20190813 间接依赖 maven
github.com/go-openapi/jsonreference v0.19.5 间接依赖 go
jakarta.xml.bind:jakarta.xml.bind-api 2.3.2 间接依赖 maven
k8s.io/client-go v0.23.0 直接依赖 go
gopkg.in/yaml.v3 v3.0.1 直接依赖 go
github.com/go-openapi/swag v0.19.14 间接依赖 go
org.apache.kerby:kerby-util 1.0.1 间接依赖 maven
org.apache.kerby:kerb-client 1.0.1 间接依赖 maven
k8s.io/apimachinery v0.24.0 直接依赖 go
client 间接依赖 pip
github.com/kubernetes-csi/drivers v1.0.2 直接依赖 go
k8s.io/component-base v0.23.0 直接依赖 go
github.com/prometheus/common v0.42.0 间接依赖 go
com.sun.jersey:jersey-client 1.19 间接依赖 maven
javax.ws.rs:jsr311-api 1.1.1 间接依赖 maven
k8s.io/klog/v2 v2.110.1 直接依赖 go
io.swagger:swagger-annotations 1.6.2 间接依赖 maven
org.apache.hadoop:hadoop-yarn-api 3.3.0 间接依赖 maven
github.com/google/go-cmp v0.5.9 间接依赖 go
org.codehaus.woodstox:stax2-api 3.1.4 间接依赖 maven
com.google.re2j:re2j 1.1 间接依赖 maven
github.com/spf13/cobra v1.7.0 直接依赖 go
org.apache.commons:commons-lang3 3.7 间接依赖 maven
org.apache.kerby:kerby-xdr 1.0.1 间接依赖 maven
commons-beanutils:commons-beanutils 1.9.4 间接依赖 maven
org.alluxio:alluxio-core-base 2.4.1 间接依赖 maven
jakarta.activation:jakarta.activation-api 1.2.1 间接依赖 maven
github.com/spf13/pflag v1.0.5 间接依赖 go
github.com/nxadm/tail v1.4.8 间接依赖 go
github.com/json-iterator/go v1.1.12 间接依赖 go
go.uber.org/multierr v1.6.0 间接依赖 go
github.com/agiledragon/gomonkey/v2 v2.10.1 直接依赖 go
org.slf4j:slf4j-log4j12 1.7.25 间接依赖 maven
org.apache.commons:commons-math3 3.1.1 间接依赖 maven
com.google.android:annotations 4.1.1.4 间接依赖 maven
k8s.io/apiserver v0.23.0 间接依赖 go
org.apache.commons:commons-compress 1.19 间接依赖 maven
io.grpc:grpc-netty 1.28.1 间接依赖 maven
org.apache.commons:commons-text 1.4 间接依赖 maven
io.grpc:grpc-protobuf 1.28.1 间接依赖 maven
google.golang.org/genproto v0.0.0-20210831024726-fe130286e0e2 间接依赖 go
github.com/beorn7/perks v1.0.1 间接依赖 go
org.codehaus.jackson:jackson-core-asl 1.9.13 间接依赖 maven
github.com/jtolds/gls v4.20.0+incompatible 间接依赖 go
org.apache.hadoop:hadoop-yarn-client 3.3.0 间接依赖 maven
golang.org/x/oauth2 v0.5.0 间接依赖 go
github.com/google/pprof v0.0.0-20211214055906-6f57359322fd 间接依赖 go
github.com/prometheus/client_model v0.3.0 间接依赖 go
com.fasterxml.jackson.module:jackson-module-jaxb-annotations 2.10.3 间接依赖 maven
org.apache.curator:curator-framework 4.2.0 间接依赖 maven
org.reflections:reflections 0.9.12 间接依赖 maven
com.rabbitmq:amqp-client 5.5.3 间接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-common 3.3.0 间接依赖 maven
org.codehaus.mojo:animal-sniffer-annotations 1.18 间接依赖 maven
github.com/mailru/easyjson v0.7.6 间接依赖 go
sigs.k8s.io/structured-merge-diff/v4 v4.2.0 间接依赖 go
javax.activation:javax.activation-api 1.2.0 间接依赖 maven
javax.servlet:javax.servlet-api 3.1.0 间接依赖 maven
sigs.k8s.io/controller-runtime v0.11.1 直接依赖 go
org.rocksdb:rocksdbjni 5.15.10 间接依赖 maven
github.com/inconshreveable/mousetrap v1.1.0 间接依赖 go
io.dropwizard.metrics:metrics-jvm 4.1.11 间接依赖 maven
com.fasterxml.jackson.core:jackson-databind 2.10.3 间接依赖 maven
org.apache.logging.log4j:log4j-slf4j-impl 2.13.3 间接依赖 maven
github.com/golang/glog v1.0.0 直接依赖 go
org.eclipse.jetty:jetty-server 9.4.20.v20190813 间接依赖 maven
org.apache.htrace:htrace-core4 4.1.0-incubating 间接依赖 maven
github.com/modern-go/reflect2 v1.0.2 间接依赖 go
org.apache.kerby:token-provider 1.0.1 间接依赖 maven
org.apache.kerby:kerb-core 1.0.1 间接依赖 maven
golang.org/x/arch v0.0.0-20190312162104-788fe5ffcd8c 间接依赖 go
commons-codec:commons-codec 1.11 间接依赖 maven
io.grpc:grpc-protobuf-lite 1.28.1 间接依赖 maven
org.eclipse.jetty.websocket:websocket-client 9.4.20.v20190813 间接依赖 maven
github.com/evanphx/json-patch v4.12.0+incompatible 间接依赖 go
org.eclipse.jetty.websocket:websocket-api 9.4.20.v20190813 间接依赖 maven
io.netty:netty-all 4.1.52.Final 直接依赖 maven
sigs.k8s.io/json v0.0.0-20211020170558-c049b76a60c6 间接依赖 go
github.com/imdario/mergo v0.3.12 间接依赖 go
k8s.io/apiextensions-apiserver v0.23.0 间接依赖 go
go.uber.org/atomic v1.7.0 间接依赖 go
com.github.stephenc.jcip:jcip-annotations 1.0-1 间接依赖 maven
io.grpc:grpc-core 1.28.1 间接依赖 maven
io.dropwizard.metrics:metrics-jmx 4.1.11 间接依赖 maven
org.xerial.snappy:snappy-java 1.0.5 间接依赖 maven
org.apache.kerby:kerb-identity 1.0.1 间接依赖 maven
(0)
上一篇 2023年12月4日
下一篇 2023年12月4日

相关推荐

  • 28msec/zorba 软件分析报告

    基础信息 项目名称:28msec/zorba 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720378303491125248/1720378313045749760 此报告由Murphysec提供 漏洞列表 …

    软件分析 2023年11月3日
    0
  • FaztWeb/nodejs-ajax-crud 软件分析报告

    基础信息 项目名称:FaztWeb/nodejs-ajax-crud 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721189361118154752/1728047477885456384 此报告由Murph…

    软件分析 2023年11月24日
    0
  • betwixt-labs/bebop 软件分析报告

    基础信息 项目名称:betwixt-labs/bebop 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720903028940279808/1720903029032554496 此报告由Murphysec提供…

    软件分析 2023年11月5日
    0
  • mortdeus/legacy-cc 软件分析报告

    基础信息 项目名称:mortdeus/legacy-cc 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1744752886765559808/1765193164259278848 此报告由Murphysec提供…

    软件分析 2024年3月6日
    0
  • HeZaiJin/AnimatedRecordingView 软件分析报告

    基础信息 项目名称:HeZaiJin/AnimatedRecordingView 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718574317204979712/1718574317251117056 此报告…

    软件分析 2023年10月29日
    0