graphql-nexus/nexus-plugin-prisma 软件分析报告

基础信息

项目名称:graphql-nexus/nexus-plugin-prisma

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1721247531643506688/1729638473365151744

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Mikaelbr Node-notifier 操作系统命令注入漏洞 OS命令注入 MPS-2020-17637 CVE-2020-7789 中危
GraphQL Playground 跨站脚本漏洞 XSS MPS-2020-8351 CVE-2020-4038 高危
isomorphic-git 路径遍历漏洞 路径遍历 MPS-2021-11104 CVE-2021-30483 中危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-11547 CVE-2021-32804 高危
node-tar 路径遍历漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-11548 CVE-2021-32803 高危
object-path 原型污染漏洞 使用不兼容类型访问资源(类型混淆) MPS-2021-18322 CVE-2021-23434 高危
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28486 CVE-2021-37701 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28488 CVE-2021-37712 高危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-28489 CVE-2021-37713 高危
nodejs 正则表达式漏洞 拒绝服务 MPS-2021-31423 CVE-2021-3777 高危
object-path 存在原型链污染 原型污染 MPS-2021-32075 CVE-2021-3805 高危
prompts 正则表达式拒绝服务漏洞 ReDoS MPS-2021-32909 中危
shell-quote 远程代码执行漏洞 命令注入 MPS-2021-34136 CVE-2021-42740 严重
Async 原型污染漏洞 原型污染 MPS-2021-34434 CVE-2021-43138 高危
json-schema 安全漏洞 原型污染 MPS-2021-34478 CVE-2021-3918 严重
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
npm path-parse 安全漏洞 拒绝服务 MPS-2021-6165 CVE-2021-23343 高危
ws 存在拒绝服务漏洞 拒绝服务 MPS-2021-7109 CVE-2021-32640 中危
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
undici CRLF注入 MPS-2022-11180 CVE-2022-31150 中危
undici 安全漏洞 跨站重定向 MPS-2022-11181 CVE-2022-31151 中危
apollo-server-core 存在信息暴露漏洞 未授权敏感信息泄露 MPS-2022-13550 高危
istanbul-reports 通过 window.opener 访问使用指向不受信任目标的 Web 链接 MPS-2022-13797 中危
tar 正则表达式拒绝服务漏洞 拒绝服务 MPS-2022-14081 低危
node-fetch 信息泄露漏洞 未授权敏感信息泄露 MPS-2022-1461 CVE-2022-0235 中危
simple-get 信息泄露漏洞 未授权敏感信息泄露 MPS-2022-2533 CVE-2022-0355 高危
Express 中的 qs 模块存在原型污染漏洞 原型污染 MPS-2022-3967 CVE-2022-24999 高危
simple-git-hooks安全漏洞 命令注入 MPS-2022-5073 CVE-2022-24066 严重
simple-git-hooks 存在命令执行漏洞 命令注入 MPS-2022-5086 CVE-2022-24433 严重
dicer 存在拒绝服务漏洞 拒绝服务 MPS-2022-5087 CVE-2022-24434 高危
undici CRLF注入 MPS-2022-51462 CVE-2022-35948 高危
undici SSRF MPS-2022-51463 CVE-2022-35949 中危
simple-git 安全漏洞 代码注入 MPS-2022-5147 CVE-2022-25860 严重
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
simple-git OS命令注入 MPS-2022-5191 CVE-2022-25912 高危
apollo-server-core 拒绝服务 拒绝服务 MPS-2022-54342 高危
nwsapi 拒绝服务 拒绝服务 MPS-2022-54623 中危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
cross-fetch 安全漏洞 授权检查错误 MPS-2022-8877 CVE-2022-1365 中危
undici 注入漏洞 注入 MPS-2023-2199 CVE-2023-23936 中危
undici 安全漏洞 ReDoS MPS-2023-3313 CVE-2023-24807 高危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
Babel 插件任意代码执行漏洞漏洞【Poc公开】 不完整的黑名单 MPS-avb9-j50z CVE-2023-45133 严重
tough-cookie 原型污染 MPS-esyq-56vx 中危
undici 信息泄露漏洞 MPS-g6am-4ry2 CVE-2023-45143 低危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
simple-git 2.31.0 3.16.0 间接依赖 强烈建议修复
shell-quote 1.7.2 1.7.3 间接依赖 强烈建议修复
graphql-playground-html 1.6.12 1.6.22 间接依赖 建议修复
@babel/traverse 7.12.12 7.23.2 间接依赖 建议修复
object-path 0.11.5 0.11.8 间接依赖 建议修复
minimist 1.2.5 1.2.6 间接依赖 建议修复
tmpl 1.0.4 1.0.5 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
qs 6.7.0 6.7.3 间接依赖 建议修复
apollo-server-core 1.4.0 3.9.0 间接依赖 建议修复
undici 3.3.6 5.26.2 间接依赖 建议修复
qs 6.5.2 6.5.3 间接依赖 建议修复
simple-get 3.1.0 3.1.1 间接依赖 建议修复
express 4.17.1 4.17.3 间接依赖 建议修复
dicer 0.3.0 间接依赖 建议修复
tough-cookie 2.5.0 4.1.3 间接依赖 建议修复
tar 6.0.5 6.1.9 间接依赖 建议修复
glob-parent 5.1.1 5.1.2 间接依赖 建议修复
json-schema 0.2.3 0.4.0 间接依赖 建议修复
dicer 0.2.5 间接依赖 建议修复
path-parse 1.0.6 1.0.7 间接依赖 建议修复
tough-cookie 3.0.1 4.1.3 间接依赖 建议修复
nwsapi 2.2.0 2.2.1 间接依赖 可选修复
async 3.2.0 3.2.2 间接依赖 可选修复
lodash.template 4.5.0 间接依赖 可选修复
semver 7.3.4 7.5.2 直接依赖 可选修复
node-notifier 8.0.1 8.0.2 直接依赖 可选修复
semver 6.3.0 7.5.2 间接依赖 可选修复
request 2.88.2 间接依赖 可选修复
istanbul-reports 3.0.2 3.1.3 间接依赖 可选修复
ws 5.2.2 5.2.3 间接依赖 可选修复
isomorphic-git 1.8.0 1.8.2 间接依赖 可选修复
semver 5.7.1 7.5.2 间接依赖 可选修复
prompts 2.4.0 2.4.2 间接依赖 可选修复
ws 7.4.2 7.4.6 间接依赖 可选修复
node-fetch 2.6.1 2.6.7 间接依赖 可选修复
lodash 4.17.20 4.17.21 间接依赖 可选修复
tslib 1.14.1 间接依赖
tslib 2.1.0 直接依赖
tslib 2.0.3 间接依赖

许可证风险

许可证类型 相关组件 许可证风险
MIT 591
ISC 54
0BSD 3
BSD-3-Clause 22
Apache-2.0 34
BSD-2-Clause 5
Unlicense 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
apollo-server-express 1.4.0 间接依赖 npm
objectorarray 1.0.4 间接依赖 npm
diff-sequences 26.6.2 间接依赖 npm
prettier 2.2.1 直接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
string-width 2.1.1 间接依赖 npm
pump 3.0.0 间接依赖 npm
crc 3.8.0 间接依赖 npm
tslib 2.1.0 直接依赖 npm
minimisted 2.0.1 间接依赖 npm
min-indent 1.0.1 间接依赖 npm
source-map 0.7.3 间接依赖 npm
@octokit/endpoint 6.0.10 间接依赖 npm
fast-glob 3.2.4 间接依赖 npm
backo2 1.0.2 间接依赖 npm
typedarray-to-buffer 3.1.5 间接依赖 npm
wrap-ansi 4.0.0 间接依赖 npm
cli-cursor 3.1.0 间接依赖 npm
pluralize 8.0.0 直接依赖 npm
merge-descriptors 1.0.1 间接依赖 npm
cliui 6.0.0 间接依赖 npm
widest-line 3.1.0 间接依赖 npm
walker 1.0.7 间接依赖 npm
unc-path-regex 0.1.2 间接依赖 npm
@babel/traverse 7.12.12 间接依赖 npm
char-regex 1.0.2 间接依赖 npm
lodash.flatten 4.4.0 间接依赖 npm
jest-haste-map 26.6.2 间接依赖 npm
cookie-signature 1.0.6 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
dotenv 9.0.2 间接依赖 npm
jest-leak-detector 26.6.2 间接依赖 npm
apollo-server-lambda 1.3.6 间接依赖 npm
human-signals 2.1.0 间接依赖 npm
parse-github-url 1.0.2 间接依赖 npm
@jest/test-sequencer 26.6.3 间接依赖 npm
open 7.3.0 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
ini 1.3.8 间接依赖 npm
graphql 15.4.0 直接依赖 npm
del 6.0.0 间接依赖 npm
apollo-server-module-graphiql 1.4.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
@octokit/plugin-rest-endpoint-methods 4.4.1 间接依赖 npm
string-length 4.0.1 间接依赖 npm
human-signals 1.1.1 间接依赖 npm
http-errors 1.7.2 间接依赖 npm
@dsherret/to-absolute-glob 2.0.2 间接依赖 npm
is-negated-glob 1.0.0 间接依赖 npm
agent-base 6.0.2 间接依赖 npm
restore-cursor 3.1.0 间接依赖 npm
@types/retry 0.12.0 间接依赖 npm
array-differ 3.0.0 间接依赖 npm
iterall 1.3.0 间接依赖 npm
core-js 2.6.12 间接依赖 npm
domexception 2.0.1 间接依赖 npm
@octokit/request-error 2.0.4 间接依赖 npm
streamsearch 0.1.2 间接依赖 npm
html-encoding-sniffer 2.0.1 间接依赖 npm
temp-dir 2.0.0 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
@prisma/get-platform 2.23.0 间接依赖 npm
supports-color 7.2.0 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
ansi-regex 3.0.0 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
cross-fetch 3.0.6 间接依赖 npm
@types/jest 26.0.19 间接依赖 npm
babel-plugin-jest-hoist 26.6.2 间接依赖 npm
lodash.memoize 4.1.2 间接依赖 npm
request 2.88.2 间接依赖 npm
yallist 4.0.0 间接依赖 npm
jest-each 26.6.2 间接依赖 npm
simple-concat 1.0.1 间接依赖 npm
@jest/types 26.6.2 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
bytes 3.1.0 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
get-package-type 0.1.0 间接依赖 npm
async 3.2.0 间接依赖 npm
aws4 1.11.0 间接依赖 npm
qs 6.5.2 间接依赖 npm
locate-path 6.0.0 间接依赖 npm
pretty-format 26.6.2 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
resolve-from 5.0.0 间接依赖 npm
http-signature 1.2.0 间接依赖 npm
@babel/highlight 7.10.4 间接依赖 npm
universal-user-agent 6.0.0 间接依赖 npm
html-escaper 2.0.2 间接依赖 npm
webidl-conversions 6.1.0 间接依赖 npm
setprototypeof 1.2.0 间接依赖 npm
parse-json 5.1.0 间接依赖 npm
encodeurl 1.0.2 间接依赖 npm
form-data 3.0.0 间接依赖 npm
ts-node 9.1.1 直接依赖 npm
is-generator-fn 2.1.0 间接依赖 npm
zip-stream 3.0.1 间接依赖 npm
p-limit 2.3.0 间接依赖 npm
@oclif/config 1.17.0 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
isarray 0.0.1 间接依赖 npm
@octokit/plugin-request-log 1.0.2 间接依赖 npm
archiver 4.0.2 间接依赖 npm
json-schema 0.2.3 间接依赖 npm
checkpoint-client 1.1.20 间接依赖 npm
bl 4.0.3 间接依赖 npm
request-promise-native 1.0.9 间接依赖 npm
snapdragon 0.8.2 间接依赖 npm
has 1.0.3 间接依赖 npm
lodash.template 4.5.0 间接依赖 npm
resolve-pkg 2.0.0 间接依赖 npm
object-path 0.11.5 间接依赖 npm
semver 6.3.0 间接依赖 npm
uuid 8.3.2 间接依赖 npm
locate-path 5.0.0 间接依赖 npm
@types/istanbul-lib-coverage 2.0.3 间接依赖 npm
form-data 2.3.3 间接依赖 npm
oauth-sign 0.9.0 间接依赖 npm
istanbul-lib-report 3.0.0 间接依赖 npm
yn 3.1.1 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
lines-and-columns 1.1.6 间接依赖 npm
array-unique 0.3.2 间接依赖 npm
typescript 4.1.3 直接依赖 npm
make-error 1.3.6 间接依赖 npm
unique-string 2.0.0 间接依赖 npm
prisma 2.18.0 直接依赖 npm
lodash 4.17.20 间接依赖 npm
@prisma/engines 2.23.0-36.adf5e8cba3daf12d456d911d72b6e9418681b28b 间接依赖 npm
is-wsl 2.2.0 间接依赖 npm
@prisma-labs/prettier-config 0.1.0 直接依赖 npm
@types/graphql-deduplicator 2.0.0 间接依赖 npm
@types/istanbul-reports 3.0.0 间接依赖 npm
extsprintf 1.3.0 间接依赖 npm
inherits 2.0.3 间接依赖 npm
destroy 1.0.4 间接依赖 npm
find-cache-dir 3.3.1 间接依赖 npm
ts-invariant 0.4.4 间接依赖 npm
emoji-regex 8.0.0 间接依赖 npm
is-unc-path 1.0.0 间接依赖 npm
content-type 1.0.4 间接依赖 npm
jest-regex-util 26.0.0 间接依赖 npm
tslib 1.14.1 间接依赖 npm
diff 4.0.2 间接依赖 npm
media-typer 0.3.0 间接依赖 npm
path-parse 1.0.6 间接依赖 npm
@types/graceful-fs 4.1.4 间接依赖 npm
@nodelib/fs.walk 1.2.6 间接依赖 npm
on-finished 2.3.0 间接依赖 npm
@wry/equality 0.1.11 间接依赖 npm
p-map 2.1.0 间接依赖 npm
dicer 0.3.0 间接依赖 npm
base64-js 1.5.1 间接依赖 npm
@sinonjs/fake-timers 6.0.1 间接依赖 npm
co 4.6.0 间接依赖 npm
has-flag 4.0.0 间接依赖 npm
@babel/helper-module-transforms 7.12.1 间接依赖 npm
apollo-link 1.2.14 间接依赖 npm
pkg-dir 4.2.0 间接依赖 npm
@tootallnate/once 1.1.2 间接依赖 npm
reusify 1.0.4 间接依赖 npm
makeerror 1.0.11 间接依赖 npm
verror 1.10.0 间接依赖 npm
@jest/globals 26.6.2 间接依赖 npm
globby 11.0.2 间接依赖 npm
parseurl 1.3.3 间接依赖 npm
tweetnacl 0.14.5 间接依赖 npm
sane 4.1.0 间接依赖 npm
get-stream 4.1.0 间接依赖 npm
raw-body 2.4.0 间接依赖 npm
@ts-morph/common 0.7.2 间接依赖 npm
p-map 4.0.0 间接依赖 npm
jest-resolve 26.6.2 间接依赖 npm
strip-bom 4.0.0 间接依赖 npm
@babel/helpers 7.12.5 间接依赖 npm
tslib 2.0.3 间接依赖 npm
jest 26.6.3 直接依赖 npm
source-map 0.6.1 直接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
decimal.js 10.2.1 间接依赖 npm
array-flatten 1.1.1 间接依赖 npm
jest-changed-files 26.6.2 间接依赖 npm
exec-sh 0.3.4 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
test-exclude 6.0.0 间接依赖 npm
@jest/source-map 26.6.2 间接依赖 npm
@babel/helper-function-name 7.12.11 间接依赖 npm
jest-environment-jsdom 26.6.2 间接依赖 npm
jest-diff 26.6.2 间接依赖 npm
fast-write-atomic 0.2.1 间接依赖 npm
async-limiter 1.0.1 间接依赖 npm
combined-stream 1.0.8 间接依赖 npm
@jest/reporters 26.6.2 间接依赖 npm
inflight 1.0.6 间接依赖 npm
tunnel-agent 0.6.0 间接依赖 npm
log-update 4.0.0 间接依赖 npm
minipass 3.1.3 间接依赖 npm
forwarded 0.1.2 间接依赖 npm
wrap-ansi 7.0.0 间接依赖 npm
prettysize 2.0.0 间接依赖 npm
@types/prettier 2.1.6 直接依赖 npm
compress-commons 3.0.0 间接依赖 npm
graphql-deduplicator 2.0.6 间接依赖 npm
p-locate 5.0.0 间接依赖 npm
apollo-server-core 1.4.0 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
ansi-regex 5.0.0 间接依赖 npm
nwsapi 2.2.0 间接依赖 npm
@prisma/client 2.23.0 直接依赖 npm
apollo-upload-server 7.1.0 间接依赖 npm
@sindresorhus/slugify 1.1.0 间接依赖 npm
p-limit 3.1.0 间接依赖 npm
react-is 17.0.1 间接依赖 npm
@kwsites/promise-deferred 1.1.1 间接依赖 npm
deprecated-decorator 0.1.6 间接依赖 npm
apollo-utilities 1.3.4 间接依赖 npm
find-up 5.0.0 间接依赖 npm
retry 0.12.0 间接依赖 npm
async-lock 1.2.8 间接依赖 npm
@types/express 4.17.9 间接依赖 npm
graphql-request 3.4.0 直接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
write-file-atomic 3.0.3 间接依赖 npm
strip-eof 1.0.0 间接依赖 npm
@types/aws-lambda 8.10.13 间接依赖 npm
@babel/helper-plugin-utils 7.10.4 间接依赖 npm
ansi-styles 4.3.0 间接依赖 npm
lodash.isplainobject 4.0.6 间接依赖 npm
execa 4.1.0 间接依赖 npm
exit-on-epipe 1.0.1 间接依赖 npm
source-map 0.5.7 间接依赖 npm
zen-observable 0.8.15 间接依赖 npm
asn1 0.2.4 间接依赖 npm
jest-docblock 26.0.0 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
@prisma/engines-version 2.23.0-36.adf5e8cba3daf12d456d911d72b6e9418681b28b 间接依赖 npm
clean-stack 2.2.0 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
merge2 1.4.1 间接依赖 npm
pify 4.0.1 间接依赖 npm
uri-js 4.4.0 间接依赖 npm
dicer 0.2.5 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
jsprim 1.4.1 间接依赖 npm
isstream 0.1.2 间接依赖 npm
node-fetch 2.6.1 间接依赖 npm
stack-utils 2.0.3 间接依赖 npm
lodash.deburr 4.1.0 间接依赖 npm
diff3 0.0.3 间接依赖 npm
fs-minipass 2.1.0 间接依赖 npm
p-each-series 2.2.0 间接依赖 npm
@types/node-fetch 2.5.7 直接依赖 npm
get-port 5.1.1 直接依赖 npm
buffer-crc32 0.2.13 间接依赖 npm
readable-stream 1.1.14 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
ajv 6.12.6 间接依赖 npm
sha.js 2.4.11 间接依赖 npm
yargs-parser 20.2.4 间接依赖 npm
micromatch 4.0.2 间接依赖 npm
graphql-playground-middleware-express 1.7.11 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
@octokit/types 6.2.1 间接依赖 npm
capture-exit 2.0.0 间接依赖 npm
jsonfile 4.0.0 间接依赖 npm
glob 7.1.6 间接依赖 npm
parse5 5.1.1 间接依赖 npm
cookie 0.4.0 间接依赖 npm
@types/babel__core 7.1.12 间接依赖 npm
saxes 5.0.1 间接依赖 npm
jest-pnp-resolver 1.2.2 间接依赖 npm
wrap-ansi 6.2.0 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
shell-quote 1.7.2 间接依赖 npm
temp-write 4.0.0 间接依赖 npm
yargs-parser 18.1.3 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
jsesc 2.5.2 间接依赖 npm
deepmerge 4.2.2 间接依赖 npm
strip-final-newline 2.0.0 间接依赖 npm
node-notifier 8.0.1 直接依赖 npm
unpipe 1.0.0 间接依赖 npm
express 4.17.1 间接依赖 npm
graphql-playground-html 1.6.12 间接依赖 npm
istanbul-lib-source-maps 4.0.0 间接依赖 npm
semver 5.7.1 间接依赖 npm
tmp 0.2.1 间接依赖 npm
env-paths 2.2.1 间接依赖 npm
tar-stream 2.2.0 间接依赖 npm
node-modules-regexp 1.0.0 间接依赖 npm
fast-json-parse 1.0.3 间接依赖 npm
ignore 5.1.8 间接依赖 npm
jsdom 16.4.0 间接依赖 npm
get-stream 6.0.0 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
graphql 14.7.0 间接依赖 npm
performance-now 2.1.0 间接依赖 npm
escape-html 1.0.3 间接依赖 npm
graphql-tools 4.0.8 间接依赖 npm
sisteransi 1.0.5 间接依赖 npm
fs-capacitor 2.0.4 间接依赖 npm
@nodelib/fs.stat 2.0.4 间接依赖 npm
@jest/core 26.6.3 间接依赖 npm
http-errors 1.8.0 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
ws 5.2.2 间接依赖 npm
string_decoder 1.3.0 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
universalify 0.1.2 间接依赖 npm
cssom 0.4.4 间接依赖 npm
yargs 15.4.1 间接依赖 npm
babel-preset-jest 26.6.2 间接依赖 npm
@babel/helper-replace-supers 7.12.11 间接依赖 npm
mime-types 2.1.28 间接依赖 npm
@jest/transform 26.6.2 间接依赖 npm
gensync 1.0.0-beta.2 间接依赖 npm
@jest/environment 26.6.2 间接依赖 npm
graphql-playground-middleware-lambda 1.7.12 间接依赖 npm
terminal-link 2.1.1 间接依赖 npm
accepts 1.3.7 间接依赖 npm
subscriptions-transport-ws 0.9.18 间接依赖 npm
dripip 0.10.0 直接依赖 npm
progress 2.0.3 间接依赖 npm
@types/parse-github-url 1.0.0 间接依赖 npm
@jest/console 26.6.2 间接依赖 npm
onetime 5.1.2 间接依赖 npm
busboy 0.2.14 间接依赖 npm
signal-exit 3.0.3 间接依赖 npm
which 2.0.2 间接依赖 npm
before-after-hook 2.1.0 间接依赖 npm
has-yarn 2.1.0 间接依赖 npm
tough-cookie 2.5.0 间接依赖 npm
crc32-stream 3.0.1 间接依赖 npm
jest-snapshot 26.6.2 间接依赖 npm
@babel/helper-validator-identifier 7.12.11 间接依赖 npm
@babel/code-frame 7.12.11 间接依赖 npm
@types/pluralize 0.0.29 直接依赖 npm
p-locate 4.1.0 间接依赖 npm
path-key 3.1.1 间接依赖 npm
istanbul-lib-instrument 4.0.3 间接依赖 npm
babel-jest 26.6.3 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
crc-32 1.2.0 间接依赖 npm
arg 4.1.3 间接依赖 npm
qs 6.7.0 间接依赖 npm
minizlib 2.1.2 间接依赖 npm
@octokit/request 5.4.12 间接依赖 npm
@types/lodash 4.14.167 直接依赖 npm
@kwsites/file-exists 1.1.1 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
@babel/parser 7.12.11 间接依赖 npm
jest-jasmine2 26.6.3 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
throat 5.0.0 间接依赖 npm
path-type 4.0.0 间接依赖 npm
resolve 1.19.0 间接依赖 npm
https-proxy-agent 5.0.0 间接依赖 npm
braces 2.3.2 间接依赖 npm
@types/yargs 15.0.12 间接依赖 npm
jest-config 26.6.3 间接依赖 npm
finalhandler 1.1.2 间接依赖 npm
content-disposition 0.5.3 间接依赖 npm
jest-mock 26.6.2 间接依赖 npm
slice-ansi 3.0.0 间接依赖 npm
graphql-middleware 4.0.1 间接依赖 npm
chalk 4.1.1 间接依赖 npm
whatwg-encoding 1.0.5 间接依赖 npm
@babel/template 7.12.7 间接依赖 npm
readable-stream 3.6.0 间接依赖 npm
methods 1.1.2 间接依赖 npm
@oclif/command 1.8.0 间接依赖 npm
p-locate 3.0.0 间接依赖 npm
@bcoe/v8-coverage 0.2.3 间接依赖 npm
debug 4.3.2 间接依赖 npm
negotiator 0.6.2 间接依赖 npm
extend 3.0.2 间接依赖 npm
simple-get 3.1.0 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
find-up 3.0.0 间接依赖 npm
path-exists 4.0.0 间接依赖 npm
ws 7.4.2 间接依赖 npm
clean-stack 3.0.1 间接依赖 npm
@types/minimatch 3.0.3 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
p-retry 4.2.0 间接依赖 npm
anymatch 3.1.1 间接依赖 npm
locate-path 3.0.0 间接依赖 npm
hasha 5.2.2 间接依赖 npm
rimraf 3.0.2 间接依赖 npm
crypto-random-string 2.0.0 间接依赖 npm
endent 2.0.1 直接依赖 npm
har-validator 5.1.5 间接依赖 npm
@cnakazawa/watch 1.0.4 间接依赖 npm
fsevents 2.3.1 直接依赖 npm
@jest/test-result 26.6.2 间接依赖 npm
is-fullwidth-code-point 3.0.0 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
@babel/generator 7.12.11 间接依赖 npm
is-path-cwd 2.2.0 间接依赖 npm
babel-preset-current-node-syntax 1.0.1 间接依赖 npm
emittery 0.7.2 间接依赖 npm
@istanbuljs/schema 0.1.2 间接依赖 npm
printj 1.1.2 间接依赖 npm
spdx-expression-parse 3.0.1 间接依赖 npm
statuses 1.5.0 间接依赖 npm
@timsuchanek/sleep-promise 8.0.1 间接依赖 npm
simple-git 2.31.0 间接依赖 npm
sshpk 1.16.1 间接依赖 npm
require-main-filename 2.0.0 间接依赖 npm
busboy 0.3.1 间接依赖 npm
shellwords 0.1.1 间接依赖 npm
exit 0.1.2 间接依赖 npm
read-pkg-up 7.0.1 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
@babel/helper-split-export-declaration 7.12.11 间接依赖 npm
body-parser-graphql 1.1.0 间接依赖 npm
escape-string-regexp 2.0.0 间接依赖 npm
resolve-cwd 3.0.0 间接依赖 npm
create-require 1.1.1 间接依赖 npm
fb-watchman 2.0.1 间接依赖 npm
picomatch 2.2.2 间接依赖 npm
is-glob 4.0.1 间接依赖 npm
toidentifier 1.0.0 间接依赖 npm
fs-jetpack 3.2.0 间接依赖 npm
callsites 3.1.0 间接依赖 npm
astral-regex 2.0.0 间接依赖 npm
vary 1.1.2 间接依赖 npm
parse-git-config 3.0.0 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
leven 3.1.0 间接依赖 npm
nanomatch 1.2.13 间接依赖 npm
@nodelib/fs.scandir 2.1.4 间接依赖 npm
lodash.union 4.6.0 间接依赖 npm
inherits 2.0.4 间接依赖 npm
tempy 1.0.0 间接依赖 npm
jsbn 0.1.1 间接依赖 npm
ms 2.1.1 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
is-path-inside 3.0.2 间接依赖 npm
ieee754 1.2.1 间接依赖 npm
@types/cors 2.8.9 间接依赖 npm
whatwg-mimetype 2.3.0 间接依赖 npm
@babel/helper-simple-access 7.12.1 间接依赖 npm
symbol-tree 3.2.4 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
clean-git-ref 2.0.1 间接依赖 npm
jest-util 26.6.2 间接依赖 npm
@oclif/plugin-help 3.2.1 间接依赖 npm
type-fest 0.16.0 间接依赖 npm
@sindresorhus/transliterate 0.1.1 间接依赖 npm
run-parallel 1.1.10 间接依赖 npm
debug 4.3.1 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
@istanbuljs/load-nyc-config 1.1.0 间接依赖 npm
deprecation 2.3.1 间接依赖 npm
fs-jetpack 4.1.0 直接依赖 npm
ts-jest 26.4.4 直接依赖 npm
graphql-extensions 0.0.10 间接依赖 npm
which-module 2.0.0 间接依赖 npm
cross-spawn 6.0.5 间接依赖 npm
graphql-scalars 1.7.0 直接依赖 npm
proxy-addr 2.0.6 间接依赖 npm
@types/cross-spawn 6.0.2 间接依赖 npm
babel-plugin-istanbul 6.0.0 间接依赖 npm
is-docker 2.1.1 间接依赖 npm
utils-merge 1.0.1 间接依赖 npm
jest-runtime 26.6.3 间接依赖 npm
commondir 1.0.1 间接依赖 npm
ini 2.0.0 间接依赖 npm
@octokit/core 3.2.4 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
cors 2.8.5 间接依赖 npm
bcrypt-pbkdf 1.0.2 间接依赖 npm
to-fast-properties 2.0.0 间接依赖 npm
istanbul-reports 3.0.2 间接依赖 npm
acorn-globals 6.0.0 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
@types/parse-git-config 3.0.0 间接依赖 npm
make-dir 3.1.0 间接依赖 npm
is-ci 2.0.0 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
jest-cli 26.6.3 间接依赖 npm
prompts 2.4.0 间接依赖 npm
acorn 7.4.1 间接依赖 npm
graphql-upload 8.1.0 间接依赖 npm
p-filter 2.1.0 间接依赖 npm
aggregate-error 3.1.0 间接依赖 npm
lru-cache 6.0.0 间接依赖 npm
camelcase 6.2.0 直接依赖 npm
@octokit/plugin-paginate-rest 2.7.0 间接依赖 npm
strip-indent 3.0.0 间接依赖 npm
apollo-tracing 0.1.4 间接依赖 npm
@types/babel__template 7.4.0 间接依赖 npm
type-fest 0.6.0 间接依赖 npm
path-to-regexp 0.1.7 间接依赖 npm
fs-capacitor 1.0.1 间接依赖 npm
is-core-module 2.2.0 间接依赖 npm
jest-resolve-dependencies 26.6.3 间接依赖 npm
apollo-cache-control 0.1.1 间接依赖 npm
pkg-up 3.1.0 间接依赖 npm
dir-glob 3.0.1 间接依赖 npm
@octokit/openapi-types 2.2.0 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
graceful-fs 4.2.4 直接依赖 npm
whatwg-url 8.4.0 间接依赖 npm
@types/babel__generator 7.6.2 间接依赖 npm
dedent 0.7.0 间接依赖 npm
@types/serve-static 1.13.8 间接依赖 npm
@types/node 14.14.20 直接依赖 npm
fs-constants 1.0.0 间接依赖 npm
data-urls 2.0.0 间接依赖 npm
strip-ansi 4.0.0 间接依赖 npm
aws-sign2 0.7.0 间接依赖 npm
xml-name-validator 3.0.0 间接依赖 npm
hosted-git-info 2.8.9 间接依赖 npm
@types/express-serve-static-core 4.17.17 间接依赖 npm
archiver-utils 2.1.0 间接依赖 npm
fresh 0.5.2 间接依赖 npm
pirates 4.0.1 间接依赖 npm
caseless 0.12.0 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
jest-get-type 26.3.0 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
ansi-escapes 4.3.1 间接依赖 npm
@types/graphql 14.5.0 间接依赖 npm
isomorphic-git 1.8.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
jest-watch-typeahead 0.6.1 直接依赖 npm
@types/mime 2.0.3 间接依赖 npm
read-pkg 5.2.0 间接依赖 npm
is-plain-object 5.0.0 间接依赖 npm
@oclif/linewrap 1.0.0 间接依赖 npm
chalk 4.1.0 间接依赖 npm
supports-hyperlinks 2.1.0 间接依赖 npm
body-parser 1.19.0 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
decompress-response 4.2.1 间接依赖 npm
isarray 1.0.0 间接依赖 npm
@sinonjs/commons 1.8.1 间接依赖 npm
@prisma/engines 2.18.0-34.da6fafb57b24e0b61ca20960c64e2d41f9e8cff1 间接依赖 npm
temp-dir 1.0.0 间接依赖 npm
graphql-subscriptions 0.5.8 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
ci-info 2.0.0 间接依赖 npm
type-fest 0.8.1 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
@types/babel__traverse 7.11.0 间接依赖 npm
nexus 1.0.0 直接依赖 npm
micromatch 3.1.10 间接依赖 npm
lodash.defaults 4.2.0 间接依赖 npm
chownr 2.0.0 间接依赖 npm
@jest/fake-timers 26.6.2 间接依赖 npm
@babel/core 7.12.10 间接依赖 npm
@types/connect 3.4.34 间接依赖 npm
jest-environment-node 26.6.2 间接依赖 npm
@oclif/errors 1.3.4 间接依赖 npm
slash 3.0.0 间接依赖 npm
@prisma/sdk 2.23.0 直接依赖 npm
http-errors 1.7.3 间接依赖 npm
@types/normalize-package-data 2.4.0 间接依赖 npm
shebang-command 2.0.0 间接依赖 npm
zen-observable-ts 0.8.21 间接依赖 npm
@oclif/parser 3.8.5 间接依赖 npm
code-block-writer 10.1.1 间接依赖 npm
graphql-yoga 1.18.3 直接依赖 npm
@octokit/graphql 4.5.8 间接依赖 npm
eventemitter3 3.1.2 间接依赖 npm
detect-newline 3.1.0 间接依赖 npm
lodash.difference 4.5.0 间接依赖 npm
type-fest 0.11.0 间接依赖 npm
find-up 4.1.0 间接依赖 npm
get-stream 5.2.0 间接依赖 npm
array-union 2.1.0 间接依赖 npm
braces 3.0.2 间接依赖 npm
@prisma/engine-core 2.23.0 间接依赖 npm
growly 1.3.0 间接依赖 npm
cjs-module-lexer 0.6.0 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
buffer 5.7.1 间接依赖 npm
node-int64 0.4.0 间接依赖 npm
common-tags 1.8.0 间接依赖 npm
arg 5.0.0 间接依赖 npm
lodash.templatesettings 4.2.0 间接依赖 npm
ms 2.1.3 间接依赖 npm
slice-ansi 4.0.0 间接依赖 npm
source-map-support 0.5.19 间接依赖 npm
normalize-path 2.1.1 间接依赖 npm
jest-matcher-utils 26.6.2 间接依赖 npm
http-proxy-agent 4.0.1 间接依赖 npm
ecc-jsbn 0.1.2 间接依赖 npm
y18n 4.0.1 间接依赖 npm
spdx-correct 3.1.1 间接依赖 npm
setprototypeof 1.1.1 间接依赖 npm
@types/istanbul-lib-report 3.0.0 间接依赖 npm
@octokit/rest 18.0.12 间接依赖 npm
jest-watcher 26.6.2 间接依赖 npm
pako 1.0.11 间接依赖 npm
extsprintf 1.4.0 间接依赖 npm
@octokit/auth-token 2.4.4 间接依赖 npm
execa 5.0.0 间接依赖 npm
etag 1.8.1 间接依赖 npm
jest-runner 26.6.3 间接依赖 npm
ms 2.0.0 间接依赖 npm
fs-extra 8.1.0 间接依赖 npm
bs-logger 0.2.6 间接依赖 npm
tar 6.0.5 间接依赖 npm
@timsuchanek/copy 1.4.5 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
commander 2.20.3 间接依赖 npm
v8-to-istanbul 7.1.0 间接依赖 npm
new-github-issue-url 0.2.1 间接依赖 npm
lazystream 1.0.0 间接依赖 npm
ci-info 3.1.1 间接依赖 npm
ts-morph 9.1.0 直接依赖 npm
@types/range-parser 1.2.3 间接依赖 npm
semver 7.3.4 直接依赖 npm
send 0.17.1 间接依赖 npm
is-ci 3.0.0 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
safe-buffer 5.2.1 间接依赖 npm
escodegen 1.14.3 间接依赖 npm
extract-files 9.0.0 间接依赖 npm
expect 26.6.2 间接依赖 npm
@types/debug 4.1.5 间接依赖 npm
w3c-hr-time 1.0.2 间接依赖 npm
tmpl 1.0.4 间接依赖 npm
symbol-observable 1.2.0 间接依赖 npm
serve-static 1.14.1 间接依赖 npm
npm-run-path 4.0.1 间接依赖 npm
multimatch 5.0.0 间接依赖 npm
uuid 3.4.0 间接依赖 npm
jest-serializer 26.6.2 间接依赖 npm
npm-run-path 2.0.2 间接依赖 npm
strip-ansi 6.0.0 间接依赖 npm
convert-source-map 1.7.0 间接依赖 npm
cli-truncate 2.1.0 间接依赖 npm
bser 2.1.1 间接依赖 npm
har-schema 2.0.0 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
end-of-stream 1.4.4 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
ipaddr.js 1.9.1 间接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
mimic-response 2.1.0 间接依赖 npm
string_decoder 0.10.31 间接依赖 npm
jest-worker 26.6.2 间接依赖 npm
git-config-path 2.0.0 间接依赖 npm
lodash 4.17.21 直接依赖 npm
ee-first 1.1.1 间接依赖 npm
collect-v8-coverage 1.0.1 间接依赖 npm
assert-plus 1.0.0 间接依赖 npm
execa 1.0.0 间接依赖 npm
is-stream 2.0.0 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
rsvp 4.8.5 间接依赖 npm
type-is 1.6.18 间接依赖 npm
@types/stack-utils 2.0.0 间接依赖 npm
glob-parent 5.1.1 间接依赖 npm
indent-string 4.0.0 间接依赖 npm
@prisma/debug 2.23.0 间接依赖 npm
@types/zen-observable 0.5.4 间接依赖 npm
normalize-package-data 2.5.0 间接依赖 npm
is-potential-custom-element-name 1.0.0 间接依赖 npm
jest-message-util 26.6.2 间接依赖 npm
minimist 1.2.5 间接依赖 npm
lodash._reinterpolate 3.0.0 间接依赖 npm
psl 1.8.0 间接依赖 npm
color-name 1.1.3 间接依赖 npm
json5 2.1.3 间接依赖 npm
debug 2.6.9 间接依赖 npm
arrify 2.0.1 间接依赖 npm
mime-db 1.45.0 间接依赖 npm
extglob 2.0.4 间接依赖 npm
globals 11.12.0 间接依赖 npm
@babel/helper-module-imports 7.12.5 间接依赖 npm
import-local 3.0.2 间接依赖 npm
color-name 1.1.4 间接依赖 npm
w3c-xmlserializer 2.0.0 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
depd 1.1.2 间接依赖 npm
@types/qs 6.9.5 间接依赖 npm
string-width 4.2.0 间接依赖 npm
tough-cookie 3.0.1 间接依赖 npm
camelcase 5.3.1 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
kleur 3.0.3 间接依赖 npm
readable-stream 2.3.7 间接依赖 npm
ms 2.1.2 间接依赖 npm
@types/body-parser 1.19.0 间接依赖 npm
fastq 1.10.0 间接依赖 npm
getpass 0.1.7 间接依赖 npm
mime 1.6.0 间接依赖 npm
jest-validate 26.6.2 间接依赖 npm
graphql-import 0.7.1 间接依赖 npm
js-yaml 3.14.1 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
once 1.4.0 间接依赖 npm
istanbul-lib-coverage 3.0.0 间接依赖 npm
escape-string-regexp 4.0.0 间接依赖 npm
is-absolute 1.0.0 间接依赖 npm
@types/semver 7.3.4 直接依赖 npm
cssstyle 2.3.0 间接依赖 npm
range-parser 1.2.1 间接依赖 npm
undici 3.3.6 间接依赖 npm
yocto-queue 0.1.0 间接依赖 npm
is-relative 1.0.0 间接依赖 npm
define-property 2.0.2 间接依赖 npm
@babel/types 7.12.12 间接依赖 npm
abab 2.0.5 间接依赖 npm
global-dirs 3.0.0 间接依赖 npm
rimraf 2.7.1 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
mkdirp 1.0.4 间接依赖 npm
@types/yargs-parser 20.2.0 间接依赖 npm
chalk 2.4.2 间接依赖 npm
@prisma/migrate 2.23.0 直接依赖 npm
@prisma/generator-helper 2.23.0 间接依赖 npm
@prisma/fetch-engine 2.23.0 间接依赖 npm
@types/jest 26.0.20 直接依赖 npm
color-convert 2.0.1 间接依赖 npm
(0)
上一篇 2023年11月29日
下一篇 2023年11月29日

相关推荐

  • daniel-sc/bash-shell-to-bat-converter 软件分析报告

    基础信息 项目名称:daniel-sc/bash-shell-to-bat-converter 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717027111687733248/1717027112337850…

    软件分析 2023年10月25日
    0
  • apache/arrow 软件分析报告

    基础信息 项目名称:apache/arrow 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720597961867968512/1720597962031546368 此报告由Murphysec提供 漏洞列表 …

    软件分析 2023年11月4日
    0
  • ant-design/ant-motion 软件分析报告

    基础信息 项目名称:ant-design/ant-motion 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720581680263512064/1720581680318038016 此报告由Murphyse…

    软件分析 2023年11月4日
    0
  • Jimmy-Shi/bean-query 软件分析报告

    基础信息 项目名称:Jimmy-Shi/bean-query 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721309448029896704/1724223143167877120 此报告由Murphysec…

    软件分析 2023年11月14日
    0
  • icattlecoder/ngMeditor 软件分析报告

    基础信息 项目名称:icattlecoder/ngMeditor 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718760075052236800/1718760075521998848 此报告由Murphys…

    软件分析 2023年10月30日
    0