internetarchive/heritrix3 软件分析报告

基础信息

项目名称:internetarchive/heritrix3

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1721280818357030912/1726644046641713152

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Eclipse Jetty 资源管理错误漏洞 拒绝服务 MPS-0e59-bdsi CVE-2023-36478 高危
LZ4 输入验证不恰当 MPS-2014-3344 CVE-2014-4611 中危
LZ4 拒绝服务漏洞 数字错误 MPS-2014-3351 CVE-2014-4715 中危
Apache HttpClient 中间人攻击漏洞 输入验证不恰当 MPS-2014-4288 CVE-2012-6153 中危
BeanShell 任意命令执行漏洞 数据处理错误 MPS-2016-1438 CVE-2016-2510 高危
Apache Zookeeper 安全漏洞 拒绝服务 MPS-2017-11297 CVE-2017-5637 高危
Netty和Play Framework 输入验证错误漏洞 未授权敏感信息泄露 MPS-2017-11682 CVE-2015-2156 高危
Apache Kafka 授权问题漏洞 身份验证不当 MPS-2018-10426 CVE-2017-12610 中危
Apache Kafka 信息泄漏漏洞 信息丢失或遗漏 MPS-2018-10430 CVE-2018-1288 中危
Google Guava 不可信数据的反序列化漏洞 不加限制或调节的资源分配 MPS-2018-5515 CVE-2018-10237 中危
Apache Zookeeper 访问控制错误漏洞 授权检查缺失 MPS-2018-6313 CVE-2018-8012 高危
Eclipse Jetty 缓存中毒漏洞 HTTP请求走私 MPS-2018-8346 CVE-2017-7656 高危
Eclipse Jetty HTTP请求走私 MPS-2018-8347 CVE-2017-7657 严重
Eclipse Jetty HTTP请求走私 MPS-2018-8415 CVE-2017-7658 严重
Netty 存在 HTTP 请求走私漏洞 HTTP请求走私 MPS-2019-12064 CVE-2019-16869 高危
Apache Log4j SocketServer反序列化漏洞 反序列化 MPS-2019-17271 CVE-2019-17571 严重
Apache Zookeeper 授权问题漏洞 授权检查缺失 MPS-2019-5668 CVE-2019-0201 中危
Google Guava 访问控制错误漏洞 关键资源权限分配不当 MPS-2020-17429 CVE-2020-8908 低危
Apache Log4j2 SmtpAppender证书验证不当漏洞 证书验证不恰当 MPS-2020-6684 CVE-2020-9488 低危
Apache Log4j JMSAppender反序列化漏洞 反序列化 MPS-2021-38359 CVE-2021-4104 高危
Eclipse Jetty 资源管理错误漏洞 对异常条件的处理不恰当 MPS-2021-3864 CVE-2021-28165 高危
Eclipse Jetty 授权检查错误 MPS-2021-3877 CVE-2021-28164 中危
Eclipse Jetty 存在信息泄露漏洞 不充分的会话过期机制 MPS-2021-8884 CVE-2021-34428 低危
commons-codec:commons-codec 存在信息泄露漏洞 未授权敏感信息泄露 MPS-2022-11853 低危
org.freemarker:freemarker 代码注入 MPS-2022-12438 高危
org.json:json 存在拒绝服务漏洞 拒绝服务 MPS-2022-13520 高危
Apache Log4j JDBCAppender SQL注入漏洞 SQL注入 MPS-2022-1444 CVE-2022-23305 严重
Apache Log4j Chainsaw反序列化漏洞 反序列化 MPS-2022-1445 CVE-2022-23307 高危
Apache Log4j 反序列化漏洞 反序列化 MPS-2022-1446 CVE-2022-23302 高危
Eclipse Jetty URI注入漏洞 注入 MPS-2022-18060 CVE-2022-2047 低危
Spring 处理 SpEL 存在拒绝服务漏洞 拒绝服务 MPS-2022-62833 CVE-2023-20861 中危
Spring Expression 存在拒绝服务漏洞 拒绝服务 MPS-2022-62835 CVE-2023-20863 高危
Eclipse Jetty 资源管理错误漏洞 拒绝服务 MPS-2023-4997 CVE-2023-26048 中危
Eclipse Jetty 信息泄露漏洞 XSS MPS-2023-4998 CVE-2023-26049 中危
Eclipse Jetty 安全漏洞 MPS-49ot-3w07 CVE-2023-40167 中危
JSON-Java 中存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-894c-qbpk 高危
snappy-java 输入验证错误漏洞 整数溢出或环绕 MPS-8znw-4jmi CVE-2023-34453 高危
snappy-java 的 compress 方法整数溢出漏洞导致拒绝服务 整数溢出或环绕 MPS-angp-mxl2 CVE-2023-34454 中危
ZooKeeper SASL 身份验证绕过漏洞 通过用户控制密钥绕过授权机制 MPS-bznr-672x CVE-2023-44981 高危
JSON-Java 安全漏洞 不加限制或调节的资源分配 MPS-m4ex-dja2 CVE-2023-5072 高危
Guava 创建拥有不安全权限的临时文件 MPS-mfku-xzh3 CVE-2023-2976 中危
Snappy 安全漏洞 不加限制或调节的资源分配 MPS-s7wb-p03z CVE-2023-43642 高危
amqp-client 拒绝服务漏洞 拒绝服务 MPS-sqnw-9vcz CVE-2023-46120 中危
Snappy 输入验证错误漏洞 不加限制或调节的资源分配 MPS-tnp7-60hk CVE-2023-34455 高危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
org.eclipse.jetty:jetty-io 9.4.37.v20210219 9.4.39.v20210325 间接依赖 建议修复
com.google.guava:guava 17.0 32.0.0-jre 间接依赖 建议修复
org.json:json 20131018 20231013 间接依赖 建议修复
io.netty:netty 3.7.0.Final 间接依赖 建议修复
org.eclipse.jetty:jetty-http 9.3.21.v20170918 11.0.16 间接依赖 建议修复
org.apache.zookeeper:zookeeper 3.4.6 3.7.2 间接依赖 建议修复
org.xerial.snappy:snappy-java 1.1.1.7 1.1.10.4 间接依赖 建议修复
log4j:log4j 1.2.17 间接依赖 建议修复
log4j:log4j 1.2.15 间接依赖 建议修复
org.eclipse.jetty:jetty-server 9.4.37.v20210219 9.4.51 直接依赖 建议修复
org.beanshell:bsh 2.0b5 直接依赖 建议修复
org.freemarker:freemarker 2.3.19 2.3.30 直接依赖 建议修复
net.jpountz.lz4:lz4 1.2.0 1.3.0 间接依赖 可选修复
org.springframework:spring-core 5.3.20 5.3.26 直接依赖 可选修复
org.springframework:spring-expression 5.3.20 5.3.27 直接依赖 可选修复
commons-httpclient:commons-httpclient 3.1 间接依赖 可选修复
com.rabbitmq:amqp-client 4.8.0 5.18.0 直接依赖 可选修复
org.apache.kafka:kafka_2.10 0.9.0.0 0.10.2.2 直接依赖 可选修复
commons-codec:commons-codec 1.6 1.13 直接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
自定义许可证 20
Apache-2.0 52
MIT 7
CDDL-1.1 2
JSON 1
GPL-2.0 1
MPL-1.1 1
BSD-3-Clause 3
AGPL-3.0 2
LGPL-2.1-or-later 1
EPL-1.0 1
BSD-2-Clause 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
org.restlet.jse:org.restlet.ext.xml 2.4.0 直接依赖 maven
com.jcraft:jsch 0.1.54 直接依赖 maven
com.google.code.gson:gson 2.8.9 直接依赖 maven
beautifulsoup4 4.9.3 间接依赖 pip
javax.xml.bind:jaxb-api 2.3.1 直接依赖 maven
commons-net:commons-net 3.9.0 直接依赖 maven
org.json:json 20131018 间接依赖 maven
org.netpreserve.commons:webarchive-commons 1.1.8 直接依赖 maven
org.apache.groovy:groovy-xml 4.0.15 间接依赖 maven
com.rabbitmq:amqp-client 4.8.0 直接依赖 maven
javax.activation:activation 1.1 间接依赖 maven
com.esotericsoftware:kryo 1.01 直接依赖 maven
com.itextpdf:itextpdf 5.5.12 直接依赖 maven
org.apache.groovy:groovy-templates 4.0.15 直接依赖 maven
io.netty:netty 3.7.0.Final 间接依赖 maven
org.apache.httpcomponents:httpmime 4.5.13 直接依赖 maven
org.java-websocket:Java-WebSocket 1.5.2 直接依赖 maven
com.martiansoftware:jsap 2.1 间接依赖 maven
jline:jline 0.9.94 间接依赖 maven
org.jvnet.staxex:stax-ex 1.8 间接依赖 maven
org.springframework:spring-core 5.3.20 直接依赖 maven
net.htmlparser.jericho:jericho-html 2.6.1 直接依赖 maven
sphinxcontrib-httpdomain 1.7.0 间接依赖 pip
com.github.crawler-commons:crawler-commons 1.0 直接依赖 maven
org.gnu.inet:libidn 1.15 间接依赖 maven
javalang 0.13.0 间接依赖 pip
org.xerial.snappy:snappy-java 1.1.1.7 间接依赖 maven
org.restlet.jse:org.restlet.ext.jetty 2.4.0 直接依赖 maven
com.googlecode.juniversalchardet:juniversalchardet 1.0.3 间接依赖 maven
com.101tec:zkclient 0.7 间接依赖 maven
org.eclipse.jetty:jetty-security 9.4.37.v20210219 直接依赖 maven
org.restlet.jse:org.restlet.ext.crypto 2.4.0 直接依赖 maven
com.googlecode.json-simple:json-simple 1.1.1 间接依赖 maven
org.slf4j:slf4j-log4j12 1.7.6 间接依赖 maven
org.eclipse.jetty:jetty-io 9.4.37.v20210219 间接依赖 maven
org.apache.zookeeper:zookeeper 3.4.6 间接依赖 maven
org.apache.groovy:groovy 4.0.15 间接依赖 maven
com.yammer.metrics:metrics-core 2.2.0 间接依赖 maven
log4j:log4j 1.2.15 间接依赖 maven
commons-cli:commons-cli 1.1 直接依赖 maven
org.eclipse.jetty:jetty-http 9.3.21.v20170918 间接依赖 maven
org.htmlparser:htmlparser 1.6 间接依赖 maven
javax.jms:jms 1.1 间接依赖 maven
org.apache.hbase:hbase-client 0.98.6-cdh5.3.5 直接依赖 maven
org.hamcrest:hamcrest-core 1.3 间接依赖 maven
org.apache.kafka:kafka_2.10 0.9.0.0 直接依赖 maven
poi:poi 2.5.1-final-20040804 直接依赖 maven
org.beanshell:bsh 2.0b5 直接依赖 maven
commons-codec:commons-codec 1.6 直接依赖 maven
org.springframework:spring-beans 5.3.20 直接依赖 maven
org.slf4j:slf4j-api 1.7.7 间接依赖 maven
com.lowagie:itext 1.3 直接依赖 maven
com.sun.xml.fastinfoset:FastInfoset 1.2.15 间接依赖 maven
org.eclipse.jetty:jetty-util 9.4.37.v20210219 直接依赖 maven
net.jpountz.lz4:lz4 1.2.0 间接依赖 maven
org.glassfish.jaxb:jaxb-runtime 2.3.1 直接依赖 maven
org.archive.heritrix:heritrix-modules 3.4.0-SNAPSHOT 直接依赖 maven
commons-collections:commons-collections 3.2.2 直接依赖 maven
commons-configuration:commons-configuration 1.8 间接依赖 maven
joda-time:joda-time 1.6 直接依赖 maven
org.springframework:spring-expression 5.3.20 直接依赖 maven
commons-lang:commons-lang 2.6 直接依赖 maven
commons-io:commons-io 2.7 直接依赖 maven
com.rethinkdb:rethinkdb-driver 2.3.3 直接依赖 maven
com.sun.jdmk:jmxtools 1.2.1 间接依赖 maven
org.eclipse.jetty:jetty-server 9.4.37.v20210219 直接依赖 maven
poi:poi-scratchpad 2.5.1-final-20040804 直接依赖 maven
org.springframework:spring-context 5.3.20 直接依赖 maven
org.slf4j:slf4j-api 1.7.30 间接依赖 maven
com.esotericsoftware:minlog 1.2 直接依赖 maven
com.anotherbigidea:javaswf CVS-SNAPSHOT-1 直接依赖 maven
com.sun.istack:istack-commons-runtime 3.0.7 间接依赖 maven
com.sun.jmx:jmxri 1.2.1 间接依赖 maven
it.unimi.dsi:dsiutils 2.0.12 间接依赖 maven
log4j:log4j 1.2.17 间接依赖 maven
org.archive.heritrix:heritrix-engine 3.4.0-SNAPSHOT 直接依赖 maven
junit:junit 4.13.1 直接依赖 maven
com.sleepycat:je 7.5.11 直接依赖 maven
org.scala-lang:scala-library 2.10.5 间接依赖 maven
org.springframework:spring-jcl 5.3.20 间接依赖 maven
org.apache.httpcomponents:httpclient 4.5.13 直接依赖 maven
org.glassfish.jaxb:txw2 2.3.1 间接依赖 maven
org.springframework:spring-aop 5.3.20 间接依赖 maven
org.apache.commons:commons-math3 3.1.1 间接依赖 maven
javax.activation:javax.activation-api 1.2.0 间接依赖 maven
javax.servlet:javax.servlet-api 3.1.0 间接依赖 maven
org.apache.groovy:groovy-jsr223 4.0.15 直接依赖 maven
org.apache.kafka:kafka-clients 0.9.0.0 间接依赖 maven
dnsjava:dnsjava 3.3.1 直接依赖 maven
org.apache.httpcomponents:httpcore 4.4.13 间接依赖 maven
commons-logging:commons-logging 1.0.4 直接依赖 maven
org.archive.heritrix:heritrix-commons 3.4.0-SNAPSHOT 直接依赖 maven
com.esotericsoftware:reflectasm 0.8 直接依赖 maven
org.restlet.jse:org.restlet 2.4.0 直接依赖 maven
javax.mail:mail 1.4 间接依赖 maven
org.freemarker:freemarker 2.3.19 直接依赖 maven
com.google.guava:guava 17.0 间接依赖 maven
commons-httpclient:commons-httpclient 3.1 间接依赖 maven
org.slf4j:slf4j-api 1.7.25 间接依赖 maven
net.sf.jopt-simple:jopt-simple 3.2 间接依赖 maven
it.unimi.dsi:fastutil 6.5.2 间接依赖 maven
(0)
上一篇 2023年11月21日
下一篇 2023年11月21日

相关推荐

  • geeeeeeeeek/WeChatLuckyMoney 软件分析报告

    基础信息 项目名称:geeeeeeeeek/WeChatLuckyMoney 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721218647023751168/1728162728788844544 此报告由M…

    软件分析 2023年11月25日
    0
  • hsl947/react-antd-multi-tabs-admin 软件分析报告

    基础信息 项目名称:hsl947/react-antd-multi-tabs-admin 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718672785240883200/1718672786402705408…

    软件分析 2023年10月30日
    0
  • htr-tech/bash2mp4 软件分析报告

    基础信息 项目名称:htr-tech/bash2mp4 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721263515833499648/1729663557531815936 此报告由Murphysec提供 …

    软件分析 2023年11月29日
    0
  • google/gdata-python-client 软件分析报告

    基础信息 项目名称:google/gdata-python-client 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721234977504432128/1728216414883368960 此报告由Mur…

    软件分析 2023年11月25日
    0
  • gibbonCode/GIBBON 软件分析报告

    基础信息 项目名称:gibbonCode/GIBBON 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718113791777751040/1718113791870025728 此报告由Murphysec提供 …

    软件分析 2023年10月28日
    0