bradleyboy/tuql 软件分析报告

基础信息

项目名称:bradleyboy/tuql

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1725371784481955840/1725371784926552064

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
sshpk 安全漏洞 不正确的正则表达式 MPS-2018-7302 CVE-2018-3737 高危
handlebars 原型污染漏洞 原型污染 MPS-2019-16888 CVE-2019-19919 严重
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
handlebars 代码注入漏洞 代码注入 MPS-2020-13732 CVE-2019-20920 高危
handlebars 安全漏洞 不可达退出条件的循环(无限循环) MPS-2020-13734 CVE-2019-20922 高危
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
Yargs Y18n 输入原型污染漏洞 动态确定对象属性修改的控制不恰当 MPS-2020-17543 CVE-2020-7774 严重
Ini 拒绝服务 MPS-2020-17544 CVE-2020-7788 高危
Mikaelbr Node-notifier 操作系统命令注入漏洞 OS命令注入 MPS-2020-17637 CVE-2020-7789 中危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
yargs-parser 原型污染漏洞 特权定义了不安全动作 MPS-2020-4006 CVE-2020-7608 中危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-11547 CVE-2021-32804 高危
node-tar 路径遍历漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-11548 CVE-2021-32803 高危
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28486 CVE-2021-37701 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28488 CVE-2021-37712 高危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-28489 CVE-2021-37713 高危
validator.js 拒绝服务漏洞 拒绝服务 MPS-2021-31021 CVE-2021-3765 高危
nodejs 正则表达式漏洞 拒绝服务 MPS-2021-31423 CVE-2021-3777 高危
prompts 正则表达式拒绝服务漏洞 ReDoS MPS-2021-32909 中危
Ruy Adorno hosted-git-info 正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-3400 CVE-2021-23362 中危
json-schema 安全漏洞 原型污染 MPS-2021-34478 CVE-2021-3918 严重
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
handlebars 远程代码执行 (RCE) 漏洞 代码注入 MPS-2021-4548 CVE-2021-23369 严重
browserslist 存在正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-5473 CVE-2021-23364 中危
handlebars 原型污染 MPS-2021-6180 CVE-2021-23383 严重
ws 存在拒绝服务漏洞 拒绝服务 MPS-2021-7109 CVE-2021-32640 中危
Moment.js 正则拒绝服务漏洞 拒绝服务 MPS-2022-11159 CVE-2022-31129 高危
acorn 存在拒绝服务漏洞 拒绝服务 MPS-2022-13525 高危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13732 高危
handlebars 存在代码注入漏洞 代码注入 MPS-2022-13733 高危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13734 严重
handlebars 拒绝服务 MPS-2022-13735 中危
istanbul-reports 通过 window.opener 访问使用指向不受信任目标的 Web 链接 MPS-2022-13797 中危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
tar 正则表达式拒绝服务漏洞 拒绝服务 MPS-2022-14081 低危
uglify-js ReDoS MPS-2022-14112 中危
validator 拒绝服务 MPS-2022-14122 中危
validator 拒绝服务 MPS-2022-14123 中危
validator 拒绝服务 MPS-2022-14124 中危
Moment.js 路径遍历漏洞 路径遍历 MPS-2022-3752 CVE-2022-24785 中危
Express 中的 qs 模块存在原型污染漏洞 原型污染 MPS-2022-3967 CVE-2022-24999 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
sequelize SQL 注入漏洞 SQL注入 MPS-2022-52071 高危
nwsapi 拒绝服务 拒绝服务 MPS-2022-54623 中危
sequelize SQL注入 SQL注入 MPS-2022-54713 严重
decode-uri-component 拒绝服务 MPS-2022-56259 CVE-2022-38900 高危
moment-timezone 存在命令注入 命令注入 MPS-2022-56430 严重
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
needle 存在Authorization请求头泄露漏洞 未授权敏感信息泄露 MPS-2022-7866 中危
feathers-sequelize 安全漏洞 特殊元素过滤不恰当 MPS-2023-0127 CVE-2023-22578 严重
feathers-sequelize 安全漏洞 SQL注入 MPS-2023-0128 CVE-2023-22579 高危
Tiki Wiki CMS Groupware 信息泄露漏洞 用 PHP 编写的软件的弱点 MPS-2023-0129 CVE-2023-22580 高危
Sequelize SQL注入 MPS-2023-4688 CVE-2023-25813 高危
dottie 安全漏洞 原型污染 MPS-2023-5126 CVE-2023-26132 高危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
fsevents 安全漏洞 代码注入 MPS-2ipy-muq0 CVE-2023-45311 严重
Babel 插件任意代码执行漏洞漏洞【Poc公开】 不完整的黑名单 MPS-avb9-j50z CVE-2023-45133 严重
tough-cookie 原型污染 MPS-esyq-56vx 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
handlebars 4.1.2 4.7.7 间接依赖 建议修复
y18n 4.0.0 4.0.1 间接依赖 建议修复
dottie 2.0.1 2.0.4 间接依赖 建议修复
json-schema 0.2.3 0.4.0 间接依赖 建议修复
validator 10.11.0 13.7.0 间接依赖 建议修复
@babel/traverse 7.5.5 7.23.2 间接依赖 建议修复
lodash 4.17.15 4.17.21 间接依赖 建议修复
ini 1.3.5 1.3.6 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
express 4.17.1 4.17.3 直接依赖 建议修复
tough-cookie 2.5.0 4.1.3 间接依赖 建议修复
sshpk 1.13.1 1.14.1 间接依赖 建议修复
minimist 0.0.8 1.2.6 间接依赖 建议修复
tar 4.4.10 4.4.18 间接依赖 建议修复
acorn 5.7.3 5.7.4 间接依赖 建议修复
moment-timezone 0.5.26 0.5.35 间接依赖 建议修复
tmpl 1.0.4 1.0.5 间接依赖 建议修复
sequelize 5.16.0 6.29.0 直接依赖 建议修复
decode-uri-component 0.2.0 0.2.1 间接依赖 建议修复
qs 6.5.2 6.5.3 间接依赖 建议修复
semver 5.4.1 7.5.2 间接依赖 可选修复
needle 2.4.0 3.1.0 间接依赖 可选修复
request 2.88.0 间接依赖 可选修复
hosted-git-info 2.5.0 2.8.9 间接依赖 可选修复
moment 2.24.0 2.29.4 间接依赖 可选修复
browserslist 4.6.6 4.16.5 间接依赖 可选修复
uglify-js 3.6.0 3.14.3 间接依赖 可选修复
nwsapi 2.1.4 2.2.1 间接依赖 可选修复
yargs-parser 13.1.1 13.1.2 间接依赖 可选修复
node-notifier 5.4.3 5.4.5 间接依赖 可选修复
prompts 2.2.1 2.4.2 直接依赖 可选修复
ws 5.2.2 5.2.3 间接依赖 可选修复
ajv 6.10.2 6.12.3 间接依赖 可选修复
fsevents 1.2.9 1.2.11 间接依赖 可选修复
istanbul-reports 2.2.6 3.1.3 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 480
BSD-3-Clause 16
Apache-2.0 15
ISC 52
BSD-2-Clause 13
Unlicense 2
WTFPL 1
CC-BY-4.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
define-properties 1.1.3 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
pirates 4.0.1 间接依赖 npm
@babel/plugin-proposal-optional-catch-binding 7.2.0 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
p-each-series 1.0.0 间接依赖 npm
mixin-deep 1.3.2 间接依赖 npm
source-map 0.5.7 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
set-value 2.0.1 间接依赖 npm
request 2.88.0 间接依赖 npm
convert-source-map 1.5.0 间接依赖 npm
jsesc 2.5.2 间接依赖 npm
rc 1.2.8 间接依赖 npm
@babel/plugin-transform-function-name 7.4.4 间接依赖 npm
@babel/helpers 7.5.5 间接依赖 npm
graceful-fs 4.1.11 间接依赖 npm
minizlib 1.2.1 间接依赖 npm
@babel/plugin-transform-block-scoped-functions 7.2.0 间接依赖 npm
is-accessor-descriptor 0.1.6 间接依赖 npm
cookie-signature 1.0.6 间接依赖 npm
is-ci 2.0.0 间接依赖 npm
chownr 1.1.2 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
has 1.0.3 间接依赖 npm
@babel/helper-member-expression-to-functions 7.5.5 间接依赖 npm
unicode-canonical-property-names-ecmascript 1.0.4 间接依赖 npm
decode-uri-component 0.2.0 间接依赖 npm
co 4.6.0 间接依赖 npm
for-in 1.0.2 间接依赖 npm
split-string 3.1.0 间接依赖 npm
throat 4.1.0 间接依赖 npm
@babel/plugin-transform-property-literals 7.2.0 间接依赖 npm
html-encoding-sniffer 1.0.2 间接依赖 npm
lodash.sortby 4.7.0 间接依赖 npm
minipass 2.4.0 间接依赖 npm
is-symbol 1.0.2 间接依赖 npm
data-urls 1.1.0 间接依赖 npm
toidentifier 1.0.0 间接依赖 npm
@babel/plugin-transform-modules-amd 7.5.0 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
es-to-primitive 1.2.0 间接依赖 npm
string-width 3.1.0 间接依赖 npm
parse-passwd 1.0.0 间接依赖 npm
har-validator 5.1.3 间接依赖 npm
os-homedir 1.0.2 间接依赖 npm
hosted-git-info 2.5.0 间接依赖 npm
@babel/plugin-transform-parameters 7.4.4 间接依赖 npm
caseless 0.12.0 间接依赖 npm
@babel/preset-env 7.5.5 直接依赖 npm
rsvp 4.8.5 间接依赖 npm
@jest/test-result 24.9.0 间接依赖 npm
snapdragon-util 3.0.1 间接依赖 npm
@babel/helper-wrap-function 7.2.0 间接依赖 npm
content-type 1.0.4 间接依赖 npm
@babel/plugin-syntax-optional-catch-binding 7.2.0 间接依赖 npm
to-regex-range 2.1.1 间接依赖 npm
is-callable 1.1.4 间接依赖 npm
inflection 1.12.0 间接依赖 npm
private 0.1.8 间接依赖 npm
sane 4.1.0 间接依赖 npm
readable-stream 2.3.6 间接依赖 npm
chokidar 2.1.8 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
aproba 1.2.0 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
jest-config 24.9.0 间接依赖 npm
webidl-conversions 4.0.2 间接依赖 npm
yargs 13.3.0 间接依赖 npm
jest-haste-map 24.9.0 间接依赖 npm
methods 1.1.2 间接依赖 npm
shellwords 0.1.1 间接依赖 npm
@babel/plugin-syntax-dynamic-import 7.2.0 间接依赖 npm
@babel/plugin-transform-sticky-regex 7.2.0 间接依赖 npm
map-cache 0.2.2 间接依赖 npm
isarray 1.0.0 间接依赖 npm
parse5 4.0.0 间接依赖 npm
vary 1.1.2 间接依赖 npm
bytes 3.1.0 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
gauge 2.7.4 间接依赖 npm
psl 1.3.0 间接依赖 npm
is-number 3.0.0 间接依赖 npm
bcrypt-pbkdf 1.0.1 间接依赖 npm
has-symbols 1.0.0 间接依赖 npm
diff-sequences 24.9.0 间接依赖 npm
encodeurl 1.0.2 间接依赖 npm
abbrev 1.1.1 间接依赖 npm
source-map-url 0.4.0 间接依赖 npm
get-value 2.0.6 间接依赖 npm
async-limiter 1.0.1 间接依赖 npm
jest-pnp-resolver 1.2.1 间接依赖 npm
ipaddr.js 1.9.0 间接依赖 npm
neo-async 2.6.1 间接依赖 npm
chalk 2.3.0 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
is-regex 1.0.4 间接依赖 npm
cors 2.8.5 直接依赖 npm
@babel/helper-split-export-declaration 7.4.4 间接依赖 npm
raw-body 2.4.0 间接依赖 npm
mime-db 1.40.0 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
@babel/helper-annotate-as-pure 7.0.0 间接依赖 npm
source-map-resolve 0.5.2 间接依赖 npm
trim-right 1.0.1 间接依赖 npm
@babel/generator 7.5.5 间接依赖 npm
node-notifier 5.4.3 间接依赖 npm
forwarded 0.1.2 间接依赖 npm
toposort-class 1.0.1 间接依赖 npm
once 1.4.0 间接依赖 npm
extsprintf 1.3.0 间接依赖 npm
retry-as-promised 3.2.0 间接依赖 npm
optimist 0.6.1 间接依赖 npm
regenerate 1.4.0 间接依赖 npm
@types/babel__core 7.1.2 间接依赖 npm
base 0.11.2 间接依赖 npm
jest-message-util 24.9.0 间接依赖 npm
tunnel-agent 0.6.0 间接依赖 npm
path-key 2.0.1 间接依赖 npm
json-schema 0.2.3 间接依赖 npm
uglify-js 3.6.0 间接依赖 npm
snapdragon-node 2.1.1 间接依赖 npm
negotiator 0.6.2 间接依赖 npm
w3c-hr-time 1.0.1 间接依赖 npm
ecc-jsbn 0.1.1 间接依赖 npm
serve-static 1.14.1 间接依赖 npm
optionator 0.8.2 间接依赖 npm
regjsparser 0.6.0 间接依赖 npm
@babel/plugin-transform-spread 7.2.2 间接依赖 npm
tar 4.4.10 间接依赖 npm
xml-name-validator 3.0.0 间接依赖 npm
ms 2.0.0 间接依赖 npm
whatwg-encoding 1.0.5 间接依赖 npm
jest-serializer 24.9.0 间接依赖 npm
growly 1.3.0 间接依赖 npm
statuses 1.5.0 间接依赖 npm
@types/yargs-parser 13.0.0 间接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
babel-plugin-jest-hoist 24.9.0 间接依赖 npm
npmlog 4.1.2 间接依赖 npm
fsevents 1.2.9 间接依赖 npm
jest-resolve 24.9.0 间接依赖 npm
@babel/plugin-transform-computed-properties 7.2.0 间接依赖 npm
request-promise-core 1.1.2 间接依赖 npm
jest-changed-files 24.9.0 间接依赖 npm
posix-character-classes 0.1.1 间接依赖 npm
validate-npm-package-license 3.0.1 间接依赖 npm
handlebars 4.1.2 间接依赖 npm
invariant 2.2.4 间接依赖 npm
repeat-element 1.1.2 间接依赖 npm
istanbul-lib-coverage 2.0.5 间接依赖 npm
to-fast-properties 2.0.0 间接依赖 npm
globals 11.12.0 间接依赖 npm
depd 1.1.2 间接依赖 npm
yargs-parser 13.1.1 间接依赖 npm
media-typer 0.3.0 间接依赖 npm
realpath-native 1.1.0 间接依赖 npm
regjsgen 0.5.0 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
find-replace 3.0.0 间接依赖 npm
express 4.17.1 直接依赖 npm
@types/istanbul-reports 1.1.1 间接依赖 npm
har-schema 2.0.0 间接依赖 npm
node-int64 0.4.0 间接依赖 npm
@babel/plugin-transform-shorthand-properties 7.2.0 间接依赖 npm
nice-try 1.0.5 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
object.assign 4.1.0 间接依赖 npm
@jest/reporters 24.9.0 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
is-bluebird 1.0.2 间接依赖 npm
resolve-url 0.2.1 间接依赖 npm
assign-symbols 1.0.0 间接依赖 npm
inherits 2.0.3 间接依赖 npm
jest-diff 24.9.0 间接依赖 npm
lodash.camelcase 4.3.0 间接依赖 npm
fast-deep-equal 2.0.1 间接依赖 npm
abab 2.0.0 间接依赖 npm
@babel/helper-call-delegate 7.4.4 间接依赖 npm
request-promise-native 1.0.7 间接依赖 npm
semver 5.4.1 间接依赖 npm
estraverse 4.3.0 间接依赖 npm
typical 4.0.0 间接依赖 npm
regexpu-core 4.5.5 间接依赖 npm
callsites 3.1.0 间接依赖 npm
moment 2.24.0 间接依赖 npm
p-reduce 1.0.0 间接依赖 npm
find-up 3.0.0 间接依赖 npm
pluralize 8.0.0 直接依赖 npm
@babel/plugin-transform-regenerator 7.4.5 间接依赖 npm
expand-brackets 2.1.4 间接依赖 npm
@babel/plugin-transform-template-literals 7.4.4 间接依赖 npm
wrap-ansi 5.1.0 间接依赖 npm
jest-environment-jsdom 24.9.0 间接依赖 npm
getpass 0.1.7 间接依赖 npm
cross-spawn 6.0.5 间接依赖 npm
kleur 3.0.3 间接依赖 npm
command-line-args 5.1.1 直接依赖 npm
escodegen 1.12.0 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
@babel/types 7.5.5 间接依赖 npm
error-ex 1.3.1 直接依赖 npm
wide-align 1.1.3 间接依赖 npm
fs-readdir-recursive 1.1.0 间接依赖 npm
@babel/plugin-transform-member-expression-literals 7.2.0 间接依赖 npm
cookie 0.4.0 间接依赖 npm
accepts 1.3.7 间接依赖 npm
@jest/core 24.9.0 直接依赖 npm
spdx-license-ids 1.2.2 间接依赖 npm
graphql 14.5.3 直接依赖 npm
acorn-globals 4.3.3 间接依赖 npm
escape-html 1.0.3 间接依赖 npm
has-flag 2.0.0 间接依赖 npm
@babel/template 7.4.4 间接依赖 npm
cache-base 1.0.1 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
define-property 2.0.2 间接依赖 npm
require-main-filename 2.0.0 间接依赖 npm
deep-extend 0.6.0 间接依赖 npm
whatwg-url 6.5.0 间接依赖 npm
resolve 1.12.0 间接依赖 npm
@jest/transform 24.9.0 间接依赖 npm
jest-resolve-dependencies 24.9.0 间接依赖 npm
validator 10.11.0 间接依赖 npm
array-back 3.1.0 间接依赖 npm
is-date-object 1.0.1 间接依赖 npm
@babel/polyfill 7.4.4 间接依赖 npm
@jest/types 24.9.0 间接依赖 npm
ignore-walk 3.0.1 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
util.promisify 1.0.0 间接依赖 npm
number-is-nan 1.0.1 直接依赖 npm
jest-regex-util 24.9.0 间接依赖 npm
@babel/plugin-proposal-object-rest-spread 7.5.5 间接依赖 npm
pn 1.1.0 间接依赖 npm
@babel/helper-optimise-call-expression 7.0.0 间接依赖 npm
needle 2.4.0 间接依赖 npm
@babel/traverse 7.5.5 间接依赖 npm
imurmurhash 0.1.4 直接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
assert-plus 1.0.0 间接依赖 npm
@babel/plugin-transform-for-of 7.4.4 间接依赖 npm
esprima 4.0.0 间接依赖 npm
@babel/plugin-transform-modules-umd 7.2.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
istanbul-reports 2.2.6 间接依赖 npm
has-value 1.0.0 间接依赖 npm
@babel/code-frame 7.5.5 间接依赖 npm
spdx-expression-parse 1.0.4 间接依赖 npm
pascalcase 0.1.1 间接依赖 npm
delegates 1.0.0 间接依赖 npm
proxy-addr 2.0.5 间接依赖 npm
array-flatten 1.1.1 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
commander 2.20.0 间接依赖 npm
is-wsl 1.1.0 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
@jest/environment 24.9.0 间接依赖 npm
istanbul-lib-source-maps 3.0.6 间接依赖 npm
prettier 1.18.2 间接依赖 npm
to-object-path 0.3.0 间接依赖 npm
cliui 5.0.0 间接依赖 npm
has-unicode 2.0.1 间接依赖 npm
glob 7.1.2 间接依赖 npm
strip-bom 3.0.0 间接依赖 npm
wordwrap 0.0.3 间接依赖 npm
log-driver 1.2.7 间接依赖 npm
@babel/plugin-transform-dotall-regex 7.4.4 间接依赖 npm
async-each 1.0.3 间接依赖 npm
@babel/plugin-transform-new-target 7.4.4 间接依赖 npm
emoji-regex 7.0.3 间接依赖 npm
oauth-sign 0.9.0 间接依赖 npm
isstream 0.1.2 间接依赖 npm
@babel/helper-builder-binary-assignment-operator-visitor 7.1.0 间接依赖 npm
makeerror 1.0.11 间接依赖 npm
tmpl 1.0.4 间接依赖 npm
@babel/plugin-syntax-async-generators 7.2.0 间接依赖 npm
cls-bluebird 2.1.0 间接依赖 npm
end-of-stream 1.4.1 间接依赖 npm
jest-environment-node 24.9.0 间接依赖 npm
uuid 3.3.3 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
urix 0.1.0 间接依赖 npm
unicode-property-aliases-ecmascript 1.0.5 间接依赖 npm
ret 0.1.15 间接依赖 npm
moment-timezone 0.5.26 间接依赖 npm
on-finished 2.3.0 间接依赖 npm
isobject 3.0.1 间接依赖 npm
npm-bundled 1.0.6 间接依赖 npm
any-promise 1.3.0 间接依赖 npm
aws4 1.8.0 间接依赖 npm
lcov-parse 0.0.10 间接依赖 npm
is-data-descriptor 0.1.4 间接依赖 npm
sequelize 5.16.0 直接依赖 npm
@babel/plugin-transform-arrow-functions 7.2.0 间接依赖 npm
js-levenshtein 1.1.6 间接依赖 npm
acorn-walk 6.2.0 间接依赖 npm
is-descriptor 0.1.6 间接依赖 npm
is-buffer 1.1.6 间接依赖 npm
@babel/helper-regex 7.5.5 间接依赖 npm
detect-newline 2.1.0 间接依赖 npm
@babel/core 7.5.5 间接依赖 npm
jest-each 24.9.0 间接依赖 npm
setprototypeof 1.1.1 间接依赖 npm
upath 1.1.2 间接依赖 npm
tweetnacl 0.14.5 间接依赖 npm
babel-preset-jest 24.9.0 间接依赖 npm
mime-types 2.1.24 间接依赖 npm
express-graphql 0.9.0 直接依赖 npm
command-line-usage 6.0.2 直接依赖 npm
import-local 2.0.0 间接依赖 npm
left-pad 1.3.0 间接依赖 npm
@babel/plugin-transform-modules-systemjs 7.5.0 间接依赖 npm
output-file-sync 2.0.1 间接依赖 npm
@babel/parser 7.5.5 间接依赖 npm
supports-color 4.5.0 间接依赖 npm
fb-watchman 2.0.0 间接依赖 npm
domexception 1.0.1 间接依赖 npm
color-name 1.1.3 间接依赖 npm
jsdom 11.12.0 间接依赖 npm
@babel/plugin-syntax-object-rest-spread 7.2.0 间接依赖 npm
cssstyle 1.4.0 间接依赖 npm
resolve-from 3.0.0 间接依赖 npm
asn1 0.2.3 间接依赖 npm
unicode-match-property-ecmascript 1.0.4 间接依赖 npm
is-plain-obj 1.1.0 间接依赖 npm
@babel/plugin-transform-classes 7.5.5 间接依赖 npm
jest-matcher-utils 24.9.0 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
ws 5.2.2 间接依赖 npm
electron-to-chromium 1.3.238 间接依赖 npm
tr46 1.0.1 间接依赖 npm
@babel/register 7.5.5 间接依赖 npm
safe-buffer 5.1.1 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
@cnakazawa/watch 1.0.3 间接依赖 npm
body-parser 1.19.0 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
performance-now 2.1.0 间接依赖 npm
nanomatch 1.2.13 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
are-we-there-yet 1.1.5 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
extend 3.0.2 间接依赖 npm
esutils 2.0.2 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
camelcase 5.3.1 间接依赖 npm
@babel/plugin-transform-named-capturing-groups-regex 7.4.5 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
form-data 2.3.3 间接依赖 npm
sqlite3 4.1.0 直接依赖 npm
http-signature 1.2.0 间接依赖 npm
wordwrapjs 4.0.0 间接依赖 npm
p-locate 3.0.0 间接依赖 npm
@babel/plugin-transform-block-scoping 7.5.5 间接依赖 npm
slash 2.0.0 间接依赖 npm
get-stream 4.1.0 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
ansi-regex 4.1.0 间接依赖 npm
@types/stack-utils 1.0.1 间接依赖 npm
static-extend 0.1.2 间接依赖 npm
@babel/plugin-proposal-dynamic-import 7.5.0 间接依赖 npm
node-releases 1.1.28 间接依赖 npm
jest-validate 24.9.0 间接依赖 npm
source-map-support 0.5.13 间接依赖 npm
astral-regex 1.0.0 间接依赖 npm
@babel/plugin-transform-unicode-regex 7.4.4 间接依赖 npm
atob 2.1.2 间接依赖 npm
@babel/helper-module-transforms 7.5.5 间接依赖 npm
@babel/cli 7.5.5 直接依赖 npm
capture-exit 2.0.0 间接依赖 npm
commondir 1.0.1 间接依赖 npm
@babel/plugin-transform-object-super 7.5.5 间接依赖 npm
jest-docblock 24.9.0 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
unicode-match-property-value-ecmascript 1.1.0 间接依赖 npm
shimmer 1.2.1 间接依赖 npm
@babel/helper-replace-supers 7.5.5 间接依赖 npm
which 1.3.0 间接依赖 npm
is-generator-fn 2.1.0 间接依赖 npm
@babel/plugin-transform-literals 7.2.0 间接依赖 npm
which-module 2.0.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
@babel/helper-define-map 7.5.5 间接依赖 npm
unpipe 1.0.0 间接依赖 npm
nwsapi 2.1.4 间接依赖 npm
sisteransi 1.0.3 间接依赖 npm
detect-libc 1.0.3 间接依赖 npm
jest-mock 24.9.0 间接依赖 npm
@babel/helper-function-name 7.1.0 间接依赖 npm
string-length 2.0.0 间接依赖 npm
argparse 1.0.9 直接依赖 npm
finalhandler 1.1.2 间接依赖 npm
merge-descriptors 1.0.1 间接依赖 npm
sequelize-pool 2.3.0 间接依赖 npm
@types/babel__template 7.0.2 间接依赖 npm
is-builtin-module 1.0.0 间接依赖 npm
is-extendable 0.1.1 间接依赖 npm
jest-leak-detector 24.9.0 间接依赖 npm
combined-stream 1.0.8 间接依赖 npm
readdirp 2.2.1 间接依赖 npm
tough-cookie 2.5.0 间接依赖 npm
browser-process-hrtime 0.1.3 间接依赖 npm
ci-info 2.0.0 间接依赖 npm
expect 24.9.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
jest-watcher 24.9.0 间接依赖 npm
@babel/helper-get-function-arity 7.0.0 间接依赖 npm
nan 2.14.0 间接依赖 npm
jsprim 1.4.1 间接依赖 npm
node-modules-regexp 1.0.0 间接依赖 npm
normalize-package-data 2.4.0 直接依赖 npm
arr-union 3.1.0 间接依赖 npm
utils-merge 1.0.1 间接依赖 npm
stack-utils 1.0.2 间接依赖 npm
class-utils 0.3.6 间接依赖 npm
growl 1.10.5 间接依赖 npm
babel-plugin-dynamic-import-node 2.3.0 间接依赖 npm
node-pre-gyp 0.11.0 间接依赖 npm
@babel/helper-plugin-utils 7.0.0 间接依赖 npm
ee-first 1.1.1 间接依赖 npm
@babel/plugin-transform-async-to-generator 7.5.0 间接依赖 npm
parseurl 1.3.3 间接依赖 npm
cssom 0.3.8 间接依赖 npm
jsbn 0.1.1 间接依赖 npm
@babel/helper-module-imports 7.0.0 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
@jest/fake-timers 24.9.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
table-layout 1.0.0 间接依赖 npm
etag 1.8.1 间接依赖 npm
fill-range 4.0.0 间接依赖 npm
regexp-tree 0.1.11 间接依赖 npm
fast-json-stable-stringify 2.0.0 间接依赖 npm
strip-ansi 5.2.0 间接依赖 npm
http-errors 1.7.2 间接依赖 npm
v8flags 3.1.3 间接依赖 npm
json-parse-better-errors 1.0.2 直接依赖 npm
snapdragon 0.8.2 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
prompts 2.2.1 直接依赖 npm
path-dirname 1.0.2 直接依赖 npm
console-control-strings 1.1.0 间接依赖 npm
exit 0.1.2 间接依赖 npm
type-is 1.6.18 间接依赖 npm
js-tokens 3.0.2 间接依赖 npm
ansi-styles 3.2.0 间接依赖 npm
path-to-regexp 0.1.7 间接依赖 npm
brace-expansion 1.1.8 间接依赖 npm
loose-envify 1.3.1 间接依赖 npm
bluebird 3.5.5 间接依赖 npm
walker 1.0.7 间接依赖 npm
reduce-flatten 2.0.0 间接依赖 npm
mime 1.6.0 间接依赖 npm
binary-extensions 1.13.1 间接依赖 npm
@babel/node 7.5.5 直接依赖 npm
find-cache-dir 2.1.0 间接依赖 npm
core-js-compat 3.2.1 间接依赖 npm
coveralls 3.0.6 直接依赖 npm
array-unique 0.3.2 间接依赖 npm
acorn 5.7.3 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
safe-regex 1.1.0 间接依赖 npm
react-is 16.9.0 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
kind-of 3.2.2 间接依赖 npm
jest 24.9.0 直接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
regenerate-unicode-properties 8.1.0 间接依赖 npm
destroy 1.0.4 间接依赖 npm
fresh 0.5.2 间接依赖 npm
caniuse-lite 1.0.30000989 间接依赖 npm
strip-json-comments 2.0.1 间接依赖 npm
pify 3.0.0 间接依赖 npm
@babel/highlight 7.5.0 间接依赖 npm
@types/istanbul-lib-coverage 2.0.1 间接依赖 npm
node-environment-flags 1.0.6 间接依赖 npm
normalize-path 2.1.1 间接依赖 npm
osenv 0.1.5 间接依赖 npm
jest-util 24.9.0 间接依赖 npm
jest-worker 24.9.0 间接依赖 npm
npm-packlist 1.4.4 间接依赖 npm
whatwg-mimetype 2.3.0 间接依赖 npm
jest-runtime 24.9.0 间接依赖 npm
collection-visit 1.0.0 间接依赖 npm
qs 6.5.2 间接依赖 npm
jest-runner 24.9.0 间接依赖 npm
color-convert 1.9.1 间接依赖 npm
punycode 1.4.1 间接依赖 npm
regenerator-transform 0.14.1 间接依赖 npm
@jest/source-map 24.9.0 间接依赖 npm
array-equal 1.0.0 间接依赖 npm
@babel/plugin-transform-destructuring 7.5.0 间接依赖 npm
@babel/plugin-transform-typeof-symbol 7.2.0 间接依赖 npm
dottie 2.0.1 间接依赖 npm
@types/istanbul-lib-report 1.1.1 间接依赖 npm
object.getownpropertydescriptors 2.0.3 间接依赖 npm
@babel/helper-explode-assignable-expression 7.1.0 间接依赖 npm
iterall 1.2.2 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
repeat-string 1.6.1 间接依赖 npm
range-parser 1.2.1 间接依赖 npm
@babel/helper-hoist-variables 7.4.4 间接依赖 npm
@types/babel__traverse 7.0.7 间接依赖 npm
graphql-sequelize 9.3.6 直接依赖 npm
unset-value 1.0.0 间接依赖 npm
aws-sign2 0.7.0 间接依赖 npm
bser 2.0.0 间接依赖 npm
inflight 1.0.6 间接依赖 npm
@types/yargs 13.0.2 间接依赖 npm
make-dir 2.1.0 间接依赖 npm
@babel/plugin-transform-exponentiation-operator 7.2.0 间接依赖 npm
istanbul-lib-instrument 3.3.0 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
npm-run-path 2.0.2 间接依赖 npm
graphql-relay 0.6.0 直接依赖 npm
nopt 4.0.1 间接依赖 npm
y18n 4.0.0 间接依赖 npm
pretty-format 24.9.0 间接依赖 npm
wkx 0.4.8 间接依赖 npm
ansi-escapes 3.2.0 间接依赖 npm
ini 1.3.5 间接依赖 npm
homedir-polyfill 1.0.3 间接依赖 npm
@babel/plugin-transform-reserved-words 7.2.0 间接依赖 npm
rimraf 2.7.1 间接依赖 npm
spdx-correct 1.0.2 间接依赖 npm
@types/node 12.7.2 间接依赖 npm
verror 1.10.0 间接依赖 npm
@types/babel__generator 7.0.2 间接依赖 npm
browser-resolve 1.11.3 间接依赖 npm
strip-eof 1.0.0 间接依赖 npm
@babel/plugin-proposal-unicode-property-regex 7.4.4 间接依赖 npm
is-binary-path 1.0.1 间接依赖 npm
@babel/plugin-proposal-async-generator-functions 7.2.0 间接依赖 npm
sshpk 1.13.1 间接依赖 npm
jest-jasmine2 24.9.0 间接依赖 npm
braces 2.3.2 间接依赖 npm
symbol-tree 3.2.4 间接依赖 npm
code-point-at 1.1.0 直接依赖 npm
mkdirp 0.5.1 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
extglob 2.0.4 间接依赖 npm
jest-get-type 24.9.0 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
@jest/test-sequencer 24.9.0 间接依赖 npm
@babel/helper-remap-async-to-generator 7.1.0 间接依赖 npm
union-value 1.0.1 间接依赖 npm
minimist 0.0.8 间接依赖 npm
use 3.1.1 间接依赖 npm
jest-snapshot 24.9.0 间接依赖 npm
es-abstract 1.13.0 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
locate-path 3.0.0 间接依赖 npm
execa 1.0.0 间接依赖 npm
send 0.17.1 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
fs-minipass 1.2.6 间接依赖 npm
@babel/plugin-syntax-json-strings 7.2.0 间接依赖 npm
@babel/plugin-transform-duplicate-keys 7.5.0 间接依赖 npm
builtin-modules 1.1.1 间接依赖 npm
@babel/plugin-proposal-json-strings 7.2.0 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
lodash 4.17.15 间接依赖 npm
pkg-dir 3.0.0 间接依赖 npm
exec-sh 0.3.2 间接依赖 npm
component-emitter 1.3.0 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
@babel/plugin-transform-modules-commonjs 7.5.0 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
@babel/helper-simple-access 7.1.0 间接依赖 npm
ajv 6.10.2 间接依赖 npm
content-disposition 0.5.3 间接依赖 npm
stealthy-require 1.1.1 间接依赖 npm
leven 3.1.0 间接依赖 npm
debug 4.1.1 间接依赖 npm
uri-js 4.2.2 间接依赖 npm
babel-jest 24.9.0 间接依赖 npm
pump 3.0.0 间接依赖 npm
istanbul-lib-report 2.0.8 间接依赖 npm
sax 1.2.4 间接依赖 npm
resolve-cwd 2.0.0 间接依赖 npm
browserslist 4.6.6 间接依赖 npm
@jest/console 24.9.0 间接依赖 npm
(0)
上一篇 2023年11月17日
下一篇 2023年11月17日

相关推荐

  • cnpm/npminstall 软件分析报告

    基础信息 项目名称:cnpm/npminstall 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716756026791428096/1716756027126972416 此报告由Murphysec提供 漏洞…

    软件分析 2023年10月24日
    0
  • dabit3/full-stack-ethereum 软件分析报告

    基础信息 项目名称:dabit3/full-stack-ethereum 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717009236931428352/1717009237199863808 此报告由Mur…

    软件分析 2023年10月25日
    0
  • jedi95/Phoenix-Miner 软件分析报告

    基础信息 项目名称:jedi95/Phoenix-Miner 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719048313483427840/1719048313705725952 此报告由Murphysec…

    软件分析 2023年10月31日
    0
  • efcl/efcl 软件分析报告

    基础信息 项目名称:efcl/efcl 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717408936125841408/1717408936163590144 此报告由Murphysec提供 漏洞列表 漏洞名…

    软件分析 2023年10月26日
    0
  • jfcoz/cryptocurrency_nuclear_power 软件分析报告

    基础信息 项目名称:jfcoz/cryptocurrency_nuclear_power 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721306526135439360/1731085731861843968…

    软件分析 2023年12月3日
    0