JosephusPaye/Keen-UI 软件分析报告

基础信息

项目名称:JosephusPaye/Keen-UI

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1721320259272396800/1724293909432979456

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
NPM包esbuild-linux-arm64内嵌恶意代码 内嵌恶意代码 MPS-1czt-vhmw 高危
brace-expansion 安全漏洞 拒绝服务 MPS-2018-1167 CVE-2017-18077 高危
postcss 存在正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-5409 CVE-2021-23382 中危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
word-wrap 安全漏洞 ReDoS MPS-2023-5109 CVE-2023-26115 高危
NPM包esbuild-windows-32内嵌恶意代码 内嵌恶意代码 MPS-57lz-wkt4 高危
NPM包esbuild-darwin-arm64内嵌恶意代码 内嵌恶意代码 MPS-8hlj-rbwu 高危
NPM包esbuild-freebsd-64内嵌恶意代码 内嵌恶意代码 MPS-le94-f1pg 高危
NPM包esbuild-windows-64内嵌恶意代码 内嵌恶意代码 MPS-m5xq-lpih 高危
Vite 安全漏洞 使用不正确的解析名称或索引 MPS-o473-85mg CVE-2023-34092 高危
NPM包esbuild-darwin-64内嵌恶意代码 内嵌恶意代码 MPS-wzhl-gya9 高危
PostCSS 安全漏洞 注入 MPS-y3tx-jzms CVE-2023-44270 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
esbuild-darwin-arm64 0.14.54 直接依赖 强烈建议修复
esbuild-windows-64 0.14.54 直接依赖 强烈建议修复
esbuild-freebsd-64 0.14.54 直接依赖 强烈建议修复
esbuild-windows-32 0.14.54 直接依赖 强烈建议修复
esbuild-darwin-64 0.14.54 直接依赖 强烈建议修复
esbuild-linux-arm64 0.14.54 直接依赖 强烈建议修复
vite 3.0.8 3.2.7 直接依赖 建议修复
brace-expansion 1.1.6 1.1.7 间接依赖 建议修复
word-wrap 1.2.3 1.2.4 间接依赖 建议修复
minimatch 3.0.3 3.0.5 间接依赖 建议修复
semver 7.3.8 7.5.2 间接依赖 可选修复
postcss 8.4.16 8.4.31 间接依赖 可选修复
postcss 5.2.18 8.4.31 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 166
ISC 27
BSD-3-Clause 5
Apache-2.0 5
CC-BY-4.0 1
BSD-2-Clause 7
Python-2.0 1
BSD 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
vite 3.0.8 直接依赖 npm
strip-json-comments 3.1.1 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
word-wrap 1.2.3 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
fsevents 2.3.2 直接依赖 npm
esbuild-linux-arm64 0.14.54 直接依赖 npm
@esbuild/linux-loong64 0.14.54 直接依赖 npm
chalk 4.1.2 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
callsites 3.1.0 间接依赖 npm
eslint-plugin-vue 9.9.0 直接依赖 npm
@vue/shared 3.2.37 间接依赖 npm
acorn 8.8.1 间接依赖 npm
js-sdsl 4.2.0 间接依赖 npm
is-number 7.0.0 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
@vue/compiler-sfc 3.2.37 间接依赖 npm
eslint-utils 3.0.0 间接依赖 npm
nanoid 3.3.4 间接依赖 npm
ignore 5.2.4 间接依赖 npm
picocolors 1.0.0 间接依赖 npm
@vue/runtime-dom 3.2.37 间接依赖 npm
anymatch 3.1.2 间接依赖 npm
esbuild-linux-32 0.14.54 直接依赖 npm
esquery 1.4.0 间接依赖 npm
optionator 0.9.1 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
eslint 8.32.0 直接依赖 npm
@nodelib/fs.scandir 2.1.5 间接依赖 npm
ansi-regex 2.0.0 间接依赖 npm
path-exists 4.0.0 间接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
balanced-match 0.4.2 间接依赖 npm
ansi-regex 5.0.1 间接依赖 npm
eslint-visitor-keys 2.1.0 间接依赖 npm
flatted 3.2.7 间接依赖 npm
esbuild-linux-mips64le 0.14.54 直接依赖 npm
wrappy 1.0.2 间接依赖 npm
once 1.4.0 间接依赖 npm
esbuild-windows-arm64 0.14.54 直接依赖 npm
@humanwhocodes/config-array 0.11.8 间接依赖 npm
glob 7.1.1 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
postcss 8.4.16 间接依赖 npm
acorn-jsx 5.3.2 间接依赖 npm
source-map 0.5.6 间接依赖 npm
@vue/compiler-ssr 3.2.37 间接依赖 npm
@vue/server-renderer 3.2.37 间接依赖 npm
esbuild-windows-32 0.14.54 直接依赖 npm
punycode 2.3.0 间接依赖 npm
yocto-queue 0.1.0 间接依赖 npm
glob 7.2.3 间接依赖 npm
which 2.0.2 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
vue 3.2.37 直接依赖 npm
prelude-ls 1.2.1 间接依赖 npm
ms 2.1.2 间接依赖 npm
run-parallel 1.2.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
magic-string 0.25.9 间接依赖 npm
tippy.js 4.2.1 直接依赖 npm
eslint-config-prettier 8.6.0 直接依赖 npm
doctrine 3.0.0 间接依赖 npm
browserslist 1.7.7 间接依赖 npm
brace-expansion 1.1.6 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
cssesc 3.0.0 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
esbuild 0.14.54 间接依赖 npm
sourcemap-codec 1.4.8 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
autoprefixer 6.7.7 直接依赖 npm
caniuse-db 1.0.30001439 间接依赖 npm
reusify 1.0.4 间接依赖 npm
semver 7.3.8 间接依赖 npm
prettier 2.8.3 直接依赖 npm
js-yaml 4.1.0 间接依赖 npm
csstype 2.6.20 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
@nodelib/fs.walk 1.2.8 间接依赖 npm
postcss 5.2.18 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
esrecurse 4.3.0 间接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
esbuild-darwin-64 0.14.54 直接依赖 npm
path-key 3.1.1 间接依赖 npm
normalize-range 0.1.2 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
isexe 1.1.2 间接依赖 npm
type-check 0.4.0 间接依赖 npm
ansi-styles 4.3.0 间接依赖 npm
esbuild-linux-riscv64 0.14.54 直接依赖 npm
isexe 2.0.0 间接依赖 npm
glob-parent 6.0.2 间接依赖 npm
esbuild-android-arm64 0.14.54 直接依赖 npm
chokidar 3.5.2 间接依赖 npm
strip-ansi 6.0.1 间接依赖 npm
rollup 2.77.3 间接依赖 npm
find-up 5.0.0 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
has-ansi 2.0.0 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
lodash.debounce 4.0.8 直接依赖 npm
postcss-selector-parser 6.0.11 间接依赖 npm
esutils 2.0.3 间接依赖 npm
flat-cache 3.0.4 间接依赖 npm
is-core-module 2.10.0 间接依赖 npm
binary-extensions 2.2.0 间接依赖 npm
sass 1.41.0 直接依赖 npm
@humanwhocodes/object-schema 1.2.1 间接依赖 npm
inherits 2.0.4 间接依赖 npm
regexpp 3.2.0 间接依赖 npm
estree-walker 2.0.2 间接依赖 npm
vue-router 4.1.3 直接依赖 npm
resolve-from 4.0.0 间接依赖 npm
cross-env 3.1.3 直接依赖 npm
which 1.2.12 间接依赖 npm
@vue/runtime-core 3.2.37 间接依赖 npm
braces 3.0.2 间接依赖 npm
fastq 1.15.0 间接依赖 npm
esbuild-sunos-64 0.14.54 直接依赖 npm
@vitejs/plugin-vue 3.0.3 直接依赖 npm
is-binary-path 2.1.0 间接依赖 npm
locate-path 6.0.0 间接依赖 npm
source-map-js 1.0.2 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
resolve 1.22.1 间接依赖 npm
xml-name-validator 4.0.0 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
text-table 0.2.0 间接依赖 npm
boolbase 1.0.0 间接依赖 npm
inflight 1.0.6 间接依赖 npm
yallist 4.0.0 间接依赖 npm
rimraf 3.0.2 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
electron-to-chromium 1.4.284 间接依赖 npm
argparse 2.0.1 间接依赖 npm
@babel/parser 7.18.11 间接依赖 npm
eslint-visitor-keys 3.3.0 间接依赖 npm
levn 0.4.1 间接依赖 npm
has 1.0.3 间接依赖 npm
color-name 1.1.4 间接依赖 npm
has-flag 4.0.0 间接依赖 npm
esbuild-freebsd-64 0.14.54 直接依赖 npm
is-glob 4.0.1 间接依赖 npm
nth-check 2.1.1 间接依赖 npm
type-fest 0.20.2 间接依赖 npm
esbuild-windows-64 0.14.54 直接依赖 npm
minimatch 3.0.3 间接依赖 npm
supports-color 3.2.3 间接依赖 npm
deep-is 0.1.4 间接依赖 npm
color-convert 2.0.1 间接依赖 npm
espree 9.4.1 间接依赖 npm
@vue/reactivity-transform 3.2.37 间接依赖 npm
@vue/reactivity 3.2.37 间接依赖 npm
eslint-scope 7.1.1 间接依赖 npm
lru-cache 6.0.0 间接依赖 npm
num2fraction 1.2.2 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
esbuild-darwin-arm64 0.14.54 直接依赖 npm
js-base64 2.1.9 间接依赖 npm
vite-plugin-banner 0.7.0 直接依赖 npm
esbuild-freebsd-arm64 0.14.54 直接依赖 npm
yallist 2.1.2 间接依赖 npm
fuzzysearch 1.0.3 直接依赖 npm
@vue/compiler-dom 3.2.37 间接依赖 npm
esbuild-linux-s390x 0.14.54 直接依赖 npm
has-flag 1.0.0 间接依赖 npm
esbuild-linux-ppc64le 0.14.54 直接依赖 npm
deepmerge 2.0.1 直接依赖 npm
balanced-match 1.0.2 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
esbuild-linux-arm 0.14.54 直接依赖 npm
picomatch 2.3.0 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
estraverse 5.3.0 间接依赖 npm
esbuild-android-64 0.14.54 直接依赖 npm
queue-microtask 1.2.3 间接依赖 npm
minimatch 3.1.2 间接依赖 npm
@vue/devtools-api 6.2.1 间接依赖 npm
chalk 1.1.3 间接依赖 npm
globals 13.19.0 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
escape-string-regexp 4.0.0 间接依赖 npm
is-path-inside 3.0.3 间接依赖 npm
vue-eslint-parser 9.1.0 间接依赖 npm
esbuild-netbsd-64 0.14.54 直接依赖 npm
source-map 0.6.1 间接依赖 npm
glob-parent 5.1.2 间接依赖 npm
postcss-value-parser 3.3.0 间接依赖 npm
cross-spawn 3.0.1 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
@eslint/eslintrc 1.4.1 间接依赖 npm
lodash 4.17.21 间接依赖 npm
debug 4.3.4 间接依赖 npm
rimraf 2.5.4 直接依赖 npm
@humanwhocodes/module-importer 1.0.1 间接依赖 npm
@vue/compiler-core 3.2.37 间接依赖 npm
p-limit 3.1.0 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
grapheme-splitter 1.0.4 间接依赖 npm
file-entry-cache 6.0.1 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
readdirp 3.6.0 间接依赖 npm
lru-cache 4.1.1 间接依赖 npm
ajv 6.12.6 间接依赖 npm
autosize 3.0.20 直接依赖 npm
shebang-command 2.0.0 间接依赖 npm
import-fresh 3.3.0 间接依赖 npm
popper.js 1.14.7 间接依赖 npm
esbuild-openbsd-64 0.14.54 直接依赖 npm
p-locate 5.0.0 间接依赖 npm
esbuild-linux-64 0.14.54 直接依赖 npm
supports-color 7.2.0 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
(0)
上一篇 2023年11月14日
下一篇 2023年11月14日

相关推荐

  • hotosm/tasking-manager 软件分析报告

    基础信息 项目名称:hotosm/tasking-manager 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718663704149098496/1718663704191041536 此报告由Murphys…

    软件分析 2023年10月30日
    0
  • KwaiAppTeam/KOOM 软件分析报告

    基础信息 项目名称:KwaiAppTeam/KOOM 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719603336427913216/1719603336981561344 此报告由Murphysec提供 漏…

    软件分析 2023年11月1日
    0
  • wix/Detox 软件分析报告

    基础信息 项目名称:wix/Detox 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719757748739817472/1719757748798537728 此报告由Murphysec提供 漏洞列表 暂无 …

    软件分析 2023年11月2日
    0
  • elyra-ai/elyra 软件分析报告

    基础信息 项目名称:elyra-ai/elyra 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721161777886072832/1725925101567692800 此报告由Murphysec提供 漏洞列…

    软件分析 2023年11月19日
    0
  • BetterDiscord/Installer 软件分析报告

    基础信息 项目名称:BetterDiscord/Installer 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716304757740142592/1716304763658305536 此报告由Murphy…

    软件分析 2023年10月23日
    0