Evolveum/midpoint 软件分析报告

基础信息

项目名称:Evolveum/midpoint

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1721175407545286656/1723081993442779136

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Eclipse Jetty 输入验证错误漏洞 拒绝服务 MPS-0e59-bdsi CVE-2023-36478 高危
Spring AMQP 反序列化漏洞 反序列化 MPS-1mr6-9hnw CVE-2023-34050 中危
H2数据库权限检验不当漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2018-10344 CVE-2018-14335 中危
Terracotta Quartz Scheduler XXE MPS-2019-8669 CVE-2019-13990 严重
Pi-Hole Adminlte 路径遍历漏洞 路径遍历 MPS-2021-27496 CVE-2021-36471 严重
H2数据库存在JNDI注入漏洞 反序列化 MPS-2021-33243 CVE-2021-42392 严重
summernote 存在跨站脚本漏洞 XSS MPS-2022-14066 中危
sweetalert2 存在行为问题漏洞 行为问题 MPS-2022-14076 低危
H2 Console 代码注入漏洞 代码注入 MPS-2022-1435 CVE-2022-23221 严重
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
woodstox-core XXE MPS-2022-54303 中危
XStream 缓冲区错误漏洞 输入验证不恰当 MPS-2022-57061 CVE-2022-40156 低危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57062 CVE-2022-40155 高危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57063 CVE-2022-40154 高危
XStream 缓冲区错误漏洞 越界写入 MPS-2022-57065 CVE-2022-40152 高危
Apache Commons BCEL 越界写入 MPS-2022-59801 CVE-2022-42920 高危
pdfmake 代码注入 MPS-2022-65554 CVE-2022-46161 严重
Apache Ivy 输入验证不恰当 MPS-2022-67125 CVE-2022-46751 中危
snakeYAML 反序列化 MPS-2022-9425 CVE-2022-1471 高危
word-wrap 安全漏洞 ReDoS MPS-2023-5109 CVE-2023-26115 高危
Eclipse Jetty 安全漏洞 MPS-49ot-3w07 CVE-2023-40167 中危
Okio 安全漏洞 数值类型间的不正确转换 MPS-a2tx-d4fb CVE-2023-3635 高危
Babel 插件任意代码执行漏洞漏洞【Poc公开】 不完整的黑名单 MPS-avb9-j50z CVE-2023-45133 严重
Apache Tomcat http请求走私漏洞 输入验证不恰当 MPS-b5of-dwyh CVE-2023-45648 中危
Hot Rod 安全漏洞 证书验证不恰当 MPS-b7oj-adm3 CVE-2023-4586 高危
Apache Tomcat 安全漏洞 清理环节不完整 MPS-hz9y-jtfe CVE-2023-42795 中危
Bouncy Castle 信任管理问题漏洞 证书验证不恰当 MPS-i6w7-d48e CVE-2023-33201 中危
crypto-js 安全漏洞 使用具有不充分计算复杂性的口令哈希 MPS-m6rl-80wf CVE-2023-46233 严重
amqp-client 拒绝服务漏洞 拒绝服务 MPS-sqnw-9vcz CVE-2023-46120 中危
Apache Tomcat FORM 重定向漏洞 跨站重定向 MPS-uy56-j8e4 CVE-2023-41080 低危
Apache Santuario 日志信息泄露漏洞 日志敏感信息泄露 MPS-xpy5-qozw CVE-2023-44483 中危
PostCSS 安全漏洞 注入 MPS-y3tx-jzms CVE-2023-44270 中危
【存在争议】FasterXML jackson-databind 代码问题漏洞 不加限制或调节的资源分配 MPS-z1bx-p8y2 CVE-2023-35116 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
com.fasterxml.woodstox:woodstox-core 5.2.1 5.4.0 间接依赖 建议修复
com.fasterxml.jackson.core:jackson-databind 2.14.3 直接依赖 建议修复
word-wrap 1.2.3 1.2.4 间接依赖 建议修复
com.squareup.okio:okio-jvm 3.0.0 3.4.0 直接依赖 建议修复
org.springframework.amqp:spring-amqp 3.0.8 3.0.10 间接依赖 建议修复
org.apache.bcel:bcel 6.3.1 6.6.0 间接依赖 建议修复
org.apache.tomcat.embed:tomcat-embed-core 10.1.12 10.1.14 直接依赖 建议修复
@babel/traverse 7.17.9 7.23.2 间接依赖 建议修复
com.h2database:h2 1.4.193 直接依赖 建议修复
pdfmake 0.2.5 0.3.0-beta.1 间接依赖 建议修复
org.quartz-scheduler:quartz 2.3.2.e3 2.3.2 直接依赖 建议修复
org.yaml:snakeyaml 1.33 2.0 间接依赖 建议修复
sweetalert2 11.4.13 11.4.18 间接依赖 可选修复
org.apache.santuario:xmlsec 2.2.4 2.2.6 间接依赖 可选修复
org.eclipse.jetty:jetty-http 11.0.15 11.0.16 间接依赖 可选修复
postcss 8.4.19 8.4.31 间接依赖 可选修复
org.apache.ivy:ivy 2.5.1 2.5.2 间接依赖 可选修复
io.netty:netty-handler 4.1.97.Final 间接依赖 可选修复
semver 6.3.0 7.5.2 间接依赖 可选修复
summernote 0.8.20 间接依赖 可选修复
org.bouncycastle:bcprov-jdk15on 1.70 直接依赖 可选修复
com.rabbitmq:amqp-client 5.16.1 5.18.0 直接依赖 可选修复
admin-lte 3.2.0 直接依赖 可选修复
crypto-js 4.1.1 4.2.0 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 387
Apache-2.0 232
自定义许可证 27
LGPL-2.1-or-later 3
ISC 25
EPL-2.0 11
BSD-3-Clause 13
BSD-2-Clause 11
GPL-2.0 1
MPL-2.0 1
CDDL-1.0 2
EPL-1.0 2
CC-BY-4.0 1
GPL-2.0-with-classpath-exception 1
Apache License, Version 2.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
immutable 4.0.0 间接依赖 npm
com.evolveum.midpoint.model:certification-impl 4.9-SNAPSHOT 直接依赖 maven
com.fasterxml.woodstox:woodstox-core 5.2.1 间接依赖 maven
mini-css-extract-plugin 2.6.0 直接依赖 npm
postcss-reduce-initial 5.1.1 间接依赖 npm
datatables.net-responsive-bs4 2.2.9 间接依赖 npm
is-number 7.0.0 间接依赖 npm
@webassemblyjs/helper-numbers 1.11.1 间接依赖 npm
jakarta.activation:jakarta.activation-api 2.1.2 间接依赖 maven
org.springframework.amqp:spring-amqp 3.0.8 间接依赖 maven
is-arguments 1.1.1 间接依赖 npm
@foliojs-fork/fontkit 1.9.1 间接依赖 npm
io.netty:netty-transport-classes-epoll 4.1.97.Final 间接依赖 maven
universalify 2.0.0 间接依赖 npm
randombytes 2.1.0 间接依赖 npm
filterizr 2.2.4 间接依赖 npm
org.hibernate.orm:hibernate-core 6.1.7.Final 直接依赖 maven
@types/istanbul-lib-coverage 2.0.4 间接依赖 npm
org.apache.wicket:wicket-auth-roles 10.0.0-M1 直接依赖 maven
glob-parent 5.1.2 间接依赖 npm
com.mysema.commons:mysema-commons-lang 0.2.4 间接依赖 maven
browser-resolve 1.11.3 间接依赖 npm
@webassemblyjs/helper-wasm-bytecode 1.11.1 间接依赖 npm
tapable 2.2.1 间接依赖 npm
jakarta.jms:jakarta.jms-api 3.1.0 直接依赖 maven
deep-equal 1.1.1 间接依赖 npm
org.apache.groovy:groovy 4.0.11 直接依赖 maven
levn 0.3.0 间接依赖 npm
source-map-js 1.0.2 间接依赖 npm
org.springframework:spring-core 6.0.11 直接依赖 maven
@babel/compat-data 7.17.7 间接依赖 npm
minimist 1.2.6 间接依赖 npm
org.apache.derby:derbytools 10.16.1.1 直接依赖 maven
postcss-colormin 5.3.0 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
browserslist 4.21.4 间接依赖 npm
org.springframework.security:spring-security-config 6.0.6 直接依赖 maven
com.google.j2objc:j2objc-annotations 2.8 间接依赖 maven
org.bouncycastle:bcpkix-jdk15on 1.70 直接依赖 maven
org.hibernate.common:hibernate-commons-annotations 6.0.6.Final 间接依赖 maven
bs-custom-file-input 1.3.4 间接依赖 npm
cssesc 3.0.0 间接依赖 npm
org.apache.velocity:velocity-engine-core 2.3 直接依赖 maven
color-name 1.1.4 间接依赖 npm
prelude-ls 1.1.2 间接依赖 npm
org.hdrhistogram:HdrHistogram 2.1.12 间接依赖 maven
postcss-merge-longhand 5.1.7 间接依赖 npm
webpack 5.76.0 直接依赖 npm
org.webjars:chartjs 4.1.2 间接依赖 maven
loader-utils 2.0.4 间接依赖 npm
io.dropwizard.metrics:metrics-core 4.2.19 间接依赖 maven
deep-is 0.1.4 间接依赖 npm
org.abego.treelayout:org.abego.treelayout.core 1.0.3 间接依赖 maven
ekko-lightbox 5.3.0 间接依赖 npm
magic-string 0.25.1 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
jakarta.xml.soap:jakarta.xml.soap-api 3.0.0 间接依赖 maven
xtend 4.0.2 间接依赖 npm
com.evolveum.midpoint.model:report-impl 4.9-SNAPSHOT 直接依赖 maven
debug 4.3.4 间接依赖 npm
org.apache.commons:commons-math3 3.6.1 间接依赖 maven
datatables.net-scroller-bs4 2.0.5 间接依赖 npm
@babel/template 7.16.7 间接依赖 npm
com.evolveum.midpoint.repo:security-api 4.9-SNAPSHOT 直接依赖 maven
org.apache.groovy:groovy-json 4.0.11 间接依赖 maven
com.evolveum.midpoint.gui:admin-gui 4.9-SNAPSHOT 直接依赖 maven
convert-source-map 1.8.0 间接依赖 npm
yallist 4.0.0 间接依赖 npm
jquery-knob-chif 1.2.13 间接依赖 npm
org.opensaml:opensaml-xmlsec-impl 4.1.1 间接依赖 maven
io.github.classgraph:classgraph 4.8.162 间接依赖 maven
COMCTL32.dll 间接依赖
clone 1.0.4 间接依赖 npm
buffer-from 1.1.2 间接依赖 npm
has 1.0.3 间接依赖 npm
stable 0.1.8 间接依赖 npm
org.ow2.asm:asm 9.5 直接依赖 maven
@jridgewell/trace-mapping 0.3.14 间接依赖 npm
com.evolveum.midpoint.model:authentication-api 4.9-SNAPSHOT 直接依赖 maven
org.javasimon:javasimon-core 4.2.0 间接依赖 maven
com.evolveum.midpoint:midpoint-localization 4.9-SNAPSHOT 直接依赖 maven
com.evolveum.midpoint.repo:security-enforcer-impl 4.9-SNAPSHOT 直接依赖 maven
org.springframework.ldap:spring-ldap-core 3.0.5 直接依赖 maven
com.evolveum.midpoint.repo:repo-test-util 4.9-SNAPSHOT 直接依赖 maven
once 1.4.0 间接依赖 npm
postcss-merge-rules 5.1.3 间接依赖 npm
com.h2database:h2 1.4.193 直接依赖 maven
klaw-sync 6.0.0 间接依赖 npm
@webpack-cli/info 2.0.0 间接依赖 npm
com.rabbitmq:amqp-client 5.16.1 直接依赖 maven
supports-color 5.5.0 间接依赖 npm
jszip 3.9.1 间接依赖 npm
net.tirasa.connid:connector-framework 1.5.1.10 直接依赖 maven
locate-path 5.0.0 间接依赖 npm
eve-raphael 0.5.0 间接依赖 npm
@babel/helper-hoist-variables 7.16.7 间接依赖 npm
org.jboss.logging:jboss-logging 3.5.3.Final 间接依赖 maven
postcss-selector-parser 6.0.10 间接依赖 npm
regexp.prototype.flags 1.4.3 间接依赖 npm
org.springframework.boot:spring-boot 3.0.10 直接依赖 maven
import-local 3.1.0 间接依赖 npm
electron-to-chromium 1.4.284 间接依赖 npm
net.minidev:json-smart 2.4.11 间接依赖 maven
com.evolveum.midpoint.model:authentication-impl 4.9-SNAPSHOT 直接依赖 maven
datatables.net-searchpanes 2.0.0 间接依赖 npm
com.nimbusds:oauth2-oidc-sdk 9.43.3 间接依赖 maven
com.evolveum.midpoint.model:notifications-api 4.9-SNAPSHOT 直接依赖 maven
postcss-unique-selectors 5.1.1 间接依赖 npm
org.opensaml:opensaml-core 4.1.1 直接依赖 maven
org.springframework.boot:spring-boot-actuator 3.0.10 直接依赖 maven
sweetalert2 11.4.13 间接依赖 npm
interpret 3.1.1 间接依赖 npm
open 7.4.2 间接依赖 npm
com.evolveum.midpoint.provisioning:ucf-impl-builtin 4.9-SNAPSHOT 直接依赖 maven
@babel/code-frame 7.16.7 间接依赖 npm
postcss-normalize-repeat-style 5.1.1 间接依赖 npm
find-cache-dir 3.3.2 间接依赖 npm
@jridgewell/resolve-uri 3.0.5 间接依赖 npm
webpack-merge 5.8.0 间接依赖 npm
knockout 3.5.1 直接依赖 npm
postcss-reduce-transforms 5.1.0 间接依赖 npm
org.apache.groovy:groovy-servlet 4.0.11 间接依赖 maven
cosmiconfig 7.0.1 间接依赖 npm
de.agilecoders.wicket.webjars:wicket-webjars 3.0.0-M4 间接依赖 maven
@types/estree 0.0.51 间接依赖 npm
uplot 1.6.19 间接依赖 npm
jquery-ui-dist 1.13.1 间接依赖 npm
unicode-properties 1.3.1 间接依赖 npm
io.netty:netty-codec 4.1.97.Final 间接依赖 maven
org.antlr:antlr4-runtime 4.10.1 间接依赖 maven
org.apache.derby:derbyclient 10.16.1.1 直接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-jdk8 1.7.22 间接依赖 maven
org.codehaus.staxmate:staxmate 2.0.1 直接依赖 maven
picocolors 1.0.0 间接依赖 npm
io.netty:netty-handler 4.1.97.Final 间接依赖 maven
org.apache.groovy:groovy-groovydoc 4.0.11 间接依赖 maven
pkg-dir 4.2.0 间接依赖 npm
pdfmake 0.2.5 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
nanoid 3.3.4 间接依赖 npm
core-util-is 1.0.3 间接依赖 npm
chartjs-color-string 0.6.0 间接依赖 npm
com.evolveum.axiom:axiom 4.9-SNAPSHOT 直接依赖 maven
io.netty:netty-buffer 4.1.97.Final 间接依赖 maven
normalize-path 3.0.0 间接依赖 npm
@types/yargs 17.0.14 间接依赖 npm
readdirp 3.6.0 间接依赖 npm
com.duosecurity:duo-universal-sdk 1.1.3 直接依赖 maven
jquery 3.6.0 间接依赖 npm
flag-icon-css 4.1.7 间接依赖 npm
org.apache.commons:commons-lang3 3.12.0 直接依赖 maven
nice-try 1.0.5 直接依赖 npm
error-ex 1.3.2 间接依赖 npm
org.apache.wss4j:wss4j-ws-security-common 2.3.3 直接依赖 maven
org.apache.derby:derbyshared 10.16.1.1 间接依赖 maven
org.opensaml:opensaml-xacml-saml-api 3.4.6 间接依赖 maven
io.netty:netty-resolver 4.1.97.Final 间接依赖 maven
org.apache.groovy:groovy-nio 4.0.11 间接依赖 maven
normalize-url 6.1.0 间接依赖 npm
postcss-discard-comments 5.1.2 间接依赖 npm
postcss-modules-local-by-default 4.0.0 间接依赖 npm
net.shibboleth.utilities:java-support 8.0.0 直接依赖 maven
org.apache.wicket:wicket-request 10.0.0-M1 直接依赖 maven
com.evolveum.midpoint.repo:task-quartz-impl 4.9-SNAPSHOT 直接依赖 maven
org.apache.cxf:cxf-core 4.0.1 直接依赖 maven
through2 2.0.5 间接依赖 npm
org.opensaml:opensaml-xacml-impl 3.4.6 间接依赖 maven
@jridgewell/source-map 0.3.2 间接依赖 npm
select2 4.0.13 间接依赖 npm
joda-time:joda-time 2.10.14 直接依赖 maven
com.squareup.okio:okio-jvm 3.0.0 直接依赖 maven
toastr 2.1.4 间接依赖 npm
org.springframework:spring-expression 6.0.11 间接依赖 maven
codemirror 5.65.2 间接依赖 npm
org.glassfish.jaxb:txw2 4.0.3 间接依赖 maven
watchpack 2.4.0 间接依赖 npm
org.testng:testng 7.8.0 直接依赖 maven
com.microsoft.sqlserver:mssql-jdbc 11.2.3.jre17 直接依赖 maven
postcss-normalize-positions 5.1.1 间接依赖 npm
io.micrometer:micrometer-core 1.10.10 间接依赖 maven
postcss-normalize-whitespace 5.1.1 间接依赖 npm
css-tree 1.1.3 间接依赖 npm
datatables.net-keytable-bs4 2.6.4 间接依赖 npm
ch.qos.logback:logback-core 1.4.11 直接依赖 maven
@types/eslint 8.4.1 间接依赖 npm
@xtuc/long 4.2.2 间接依赖 npm
org.opensaml:opensaml-xacml-api 3.4.6 间接依赖 maven
colord 2.9.3 间接依赖 npm
com.evolveum.midpoint:midpoint-samples 4.9-SNAPSHOT 直接依赖 maven
dropzone 5.9.3 间接依赖 npm
org.springframework:spring-webmvc 6.0.11 直接依赖 maven
shallow-copy 0.0.1 间接依赖 npm
org.apache.groovy:groovy-yaml 4.0.11 间接依赖 maven
org.opensaml:opensaml-xacml-saml-impl 3.4.6 间接依赖 maven
@types/node 17.0.23 间接依赖 npm
org.springframework.security:spring-security-saml2-service-provider 6.0.6 直接依赖 maven
ev-emitter 1.1.1 间接依赖 npm
@babel/helper-module-imports 7.16.7 间接依赖 npm
events 3.3.0 间接依赖 npm
com.evolveum.chartjs:wicket-chartjs-core 0.3 直接依赖 maven
shebang-command 2.0.0 间接依赖 npm
path-key 3.1.1 间接依赖 npm
io.micrometer:micrometer-commons 1.10.10 间接依赖 maven
org.springframework.security:spring-security-crypto 6.0.6 间接依赖 maven
postcss-normalize-url 5.1.0 间接依赖 npm
@babel/core 7.17.9 直接依赖 npm
brotli 1.3.2 间接依赖 npm
org.apache.wicket:wicket-util 10.0.0-M1 直接依赖 maven
gensync 1.0.0-beta.2 间接依赖 npm
shallow-clone 3.0.1 间接依赖 npm
acorn 7.4.1 间接依赖 npm
@jridgewell/set-array 1.1.2 间接依赖 npm
base64-js 1.3.1 间接依赖 npm
com.evolveum.midpoint.model:notifications-impl 4.9-SNAPSHOT 直接依赖 maven
com.evolveum.midpoint.repo:system-init 4.9-SNAPSHOT 直接依赖 maven
path-type 4.0.0 间接依赖 npm
@babel/types 7.17.0 间接依赖 npm
datatables.net-rowreorder 1.2.8 间接依赖 npm
moment-timezone 0.5.37 间接依赖 npm
tempusdominus-core 5.19.3 直接依赖 npm
datatables.net-select 1.3.4 间接依赖 npm
org.slf4j:slf4j-api 2.0.7 直接依赖 maven
datatables.net-autofill 2.3.9 间接依赖 npm
com.fasterxml.jackson.module:jackson-module-parameter-names 2.14.3 间接依赖 maven
pako 1.0.11 间接依赖 npm
overlayscrollbars 1.13.1 间接依赖 npm
com.evolveum.midpoint.model:model-impl 4.9-SNAPSHOT 直接依赖 maven
org.opensaml:opensaml-profile-api 4.1.1 间接依赖 maven
com.evolveum.midpoint.repo:task-api 4.9-SNAPSHOT 直接依赖 maven
xerces:xercesImpl 2.12.2 间接依赖 maven
org.apache.commons:commons-csv 1.10.0 直接依赖 maven
isexe 2.0.0 间接依赖 npm
cssnano-preset-default 5.2.13 间接依赖 npm
stylehacks 5.1.1 间接依赖 npm
org.apache.groovy:groovy-console 4.0.11 间接依赖 maven
parent-module 1.0.1 间接依赖 npm
org.apache.bcel:bcel 6.3.1 间接依赖 maven
jakarta.transaction:jakarta.transaction-api 2.0.1 间接依赖 maven
word-wrap 1.2.3 间接依赖 npm
datatables.net-colreorder-bs4 1.5.5 间接依赖 npm
org.springframework.boot:spring-boot-starter-actuator 3.0.10 直接依赖 maven
css-loader 6.7.2 直接依赖 npm
org.apache.ws.xmlschema:xmlschema-core 2.2.5 间接依赖 maven
org.springframework.security:spring-security-oauth2-jose 6.0.6 直接依赖 maven
lodash.memoize 4.1.2 间接依赖 npm
com.fasterxml.jackson.core:jackson-databind 2.14.3 直接依赖 maven
@webassemblyjs/floating-point-hex-parser 1.11.1 间接依赖 npm
loader-runner 4.2.0 间接依赖 npm
terser 5.14.2 间接依赖 npm
com.squareup.retrofit2:retrofit 2.9.0 间接依赖 maven
json-parse-even-better-errors 2.3.1 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
com.evolveum.midpoint.repo:repo-sql-impl-test 4.9-SNAPSHOT 直接依赖 maven
org.apache.httpcomponents.core5:httpcore5-h2 5.1.5 间接依赖 maven
popper.js 1.16.1 间接依赖 npm
org.cryptacular:cryptacular 1.2.4 间接依赖 maven
js-tokens 4.0.0 间接依赖 npm
postcss-modules-scope 3.0.0 间接依赖 npm
postcss-loader 7.0.1 直接依赖 npm
chokidar 3.5.3 间接依赖 npm
com.github.stephenc.jcip:jcip-annotations 1.0-1 间接依赖 maven
@types/istanbul-lib-report 3.0.0 间接依赖 npm
klona 2.0.5 间接依赖 npm
datatables.net-rowgroup-bs4 1.1.4 间接依赖 npm
webpack-sources 3.2.3 间接依赖 npm
flag-icons 6.4.2 直接依赖 npm
is-extglob 2.1.1 间接依赖 npm
chartjs-color 2.4.1 间接依赖 npm
jsonfile 6.1.0 间接依赖 npm
org.apache.cxf:cxf-rt-rs-client 4.0.1 直接依赖 maven
com.github.inamik.text.tables:inamik-text-tables 0.8 直接依赖 maven
org.springframework.boot:spring-boot-starter-logging 3.0.10 间接依赖 maven
io.netty:netty-transport-native-unix-common 4.1.97.Final 间接依赖 maven
org.eclipse.jetty:jetty-http 11.0.15 间接依赖 maven
is-date-object 1.0.5 间接依赖 npm
@webassemblyjs/leb128 1.11.1 间接依赖 npm
@babel/helper-environment-visitor 7.16.7 间接依赖 npm
@ampproject/remapping 2.1.2 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
datatables.net 1.11.5 间接依赖 npm
commander 7.2.0 间接依赖 npm
cssnano 5.1.14 间接依赖 npm
datatables.net-scroller 2.0.5 间接依赖 npm
com.fasterxml.jackson.core:jackson-annotations 2.14.3 直接依赖 maven
fast-memoize 2.5.2 间接依赖 npm
org.springframework:spring-messaging 6.0.11 间接依赖 maven
css-minimizer-webpack-plugin 4.2.2 直接依赖 npm
datatables.net-fixedheader 3.2.2 间接依赖 npm
serialize-javascript 6.0.0 间接依赖 npm
tiny-inflate 1.0.3 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
datatables.net-colreorder 1.5.5 间接依赖 npm
org.apache.httpcomponents.client5:httpclient5 5.1.4 直接依赖 maven
com.auth0:java-jwt 3.3.0 间接依赖 maven
static-module 3.0.4 间接依赖 npm
jquery-validation 1.19.5 间接依赖 npm
expose-loader 3.1.0 直接依赖 npm
com.evolveum.prism:prism-api 4.9-SNAPSHOT 直接依赖 maven
@sinclair/typebox 0.24.51 间接依赖 npm
org.apache.logging.log4j:log4j-to-slf4j 2.19.0 间接依赖 maven
ast-transform 0.0.0 间接依赖 npm
datatables.net-keytable 2.6.4 间接依赖 npm
commons-javaflow:commons-javaflow 20060411 直接依赖 maven
os-tmpdir 1.0.2 间接依赖 npm
org.apache.commons:commons-collections4 4.4 直接依赖 maven
clone-deep 4.0.1 间接依赖 npm
@jest/schemas 29.0.0 间接依赖 npm
sparklines 1.3.0 间接依赖 npm
com.fasterxml.jackson.datatype:jackson-datatype-jdk8 2.14.3 间接依赖 maven
@xtuc/ieee754 1.2.0 间接依赖 npm
org.quartz-scheduler:quartz 2.3.2.e3 直接依赖 maven
datatables.net-autofill-bs4 2.3.9 间接依赖 npm
@babel/generator 7.17.9 间接依赖 npm
flot 4.2.2 间接依赖 npm
org.springframework.boot:spring-boot-starter 3.0.10 间接依赖 maven
org.slf4j:jcl-over-slf4j 2.0.7 直接依赖 maven
ajv 6.12.6 间接依赖 npm
com.evolveum.midpoint.model:report-api 4.9-SNAPSHOT 直接依赖 maven
eslint-scope 5.1.1 间接依赖 npm
inflight 1.0.6 间接依赖 npm
@webpack-cli/serve 2.0.0 间接依赖 npm
datatables.net-searchbuilder-bs4 1.3.2 间接依赖 npm
com.squareup.retrofit2:converter-jackson 2.9.0 间接依赖 maven
estraverse 1.5.1 间接依赖 npm
@types/yargs-parser 21.0.0 间接依赖 npm
@webassemblyjs/wasm-parser 1.11.1 间接依赖 npm
org.springframework.boot:spring-boot-starter-json 3.0.10 间接依赖 maven
org.ow2.asm:asm-analysis 9.5 间接依赖 maven
buffer-equal 0.0.1 间接依赖 npm
@types/eslint-scope 3.7.3 间接依赖 npm
org.springframework:spring-test 6.0.11 直接依赖 maven
com.evolveum.midpoint.model:workflow-api 4.9-SNAPSHOT 直接依赖 maven
commons-io:commons-io 2.13.0 直接依赖 maven
org.apache.wicket:wicket-commons-fileupload 10.0.0-M1 间接依赖 maven
com.evolveum.midpoint.repo:security-enforcer-api 4.9-SNAPSHOT 直接依赖 maven
org.apache.activemq:artemis-commons 2.30.0 直接依赖 maven
commons-beanutils:commons-beanutils 1.9.4 直接依赖 maven
com.evolveum.midpoint.model:certification-api 4.9-SNAPSHOT 直接依赖 maven
graceful-fs 4.2.10 间接依赖 npm
com.evolveum.commons:test-ng 4.9-SNAPSHOT 直接依赖 maven
org.jvnet.jaxb2_commons:jaxb2-basics-runtime 1.11.1 直接依赖 maven
@babel/helper-module-transforms 7.17.7 间接依赖 npm
@webassemblyjs/helper-api-error 1.11.1 间接依赖 npm
com.evolveum.midpoint.repo:repo-common 4.9-SNAPSHOT 直接依赖 maven
is-core-module 2.8.1 间接依赖 npm
braces 3.0.2 间接依赖 npm
USER32.dll 间接依赖
msvcrt.dll 间接依赖
org.fusesource.jansi:jansi 2.4.0 直接依赖 maven
datatables.net-fixedheader-bs4 3.2.2 间接依赖 npm
cssnano-utils 3.1.0 间接依赖 npm
is-wsl 2.2.0 间接依赖 npm
org.springframework.boot:spring-boot-actuator-autoconfigure 3.0.10 直接依赖 maven
org.opensaml:opensaml-storage-api 4.1.1 间接依赖 maven
@jridgewell/gen-mapping 0.3.2 间接依赖 npm
org.apache.groovy:groovy-swing 4.0.11 间接依赖 maven
postcss-normalize-display-values 5.1.0 间接依赖 npm
ace-builds 1.4.14 直接依赖 npm
import-fresh 3.3.0 间接依赖 npm
com.google.guava:listenablefuture 9999.0-empty-to-avoid-conflict-with-guava 间接依赖 maven
com.zaxxer:HikariCP 4.0.3 直接依赖 maven
com.beust:jcommander 1.82 直接依赖 maven
png-js 1.0.0 间接依赖 npm
commondir 1.0.1 间接依赖 npm
mime-types 2.1.35 间接依赖 npm
bootstrap-slider 11.0.2 间接依赖 npm
org.apache.wicket:wicket-ioc 10.0.0-M1 直接依赖 maven
org.slf4j:jul-to-slf4j 2.0.7 直接依赖 maven
org.jasypt:jasypt 1.9.3 间接依赖 maven
csso 4.2.0 间接依赖 npm
com.evolveum.midpoint.tools:ninja 4.9-SNAPSHOT 直接依赖 maven
com.evolveum.midpoint.infra:test-util 4.9-SNAPSHOT 直接依赖 maven
@discoveryjs/json-ext 0.5.7 间接依赖 npm
org.webjars:jquery 3.6.0 直接依赖 maven
org.apache.wicket:wicket-spring 10.0.0-M1 直接依赖 maven
scope-analyzer 2.1.2 间接依赖 npm
org.springframework.security:spring-security-oauth2-resource-server 6.0.6 直接依赖 maven
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
@webassemblyjs/ieee754 1.11.1 间接依赖 npm
file-loader 6.2.0 直接依赖 npm
org.springframework:spring-jdbc 6.0.11 直接依赖 maven
imagesloaded 4.1.4 间接依赖 npm
org.assertj:assertj-core 3.23.1 直接依赖 maven
org.springframework.security:spring-security-ldap 6.0.6 直接依赖 maven
info.picocli:picocli 4.7.1 间接依赖 maven
org.springframework.boot:spring-boot-starter-web 3.0.10 直接依赖 maven
io.micrometer:micrometer-observation 1.10.10 间接依赖 maven
lodash.uniq 4.5.0 间接依赖 npm
org.bouncycastle:bcutil-jdk15on 1.70 间接依赖 maven
jakarta.jws:jakarta.jws-api 3.0.0 间接依赖 maven
json5 2.2.3 间接依赖 npm
com.evolveum.polygon:connector-csv 2.7 直接依赖 maven
xml-resolver:xml-resolver 1.2 间接依赖 maven
com.zaxxer:SparseBitSet 1.2 间接依赖 maven
amdefine 1.0.1 直接依赖 npm
net.bytebuddy:byte-buddy 1.14.9 直接依赖 maven
com.evolveum.midpoint.model:rest-impl 4.9-SNAPSHOT 直接依赖 maven
is-regex 1.1.4 间接依赖 npm
org.springframework:spring-tx 6.0.11 直接依赖 maven
org.apache.activemq:artemis-jms-client 2.30.0 直接依赖 maven
org.opensaml:opensaml-soap-api 4.1.1 间接依赖 maven
is-binary-path 2.1.0 间接依赖 npm
jqvmap-novulnerability 1.5.1 间接依赖 npm
org.apache.tomcat.embed:tomcat-embed-core 10.1.12 直接依赖 maven
jline:jline 2.14.6 间接依赖 maven
com.google.errorprone:error_prone_annotations 2.10.0 间接依赖 maven
com.squareup.okhttp3:logging-interceptor 4.10.0 间接依赖 maven
org.jboss:jandex 2.4.2.Final 间接依赖 maven
com.nimbusds:content-type 2.2 间接依赖 maven
org.springframework.security:spring-security-oauth2-core 6.0.6 直接依赖 maven
glob 7.2.0 间接依赖 npm
jakarta.annotation:jakarta.annotation-api 2.1.1 直接依赖 maven
postcss-discard-empty 5.1.1 间接依赖 npm
org.apache.commons:commons-text 1.10.0 直接依赖 maven
@ttskch/select2-bootstrap4-theme 1.5.2 间接依赖 npm
datatables.net-rowreorder-bs4 1.2.8 间接依赖 npm
org.apache.cxf:cxf-rt-frontend-jaxrs 4.0.1 直接依赖 maven
com.evolveum.midpoint.repo:audit-api 4.9-SNAPSHOT 直接依赖 maven
is-glob 4.0.3 间接依赖 npm
com.evolveum.polygon:connector-ldap 3.7 直接依赖 maven
mime-db 1.52.0 间接依赖 npm
org.apache.ivy:ivy 2.5.1 间接依赖 maven
yaml 1.10.2 间接依赖 npm
com.evolveum.midpoint.provisioning:ucf-impl-connid 4.9-SNAPSHOT 直接依赖 maven
sax 1.2.4 间接依赖 npm
org.apache.activemq:artemis-core-client 2.30.0 直接依赖 maven
datatables.net-buttons 2.2.2 间接依赖 npm
@webassemblyjs/utf8 1.11.1 间接依赖 npm
datatables.net-searchpanes-bs4 1.4.0 间接依赖 npm
com.evolveum.midpoint.model:model-common 4.9-SNAPSHOT 直接依赖 maven
@fontsource/source-sans-pro 4.5.9 直接依赖 npm
com.google.guava:failureaccess 1.0.1 间接依赖 maven
@babel/helper-validator-identifier 7.16.7 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk7 1.7.22 间接依赖 maven
org.cache2k:cache2k-core 2.0.0.Final 直接依赖 maven
ast-types 0.7.8 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
com.sleepycat:je 5.0.103 直接依赖 maven
@webassemblyjs/wast-printer 1.11.1 间接依赖 npm
org.apache.httpcomponents:httpcore 4.4.14 直接依赖 maven
escape-string-regexp 1.0.5 间接依赖 npm
globals 11.12.0 间接依赖 npm
postcss-convert-values 5.1.3 间接依赖 npm
com.evolveum.midpoint.infra:common 4.9-SNAPSHOT 直接依赖 maven
com.evolveum.midpoint.infra:schema 4.9-SNAPSHOT 直接依赖 maven
dfa 1.2.0 间接依赖 npm
org.apache.groovy:groovy-templates 4.0.11 间接依赖 maven
com.evolveum.midpoint.repo:repo-sql-impl 4.9-SNAPSHOT 直接依赖 maven
jquery-mousewheel 3.1.13 间接依赖 npm
@babel/helper-validator-option 7.16.7 间接依赖 npm
org.apache.derby:derbynet 10.16.1.1 直接依赖 maven
sass-loader 13.2.0 直接依赖 npm
org.apache.activemq:artemis-selector 2.30.0 间接依赖 maven
summernote 0.8.20 间接依赖 npm
neo-async 2.6.2 间接依赖 npm
com.evolveum.commons:util 4.9-SNAPSHOT 直接依赖 maven
inherits 2.0.4 间接依赖 npm
acorn-node 1.8.2 间接依赖 npm
io.netty:netty-common 4.1.97.Final 间接依赖 maven
com.evolveum.midpoint.repo:repo-api 4.9-SNAPSHOT 直接依赖 maven
com.evolveum.midpoint.model:cases-api 4.9-SNAPSHOT 直接依赖 maven
tmp 0.0.33 间接依赖 npm
set-immediate-shim 1.0.1 间接依赖 npm
org.apache.groovy:groovy-astbuilder 4.0.11 直接依赖 maven
postcss-modules-extract-imports 3.0.0 间接依赖 npm
duplexer2 0.1.4 间接依赖 npm
@yarnpkg/lockfile 1.1.0 间接依赖 npm
postcss-minify-selectors 5.2.1 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
balanced-match 1.0.2 间接依赖 npm
org.springframework:spring-aop 6.0.11 直接依赖 maven
com.evolveum.midpoint.repo:repo-cache 4.9-SNAPSHOT 直接依赖 maven
parse-json 5.2.0 间接依赖 npm
is-ci 2.0.0 间接依赖 npm
lie 3.3.0 间接依赖 npm
type-check 0.3.2 间接依赖 npm
comdlg32.dll 间接依赖
org.apache.commons:commons-compress 1.21 间接依赖 maven
postcss 8.4.19 间接依赖 npm
postcss-discard-duplicates 5.1.0 间接依赖 npm
org.postgresql:postgresql 42.5.4 直接依赖 maven
esrecurse 4.3.0 间接依赖 npm
org.apache.wicket:wicket-devutils 10.0.0-M1 直接依赖 maven
source-map-support 0.5.21 间接依赖 npm
org.eclipse.jetty:jetty-io 11.0.15 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-common 1.7.22 间接依赖 maven
has-flag 3.0.0 间接依赖 npm
com.j2html:j2html 1.4.0 直接依赖 maven
xmldoc 1.1.2 间接依赖 npm
es-module-lexer 0.9.3 间接依赖 npm
@foliojs-fork/restructure 2.0.2 间接依赖 npm
org.apache.groovy:groovy-all 4.0.11 直接依赖 maven
postcss-discard-overridden 5.1.0 间接依赖 npm
org.latencyutils:LatencyUtils 2.0.3 间接依赖 maven
org.apache.httpcomponents:httpclient 4.5.14 直接依赖 maven
com.evolveum.midpoint.repo:audit-log-impl 4.9-SNAPSHOT 直接依赖 maven
postcss-svgo 5.1.0 间接依赖 npm
org.eclipse.jetty.toolchain:jetty-jakarta-servlet-api 5.0.2 间接依赖 maven
path-parse 1.0.7 间接依赖 npm
net.ttddyy:datasource-proxy 1.7 直接依赖 maven
postcss-minify-params 5.1.4 间接依赖 npm
org.cache2k:cache2k-api 2.0.0.Final 直接依赖 maven
ch.qos.logback:logback-classic 1.4.11 直接依赖 maven
org.springframework:spring-orm 6.0.11 直接依赖 maven
@babel/helper-function-name 7.17.9 间接依赖 npm
fs-extra 10.1.0 间接依赖 npm
org.apache.cxf:cxf-rt-rs-extension-providers 4.0.1 直接依赖 maven
com.sun.xml.bind.external:relaxng-datatype 4.0.3 间接依赖 maven
@babel/helper-simple-access 7.17.7 间接依赖 npm
binary-extensions 2.2.0 间接依赖 npm
com.querydsl:querydsl-sql 5.0.0 直接依赖 maven
net.tirasa.connid:connector-framework-internal 1.5.1.10 直接依赖 maven
io.netty:netty-handler-proxy 4.1.97.Final 间接依赖 maven
which 2.0.2 间接依赖 npm
com.evolveum.midpoint.repo:security-impl 4.9-SNAPSHOT 直接依赖 maven
io.netty:netty-transport-classes-kqueue 4.1.97.Final 间接依赖 maven
org.apache.wicket:wicket-datetime 8.0.0-M7 直接依赖 maven
org.springframework.security:spring-security-core 6.0.6 直接依赖 maven
caniuse-api 3.0.0 间接依赖 npm
@babel/helper-split-export-declaration 7.16.7 间接依赖 npm
is-docker 2.2.1 间接依赖 npm
org.apache.groovy:groovy-groovysh 4.0.11 间接依赖 maven
jakarta.inject:jakarta.inject-api 2.0.0 间接依赖 maven
org.forgerock.opendj:opendj 2.6.2 直接依赖 maven
com.evolveum.midpoint.model:workflow-impl 4.9-SNAPSHOT 直接依赖 maven
readable-stream 2.3.7 间接依赖 npm
isarray 1.0.0 间接依赖 npm
org.opensaml:opensaml-security-impl 4.1.1 间接依赖 maven
com.squareup.okhttp3:okhttp 4.10.0 直接依赖 maven
org.yaml:snakeyaml 1.33 间接依赖 maven
jsesc 2.5.2 间接依赖 npm
jakarta.xml.bind:jakarta.xml.bind-api 4.0.0 直接依赖 maven
commons-validator:commons-validator 1.7 直接依赖 maven
io.netty:netty-transport-native-kqueue 4.1.97.Final 间接依赖 maven
com.evolveum.commons:concepts 4.9-SNAPSHOT 直接依赖 maven
net.minidev:accessors-smart 2.4.11 间接依赖 maven
org.danekja:jdk-serializable-functional 1.9.0 间接依赖 maven
org.apache.groovy:groovy-jsr223 4.0.11 间接依赖 maven
make-dir 3.1.0 间接依赖 npm
@webassemblyjs/wasm-edit 1.11.1 间接依赖 npm
@popperjs/core 2.11.5 直接依赖 npm
io.netty:netty-transport-native-epoll 4.1.97.Final 间接依赖 maven
brfs 2.0.2 间接依赖 npm
object-is 1.1.5 间接依赖 npm
org.eclipse.angus:jakarta.mail 1.0.0 直接依赖 maven
org.wicketstuff:wicketstuff-select2 9.12.0 直接依赖 maven
org.jgroups:jgroups 5.2.16.Final 间接依赖 maven
NETAPI32.dll 间接依赖
icheck-bootstrap 3.0.1 间接依赖 npm
@webassemblyjs/wasm-opt 1.11.1 间接依赖 npm
com.evolveum.icf:dummy-connector-fake 4.9-SNAPSHOT 直接依赖 maven
@webassemblyjs/helper-buffer 1.11.1 间接依赖 npm
com.google.guava:guava 32.1.2-jre 直接依赖 maven
org.apache.logging.log4j:log4j-api 2.19.0 间接依赖 maven
fill-range 7.0.1 间接依赖 npm
chrome-trace-event 1.0.3 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib 1.7.22 间接依赖 maven
org.opensaml:opensaml-saml-api 4.1.1 直接依赖 maven
datatables.net-select-bs4 1.3.4 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
caniuse-lite 1.0.30001512 间接依赖 npm
org.codehaus.woodstox:stax2-api 4.2.1 间接依赖 maven
ajv-keywords 3.5.2 间接依赖 npm
@babel/traverse 7.17.9 间接依赖 npm
org.apache.qpid:qpid-broker-core 8.0.4 直接依赖 maven
static-eval 2.1.0 间接依赖 npm
ajv-formats 2.1.1 间接依赖 npm
find-up 4.1.0 间接依赖 npm
sass 1.56.1 直接依赖 npm
com.evolveum.midpoint.repo:repo-sqlbase 4.9-SNAPSHOT 直接依赖 maven
org.springframework.boot:spring-boot-starter-security 3.0.10 直接依赖 maven
org.apache.cxf:cxf-rt-transports-http 4.0.1 间接依赖 maven
jakarta.xml.ws:jakarta.xml.ws-api 3.0.1 直接依赖 maven
com.evolveum.midpoint.repo:repo-sqale 4.9-SNAPSHOT 直接依赖 maven
bootstrap-switch 3.3.4 间接依赖 npm
ADVAPI32.dll 间接依赖
enhanced-resolve 5.12.0 间接依赖 npm
anymatch 3.1.2 间接依赖 npm
isobject 3.0.1 间接依赖 npm
escalade 3.1.1 间接依赖 npm
optionator 0.8.3 直接依赖 npm
daterangepicker 3.1.0 间接依赖 npm
org.opensaml:opensaml-security-api 4.1.1 直接依赖 maven
safe-buffer 5.1.2 间接依赖 npm
update-browserslist-db 1.0.10 间接依赖 npm
fullcalendar 5.11.0 间接依赖 npm
datatables.net-searchbuilder 1.3.2 间接依赖 npm
org.apache.groovy:groovy-macro 4.0.11 间接依赖 maven
com.evolveum.midpoint.provisioning:provisioning-impl 4.9-SNAPSHOT 直接依赖 maven
admin-lte 3.2.0 直接依赖 npm
@foliojs-fork/linebreak 1.1.1 间接依赖 npm
commons-codec:commons-codec 1.15 直接依赖 maven
safer-buffer 2.1.2 间接依赖 npm
postcss-ordered-values 5.1.3 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
wildcard 2.0.0 间接依赖 npm
css-select 4.3.0 间接依赖 npm
org.springframework.retry:spring-retry 2.0.2 直接依赖 maven
org.aspectj:aspectjweaver 1.9.20 间接依赖 maven
org.apache.groovy:groovy-cli-picocli 4.0.11 间接依赖 maven
org.springframework:spring-beans 6.0.11 直接依赖 maven
org.apache.wicket:wicket-core 10.0.0-M1 直接依赖 maven
datatables.net-fixedcolumns 4.0.2 间接依赖 npm
org.apache.groovy:groovy-docgenerator 4.0.11 间接依赖 maven
org.springframework.security:spring-security-web 6.0.6 直接依赖 maven
jquery-mapael 2.2.0 间接依赖 npm
style-loader 3.3.1 直接依赖 npm
emojis-list 3.0.0 间接依赖 npm
micromatch 4.0.5 间接依赖 npm
bootstrap-colorpicker 3.4.0 间接依赖 npm
com.fasterxml:classmate 1.5.1 间接依赖 maven
com.fasterxml.jackson.datatype:jackson-datatype-jsr310 2.14.3 间接依赖 maven
org.springframework:spring-aspects 6.0.11 直接依赖 maven
org.bouncycastle:bcprov-jdk15on 1.70 直接依赖 maven
org.opensaml:opensaml-saml-impl 4.1.1 间接依赖 maven
ion-rangeslider 2.3.1 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
rechoir 0.8.0 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
org.ehcache:ehcache 3.8.1 间接依赖 maven
wrappy 1.0.2 间接依赖 npm
find-yarn-workspace-root 2.0.0 间接依赖 npm
GDI32.dll 间接依赖
postcss-normalize-unicode 5.1.1 间接依赖 npm
envinfo 7.8.1 间接依赖 npm
chart.js 2.9.4 间接依赖 npm
node-releases 2.0.6 间接依赖 npm
org.glassfish.jaxb:jaxb-runtime 4.0.3 间接依赖 maven
org.apache.httpcomponents.core5:httpcore5 5.1.5 直接依赖 maven
postcss-normalize-timing-functions 5.1.0 间接依赖 npm
@types/istanbul-reports 3.0.1 间接依赖 npm
datatables.net-fixedcolumns-bs4 4.0.2 间接依赖 npm
picomatch 2.3.1 间接依赖 npm
webpack-cli 5.0.0 直接依赖 npm
io.netty:netty-transport 4.1.97.Final 间接依赖 maven
com.oracle.database.jdbc:ojdbc11 21.7.0.0 直接依赖 maven
org.apache.wss4j:wss4j-ws-security-dom 2.3.3 直接依赖 maven
org.eclipse.jetty:jetty-util 11.0.15 间接依赖 maven
@babel/parser 7.17.9 间接依赖 npm
datatables.net-rowgroup 1.1.4 间接依赖 npm
org.springframework.boot:spring-boot-starter-amqp 3.0.10 直接依赖 maven
@sweetalert2/theme-bootstrap-4 5.0.10 间接依赖 npm
minimatch 3.1.2 间接依赖 npm
moment 2.29.4 间接依赖 npm
chalk 2.4.2 间接依赖 npm
com.evolveum.midpoint.model:model-test 4.9-SNAPSHOT 直接依赖 maven
is-plain-object 2.0.4 间接依赖 npm
bs-stepper 1.7.0 间接依赖 npm
patch-package 6.5.0 直接依赖 npm
com.evolveum.polygon:dbcommon 2.3 间接依赖 maven
bootstrap-select 1.13.18 直接依赖 npm
com.evolveum.midpoint.provisioning:provisioning-api 4.9-SNAPSHOT 直接依赖 maven
fastest-levenshtein 1.0.12 间接依赖 npm
immediate 3.0.6 间接依赖 npm
io.netty:netty-codec-http 4.1.97.Final 间接依赖 maven
tempusdominus-bootstrap-4 5.39.2 间接依赖 npm
org.springframework.boot:spring-boot-autoconfigure 3.0.10 直接依赖 maven
com.fasterxml.jackson.core:jackson-core 2.14.3 直接依赖 maven
postcss-calc 8.2.4 间接依赖 npm
unicode-trie 2.0.0 间接依赖 npm
org.apache.cxf:cxf-rt-security 4.0.1 间接依赖 maven
com.github.javaparser:javaparser-core 3.25.1 间接依赖 maven
inputmask 5.0.7 间接依赖 npm
datatables.net-buttons-bs4 2.2.2 间接依赖 npm
resolve 1.22.0 间接依赖 npm
jest-util 29.3.1 直接依赖 npm
org.ow2.asm:asm-tree 9.5 间接依赖 maven
@babel/helpers 7.17.9 间接依赖 npm
concat-stream 1.6.2 间接依赖 npm
org.springframework.boot:spring-boot-loader 3.0.10 直接依赖 maven
to-fast-properties 2.0.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
slash 2.0.0 间接依赖 npm
org.apache.cxf:cxf-rt-transports-http-jetty 4.0.1 直接依赖 maven
@webassemblyjs/ast 1.11.1 间接依赖 npm
glob-to-regexp 0.4.1 间接依赖 npm
org.eclipse.jetty:jetty-server 11.0.15 直接依赖 maven
KERNEL32.dll 间接依赖
org.codehaus.janino:janino 3.1.4 直接依赖 maven
resolve-cwd 3.0.0 间接依赖 npm
@webpack-cli/configtest 2.0.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
@foliojs-fork/pdfkit 0.13.0 间接依赖 npm
jest-worker 27.5.1 间接依赖 npm
org.springframework.boot:spring-boot-starter-tomcat 3.0.10 直接依赖 maven
com.evolveum.midpoint.provisioning:ucf-api 4.9-SNAPSHOT 直接依赖 maven
com.evolveum.midpoint.model:model-api 4.9-SNAPSHOT 直接依赖 maven
fast-deep-equal 3.1.3 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
org.slf4j:log4j-over-slf4j 2.0.7 直接依赖 maven
brace-expansion 1.1.11 间接依赖 npm
ms 2.1.2 间接依赖 npm
fastclick 1.0.6 间接依赖 npm
escodegen 1.2.0 间接依赖 npm
@webassemblyjs/wasm-gen 1.11.1 间接依赖 npm
lines-and-columns 1.2.4 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
semver 6.3.0 间接依赖 npm
css-declaration-sorter 6.3.1 间接依赖 npm
org.opensaml:opensaml-messaging-api 4.1.1 间接依赖 maven
org.glassfish.jaxb:jaxb-core 4.0.3 间接依赖 maven
lilconfig 2.0.6 间接依赖 npm
raphael 2.3.0 间接依赖 npm
@jridgewell/sourcemap-codec 1.4.11 间接依赖 npm
com.evolveum.icf:dummy-resource 4.9-SNAPSHOT 直接依赖 maven
jakarta.ws.rs:jakarta.ws.rs-api 3.1.0 直接依赖 maven
bootstrap 3.4.1 间接依赖 npm
org.eclipse.angus:angus-activation 2.0.1 间接依赖 maven
com.evolveum.prism:prism-impl 4.9-SNAPSHOT 直接依赖 maven
jsgrid 1.5.3 间接依赖 npm
postcss-normalize-string 5.1.0 间接依赖 npm
@lgaitan/pace-progress 1.0.7 间接依赖 npm
@trysound/sax 0.2.0 间接依赖 npm
com.evolveum.icf:dummy-connector 4.9-SNAPSHOT 直接依赖 maven
org.springframework.boot:spring-boot-loader-tools 3.0.10 直接依赖 maven
uri-js 4.4.1 间接依赖 npm
org.hibernate.orm:hibernate-ant 6.1.7.Final 直接依赖 maven
function-bind 1.1.1 间接依赖 npm
com.sun.istack:istack-commons-runtime 4.1.2 间接依赖 maven
babel-loader 9.1.0 直接依赖 npm
com.querydsl:querydsl-core 5.0.0 直接依赖 maven
browserify-optional 1.0.1 间接依赖 npm
commons-collections:commons-collections 3.2.2 间接依赖 maven
source-map 0.5.7 间接依赖 npm
org.apache.groovy:groovy-xml 4.0.11 间接依赖 maven
lru-cache 6.0.0 直接依赖 npm
org.opensaml:opensaml-soap-impl 4.1.1 间接依赖 maven
schema-utils 4.0.0 间接依赖 npm
io.netty:netty-codec-socks 4.1.97.Final 间接依赖 maven
p-locate 4.1.0 间接依赖 npm
iconv-lite 0.6.3 间接依赖 npm
org.apache.santuario:xmlsec 2.2.4 间接依赖 maven
@webassemblyjs/helper-wasm-section 1.11.1 间接依赖 npm
com.google.code.findbugs:jsr305 3.0.2 间接依赖 maven
path-exists 4.0.0 间接依赖 npm
org.codehaus.janino:commons-compiler 3.1.10 间接依赖 maven
require-from-string 2.0.2 直接依赖 npm
callsites 3.1.0 间接依赖 npm
postcss-modules-values 4.0.0 间接依赖 npm
org.opensaml:opensaml-xmlsec-api 4.1.1 直接依赖 maven
@babel/helper-compilation-targets 7.17.7 间接依赖 npm
@types/json-schema 7.0.11 间接依赖 npm
svgo 2.8.0 间接依赖 npm
com.fasterxml.jackson.dataformat:jackson-dataformat-yaml 2.14.3 间接依赖 maven
org.apache.commons:commons-configuration2 2.8.0 直接依赖 maven
org.apache.wicket:wicket-extensions 10.0.0-M1 直接依赖 maven
@fortawesome/fontawesome-free 6.1.1 间接依赖 npm
merge-source-map 1.0.4 间接依赖 npm
org.apache.groovy:groovy-datetime 4.0.11 间接依赖 maven
org.checkerframework:checker-qual 3.19.0 间接依赖 maven
ci-info 2.0.0 间接依赖 npm
postcss-minify-font-values 5.1.0 间接依赖 npm
rimraf 2.7.1 间接依赖 npm
@jest/types 29.3.1 间接依赖 npm
com.github.openjson:openjson 1.0.12 直接依赖 maven
postcss-value-parser 4.2.0 间接依赖 npm
bootstrap4-duallistbox 4.0.2 间接依赖 npm
org.apache.groovy:groovy-jmx 4.0.11 间接依赖 maven
object-inspect 1.12.0 间接依赖 npm
org.apache.poi:poi 5.2.3 直接依赖 maven
big.js 5.2.2 间接依赖 npm
postcss-minify-gradients 5.1.1 间接依赖 npm
org.apache.tomcat.embed:tomcat-embed-websocket 10.1.12 间接依赖 maven
postcss-normalize-charset 5.1.0 间接依赖 npm
org.apache.derby:derby 10.16.1.1 直接依赖 maven
crypto-js 4.1.1 间接依赖 npm
org.jetbrains:annotations 21.0.1 直接依赖 maven
resolve-from 4.0.0 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
jakarta.persistence:jakarta.persistence-api 3.1.0 直接依赖 maven
org.glassfish.jaxb:xsom 4.0.3 间接依赖 maven
icss-utils 5.1.0 间接依赖 npm
datatables.net-responsive 2.2.9 间接依赖 npm
org.ow2.asm:asm-util 9.5 间接依赖 maven
colorette 2.0.16 间接依赖 npm
com.evolveum.polygon:connector-databasetable 1.5.1.0 直接依赖 maven
bootstrap4-toggle 3.6.1 直接依赖 npm
SHELL32.dll 间接依赖
org.springframework.security:spring-security-oauth2-client 6.0.6 直接依赖 maven
quote-stream 1.0.2 间接依赖 npm
org.springframework:spring-context 6.0.11 直接依赖 maven
org.apache.tomcat.embed:tomcat-embed-el 10.1.12 间接依赖 maven
@types/parse-json 4.0.0 间接依赖 npm
com.thoughtworks.qdox:qdox 1.12.1 间接依赖 maven
org.springframework:spring-web 6.0.11 直接依赖 maven
com.nimbusds:lang-tag 1.7 间接依赖 maven
@babel/highlight 7.17.9 间接依赖 npm
com.nimbusds:nimbus-jose-jwt 9.15.2 直接依赖 maven
fsevents 2.3.2 间接依赖 npm
org.apache.groovy:groovy-sql 4.0.11 间接依赖 maven
org.springframework.amqp:spring-rabbit 3.0.8 间接依赖 maven
com.evolveum.midpoint.model:cases-impl 4.9-SNAPSHOT 直接依赖 maven
datatables.net-bs4 1.11.5 间接依赖 npm
bootstrap-multiselect 1.1.0 直接依赖 npm
terser-webpack-plugin 5.3.1 间接依赖 npm
(0)
上一篇 2023年11月11日
下一篇 2023年11月11日

相关推荐

  • binaryer/rawip4j 软件分析报告

    基础信息 项目名称:binaryer/rawip4j 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1722172151012814848/1722172154900934656 此报告由Murphysec提供 漏…

    软件分析 2023年11月8日
    0
  • daybrush/selecto 软件分析报告

    基础信息 项目名称:daybrush/selecto 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717080281823444992/1717080281928302592 此报告由Murphysec提供 漏…

    软件分析 2023年10月25日
    0
  • jehna/objective-facebook 软件分析报告

    基础信息 项目名称:jehna/objective-facebook 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721301727385780224/1729727143858364416 此报告由Murph…

    软件分析 2023年11月29日
    0
  • XmacsLabs/mogan 软件分析报告

    基础信息 项目名称:XmacsLabs/mogan 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1755392319529684992/1755392319571628032 此报告由Murphysec提供 漏洞…

    软件分析 2024年2月8日
    0
  • alexlafroscia/ember-react-components 软件分析报告

    基础信息 项目名称:alexlafroscia/ember-react-components 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715638026507173888/17156380269056327…

    软件分析 2023年10月23日
    0