andreaferretti/paths-js 软件分析报告

基础信息

项目名称:andreaferretti/paths-js

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1720562162606718976/1720562162648662016

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
cached-path-relative 安全漏洞 原型污染 MPS-2018-14478 CVE-2018-16472 高危
Minimatch 拒绝服务漏洞 拒绝服务 MPS-2018-6725 CVE-2016-10540 高危
Growl 安全漏洞 OS命令注入 MPS-2018-7026 CVE-2017-16042 严重
debug 模块拒绝服务漏洞 拒绝服务 MPS-2018-7210 CVE-2017-16137 中危
lodash node 拒绝服务漏洞 拒绝服务 MPS-2018-7315 CVE-2018-3721 中危
lodash 存在拒绝服务漏洞 拒绝服务 MPS-2019-1228 CVE-2018-16487 中危
lodash 不加限制或调节的资源分配 MPS-2019-8123 CVE-2019-1010266 中危
lodash 原型污染漏洞 拒绝服务 MPS-2019-8636 CVE-2019-10744 严重
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
Yargs Y18n 输入原型污染漏洞 动态确定对象属性修改的控制不恰当 MPS-2020-17543 CVE-2020-7774 严重
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
Elliptic package 签名伪造漏洞 整数溢出或环绕 MPS-2020-8202 CVE-2020-13822 高危
Indutny Elliptic 加密问题漏洞 密码算法不安全 MPS-2021-1176 CVE-2020-28498 中危
cached-path-relative 安全漏洞 原型污染 MPS-2021-19557 CVE-2021-23518 严重
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
shell-quote 远程代码执行漏洞 命令注入 MPS-2021-34136 CVE-2021-42740 严重
braces 拒绝服务 MPS-2021-3692 CVE-2018-1109 中危
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
npm path-parse 安全漏洞 拒绝服务 MPS-2021-6165 CVE-2021-23343 高危
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
elliptic 竞争条件 MPS-2022-13653 中危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
minimatch 拒绝服务 MPS-2022-13882 高危
mocha 不正确的正则表达式 MPS-2022-13886 中危
uglify-js ReDoS MPS-2022-14112 中危
mocha ReDoS 漏洞 ReDoS MPS-2022-54598 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
Tauri 原型污染漏洞 原型污染 MPS-2022-65568 CVE-2022-46175 高危
debug 安全漏洞 ReDoS MPS-2023-0646 CVE-2017-20165 高危
fsevents 安全漏洞 代码注入 MPS-2ipy-muq0 CVE-2023-45311 严重
browserify-sign 密码学签名的验证不恰当 MPS-gimb-o69n CVE-2023-46234 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
growl 1.9.2 1.10.0 间接依赖 强烈建议修复
shell-quote 1.6.1 1.7.3 间接依赖 强烈建议修复
path-parse 1.0.5 1.0.7 间接依赖 建议修复
minimist 1.2.0 1.2.6 间接依赖 建议修复
mocha 2.5.3 直接依赖 建议修复
json5 0.4.0 1.0.2 间接依赖 建议修复
lodash 3.10.1 4.17.21 间接依赖 建议修复
debug 2.6.8 2.6.9 间接依赖 建议修复
elliptic 6.4.0 6.5.4 间接依赖 建议修复
minimatch 2.0.10 3.0.5 间接依赖 建议修复
browserify-sign 4.0.4 4.2.2 间接依赖 建议修复
y18n 3.2.1 3.2.2 间接依赖 建议修复
glob-parent 2.0.0 5.1.2 间接依赖 建议修复
cached-path-relative 1.0.1 1.1.0 间接依赖 建议修复
fsevents 1.1.2 1.2.11 间接依赖 可选修复
braces 1.8.5 2.3.1 间接依赖 可选修复
uglify-js 2.8.29 3.14.3 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 241
ISC 16
BSD-2-Clause 2
BSD-3-Clause 4
BSD 2
Public Domain 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
convert-source-map 1.5.0 间接依赖 npm
fsevents 1.1.2 间接依赖 npm
output-file-sync 1.1.2 间接依赖 npm
builtin-status-codes 3.0.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
safe-buffer 5.1.1 间接依赖 npm
for-own 0.1.5 间接依赖 npm
lcid 1.0.0 间接依赖 npm
buffer 3.6.0 间接依赖 npm
transform-filter 0.1.1 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
growl 1.9.2 间接依赖 npm
diffie-hellman 5.0.2 间接依赖 npm
is-posix-bracket 0.1.1 间接依赖 npm
subarg 1.0.0 间接依赖 npm
hash.js 1.1.3 间接依赖 npm
babel-plugin-constant-folding 1.0.1 间接依赖 npm
xtend 4.0.1 间接依赖 npm
amdefine 1.0.1 直接依赖 npm
astw 2.2.0 间接依赖 npm
globals 6.4.1 间接依赖 npm
create-hmac 1.1.6 间接依赖 npm
once 1.4.0 间接依赖 npm
JSONStream 1.3.1 间接依赖 npm
leven 1.0.2 间接依赖 npm
stream-splicer 2.0.0 间接依赖 npm
is-primitive 2.0.0 间接依赖 npm
number-is-nan 1.0.1 间接依赖 npm
lexical-scope 1.2.0 间接依赖 npm
acorn 4.0.13 间接依赖 npm
insert-module-globals 7.0.1 间接依赖 npm
module-deps 4.1.1 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
os-browserify 0.1.2 间接依赖 npm
extglob 0.3.2 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
util 0.10.3 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
async-each 1.0.1 间接依赖 npm
constants-browserify 1.0.0 间接依赖 npm
bn.js 4.11.8 间接依赖 npm
process-nextick-args 1.0.7 间接依赖 npm
string_decoder 1.0.3 间接依赖 npm
jsonparse 1.3.1 间接依赖 npm
jade 0.26.3 间接依赖 npm
kind-of 3.2.2 间接依赖 npm
babel-plugin-jscript 1.0.4 间接依赖 npm
glob-base 0.3.0 间接依赖 npm
lodash.memoize 3.0.4 间接依赖 npm
vm-browserify 0.0.4 间接依赖 npm
home-or-tmp 1.0.0 间接依赖 npm
querystring 0.2.0 间接依赖 npm
yargs 3.27.0 间接依赖 npm
is-extglob 1.0.0 间接依赖 npm
through2 2.0.3 间接依赖 npm
tryor 0.1.2 间接依赖 npm
des.js 1.0.0 间接依赖 npm
y18n 3.2.1 间接依赖 npm
url 0.11.0 间接依赖 npm
is-glob 2.0.1 间接依赖 npm
console-browserify 1.1.0 间接依赖 npm
babel-plugin-react-constant-elements 1.0.3 间接依赖 npm
iconv-lite 0.4.18 间接依赖 npm
hash-base 2.0.2 间接依赖 npm
uglify-js 2.8.29 间接依赖 npm
regexpu 1.3.0 间接依赖 npm
md5.js 1.3.4 间接依赖 npm
lodash.assign 4.2.0 间接依赖 npm
expand-brackets 0.1.5 间接依赖 npm
brorand 1.1.0 间接依赖 npm
binary-extensions 1.10.0 间接依赖 npm
try-resolve 1.0.1 间接依赖 npm
is-buffer 1.1.5 间接依赖 npm
commoner 0.10.8 间接依赖 npm
jsesc 0.5.0 间接依赖 npm
path-parse 1.0.5 间接依赖 npm
readable-stream 2.3.3 间接依赖 npm
isarray 1.0.0 间接依赖 npm
chalk 1.1.3 间接依赖 npm
babel-plugin-member-expression-literals 1.0.1 间接依赖 npm
lodash.defaults 4.2.0 间接依赖 npm
arr-diff 2.0.0 间接依赖 npm
source-map 0.5.7 间接依赖 npm
micromatch 2.3.11 间接依赖 npm
pako 0.2.9 间接依赖 npm
process 0.11.10 间接依赖 npm
babel-plugin-eval 1.0.1 间接依赖 npm
babel-plugin-react-display-name 1.0.3 间接依赖 npm
minimalistic-assert 1.0.0 间接依赖 npm
center-align 0.1.3 间接依赖 npm
babel-plugin-inline-environment-variables 1.0.1 间接依赖 npm
fs-readdir-recursive 0.1.2 间接依赖 npm
crypto-browserify 3.11.1 间接依赖 npm
os-locale 1.4.0 间接依赖 npm
lodash 3.10.1 间接依赖 npm
buffer-xor 1.0.3 间接依赖 npm
shell-quote 1.6.1 间接依赖 npm
pbkdf2 3.0.13 间接依赖 npm
esprima-fb 15001.1001.0-dev-harmony-fb 间接依赖 npm
punycode 1.4.1 间接依赖 npm
minifyify 7.3.5 直接依赖 npm
repeating 1.1.3 间接依赖 npm
regjsparser 0.1.5 间接依赖 npm
to-fast-properties 1.0.3 间接依赖 npm
regjsgen 0.2.0 间接依赖 npm
q 1.5.0 间接依赖 npm
inline-source-map 0.6.2 间接依赖 npm
stable 0.1.6 间接依赖 npm
is-dotfile 1.0.3 间接依赖 npm
babel 5.8.38 直接依赖 npm
preserve 0.2.0 间接依赖 npm
sigmund 1.0.1 直接依赖 npm
is-binary-path 1.0.1 间接依赖 npm
anymatch 1.3.2 间接依赖 npm
inherits 2.0.3 间接依赖 npm
simple-fmt 0.1.0 间接依赖 npm
typedarray 0.0.6 间接依赖 npm
function-bind 1.1.0 间接依赖 npm
mocha 2.5.3 直接依赖 npm
alter 0.2.0 间接依赖 npm
indexof 0.0.1 间接依赖 npm
path-browserify 0.0.0 间接依赖 npm
arrify 1.0.1 间接依赖 npm
babel-plugin-proto-to-assign 1.0.4 间接依赖 npm
parse-glob 3.0.4 间接依赖 npm
multimatch 2.1.0 间接依赖 npm
to-arraybuffer 1.0.1 间接依赖 npm
readdirp 2.1.0 间接依赖 npm
elliptic 6.4.0 间接依赖 npm
read-only-stream 2.0.0 间接依赖 npm
user-home 1.1.1 间接依赖 npm
regenerator 0.8.40 间接依赖 npm
babel-plugin-undeclared-variables-check 1.0.2 间接依赖 npm
cliui 2.1.0 间接依赖 npm
breakable 1.0.0 间接依赖 npm
filename-regex 2.0.1 间接依赖 npm
public-encrypt 4.0.0 间接依赖 npm
concat-stream 1.5.2 间接依赖 npm
base64-js 0.0.8 间接依赖 npm
lodash.foreach 4.5.0 间接依赖 npm
stringmap 0.2.2 间接依赖 npm
through 2.3.8 间接依赖 npm
invert-kv 1.0.0 间接依赖 npm
cipher-base 1.0.4 间接依赖 npm
asn1.js 4.9.1 间接依赖 npm
esutils 2.0.2 间接依赖 npm
ripemd160 2.0.1 间接依赖 npm
ms 2.0.0 间接依赖 npm
timers-browserify 1.4.2 间接依赖 npm
browser-pack 6.0.2 间接依赖 npm
browser-resolve 1.11.2 间接依赖 npm
duplexer2 0.1.4 间接依赖 npm
path-platform 0.11.15 间接依赖 npm
ansi-styles 2.2.1 间接依赖 npm
parents 1.0.1 间接依赖 npm
stream-http 2.7.2 间接依赖 npm
evp_bytestokey 1.0.2 间接依赖 npm
private 0.1.7 间接依赖 npm
browserify-zlib 0.1.4 间接依赖 npm
simple-is 0.2.0 间接依赖 npm
deps-sort 2.0.0 间接依赖 npm
wordwrap 0.0.2 间接依赖 npm
array-uniq 1.0.3 间接依赖 npm
ast-types 0.9.6 间接依赖 npm
create-hash 1.1.3 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
is-finite 1.0.2 间接依赖 npm
debug 2.6.8 间接依赖 npm
resolve 1.4.0 间接依赖 npm
umd 3.0.1 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
regenerate 1.3.2 间接依赖 npm
core-js 1.2.7 间接依赖 npm
syntax-error 1.3.0 间接依赖 npm
browserify-des 1.0.0 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
graceful-fs 4.1.11 间接依赖 npm
querystring-es3 0.2.1 间接依赖 npm
uglify-to-browserify 1.0.2 间接依赖 npm
glob-parent 2.0.0 间接依赖 npm
is-equal-shallow 0.1.3 间接依赖 npm
supports-color 2.0.0 间接依赖 npm
jsonify 0.0.0 间接依赖 npm
babel-plugin-remove-console 1.0.1 间接依赖 npm
babylon 5.8.38 间接依赖 npm
normalize-path 2.1.1 间接依赖 npm
lazy-cache 1.0.4 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
regex-cache 0.4.3 间接依赖 npm
miller-rabin 4.0.0 间接依赖 npm
align-text 0.1.4 间接依赖 npm
lodash.bind 4.2.1 间接依赖 npm
array-unique 0.2.1 间接依赖 npm
window-size 0.1.4 间接依赖 npm
https-browserify 0.0.1 间接依赖 npm
js-tokens 1.0.1 间接依赖 npm
array-reduce 0.0.0 间接依赖 npm
babel-plugin-dead-code-elimination 1.0.2 间接依赖 npm
ast-traverse 0.1.1 间接依赖 npm
camelcase 1.2.1 间接依赖 npm
array-differ 1.0.0 间接依赖 npm
browserify-cipher 1.0.0 间接依赖 npm
commander 2.11.0 间接依赖 npm
path-exists 1.0.0 间接依赖 npm
date-now 0.1.4 间接依赖 npm
babel-plugin-runtime 1.0.7 间接依赖 npm
babel-plugin-remove-debugger 1.0.1 间接依赖 npm
bluebird 2.11.0 间接依赖 npm
expand-range 1.8.2 间接依赖 npm
recast 0.10.33 间接依赖 npm
object.omit 2.0.1 间接依赖 npm
babel-core 5.8.38 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
tmp 0.0.28 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
json-stable-stringify 0.0.1 间接依赖 npm
stringset 0.2.1 间接依赖 npm
stream-combiner2 1.1.1 间接依赖 npm
nan 2.6.2 间接依赖 npm
minimalistic-crypto-utils 1.0.1 间接依赖 npm
array-union 1.0.2 间接依赖 npm
defs 1.1.1 间接依赖 npm
array-map 0.0.0 间接依赖 npm
json5 0.4.0 间接依赖 npm
right-align 0.1.3 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
get-stdin 4.0.1 间接依赖 npm
to-iso-string 0.0.2 间接依赖 npm
minimatch 2.0.10 间接依赖 npm
slash 1.0.0 间接依赖 npm
create-ecdh 4.0.0 间接依赖 npm
expect.js 0.3.1 直接依赖 npm
assert 1.3.0 间接依赖 npm
shasum 1.0.2 间接依赖 npm
babel-plugin-property-literals 1.0.1 间接依赖 npm
events 1.1.1 间接依赖 npm
cached-path-relative 1.0.1 间接依赖 npm
stream-browserify 2.0.1 间接依赖 npm
brace-expansion 1.1.8 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
defined 1.0.0 间接依赖 npm
array-filter 0.0.1 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
repeat-element 1.1.2 间接依赖 npm
ieee754 1.1.8 间接依赖 npm
htmlescape 1.1.1 间接依赖 npm
browserify-rsa 4.0.1 间接依赖 npm
source-map-support 0.2.10 间接依赖 npm
chokidar 1.7.0 间接依赖 npm
trim-right 1.0.1 间接依赖 npm
hmac-drbg 1.0.1 间接依赖 npm
babel-plugin-undefined-to-void 1.1.6 间接依赖 npm
has 1.0.1 间接依赖 npm
sha.js 2.4.8 间接依赖 npm
glob 5.0.15 间接依赖 npm
labeled-stream-splicer 2.0.0 间接依赖 npm
domain-browser 1.1.7 间接依赖 npm
combine-source-map 0.7.2 间接依赖 npm
randombytes 2.0.5 间接依赖 npm
diff 1.4.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
braces 1.8.5 间接依赖 npm
browserify 12.0.2 直接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
minimist 1.2.0 间接依赖 npm
set-immediate-shim 1.0.1 间接依赖 npm
browserify-sign 4.0.4 间接依赖 npm
has-ansi 2.0.0 间接依赖 npm
inflight 1.0.6 间接依赖 npm
is-extendable 0.1.1 间接依赖 npm
browserify-aes 1.0.6 间接依赖 npm
detect-indent 3.0.1 间接依赖 npm
detective 4.5.0 间接依赖 npm
lru-cache 2.7.3 直接依赖 npm
is-integer 1.0.7 间接依赖 npm
parse-asn1 5.1.0 间接依赖 npm
tty-browserify 0.0.0 间接依赖 npm
(0)
上一篇 2023年11月4日
下一篇 2023年11月4日

相关推荐

  • martinrotter/rssguard 软件分析报告

    基础信息 项目名称:martinrotter/rssguard 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1755811481124409344/1755811481170546688 此报告由Murphyse…

    软件分析 2024年2月9日
    0
  • akexorcist/RoundCornerProgressBar 软件分析报告

    基础信息 项目名称:akexorcist/RoundCornerProgressBar 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715596160668401664/1715596161574371328 …

    软件分析 2023年10月23日
    0
  • dusdong/yycms 软件分析报告

    基础信息 项目名称:dusdong/yycms 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721151980302237696/1725855216588775424 此报告由Murphysec提供 漏洞列表…

    软件分析 2023年11月18日
    0
  • xiaq/elvish 软件分析报告

    基础信息 项目名称:xiaq/elvish 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719960963951411200/1719960967155859456 此报告由Murphysec提供 漏洞列表 漏…

    软件分析 2023年11月2日
    0
  • angristan/openvpn-install 软件分析报告

    基础信息 项目名称:angristan/openvpn-install 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1724995653204922368/1724995654798757888 此报告由Murp…

    软件分析 2023年11月16日
    0