4paradigm/OpenMLDB 软件分析报告

基础信息

项目名称:4paradigm/OpenMLDB

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1720478317733646336/1720478318169853952

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Eclipse Jetty 输入验证错误漏洞 拒绝服务 MPS-0e59-bdsi CVE-2023-36478 高危
Apache Airflow DAG 访问控制不当漏洞 授权机制不恰当 MPS-1dor-ax84 CVE-2023-40611 中危
Apache HttpClient 中间人攻击漏洞 对宿主不匹配的证书验证不恰当 MPS-2014-4112 CVE-2014-3577 中危
Apache HttpClient 中间人攻击漏洞 输入验证不恰当 MPS-2014-4288 CVE-2012-6153 中危
Apache Hadoop 信息泄漏漏洞 未授权敏感信息泄露 MPS-2018-0896 CVE-2017-15713 中危
Apache Hadoop YARN NodeManager 信息泄漏漏洞 未授权敏感信息泄露 MPS-2018-1035 CVE-2017-15718 严重
Apache Commons Compress 存在拒绝服务漏洞 不可达退出条件的循环(无限循环) MPS-2018-11233 CVE-2018-11771 中危
Apache Hadoop 路径遍历漏洞 路径遍历 MPS-2018-14698 CVE-2018-8009 高危
Google Guava 不可信数据的反序列化漏洞 不加限制或调节的资源分配 MPS-2018-5515 CVE-2018-10237 中危
Apache Commons Beanutils 存在不可信数据的反序列化漏洞 反序列化 MPS-2019-10233 CVE-2019-10086 高危
Netty 存在 HTTP 请求走私漏洞 HTTP请求走私 MPS-2019-12064 CVE-2019-16869 高危
Red Hat JBoss Enterprise Application Platform 代码问题漏洞 反序列化 MPS-2019-12470 CVE-2019-10202 严重
Apache POI XXE MPS-2019-13682 CVE-2019-12415 中危
jackson-mapper-asl XXE MPS-2019-15048 CVE-2019-10172 高危
Apache Log4j SocketServer反序列化漏洞 反序列化 MPS-2019-17271 CVE-2019-17571 严重
Apache Tika ecursiveParserWrapper缓冲区错误漏洞 不加限制或调节的资源分配 MPS-2019-9190 CVE-2019-10088 高危
Apache Tika RecursiveParserWrapper缓冲区错误漏洞 不加限制或调节的资源分配 MPS-2019-9192 CVE-2019-10094 高危
Apache Airflow 跨站脚本漏洞 XSS MPS-2020-17186 CVE-2020-17515 中危
Apache HttpClient URI解析错误漏洞 XSS MPS-2020-17341 CVE-2020-13956 中危
Google Guava 访问控制错误漏洞 关键资源权限分配不当 MPS-2020-17429 CVE-2020-8908 低危
Netty ZlibDecoders 存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2020-5127 CVE-2020-11612 高危
Apache Log4j2 SmtpAppender证书验证不当漏洞 证书验证不恰当 MPS-2020-6684 CVE-2020-9488 低危
Apache Ant 临时文件不安全问题 将资源暴露给错误范围 MPS-2020-7418 CVE-2020-1945 中危
Apache XMLBeans XML实体扩展 MPS-2021-0600 CVE-2021-23926 严重
Apache Commons Compress 安存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10550 CVE-2021-35517 高危
Apache Commons Compress 存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10551 CVE-2021-35516 高危
Apache Commons Compress 存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10564 CVE-2021-36090 高危
Apache Commons Compress 无限循环漏洞 不可达退出条件的循环(无限循环) MPS-2021-10565 CVE-2021-35515 高危
Eclipse Jetty 编码字符敏感信息泄露漏洞 未授权敏感信息泄露 MPS-2021-10800 CVE-2021-34429 中危
Netty 在具有不安全权限的目录中创建临时文件 MPS-2021-1580 CVE-2021-21290 中危
Apache Airflow 访问控制错误漏洞 关键功能的认证机制缺失 MPS-2021-17384 CVE-2021-35936 中危
Apache Airflow 安全漏洞 权限、特权和访问控制 MPS-2021-1872 CVE-2021-26559 中危
Google protobuf DOS漏洞 不正确的行为次序 MPS-2021-19066 CVE-2021-22569 中危
netplex json-smart-v 分布式拒绝服务攻击 对因果或异常条件的不恰当检查 MPS-2021-2102 CVE-2021-27568 严重
Netty Bzip2Decoder 存在资源穷尽漏洞 拒绝服务 MPS-2021-28116 CVE-2021-37136 高危
Netty 存在资源穷尽漏洞 拒绝服务 MPS-2021-28117 CVE-2021-37137 高危
Apache Commons Net 未授权敏感信息泄露 MPS-2021-28440 CVE-2021-37533 中危
Apache Dubbo hessian-lite反序列化漏洞 反序列化 MPS-2021-35101 CVE-2021-43297 严重
Apache Log4j JMSAppender反序列化漏洞 反序列化 MPS-2021-38359 CVE-2021-4104 高危
Apache Airflow 跨站脚本漏洞 XSS MPS-2021-38886 CVE-2021-45229 中危
Apache Airflow 权限许可和访问控制问题漏洞 访问控制不当 MPS-2021-38887 CVE-2021-45230 中危
Apache Commons IO 存在路径遍历漏洞 路径遍历 MPS-2021-4531 CVE-2021-29425 中危
Eclipse Jetty 信息泄露漏洞 未授权敏感信息泄露 MPS-2021-55442 CVE-2021-34429 中危
Apache Airflow 跨站脚本漏洞 XSS MPS-2021-6126 CVE-2021-28359 中危
json-smart 存在拒绝服务漏洞 越界写入 MPS-2021-7737 CVE-2021-31684 高危
Eclipse Jetty 存在信息泄露漏洞 不充分的会话过期机制 MPS-2021-8884 CVE-2021-34428 低危
Apache Ant 拒绝服务漏洞 长度参数不一致性处理不恰当 MPS-2021-9827 CVE-2021-36373 中危
Apache Ant 拒绝服务漏洞 长度参数不一致性处理不恰当 MPS-2021-9847 CVE-2021-36374 中危
Apache Tika 拒绝服务漏洞 拒绝服务 MPS-2022-10977 CVE-2022-30973 中危
PostgreSQL JDBC 存在 SQL 注入漏洞 SQL注入 MPS-2022-11227 CVE-2022-31197 高危
org.testng:testng 存在不安全的依赖解析漏洞 从非可信控制范围包含功能例程 MPS-2022-11842 中危
commons-codec:commons-codec 存在信息泄露漏洞 未授权敏感信息泄露 MPS-2022-11853 低危
io.netty:netty-handler 存在证书验证不恰当漏洞 证书验证不恰当 MPS-2022-12067 中危
com.beust:jcommander 存在从非可信控制范围包含功能例程漏洞 从非可信控制范围包含功能例程 MPS-2022-12225 中危
com.google.code.gson:gson 存在BigDecimal拒绝服务漏洞 反序列化 MPS-2022-12287 CVE-2022-25647 高危
Apache HttpClient URI解析错误漏洞 相对路径遍历 MPS-2022-12292 中危
FasterXML Jackson-databind 拒绝服务漏洞 拒绝服务 MPS-2022-12500 中危
Apache Log4j JDBCAppender SQL注入漏洞 SQL注入 MPS-2022-1444 CVE-2022-23305 严重
Apache Log4j Chainsaw反序列化漏洞 反序列化 MPS-2022-1445 CVE-2022-23307 高危
Apache Log4j 反序列化漏洞 反序列化 MPS-2022-1446 CVE-2022-23302 高危
Eclipse Jetty URI注入漏洞 注入 MPS-2022-18060 CVE-2022-2047 低危
Apache Tika 拒绝服务漏洞 拒绝服务 MPS-2022-19059 CVE-2022-33879 中危
Apache Airflow 操作系统命令注入漏洞 OS命令注入 MPS-2022-3197 CVE-2022-24288 高危
Netty 存在信息泄露漏洞 将资源暴露给错误范围 MPS-2022-3790 CVE-2022-24823 中危
Apache Hadoop 存在shell命令注入漏洞 参数注入或修改 MPS-2022-4190 CVE-2022-25168 严重
snakeYAML 拒绝服务 MPS-2022-5144 CVE-2022-25857 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
Apache Airflow 未授权敏感信息泄露 MPS-2022-55312 CVE-2022-38170 中危
snakeYAML 栈缓冲区溢出 MPS-2022-56040 CVE-2022-38751 中危
snakeYAML 栈缓冲区溢出 MPS-2022-56041 CVE-2022-38752 低危
snakeYAML 栈缓冲区溢出 MPS-2022-56051 CVE-2022-38750 中危
snakeYAML 拒绝服务 MPS-2022-56081 CVE-2022-38749 中危
protobuf-java 存在输入验证不当漏洞 拒绝服务 MPS-2022-56472 CVE-2022-3171 中危
XStream 缓冲区错误漏洞 输入验证不恰当 MPS-2022-57061 CVE-2022-40156 低危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57062 CVE-2022-40155 高危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57063 CVE-2022-40154 高危
XStream 缓冲区错误漏洞 越界写入 MPS-2022-57065 CVE-2022-40152 高危
Jettison 拒绝服务 MPS-2022-57067 CVE-2022-40150 高危
Jettison 越界写入 MPS-2022-57068 CVE-2022-40149 高危
Python 安全漏洞 ReDoS MPS-2022-57238 CVE-2022-40897 中危
Apache Airflow会话控制不当漏洞 访问控制不当 MPS-2022-58249 CVE-2022-41672 中危
SnakeYAML 栈缓冲区溢出 MPS-2022-58478 CVE-2022-41854 中危
Netty 未经控制的递归 MPS-2022-58518 CVE-2022-41881 中危
Netty 解释冲突 MPS-2022-58552 CVE-2022-41915 中危
pgjdbc 不安全的临时文件 MPS-2022-58583 CVE-2022-41946 中危
FasterXML jackson-databind 小于2.14.0-rc1拒绝服务漏洞 拒绝服务 MPS-2022-58653 CVE-2022-42003 中危
FasterXML jackson-databind 小于2.13.4拒绝服务漏洞 拒绝服务 MPS-2022-58654 CVE-2022-42004 中危
Apache Hadoop 存在路径遍历漏洞 路径遍历 MPS-2022-5920 CVE-2022-26612 严重
IBM WebSphere Application Server Liberty 存在拒绝服务漏洞 对因果或异常条件的不恰当检查 MPS-2022-59813 CVE-2022-3509 中危
Google protobuf 安全漏洞 拒绝服务 MPS-2022-59814 CVE-2022-3510 高危
Apache Dubbo Hessian 反序列化 MPS-2022-60411 CVE-2022-39198 高危
Apache Airflow XSS MPS-2022-61326 CVE-2022-43982 中危
Apache Airflow 跨站重定向 MPS-2022-61329 CVE-2022-43985 中危
FasterXML jackson-databind 拒绝服务漏洞 越界写入 MPS-2022-6242 CVE-2020-36518 高危
Apache Airflow 跨站重定向 MPS-2022-64544 CVE-2022-45402 中危
Apache Airflow 代码注入 MPS-2022-64582 CVE-2022-40127 中危
TestNG 路径遍历 MPS-2022-64736 CVE-2022-4065 高危
Jettison 越界写入 MPS-2022-64973 CVE-2022-45685 高危
Apache Airflow 信息泄露漏洞 MPS-2022-66910 CVE-2022-46651 中危
Apache Airflow 未授权敏感信息泄露 MPS-2022-7027 CVE-2022-27949 中危
snakeYAML 反序列化 MPS-2022-9425 CVE-2022-1471 高危
Apache Tika 正则表达式拒绝服务漏洞 拒绝服务 MPS-2022-9836 CVE-2022-30126 中危
Apache Airflow 路径遍历漏洞 路径遍历 MPS-2023-0704 CVE-2023-22887 中危
Apache Airflow 输入验证错误漏洞 MPS-2023-0705 CVE-2023-22888 中危
Apache Kafka Connect 模块JNDI注入漏洞 反序列化 MPS-2023-3834 CVE-2023-25194 高危
Apache Airflow 未授权敏感信息泄露 MPS-2023-4527 CVE-2023-25695 低危
Apache Airflow 存在权限控制不当 权限管理不当 MPS-2023-4595 CVE-2023-25754 中危
Eclipse Jetty 资源管理错误漏洞 拒绝服务 MPS-2023-4997 CVE-2023-26048 中危
Eclipse Jetty 信息泄露漏洞 XSS MPS-2023-4998 CVE-2023-26049 中危
java-xmlbuilder 代码问题漏洞 XXE MPS-2023-5040 CVE-2014-125087 严重
netplex json-smart 安全漏洞 未经控制的递归 MPS-2023-7760 CVE-2023-1370 高危
Jettison 安全漏洞 未经控制的递归 MPS-2023-8270 CVE-2023-1436 高危
jackson-databind 拒绝服务漏洞 拒绝服务 MPS-2023-8438 CVE-2021-46877 中危
Apache Airflow 输入验证错误漏洞 输入验证不恰当 MPS-2023-8610 CVE-2023-28707 高危
Apache Airflow 存在存储型XSS漏洞 XSS MPS-2023-9489 CVE-2023-29247 中危
Apache Airflow Run Task 权限绕过漏洞 访问控制不当 MPS-2vhe-kp7q CVE-2023-39508 严重
Eclipse Jetty 安全漏洞 MPS-49ot-3w07 CVE-2023-40167 中危
snappy-java 输入验证错误漏洞 整数溢出或环绕 MPS-8znw-4jmi CVE-2023-34453 高危
Apache Airflow 安全漏洞 将资源暴露给错误范围 MPS-92y7-iq4w CVE-2023-42792 中危
Netty 资源管理错误漏洞 拒绝服务 MPS-9u07-bna1 CVE-2023-34462 中危
Okio 安全漏洞 数值类型间的不正确转换 MPS-a2tx-d4fb CVE-2023-3635 高危
snappy-java 的 compress 方法整数溢出漏洞导致拒绝服务 整数溢出或环绕 MPS-angp-mxl2 CVE-2023-34454 中危
Hot Rod 安全漏洞 证书验证不恰当 MPS-b7oj-adm3 CVE-2023-4586 高危
ZooKeeper SASL 身份验证绕过漏洞 通过用户控制密钥绕过授权机制 MPS-bznr-672x CVE-2023-44981 高危
Apache Airflow 渲染模版配置泄露漏洞 通过发送数据的信息暴露 MPS-dva6-4mre CVE-2023-40712 中危
Apache Airflow 信息泄露漏洞 未授权敏感信息泄露 MPS-gctm-qode CVE-2023-42780 中危
Requests Proxy-Authorization 标头泄露漏洞 未授权敏感信息泄露 MPS-hr61-tzey CVE-2023-32681 中危
Guava 创建拥有不安全权限的临时文件 MPS-mfku-xzh3 CVE-2023-2976 中危
Apache Airflow SMTP/IMAP 客户端存在 MITM 漏洞 证书验证不恰当 MPS-psic-9h2a CVE-2023-39441 低危
Apache Airflow 信息泄露漏洞 未授权敏感信息泄露 MPS-q2lw-uo98 CVE-2023-42663 中危
Apache Airflow 输入验证错误漏洞 ReDoS MPS-re53-ylwz CVE-2023-36543 中危
Snappy 安全漏洞 不加限制或调节的资源分配 MPS-s7wb-p03z CVE-2023-43642 高危
Snappy 输入验证错误漏洞 不加限制或调节的资源分配 MPS-tnp7-60hk CVE-2023-34455 高危
Apache Airflow 代码问题漏洞 MPS-vb7t-dq04 CVE-2023-37379 高危
Apache Airflow 安全漏洞 授权检查错误 MPS-w6vd-20zh CVE-2023-35908 中危
Apache Airflow访问控制错误漏洞 会话固定 MPS-wuhl-b1gm CVE-2023-40273 高危
【存在争议】FasterXML jackson-databind 代码问题漏洞 不加限制或调节的资源分配 MPS-z1bx-p8y2 CVE-2023-35116 中危
SQLite JDBC 远程代码执行漏洞 代码注入 MPS-zprx-hdwf CVE-2023-32697 高危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
org.postgresql:postgresql 42.3.3 42.3.8 直接依赖 建议修复
com.fasterxml.woodstox:woodstox-core 5.3.0 5.4.0 间接依赖 建议修复
org.apache.commons:commons-compress 1.8.1 1.21 间接依赖 建议修复
org.codehaus.jettison:jettison 1.1 1.5.4 间接依赖 建议修复
org.apache.hadoop:hadoop-common 3.3.1 3.3.3 直接依赖 建议修复
com.google.guava:guava 11.0.2 32.0.0-jre 间接依赖 建议修复
org.xerial.snappy:snappy-java 1.1.8.2 1.1.10.4 间接依赖 建议修复
io.netty:netty-handler 4.1.42.Final 间接依赖 建议修复
requests 2.27.1 2.31.0 间接依赖 建议修复
net.minidev:json-smart 2.4.7 2.4.9 间接依赖 建议修复
org.xerial:sqlite-jdbc 3.34.0 3.41.2.2 直接依赖 建议修复
io.netty:netty-handler 4.1.77.Final 间接依赖 建议修复
log4j:log4j 1.2.17 间接依赖 建议修复
com.fasterxml.jackson.core:jackson-databind 2.12.7 间接依赖 建议修复
apache-airflow 2.0 2.7.2 间接依赖 建议修复
org.eclipse.jetty:jetty-webapp 9.4.43.v20210629 9.4.43 间接依赖 建议修复
org.codehaus.jackson:jackson-mapper-asl 1.9.2 间接依赖 建议修复
com.fasterxml.jackson.core:jackson-databind 2.10.5.1 间接依赖 建议修复
org.apache.zookeeper:zookeeper 3.5.6 3.7.2 间接依赖 建议修复
com.google.guava:guava 28.1-android 32.0.0-jre 间接依赖 建议修复
org.xerial.snappy:snappy-java 1.1.8.4 1.1.10.4 间接依赖 建议修复
org.apache.zookeeper:zookeeper 3.4.14 3.7.2 直接依赖 建议修复
com.alibaba:hessian-lite 3.2.6 3.2.13 间接依赖 建议修复
org.apache.xmlbeans:xmlbeans 2.6.0 3.0.0 间接依赖 建议修复
org.eclipse.jetty:jetty-server 9.4.43.v20210629 9.4.51 间接依赖 建议修复
com.google.protobuf:protobuf-java 3.11.4 3.16.3 间接依赖 建议修复
net.minidev:json-smart 2.4.2 2.4.9 间接依赖 建议修复
net.minidev:json-smart 2.2.1 2.4.9 间接依赖 建议修复
com.squareup.okio:okio 1.6.0 3.4.0 间接依赖 建议修复
com.jamesmurty.utils:java-xmlbuilder 0.4 1.2 间接依赖 建议修复
org.eclipse.jetty:jetty-webapp 9.4.40.v20210413 9.4.43 间接依赖 建议修复
org.apache.hadoop:hadoop-common 2.7.4 3.2.4 间接依赖 建议修复
org.apache.commons:commons-compress 1.19 1.21 间接依赖 建议修复
org.eclipse.jetty:jetty-http 9.4.43.v20210629 11.0.16 间接依赖 建议修复
org.eclipse.jetty:jetty-server 9.4.40.v20210413 9.4.51 间接依赖 建议修复
org.apache.kafka:kafka-clients 3.1.0 3.4.0 直接依赖 建议修复
org.apache.poi:poi-ooxml 3.17 4.1.1 直接依赖 建议修复
org.xerial.snappy:snappy-java 1.1.2.6 1.1.10.4 间接依赖 建议修复
io.netty:netty-codec 4.1.42.Final 4.1.68.Final 间接依赖 建议修复
org.codehaus.jackson:jackson-mapper-asl 1.9.13 间接依赖 建议修复
com.squareup.okio:okio 1.15.0 3.4.0 间接依赖 建议修复
commons-beanutils:commons-beanutils 1.7.0 1.9.4 间接依赖 建议修复
org.apache.tika:tika-core 1.20 2.4.1 间接依赖 建议修复
org.eclipse.jetty:jetty-http 9.4.40.v20210413 11.0.16 间接依赖 建议修复
org.xerial.snappy:snappy-java 1.1.7.2 1.1.10.4 直接依赖 建议修复
io.netty:netty 3.10.6.Final 间接依赖 建议修复
com.google.guava:guava 14.0.1 32.0.0-jre 直接依赖 建议修复
org.yaml:snakeyaml 1.28 2.0 间接依赖 建议修复
com.google.guava:guava 27.0-jre 32.0.0-jre 间接依赖 建议修复
io.netty:netty-common 4.1.42.Final 4.1.77.Final 间接依赖 可选修复
commons-httpclient:commons-httpclient 3.1 直接依赖 可选修复
org.apache.commons:commons-compress 1.4.1 1.21 间接依赖 可选修复
com.google.protobuf:protobuf-java 3.16.1 3.16.3 间接依赖 可选修复
io.netty:netty-transport-native-epoll 4.1.42.Final 4.1.59.Final 间接依赖 可选修复
com.google.code.gson:gson 2.2.4 2.8.9 间接依赖 可选修复
commons-io:commons-io 2.4 2.7 间接依赖 可选修复
org.apache.httpcomponents:httpclient 4.1.2 4.5.13 间接依赖 可选修复
com.beust:jcommander 1.72 1.75 间接依赖 可选修复
commons-codec:commons-codec 1.11 1.13 间接依赖 可选修复
org.testng:testng 6.14.3 7.7.0 直接依赖 可选修复
io.netty:netty-codec-haproxy 4.1.77.Final 4.1.86.final 间接依赖 可选修复
semver 6.3.0 7.5.2 间接依赖 可选修复
commons-net:commons-net 3.6 3.9.0 间接依赖 可选修复
setuptools 62.3.2 65.5.1 间接依赖 可选修复
com.google.code.gson:gson 2.8.5 2.8.9 间接依赖 可选修复
io.netty:netty-codec-http 4.1.77.Final 4.1.86.final 间接依赖 可选修复
com.google.code.gson:gson 2.8.6 2.8.9 间接依赖 可选修复
org.apache.ant:ant 1.9.6 1.9.16 间接依赖 可选修复
commons-codec:commons-codec 1.10 1.13 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
Apache-2.0 385
自定义许可证 53
MIT 122
CDDL-1.1 10
BSD-2-Clause 6
BSD-3-Clause 10
LGPL-2.1 8
ISC 22
BSD 1
EPL-1.0 6
CC-BY-3.0 1
MPL-1.1 1
CC0-1.0 1
CDDL-1.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
org.apache.commons:commons-csv 1.9.0 直接依赖 maven
org.apache.logging.log4j:log4j-api 2.13.2 间接依赖 maven
org.apache.curator:curator-client 4.2.0 直接依赖 maven
org.eclipse.jetty:jetty-client 9.4.43.v20210629 间接依赖 maven
org.xerial.snappy:snappy-java 1.1.7.2 直接依赖 maven
io.netty:netty-resolver-dns 4.1.77.Final 间接依赖 maven
com.fasterxml.jackson.jaxrs:jackson-jaxrs-base 2.10.5 间接依赖 maven
com.oracle.database.xml:xdb 19.7.0.0 间接依赖 maven
com.4paradigm.openmldb:openmldb-batch 0.4.3 直接依赖 maven
setuptools 62.3.2 间接依赖 pip
org.xerial:sqlite-jdbc 3.34.0 直接依赖 maven
org.codehaus.mojo:animal-sniffer-annotations 1.18 间接依赖 maven
allure-pytest 2.8.9 间接依赖 pip
spdx-expression-parse 3.0.1 间接依赖 npm
ansi-styles 4.3.0 间接依赖 npm
com.sun.jersey:jersey-servlet 1.19 间接依赖 maven
ruamel.yaml 0.16.12 间接依赖 pip
org.apache.flink:flink-runtime 1.14.6 间接依赖 maven
org.apache.kerby:token-provider 1.0.1 间接依赖 maven
modify-values 1.0.1 间接依赖 npm
org.apache.parquet:parquet-common 1.12.2 间接依赖 maven
org.apache.flink:flink-queryable-state-client-java 1.14.6 间接依赖 maven
org.eclipse.jetty:jetty-http 9.4.43.v20210629 间接依赖 maven
com.github.luben:zstd-jni 1.4.9-1 间接依赖 maven
net.sourceforge.jtds:jtds 1.3.1 直接依赖 maven
org.xerial.snappy:snappy-java 1.1.8.2 间接依赖 maven
it.unimi.dsi:fastutil 7.0.13 间接依赖 maven
mysql:mysql-connector-java 8.0.28 直接依赖 maven
commons-codec:commons-codec 1.15 间接依赖 maven
org.xerial.snappy:snappy-java 1.1.2.6 间接依赖 maven
org.apache.commons:commons-collections4 4.1 间接依赖 maven
com.4paradigm.openmldb.test-tool:command-tool 1.0-SNAPSHOT 直接依赖 maven
org.apache.yetus:audience-annotations 0.5.0 间接依赖 maven
org.mortbay.jetty:jetty-util 6.1.26 间接依赖 maven
org.apache.flink:flink-shaded-netty 4.1.65.Final-14.0 间接依赖 maven
org.apache.flink:flink-metrics-core 1.14.6 间接依赖 maven
io.netty:netty-all 4.1.51.Final 间接依赖 maven
commons-cli:commons-cli 1.2 间接依赖 maven
chalk 2.4.2 间接依赖 npm
org.apache.kerby:kerb-util 1.0.1 间接依赖 maven
com.jcraft:jsch 0.1.54 间接依赖 maven
org.apache.tika:tika-core 1.20 间接依赖 maven
org.apache.spark:spark-tags_2.12 3.2.1 间接依赖 maven
org.apache.commons:commons-compress 1.8.1 间接依赖 maven
kind-of 6.0.3 间接依赖 npm
com.4paradigm.openmldb:openmldb-sdk-test 0.1.0-SNAPSHOT 直接依赖 maven
strip-bom 3.0.0 间接依赖 npm
org.apache.commons:commons-lang3 3.5 直接依赖 maven
org.scala-lang:scala-library 2.12.8 直接依赖 maven
com.4paradigm.openmldb:hybridse-proto 0.8.3-SNAPSHOT 直接依赖 maven
org.eclipse.jetty:jetty-http 9.4.40.v20210413 间接依赖 maven
io.confluent:common-utils 6.0.0 直接依赖 maven
io.netty:netty-common 4.1.42.Final 间接依赖 maven
ch.ethz.ganymed:ganymed-ssh2 262 直接依赖 maven
com.fasterxml.jackson.module:jackson-module-jaxb-annotations 2.10.5 间接依赖 maven
com.beust:jcommander 1.72 间接依赖 maven
conventional-changelog-core 4.2.4 间接依赖 npm
io.netty:netty 3.10.6.Final 间接依赖 maven
com.dyuproject.protostuff:protostuff-collectionschema 1.0.7 间接依赖 maven
com.oracle.database.nls:orai18n 19.7.0.0 间接依赖 maven
org.apache.hadoop:hadoop-client 3.3.4 直接依赖 maven
p-locate 2.0.0 间接依赖 npm
@babel/code-frame 7.18.6 直接依赖 npm
io.netty:netty-transport-native-unix-common 4.1.77.Final 间接依赖 maven
io.fabric8:kubernetes-model-events 5.11.2 间接依赖 maven
org.codehaus.jackson:jackson-jaxrs 1.9.2 间接依赖 maven
org.xerial:sqlite-jdbc 3.41.2.2 直接依赖 maven
org.slf4j:slf4j-log4j12 1.7.32 直接依赖 maven
conventional-changelog-express 2.0.6 间接依赖 npm
com.nimbusds:nimbus-jose-jwt 9.8.1 间接依赖 maven
org.apache.commons:commons-lang3 3.9 直接依赖 maven
org.apache.curator:curator-client 2.7.1 间接依赖 maven
org.apache.yetus:audience-annotations 0.12.0 间接依赖 maven
org.apache.kerby:kerby-config 1.0.1 间接依赖 maven
com.oracle.database.jdbc:ucp 19.7.0.0 间接依赖 maven
lines-and-columns 1.2.4 直接依赖 npm
com.google.protobuf:protobuf-java 3.16.1 间接依赖 maven
com.google.errorprone:error_prone_annotations 2.18.0 间接依赖 maven
com.fasterxml.jackson.module:jackson-module-jaxb-annotations 2.12.7 间接依赖 maven
org.checkerframework:checker-qual 3.33.0 间接依赖 maven
semver 6.3.0 间接依赖 npm
org.apache.commons:commons-math3 3.5 间接依赖 maven
com.google.inject.extensions:guice-servlet 4.0 间接依赖 maven
com.4paradigm.openmldb:openmldb-common 0.8.3-SNAPSHOT 直接依赖 maven
conventional-changelog-atom 2.0.8 间接依赖 npm
org.apache.parquet:parquet-encoding 1.10.0 间接依赖 maven
org.slf4j:slf4j-api 1.7.32 直接依赖 maven
com.4paradigm.openmldb:openmldb-common 0.8.3 间接依赖 maven
camelcase 5.3.1 间接依赖 npm
escalade 3.1.1 间接依赖 npm
io.fabric8:kubernetes-model-networking 5.11.2 间接依赖 maven
io.fabric8:zjsonpatch 0.3.0 间接依赖 maven
org.apache.flink:flink-rpc-akka-loader 1.14.6 间接依赖 maven
through 2.3.8 间接依赖 npm
javax.ws.rs:jsr311-api 1.1.1 间接依赖 maven
org.yaml:snakeyaml 1.28 间接依赖 maven
io.fabric8:kubernetes-model-flowcontrol 5.11.2 间接依赖 maven
com.google.code.gson:gson 2.8.5 间接依赖 maven
io.netty:netty-handler-proxy 4.1.77.Final 间接依赖 maven
org.apache.httpcomponents:httpcore 4.4.13 间接依赖 maven
org.tukaani:xz 1.5 间接依赖 maven
org.apache.commons:commons-configuration2 2.1.1 间接依赖 maven
spdx-correct 3.1.1 间接依赖 npm
com.4paradigm.openmldb:openmldb-native 0.2.3 间接依赖 maven
gitconfiglocal 1.0.0 间接依赖 npm
org.apache.flink:flink-optimizer 1.14.6 间接依赖 maven
javax.servlet:javax.servlet-api 3.1.0 间接依赖 maven
io.fabric8:kubernetes-model-discovery 5.11.2 间接依赖 maven
org.apache.hadoop.thirdparty:hadoop-shaded-guava 1.1.1 间接依赖 maven
conventional-commits-filter 2.0.7 间接依赖 npm
org.apache.kerby:kerb-server 1.0.1 间接依赖 maven
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
y18n 5.0.8 间接依赖 npm
io.netty:netty-handler 4.1.77.Final 间接依赖 maven
org.apache.hadoop:hadoop-aws 3.3.1 直接依赖 maven
org.apache.poi:poi-ooxml-schemas 3.17 间接依赖 maven
io.fabric8:kubernetes-model-scheduling 5.11.2 间接依赖 maven
com.eclipsesource.j2v8:j2v8_linux_x86_64 4.6.0 间接依赖 maven
org.apache.hadoop:hadoop-common 3.3.1 直接依赖 maven
process-nextick-args 2.0.1 直接依赖 npm
io.netty:netty-transport-classes-kqueue 4.1.77.Final 间接依赖 maven
net.minidev:json-smart 2.4.7 间接依赖 maven
org.slf4j:slf4j-api 1.7.21 直接依赖 maven
org.apache.commons:commons-math3 3.2 间接依赖 maven
org.apache.flink:flink-scala_2.12 1.14.6 间接依赖 maven
conventional-changelog-writer 5.0.1 间接依赖 npm
org.codehaus.jackson:jackson-core-asl 1.9.2 间接依赖 maven
io.fabric8:kubernetes-model-apps 5.11.2 间接依赖 maven
org.apache.logging.log4j:log4j-core 2.17.2 直接依赖 maven
com.4paradigm.openmldb:openmldb-deploy 0.1.0-SNAPSHOT 直接依赖 maven
com.squareup.okhttp3:okhttp 3.12.12 间接依赖 maven
is-text-path 1.0.1 间接依赖 npm
com.google.guava:guava 14.0.1 直接依赖 maven
commons-codec:commons-codec 1.13 间接依赖 maven
org.apache.flink:flink-java 1.14.6 直接依赖 maven
org.codehaus.jackson:jackson-xc 1.8.3 间接依赖 maven
javax.activation:javax.activation-api 1.2.0 间接依赖 maven
com.google.protobuf:protobuf-java-util 3.11.0 直接依赖 maven
commons-beanutils:commons-beanutils 1.9.4 间接依赖 maven
org.apache.parquet:parquet-common 1.10.0 间接依赖 maven
org.projectlombok:lombok 1.18.12 直接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-core 3.3.4 间接依赖 maven
com.baidu:brpc-java-communication 3.0.2 间接依赖 maven
org.apache.commons:commons-math3 3.1.1 间接依赖 maven
camelcase-keys 6.2.2 间接依赖 npm
com.oracle.database.security:osdt_cert 19.7.0.0 间接依赖 maven
org.apache.parquet:parquet-encoding 1.12.2 间接依赖 maven
org.apache.directory.api:api-util 1.0.0-M20 间接依赖 maven
minimist 1.2.6 间接依赖 npm
org.apache.logging.log4j:log4j-api 2.17.2 间接依赖 maven
guru.nidi:graphviz-java 0.18.0 直接依赖 maven
py4j 0.10.9 间接依赖 pip
org.eclipse.jetty:jetty-webapp 9.4.40.v20210413 间接依赖 maven
io.fabric8:kubernetes-model-common 5.11.2 间接依赖 maven
org.eclipse.jetty:jetty-util-ajax 9.4.40.v20210413 间接依赖 maven
has-flag 3.0.0 间接依赖 npm
joda-time:joda-time 2.9.4 直接依赖 maven
com.mchange:c3p0 0.9.5.5 直接依赖 maven
com.jayway.jsonpath:json-path 2.2.0 直接依赖 maven
org.eclipse.jetty:jetty-util 9.4.40.v20210413 间接依赖 maven
commons-beanutils:commons-beanutils-core 1.8.0 间接依赖 maven
meow 8.1.2 间接依赖 npm
strip-indent 3.0.0 间接依赖 npm
io.fabric8:kubernetes-model-batch 5.11.2 间接依赖 maven
normalize-package-data 3.0.3 间接依赖 npm
io.netty:netty-transport 4.1.77.Final 间接依赖 maven
org.apache.hadoop:hadoop-annotations 3.3.4 间接依赖 maven
conventional-changelog-jshint 2.0.9 间接依赖 npm
org.openjdk.jmh:jmh-generator-annprocess 1.32 直接依赖 maven
org.apache.ant:ant-launcher 1.9.6 间接依赖 maven
org.ow2.asm:asm 5.0.3 间接依赖 maven
io.netty:netty-transport-classes-epoll 4.1.77.Final 间接依赖 maven
io.fabric8:kubernetes-model-policy 5.11.2 间接依赖 maven
org.apache.httpcomponents:httpclient 4.1.2 间接依赖 maven
requests 2.27.1 间接依赖 pip
org.apache.httpcomponents:httpcore 4.1.2 间接依赖 maven
conventional-changelog-eslint 3.0.9 间接依赖 npm
org.openjdk.jmh:jmh-generator-annprocess 1.22 直接依赖 maven
io.netty:netty-handler 4.1.42.Final 间接依赖 maven
org.apache.flink:flink-shaded-guava 30.1.1-jre-14.0 间接依赖 maven
com.4paradigm.openmldb:hybridse-native 0.8.3-SNAPSHOT 直接依赖 maven
conventional-changelog-preset-loader 2.3.4 间接依赖 npm
org.eclipse.jetty:jetty-xml 9.4.40.v20210413 间接依赖 maven
org.objenesis:objenesis 2.1 间接依赖 maven
spdx-exceptions 2.3.0 间接依赖 npm
com.google.guava:guava 11.0.2 间接依赖 maven
io.qameta.allure:allure-model 2.12.1 间接依赖 maven
io.netty:netty-codec-xml 4.1.77.Final 间接依赖 maven
com.4paradigm.openmldb:openmldb-jdbc 0.2.3 直接依赖 maven
org.slf4j:slf4j-log4j12 1.7.19 直接依赖 maven
com.4paradigm.openmldb:openmldb-batch 0.7.0-SNAPSHOT 直接依赖 maven
aopalliance:aopalliance 1.0 间接依赖 maven
org.slf4j:slf4j-reload4j 1.7.36 间接依赖 maven
yallist 4.0.0 间接依赖 npm
com.oracle.database.ha:simplefan 19.7.0.0 间接依赖 maven
com.google.errorprone:error_prone_annotations 2.3.3 间接依赖 maven
org.apache.commons:commons-math3 3.6.1 间接依赖 maven
org.apache.flink:flink-clients_2.12 1.14.6 直接依赖 maven
io.netty:netty-common 4.1.77.Final 间接依赖 maven
org.scala-lang:scala-compiler 2.12.7 间接依赖 maven
com.sun.jersey:jersey-json 1.9 间接依赖 maven
org.json:org.json chargebee-1.0 直接依赖 maven
hard-rejection 2.1.0 间接依赖 npm
ch.qos.reload4j:reload4j 1.2.18.3 间接依赖 maven
decamelize-keys 1.1.0 间接依赖 npm
com.fasterxml.jackson.jaxrs:jackson-jaxrs-base 2.12.7 间接依赖 maven
org.apache.kerby:kerb-client 1.0.1 间接依赖 maven
commons-io:commons-io 2.7 直接依赖 maven
color-name 1.1.4 间接依赖 npm
org.codehaus.jackson:jackson-core-asl 1.9.11 间接依赖 maven
com.fasterxml.jackson.core:jackson-annotations 2.10.5 间接依赖 maven
com.google.guava:guava 27.0-jre 间接依赖 maven
io.netty:netty-resolver 4.1.42.Final 间接依赖 maven
org.apache.hadoop:hadoop-hdfs-client 3.3.4 间接依赖 maven
org.apache.kerby:kerby-util 1.0.1 间接依赖 maven
read-pkg-up 3.0.0 间接依赖 npm
org.apache.curator:curator-recipes 4.2.0 直接依赖 maven
org.jline:jline 3.9.0 间接依赖 maven
path-type 3.0.0 间接依赖 npm
com.4paradigm.openmldb:openmldb-spark-connector 0.8.3-SNAPSHOT 直接依赖 maven
org.apache.flink:flink-shaded-jackson 2.12.4-14.0 间接依赖 maven
org.apache.flink:flink-hadoop-fs 1.14.6 间接依赖 maven
com.squareup.okhttp:okhttp 2.7.5 间接依赖 maven
uuid 3.4.0 间接依赖 npm
com.fasterxml.jackson.core:jackson-core 2.13.0 间接依赖 maven
org.slf4j:slf4j-log4j12 1.7.21 直接依赖 maven
com.squareup:protoparser 3.1.5 间接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-jobclient 3.2.4 间接依赖 maven
io.netty:netty-transport-sctp 4.1.77.Final 间接依赖 maven
com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider 2.10.5 间接依赖 maven
io.fabric8:kubernetes-model-coordination 5.11.2 间接依赖 maven
com.google.j2objc:j2objc-annotations 2.8 间接依赖 maven
com.thoughtworks.paranamer:paranamer 2.7 间接依赖 maven
net.sourceforge.javacsv:javacsv 2.0 直接依赖 maven
com.twitter:chill_2.12 0.7.6 间接依赖 maven
net.arnx:nashorn-promise 0.1.1 间接依赖 maven
supports-color 5.5.0 间接依赖 npm
org.ow2.asm:asm 8.0.1 间接依赖 maven
org.apache.parquet:parquet-column 1.12.2 直接依赖 maven
javax.xml.bind:jaxb-api 2.2.2 间接依赖 maven
org.apache.commons:commons-collections4 4.4 直接依赖 maven
commons-codec:commons-codec 1.10 间接依赖 maven
org.webjars.npm:viz.js-for-graphviz-java 2.1.3 间接依赖 maven
com.oracle.database.security:oraclepki 19.7.0.0 间接依赖 maven
io.fabric8:kubernetes-model-certificates 5.11.2 间接依赖 maven
org.apache.kerby:kerb-crypto 1.0.1 间接依赖 maven
org.eclipse.jetty.websocket:websocket-client 9.4.43.v20210629 间接依赖 maven
org.eclipse.jetty:jetty-util 9.4.43.v20210629 间接依赖 maven
com.4paradigm.openmldb:openmldb-native 0.8.1-allinone 直接依赖 maven
io.fabric8:kubernetes-model-rbac 5.11.2 间接依赖 maven
cliui 7.0.4 间接依赖 npm
git-raw-commits 2.0.11 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
org.apache.hadoop:hadoop-common 3.3.4 直接依赖 maven
org.codehaus.woodstox:stax2-api 4.2.1 间接依赖 maven
split2 3.2.2 间接依赖 npm
text-extensions 1.9.0 间接依赖 npm
javax.inject:javax.inject 1 间接依赖 maven
org.javassist:javassist 3.22.0-CR1 间接依赖 maven
com.google.re2j:re2j 1.1 间接依赖 maven
org.apache.kerby:kerb-identity 1.0.1 间接依赖 maven
org.eclipse.jetty:jetty-webapp 9.4.43.v20210629 间接依赖 maven
com.fasterxml.woodstox:woodstox-core 5.3.0 间接依赖 maven
yargs 16.2.0 间接依赖 npm
com.google.guava:guava 28.1-android 间接依赖 maven
type-fest 0.18.1 间接依赖 npm
org.apache.kerby:kerb-simplekdc 1.0.1 间接依赖 maven
com.google.protobuf:protobuf-java 3.16.3 直接依赖 maven
org.apache.hadoop:hadoop-common 2.7.4 间接依赖 maven
indent-string 4.0.0 间接依赖 npm
org.apache.kerby:kerby-asn1 1.0.1 间接依赖 maven
neo-async 2.6.2 间接依赖 npm
org.apache.hadoop:hadoop-yarn-api 3.2.4 间接依赖 maven
com.google.code.gson:gson 2.8.9 直接依赖 maven
org.apache.htrace:htrace-core 3.1.0-incubating 间接依赖 maven
org.apache.hadoop:hadoop-auth 3.3.4 间接依赖 maven
org.apache.flink:flink-connector-base 1.14.6 间接依赖 maven
org.eclipse.jetty:jetty-security 9.4.40.v20210413 间接依赖 maven
xtend 4.0.2 直接依赖 npm
org.apache.hadoop:hadoop-auth 2.7.4 间接依赖 maven
org.jooq:joor-java-8 0.9.10 间接依赖 maven
org.apache.spark:spark-launcher_2.12 3.2.1 直接依赖 maven
org.apache.flink:flink-shaded-zookeeper-3 3.4.14-14.0 间接依赖 maven
org.apache.hadoop:hadoop-annotations 3.3.1 间接依赖 maven
com.sun.xml.bind:jaxb-impl 2.2.3-1 间接依赖 maven
org.apache.flink:flink-shaded-asm-7 7.1-14.0 间接依赖 maven
github.com/davecgh/go-spew v1.1.1 间接依赖 go
com.fasterxml.jackson.core:jackson-annotations 2.12.7 间接依赖 maven
commons-pool:commons-pool 1.6 间接依赖 maven
org.eclipse.jetty:jetty-servlet 9.4.40.v20210413 间接依赖 maven
io.netty:netty-buffer 4.1.42.Final 间接依赖 maven
com.google.guava:guava 32.0.0-jre 直接依赖 maven
io.fabric8:kubernetes-model-admissionregistration 5.11.2 间接依赖 maven
git-remote-origin-url 2.0.0 间接依赖 npm
org.apache.parquet:parquet-hadoop 1.10.0 间接依赖 maven
com.oracle.database.xml:xmlparserv2 19.7.0.0 间接依赖 maven
com.oracle.database.security:osdt_core 19.7.0.0 间接依赖 maven
core-util-is 1.0.3 直接依赖 npm
org.eclipse.jetty:jetty-xml 9.4.43.v20210629 间接依赖 maven
org.spark-project.spark:unused 1.0.0 间接依赖 maven
org.apache.flink:flink-connector-files 1.14.6 直接依赖 maven
log4j:log4j 1.2.17 间接依赖 maven
pify 2.3.0 间接依赖 npm
io.netty:netty-codec 4.1.77.Final 间接依赖 maven
io.netty:netty-codec-stomp 4.1.77.Final 间接依赖 maven
org.apache.parquet:parquet-column 1.10.0 间接依赖 maven
org.mortbay.jetty:jetty 6.1.26 间接依赖 maven
org.yaml:snakeyaml 2.0 直接依赖 maven
lodash.ismatch 4.4.0 间接依赖 npm
@babel/highlight 7.18.6 间接依赖 npm
javax.xml.bind:jaxb-api 2.2.11 间接依赖 maven
io.netty:netty-resolver-dns-classes-macos 4.1.77.Final 间接依赖 maven
conventional-commits-parser 3.2.4 间接依赖 npm
org.apache.directory.server:apacheds-kerberos-codec 2.0.0-M15 间接依赖 maven
org.apache.directory.server:apacheds-i18n 2.0.0-M15 间接依赖 maven
org.apache.parquet:parquet-format 2.4.0 间接依赖 maven
guru.nidi.com.kitfox:svgSalamander 1.1.3 间接依赖 maven
org.apache.kafka:kafka-clients 3.1.0 直接依赖 maven
commons-net:commons-net 3.6 间接依赖 maven
org.apache.hadoop:hadoop-hdfs-client 3.2.4 间接依赖 maven
com.fasterxml.jackson.datatype:jackson-datatype-jsr310 2.13.0 间接依赖 maven
dateformat 3.0.3 间接依赖 npm
io.fabric8:kubernetes-model-apiextensions 5.11.2 间接依赖 maven
trim-newlines 3.0.1 间接依赖 npm
org.codehaus.jackson:jackson-jaxrs 1.8.3 间接依赖 maven
q 1.5.1 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
io.netty:netty-codec-http2 4.1.77.Final 间接依赖 maven
io.netty:netty-codec-mqtt 4.1.77.Final 间接依赖 maven
org.xerial.snappy:snappy-java 1.1.8.4 间接依赖 maven
ch.qos.logback:logback-core 1.2.9 直接依赖 maven
conventional-changelog-ember 2.0.9 间接依赖 npm
source-map 0.6.1 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
com.sun.jersey:jersey-client 1.19 间接依赖 maven
dot-prop 5.3.0 间接依赖 npm
com.sun.jersey:jersey-server 1.19 间接依赖 maven
function-bind 1.1.1 间接依赖 npm
hosted-git-info 4.1.0 间接依赖 npm
org.apache.commons:commons-lang3 3.12.0 直接依赖 maven
tempfile 3.0.0 间接依赖 npm
org.codehaus.mojo:animal-sniffer-annotations 1.17 间接依赖 maven
commons-lang:commons-lang 2.6 间接依赖 maven
org.apache.poi:poi 4.1.1 直接依赖 maven
github.com/pmezard/go-difflib v1.0.0 间接依赖 go
org.apache.hadoop:hadoop-annotations 3.2.4 间接依赖 maven
lodash 4.17.21 间接依赖 npm
io.netty:netty-codec-socks 4.1.77.Final 间接依赖 maven
javax.annotation:javax.annotation-api 1.3.2 间接依赖 maven
nb-log 4.5 间接依赖 pip
json-stringify-safe 5.0.1 间接依赖 npm
graceful-fs 4.2.10 间接依赖 npm
com.4paradigm.openmldb:hybridse-sdk 0.8.3-SNAPSHOT 直接依赖 maven
gopkg.in/yaml.v3 v3.0.1 间接依赖 go
com.4paradigm.openmldb:openmldb-native 0.7.0-allinone 直接依赖 maven
com.github.virtuald:curvesapi 1.04 间接依赖 maven
com.github.stephenc.jcip:jcip-annotations 1.0-1 间接依赖 maven
io.fabric8:kubernetes-model-storageclass 5.11.2 间接依赖 maven
io.netty:netty-transport-native-epoll 4.1.42.Final 间接依赖 maven
io.fabric8:kubernetes-model-extensions 5.11.2 间接依赖 maven
org.wildfly.openssl:wildfly-openssl 1.0.7.Final 间接依赖 maven
com.amazonaws:aws-java-sdk-bundle 1.11.901 间接依赖 maven
conventional-changelog-jquery 3.0.11 间接依赖 npm
com.jamesmurty.utils:java-xmlbuilder 0.4 间接依赖 maven
commons-digester:commons-digester 1.8 间接依赖 maven
org.apache.parquet:parquet-jackson 1.10.1 间接依赖 maven
com.fasterxml.jackson.dataformat:jackson-dataformat-yaml 2.13.0 间接依赖 maven
read-pkg 3.0.0 间接依赖 npm
org.apache.poi:poi-ooxml 3.17 直接依赖 maven
apache-airflow 2.0 间接依赖 pip
split 1.0.1 间接依赖 npm
org.projectlombok:lombok 1.18.26 直接依赖 maven
org.apache.parquet:parquet-common 1.10.1 间接依赖 maven
org.openjdk.jmh:jmh-core 1.32 直接依赖 maven
com.google.j2objc:j2objc-annotations 1.3 间接依赖 maven
map-obj 4.3.0 间接依赖 npm
commons-logging:commons-logging 1.1.3 间接依赖 maven
PyYAML 5.4 间接依赖 pip
com.google.code.gson:gson 2.2.4 间接依赖 maven
org.apache.hadoop:hadoop-annotations 2.7.4 间接依赖 maven
handlebars 4.7.7 间接依赖 npm
color-convert 2.0.1 间接依赖 npm
dargs 7.0.0 间接依赖 npm
org.apache.avro:avro 1.8.2 间接依赖 maven
com.4paradigm.openmldb:openmldb-batchjob 0.8.3-SNAPSHOT 直接依赖 maven
parse-json 4.0.0 间接依赖 npm
com.github.mifmif:generex 1.0.2 间接依赖 maven
/usr/lib/libSystem.B.dylib 间接依赖
com.twitter:chill-java 0.7.6 间接依赖 maven
pyspark 3.2.2 间接依赖 pip
com.4paradigm.openmldb:openmldb-jdbc 0.7.0-SNAPSHOT 直接依赖 maven
is-obj 2.0.0 间接依赖 npm
conventional-changelog-cli 2.2.2 直接依赖 npm
net.jcip:jcip-annotations 1.0 直接依赖 maven
commons-logging:commons-logging 1.2 间接依赖 maven
io.fabric8:kubernetes-client 5.11.2 直接依赖 maven
org.apache.hadoop:hadoop-auth 3.2.4 间接依赖 maven
org.apache.hadoop:hadoop-auth 3.3.1 间接依赖 maven
com.github.luben:zstd-jni 1.5.0-4 间接依赖 maven
org.codehaus.jackson:jackson-mapper-asl 1.9.2 间接依赖 maven
git-semver-tags 4.1.1 间接依赖 npm
net.minidev:accessors-smart 2.4.2 间接依赖 maven
@hutson/parse-repository-url 3.0.2 间接依赖 npm
spdx-license-ids 3.0.11 间接依赖 npm
io.qameta.allure:allure-testng 2.12.1 直接依赖 maven
org.apache.kerby:kerb-common 1.0.1 间接依赖 maven
io.netty:netty-buffer 4.1.77.Final 间接依赖 maven
org.apache.kerby:kerb-admin 1.0.1 间接依赖 maven
com.google.http-client:google-http-client-jackson 1.23.0 直接依赖 maven
org.apache.kerby:kerby-xdr 1.0.1 间接依赖 maven
has 1.0.3 间接依赖 npm
io.netty:netty-codec-http 4.1.77.Final 间接依赖 maven
org.codehaus.jettison:jettison 1.1 间接依赖 maven
conventional-changelog-codemirror 2.0.8 间接依赖 npm
faker 间接依赖 pip
org.checkerframework:checker-qual 3.5.0 间接依赖 maven
util-deprecate 1.0.2 间接依赖 npm
com.4paradigm.openmldb:openmldb-jdbc 0.8.1 直接依赖 maven
org.apache.flink:flink-core 1.14.6 间接依赖 maven
com.googlecode.protobuf-java-format:protobuf-java-format 1.4 间接依赖 maven
org.apache-extras.beanshell:bsh 2.0b6 间接依赖 maven
org.eclipse.jetty:jetty-io 9.4.43.v20210629 间接依赖 maven
commons-codec:commons-codec 1.11 间接依赖 maven
org.testng:testng 6.14.3 直接依赖 maven
wordwrap 1.0.0 间接依赖 npm
jakarta.activation:jakarta.activation-api 1.2.1 间接依赖 maven
com.4paradigm.openmldb:openmldb-native 0.8.3 间接依赖 maven
org.apache.zookeeper:zookeeper-jute 3.5.6 间接依赖 maven
org.postgresql:postgresql 42.3.3 直接依赖 maven
commons-beanutils:commons-beanutils 1.7.0 间接依赖 maven
net.minidev:json-smart 2.2.1 间接依赖 maven
redis.clients:jedis 3.3.0 直接依赖 maven
com.dyuproject.protostuff:protostuff-api 1.0.7 间接依赖 maven
org.ow2.asm:asm 6.0_ALPHA 间接依赖 maven
load-json-file 4.0.0 间接依赖 npm
com.sun.jersey.contribs:jersey-guice 1.19 间接依赖 maven
js-tokens 4.0.0 间接依赖 npm
org.apache.parquet:parquet-encoding 1.10.1 间接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-jobclient 3.3.4 间接依赖 maven
locate-path 2.0.0 间接依赖 npm
org.apache.kerby:kerby-pkix 1.0.1 间接依赖 maven
inherits 2.0.4 间接依赖 npm
io.fabric8:kubernetes-model-node 5.11.2 间接依赖 maven
org.lz4:lz4-java 1.8.0 间接依赖 maven
com.microsoft.sqlserver:mssql-jdbc 8.4.1.jre8 直接依赖 maven
net.minidev:accessors-smart 1.1 间接依赖 maven
io.netty:netty-codec-haproxy 4.1.77.Final 间接依赖 maven
com.baidu:jprotobuf 1.11.11 间接依赖 maven
com.oracle.database.ha:ons 19.7.0.0 间接依赖 maven
net.minidev:accessors-smart 2.4.7 间接依赖 maven
com.esotericsoftware.kryo:kryo 2.24.0 间接依赖 maven
github.com/stretchr/testify v1.8.0 直接依赖 go
com.sun.jersey:jersey-json 1.19 间接依赖 maven
compare-func 2.0.0 间接依赖 npm
org.apache.parquet:parquet-column 1.10.1 间接依赖 maven
io.netty:netty-transport-rxtx 4.1.77.Final 间接依赖 maven
com.google.http-client:google-http-client 1.23.0 间接依赖 maven
com.dyuproject.protostuff:protostuff-runtime 1.0.7 间接依赖 maven
commons-httpclient:commons-httpclient 3.1 直接依赖 maven
io.qameta.allure:allure-java-commons 2.12.1 间接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-common 3.2.4 间接依赖 maven
add-stream 1.0.0 间接依赖 npm
com.google.code.gson:gson 2.8.6 间接依赖 maven
stax:stax-api 1.0.1 间接依赖 maven
org.slf4j:slf4j-api 1.7.19 直接依赖 maven
lru-cache 6.0.0 间接依赖 npm
io.netty:netty-transport 4.1.42.Final 间接依赖 maven
org.eclipse.jetty:jetty-security 9.4.43.v20210629 间接依赖 maven
org.apache.ant:ant 1.9.6 间接依赖 maven
array-ify 1.0.0 间接依赖 npm
isarray 1.0.0 直接依赖 npm
io.netty:netty-codec 4.1.42.Final 间接依赖 maven
org.apache.parquet:parquet-jackson 1.12.2 间接依赖 maven
com.4paradigm.openmldb:openmldb-test-common 0.1.0-SNAPSHOT 直接依赖 maven
com.google.inject:guice 4.0 间接依赖 maven
@types/minimist 1.2.2 间接依赖 npm
resolve 1.22.1 直接依赖 npm
ini 1.3.8 间接依赖 npm
io.netty:netty-resolver 4.1.77.Final 间接依赖 maven
org.checkerframework:checker-compat-qual 2.5.5 间接依赖 maven
find-up 2.1.0 间接依赖 npm
io.fabric8:kubernetes-model-metrics 5.11.2 间接依赖 maven
com.fasterxml.jackson.core:jackson-databind 2.10.5.1 间接依赖 maven
is-core-module 2.10.0 间接依赖 npm
through2 4.0.2 间接依赖 npm
JSONStream 1.3.5 间接依赖 npm
com.4paradigm.openmldb:openmldb-native 0.7.0-SNAPSHOT 直接依赖 maven
dk.brics.automaton:automaton 1.11-8 间接依赖 maven
org.apache.flink:flink-annotations 1.14.6 间接依赖 maven
io.netty:netty-transport-native-epoll 4.1.77.Final 间接依赖 maven
org.apache.commons:commons-pool2 2.6.2 间接依赖 maven
org.eclipse.jetty:jetty-util-ajax 9.4.43.v20210629 间接依赖 maven
org.slf4j:slf4j-api 1.7.25 直接依赖 maven
org.apache.hadoop:hadoop-hdfs 3.3.4 直接依赖 maven
org.apache.flink:flink-streaming-java_2.12 1.14.6 直接依赖 maven
org.apache.htrace:htrace-core4 4.1.0-incubating 间接依赖 maven
redent 3.0.0 间接依赖 npm
org.codehaus.jackson:jackson-core-asl 1.9.13 间接依赖 maven
ch.qos.logback:logback-classic 1.2.8 直接依赖 maven
get-pkg-repo 4.2.1 间接依赖 npm
org.codehaus.jackson:jackson-mapper-asl 1.9.13 间接依赖 maven
org.apache.flink:flink-file-sink-common 1.14.6 间接依赖 maven
io.netty:netty-codec-memcache 4.1.77.Final 间接依赖 maven
io.netty:netty-all 4.1.77.Final 间接依赖 maven
io.netty:netty-codec-dns 4.1.77.Final 间接依赖 maven
conventional-changelog 3.1.25 间接依赖 npm
javax.xml.stream:stax-api 1.0-2 间接依赖 maven
org.eclipse.jetty.websocket:websocket-api 9.4.43.v20210629 间接依赖 maven
com.esotericsoftware.minlog:minlog 1.2 间接依赖 maven
org.eclipse.jetty.websocket:websocket-common 9.4.43.v20210629 间接依赖 maven
io.fabric8:kubernetes-model-autoscaling 5.11.2 间接依赖 maven
org.apache.flink:flink-runtime-web_2.12 1.14.6 直接依赖 maven
org.apache.commons:commons-pool2 2.4.2 间接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-common 3.3.4 间接依赖 maven
io.netty:netty-resolver-dns-native-macos 4.1.77.Final 间接依赖 maven
org.apache.hadoop:hadoop-yarn-common 3.2.4 间接依赖 maven
pytest 5.3.5 间接依赖 pip
conventional-changelog-angular 5.0.13 间接依赖 npm
json-parse-even-better-errors 2.3.1 直接依赖 npm
org.apache.flink:flink-shaded-force-shading 14.0 间接依赖 maven
dnsjava:dnsjava 2.1.7 间接依赖 maven
org.checkerframework:checker-qual 2.5.2 间接依赖 maven
yargs-parser 20.2.9 间接依赖 npm
joda-time:joda-time 2.10 直接依赖 maven
io.netty:netty-transport-udt 4.1.77.Final 间接依赖 maven
com.4paradigm.openmldb:openmldb-native 0.8.3-SNAPSHOT 直接依赖 maven
org.slf4j:slf4j-reload4j 1.7.35 间接依赖 maven
org.apache.commons:commons-compress 1.4.1 间接依赖 maven
ch.qos.reload4j:reload4j 1.2.22 间接依赖 maven
org.apache.zookeeper:zookeeper 3.4.14 直接依赖 maven
org.apache.hadoop:hadoop-yarn-client 3.3.4 直接依赖 maven
io.netty:netty-codec-smtp 4.1.77.Final 间接依赖 maven
com.google.guava:listenablefuture 9999.0-empty-to-avoid-conflict-with-guava 间接依赖 maven
com.squareup.okio:okio 1.15.0 间接依赖 maven
org.apache.parquet:parquet-jackson 1.10.0 间接依赖 maven
uglify-js 3.16.3 间接依赖 npm
io.netty:netty-codec-redis 4.1.77.Final 间接依赖 maven
org.apache.kerby:kerb-core 1.0.1 间接依赖 maven
com.google.guava:failureaccess 1.0 间接依赖 maven
com.fasterxml.jackson.core:jackson-core 2.10.5 间接依赖 maven
org.mortbay.jetty:jetty-sslengine 6.1.26 间接依赖 maven
commons-collections:commons-collections 3.2.2 直接依赖 maven
com.sun.jersey:jersey-core 1.19 间接依赖 maven
org.apache.flink:flink-rpc-core 1.14.6 间接依赖 maven
@types/normalize-package-data 2.4.1 直接依赖 npm
jsonparse 1.3.1 间接依赖 npm
com.4paradigm.openmldb:openmldb-native 0.4.3-macos 直接依赖 maven
com.oracle.database.jdbc:ojdbc8 19.7.0.0 间接依赖 maven
com.google.guava:failureaccess 1.0.1 间接依赖 maven
com.4paradigm.openmldb:openmldb-jdbc 0.8.3-SNAPSHOT 直接依赖 maven
@babel/helper-validator-identifier 7.18.6 间接依赖 npm
io.netty:netty-transport-native-kqueue 4.1.77.Final 间接依赖 maven
org.apache.logging.log4j:log4j-to-slf4j 2.13.2 直接依赖 maven
net.java.dev.jets3t:jets3t 0.9.0 间接依赖 maven
org.openjdk.jmh:jmh-core 1.22 直接依赖 maven
org.apache.parquet:parquet-hadoop 1.10.1 间接依赖 maven
quick-lru 4.0.1 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
org.apache.commons:commons-text 1.4 间接依赖 maven
org.codehaus.jackson:jackson-xc 1.9.2 间接依赖 maven
org.apache.httpcomponents:httpclient 4.5.13 直接依赖 maven
com.squareup.okhttp3:logging-interceptor 3.12.12 间接依赖 maven
com.alibaba:hessian-lite 3.2.6 间接依赖 maven
io.fabric8:kubernetes-model-core 5.11.2 间接依赖 maven
conventional-changelog-conventionalcommits 4.6.3 间接依赖 npm
org.apache.httpcomponents:httpmime 4.5.2 直接依赖 maven
org.eclipse.jetty:jetty-io 9.4.40.v20210413 间接依赖 maven
get-caller-file 2.0.5 间接依赖 npm
string-width 4.2.3 间接依赖 npm
org.apache.parquet:parquet-avro 1.10.0 直接依赖 maven
org.apache.commons:commons-compress 1.19 间接依赖 maven
arrify 1.0.1 间接依赖 npm
minimist-options 4.1.0 间接依赖 npm
min-indent 1.0.1 间接依赖 npm
com.4paradigm.openmldb:openmldb-jdbc 0.7.0 直接依赖 maven
xmlenc:xmlenc 0.52 间接依赖 maven
com.google.j2objc:j2objc-annotations 1.1 间接依赖 maven
org.apache.zookeeper:zookeeper 3.5.6 间接依赖 maven
org.apache.hadoop:hadoop-yarn-common 3.3.4 间接依赖 maven
commons-daemon:commons-daemon 1.0.13 间接依赖 maven
org.fusesource.leveldbjni:leveldbjni-all 1.8 间接依赖 maven
org.apache.hadoop:hadoop-common 3.2.4 间接依赖 maven
org.apache.commons:commons-lang3 3.4 直接依赖 maven
org.apache.directory.api:api-asn1-api 1.0.0-M20 间接依赖 maven
com.thoughtworks.paranamer:paranamer 2.3 间接依赖 maven
io.netty:netty-transport-native-unix-common 4.1.42.Final 间接依赖 maven
org.apache.parquet:parquet-format-structures 1.12.2 间接依赖 maven
org.apache.commons:commons-exec 1.3 直接依赖 maven
org.apache.hadoop:hadoop-client 3.2.4 直接依赖 maven
org.apache.hadoop:hadoop-yarn-client 3.2.4 间接依赖 maven
commons-configuration:commons-configuration 1.6 间接依赖 maven
org.apache.avro:avro 1.7.7 间接依赖 maven
com.mchange:mchange-commons-java 0.2.19 间接依赖 maven
com.oracle.database.jdbc:ojdbc8-production 19.7.0.0 直接依赖 maven
com.jcraft:jsch 0.1.55 间接依赖 maven
org.apache.xmlbeans:xmlbeans 2.6.0 间接依赖 maven
com.4paradigm.openmldb:openmldb-jdbc 0.8.3 直接依赖 maven
org.apache.parquet:parquet-hadoop 1.12.2 直接依赖 maven
tenacity 8.0.1 间接依赖 pip
com.squareup.okio:okio 1.6.0 间接依赖 maven
com.github.spotbugs:spotbugs-annotations 3.1.9 间接依赖 maven
com.fasterxml.jackson.jaxrs:jackson-jaxrs-json-provider 2.12.7 间接依赖 maven
org.apache.hadoop:hadoop-yarn-api 3.3.4 间接依赖 maven
org.apache.curator:curator-framework 4.2.0 直接依赖 maven
com.fasterxml.jackson.core:jackson-databind 2.12.7 间接依赖 maven
javax.activation:activation 1.1 间接依赖 maven
com.google.code.findbugs:jsr305 3.0.2 间接依赖 maven
org.apache.commons:commons-compress 1.21 间接依赖 maven
temp-dir 2.0.0 间接依赖 npm
com.dyuproject.protostuff:protostuff-core 1.0.7 间接依赖 maven
path-exists 3.0.0 间接依赖 npm
javax.servlet.jsp:jsp-api 2.1 间接依赖 maven
jakarta.xml.bind:jakarta.xml.bind-api 2.3.2 间接依赖 maven
readable-stream 3.6.0 间接依赖 npm
net.minidev:json-smart 2.4.2 间接依赖 maven
org.slf4j:slf4j-log4j12 1.7.25 直接依赖 maven
org.apache.hadoop:hadoop-mapreduce-client-core 3.2.4 间接依赖 maven
com.google.protobuf:protobuf-java 3.11.4 间接依赖 maven
org.eclipse.jetty:jetty-server 9.4.40.v20210413 间接依赖 maven
commons-io:commons-io 2.4 间接依赖 maven
jline:jline 0.9.94 间接依赖 maven
net.sf.jopt-simple:jopt-simple 4.6 间接依赖 maven
path-parse 1.0.7 间接依赖 npm
cglib:cglib 3.2.5 间接依赖 maven
org.apache.hadoop.thirdparty:hadoop-shaded-protobuf_3_7 1.1.1 间接依赖 maven
string_decoder 1.3.0 间接依赖 npm
org.eclipse.jetty:jetty-servlet 9.4.43.v20210629 间接依赖 maven
org.eclipse.jetty:jetty-server 9.4.43.v20210629 间接依赖 maven
commons-cli:commons-cli 1.3.1 间接依赖 maven
com.baidu:brpc-java 3.0.2 直接依赖 maven
(0)
上一篇 2023年11月4日
下一篇 2023年11月4日

相关推荐

  • Allen7D/mini-shop-server 软件分析报告

    基础信息 项目名称:Allen7D/mini-shop-server 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1720544928249331712/1720544928282886144 此报告由Murph…

    软件分析 2023年11月4日
    0
  • izniburak/query-builder 软件分析报告

    基础信息 项目名称:izniburak/query-builder 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721288964630728704/1724045731679395840 此报告由Murphy…

    软件分析 2023年11月13日
    0
  • fathyb/carbonyl 软件分析报告

    基础信息 项目名称:fathyb/carbonyl 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721188485263593472/1728045521270431744 此报告由Murphysec提供 漏洞…

    软件分析 2023年11月24日
    0
  • apache/fluo 软件分析报告

    基础信息 项目名称:apache/fluo 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1727361742383566848/1727361742442287104 此报告由Murphysec提供 漏洞列表 漏…

    软件分析 2023年11月23日
    0
  • mindspore-lab/mindpet 软件分析报告

    基础信息 项目名称:mindspore-lab/mindpet 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715387668472922112/1715387668644888576 此报告由Murphyse…

    软件分析 2023年10月23日
    0