JetBrains/compose-jb 软件分析报告

基础信息

项目名称:JetBrains/compose-jb

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1719101617890525184/1719101617924079616

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
低危
socket.io 拒绝服务漏洞 拒绝服务 MPS-15wb-xgoz CVE-2023-32695 高危
Connect2id Nimbus JOSE+JWT 存在对异常或异常情况的不当检查漏洞 对异常条件的处理不恰当 MPS-2019-13154 CVE-2019-17195 中危
Apache CXF 存在反射型 XSS 漏洞 XSS MPS-2020-16278 CVE-2020-13954 中危
Apache HttpClient URI解析错误漏洞 XSS MPS-2020-17341 CVE-2020-13956 中危
Google Guava 访问控制错误漏洞 关键资源权限分配不当 MPS-2020-17429 CVE-2020-8908 低危
Bouncy Castle 认证绕过漏洞 使用错误因素进行比较 MPS-2020-17843 CVE-2020-28052 高危
Apache Commons Compress 安存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10550 CVE-2021-35517 高危
Apache Commons Compress 存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10551 CVE-2021-35516 高危
Apache Commons Compress 存在拒绝服务漏洞 不加限制或调节的资源分配 MPS-2021-10564 CVE-2021-36090 高危
Apache Commons Compress 无限循环漏洞 不可达退出条件的循环(无限循环) MPS-2021-10565 CVE-2021-35515 高危
ansi-html 拒绝服务 MPS-2021-17628 CVE-2021-23424 高危
Google protobuf DOS漏洞 不正确的行为次序 MPS-2021-19066 CVE-2021-22569 中危
Apache PDFBox 过度迭代 MPS-2021-3221 CVE-2021-27807 中危
Apache PDFBox 未经控制的内存分配 MPS-2021-3222 CVE-2021-27906 中危
Apache Tika 不可达退出条件的循环(无限循环) MPS-2021-3726 CVE-2021-28657 中危
Apache Commons IO 存在路径遍历漏洞 路径遍历 MPS-2021-4531 CVE-2021-29425 中危
Bouncy Castle 私钥信息泄露漏洞 竞争条件 MPS-2021-7064 CVE-2020-15522 中危
JDOM 存在 XXE 注入漏洞 XXE MPS-2021-8350 CVE-2021-33813 高危
Apache PDFBox 不可达退出条件的循环(无限循环) MPS-2021-8549 CVE-2021-31812 中危
Apache PDFBox 不加限制或调节的资源分配 MPS-2021-8633 CVE-2021-31811 中危
Digital Bazaar Forge 存在输入验证错误漏洞 跨站重定向 MPS-2022-0421 CVE-2022-0122 中危
Apache Tika 拒绝服务漏洞 拒绝服务 MPS-2022-10977 CVE-2022-30973 中危
com.google.code.gson:gson 存在BigDecimal拒绝服务漏洞 反序列化 MPS-2022-12287 CVE-2022-25647 高危
FasterXML Jackson-databind 拒绝服务漏洞 拒绝服务 MPS-2022-12500 中危
node-forge 原型污染 MPS-2022-13920 中危
Apache XercesJ XPath盲注 MPS-2022-1864 CVE-2022-23437 中危
Apache Tika 拒绝服务漏洞 拒绝服务 MPS-2022-19059 CVE-2022-33879 中危
junrar 拒绝服务漏洞 不可达退出条件的循环(无限循环) MPS-2022-2023 CVE-2022-23596 高危
JetBrains Kotlin 加锁机制不恰当 MPS-2022-3233 CVE-2022-24329 中危
node-forge 密码签名验证不当漏洞 密码学签名的验证不恰当 MPS-2022-3738 CVE-2022-24771 高危
node-forge 密码签名验证不当漏洞 密码学签名的验证不恰当 MPS-2022-3739 CVE-2022-24772 高危
node-forge 密码签名验证不当漏洞 密码学签名的验证不恰当 MPS-2022-3740 CVE-2022-24773 中危
jsoup XSS MPS-2022-51547 CVE-2022-36033 中危
Bouncy Castle 密码学问题 MPS-2022-54305 中危
mocha ReDoS 漏洞 ReDoS MPS-2022-54598 高危
JetBrains Ktor framework 安全漏洞 不充分的比较 MPS-2022-55372 CVE-2022-38179 中危
JetBrains Ktor framework 安全漏洞 身份验证不当 MPS-2022-55373 CVE-2022-38180 中危
Apache POI 不加限制或调节的资源分配 MPS-2022-5663 CVE-2022-26336 中危
XStream 缓冲区错误漏洞 输入验证不恰当 MPS-2022-57061 CVE-2022-40156 低危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57062 CVE-2022-40155 高危
xstream project跨界内存写漏洞 跨界内存写 MPS-2022-57063 CVE-2022-40154 高危
XStream 缓冲区错误漏洞 越界写入 MPS-2022-57065 CVE-2022-40152 高危
FasterXML jackson-databind 小于2.14.0-rc1拒绝服务漏洞 拒绝服务 MPS-2022-58653 CVE-2022-42003 中危
FasterXML jackson-databind 小于2.13.4拒绝服务漏洞 拒绝服务 MPS-2022-58654 CVE-2022-42004 中危
IBM WebSphere Application Server Liberty 存在拒绝服务漏洞 对因果或异常条件的不恰当检查 MPS-2022-59813 CVE-2022-3509 中危
FasterXML jackson-databind 拒绝服务漏洞 越界写入 MPS-2022-6242 CVE-2020-36518 高危
Apache CXF 未授权敏感信息泄露 MPS-2022-66587 CVE-2022-46363 高危
Apache CXF SSRF MPS-2022-66588 CVE-2022-46364 高危
JetBrains Ktor Native 安全漏洞 使用不充分的随机数 MPS-2022-8733 CVE-2022-29035 低危
Apache Tika 正则表达式拒绝服务漏洞 拒绝服务 MPS-2022-9836 CVE-2022-30126 中危
Webpack 安全漏洞 MPS-2023-7721 CVE-2023-28154 严重
jackson-databind 拒绝服务漏洞 拒绝服务 MPS-2023-8438 CVE-2021-46877 中危
Okio 安全漏洞 数值类型间的不正确转换 MPS-a2tx-d4fb CVE-2023-3635 高危
Engine.IO 存在拒绝服务漏洞 MPS-b79p-4aco CVE-2023-31125 中危
Bouncy Castle 信任管理问题漏洞 证书验证不恰当 MPS-i6w7-d48e CVE-2023-33201 中危
Guava 创建拥有不安全权限的临时文件 MPS-mfku-xzh3 CVE-2023-2976 中危
【存在争议】FasterXML jackson-databind 代码问题漏洞 不加限制或调节的资源分配 MPS-z1bx-p8y2 CVE-2023-35116 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
engine.io 6.4.1 6.4.2 间接依赖 建议修复
org.apache.commons:commons-compress 1.20 1.21 间接依赖 建议修复
com.fasterxml.woodstox:woodstox-core 6.2.4 6.4.0 间接依赖 建议修复
org.apache.cxf:cxf-core 3.3.6 3.4.10 间接依赖 建议修复
com.fasterxml.jackson.core:jackson-databind 2.12.5 间接依赖 建议修复
com.squareup.okio:okio 2.6.0 3.4.0 间接依赖 建议修复
com.google.guava:guava 28.2-jre 32.0.0-jre 间接依赖 建议修复
com.google.protobuf:protobuf-java 3.11.4 3.16.3 间接依赖 建议修复
org.bouncycastle:bcprov-jdk15on 1.65 间接依赖 建议修复
node-forge 0.10.0 1.3.0 间接依赖 建议修复
com.nimbusds:nimbus-jose-jwt 6.0 7.8.1 直接依赖 建议修复
socket.io-parser 4.2.2 4.2.3 间接依赖 建议修复
ansi-html 0.0.7 0.0.8 间接依赖 建议修复
mocha 10.0.0 直接依赖 建议修复
webpack 5.74.0 5.76.0 直接依赖 建议修复
org.jetbrains.kotlin:kotlin-stdlib 1.5.21 1.6.0 间接依赖 可选修复
org.apache.tika:tika-core 1.24.1 2.4.1 间接依赖 可选修复
org.jsoup:jsoup 1.14.3 1.15.3 直接依赖 可选修复
org.apache.cxf:cxf-rt-transports-http 3.3.6 3.4.10 间接依赖 可选修复
commons-io:commons-io 2.6 2.7 间接依赖 可选修复
org.jdom:jdom2 2.0.6 2.0.6.1 间接依赖 可选修复
org.apache.httpcomponents:httpclient 4.5.12 4.5.13 间接依赖 可选修复
org.apache.tika:tika-parsers 1.24.1 1.26 直接依赖 可选修复
org.apache.pdfbox:pdfbox 2.0.19 2.0.24 间接依赖 可选修复
org.jetbrains.kotlin:kotlin-stdlib 1.5.31 1.6.0 直接依赖 可选修复
io.ktor:ktor-client-core 1.6.4 2.1.0 间接依赖 可选修复
org.apache.poi:poi-scratchpad 4.1.2 5.2.1 间接依赖 可选修复
io.ktor:ktor-utils 1.6.4 2.1.0 间接依赖 可选修复
xerces:xercesImpl 2.12.0 2.12.2 间接依赖 可选修复
com.google.code.gson:gson 2.8.6 2.8.9 间接依赖 可选修复
com.github.junrar:junrar 4.0.0 7.4.1 间接依赖 可选修复
com.squareup.okhttp3:okhttp 4.6.0 4.9.2 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
Apache-2.0 323
MIT 404
自定义许可证 32
BSD-3-Clause 13
ISC 32
EPL-2.0 1
GPL-3.0 1
Unlicense 2
BSD-2-Clause 8
LGPL-2.1 3
EPL-1.0 2
0BSD 1
CC-BY-4.0 1
Python-2.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
joda-time:joda-time 2.2 间接依赖 maven
org.jetbrains.compose.animation:animation-desktop 1.0.0-alpha1 间接依赖 maven
org.apache.tika:tika-parsers 1.24.1 直接依赖 maven
org.jetbrains.compose.ui:ui-unit 1.0.0-alpha1 间接依赖 maven
readdirp 3.6.0 间接依赖 npm
org.jetbrains.compose.ui:ui-unit-desktop 1.0.0-alpha1 间接依赖 maven
org.apache.cxf:cxf-rt-frontend-jaxrs 3.3.6 间接依赖 maven
yocto-queue 0.1.0 间接依赖 npm
@types/node 12.20.55 直接依赖 npm
mime 2.6.0 间接依赖 npm
androidx.activity:activity-compose 1.5.0 直接依赖 maven
org.jetbrains.compose.ui:ui 1.0.0 间接依赖 maven
org.tallison:jmatio 1.5 间接依赖 maven
merge-stream 2.0.0 间接依赖 npm
@webassemblyjs/helper-buffer 1.11.1 间接依赖 npm
org.itadaki:bzip2 0.9.1 间接依赖 maven
org.apache.sis.storage:sis-storage 1.0 间接依赖 maven
proxy-addr 2.0.7 间接依赖 npm
org.jetbrains.compose.animation:animation-core-desktop 1.0.0-alpha1 间接依赖 maven
com.github.stephenc.jcip:jcip-annotations 1.0-1 直接依赖 maven
globby 11.1.0 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk8 1.9.10 直接依赖 maven
org.apache.httpcomponents:httpmime 4.5.12 间接依赖 maven
androidx.camera:camera-lifecycle 1.2.3 直接依赖 maven
define-properties 1.2.0 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core 1.5.2 间接依赖 maven
@babel/highlight 7.22.5 间接依赖 npm
@webassemblyjs/ieee754 1.11.1 间接依赖 npm
buffer-indexof 1.1.1 间接依赖 npm
is-regex 1.1.4 间接依赖 npm
has-flag 4.0.0 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core 1.5.0 间接依赖 maven
org.jetbrains.compose.desktop:desktop 1.0.0 间接依赖 maven
date-format 4.0.14 间接依赖 npm
org.jetbrains.compose.material:material-desktop 1.0.0 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-common 1.9.0 直接依赖 maven
com.beust:jcommander 1.78 间接依赖 maven
thunky 1.1.0 间接依赖 npm
shebang-command 2.0.0 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk7 1.9.10 间接依赖 maven
faye-websocket 0.11.4 间接依赖 npm
org.jetbrains.compose.ui:ui-geometry 1.5.2 间接依赖 maven
fresh 0.5.2 间接依赖 npm
http-proxy 1.18.1 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-datetime-jvm 0.2.0 间接依赖 maven
@webassemblyjs/floating-point-hex-parser 1.11.1 间接依赖 npm
org.jetbrains.compose.runtime:runtime-saveable-desktop 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.ui:ui-desktop 1.0.0 间接依赖 maven
org.jetbrains.compose.animation:animation 1.0.0-alpha1 间接依赖 maven
@webassemblyjs/leb128 1.11.1 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
org.jetbrains.compose.animation:animation-desktop 1.0.0 间接依赖 maven
decode-uri-component 0.2.2 间接依赖 npm
org.ow2.asm:asm 8.0.1 直接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-jdk8 1.8.21 间接依赖 maven
@webassemblyjs/helper-numbers 1.11.1 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib 1.6.10 间接依赖 maven
org.jetbrains.compose.runtime:runtime-saveable 1.0.0 间接依赖 maven
org.apache.ws.xmlschema:xmlschema-core 2.2.5 间接依赖 maven
express 4.18.2 间接依赖 npm
is-binary-path 2.1.0 间接依赖 npm
net.minidev:json-smart 直接依赖 maven
org.apache.commons:commons-csv 1.8 间接依赖 maven
json-schema-traverse 0.4.1 间接依赖 npm
once 1.4.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
com.google.code.gson:gson 2.8.6 间接依赖 maven
org.jetbrains.compose.foundation:foundation 1.0.0 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-jdk7 1.8.21 间接依赖 maven
emoji-regex 8.0.0 间接依赖 npm
org.jetbrains.compose.material:material-ripple-desktop 1.5.2 间接依赖 maven
org.jetbrains.compose.ui:ui-graphics-desktop 1.0.0 间接依赖 maven
org.jetbrains.compose.runtime:runtime-saveable-desktop 1.0.0 间接依赖 maven
webpack-cli 4.10.0 直接依赖 npm
org.codelibs:jhighlight 1.0.3 间接依赖 maven
ua-parser-js 0.7.35 间接依赖 npm
call-bind 1.0.2 间接依赖 npm
com.zaxxer:HikariCP-java7 2.4.13 间接依赖 maven
engine.io-parser 5.0.6 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
io.ktor:ktor-network 1.6.4 间接依赖 maven
jakarta.ws.rs:jakarta.ws.rs-api 2.1.5 间接依赖 maven
escape-string-regexp 4.0.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
edu.ucar:cdm 4.5.5 间接依赖 maven
statuses 2.0.1 间接依赖 npm
net.jcip:jcip-annotations 1.0 间接依赖 maven
org.jetbrains.compose.animation:animation 1.0.0 间接依赖 maven
schema-utils 4.0.0 间接依赖 npm
commons-codec:commons-codec 1.13 间接依赖 maven
camelcase 6.3.0 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-swing 1.6.4 直接依赖 maven
@types/estree 0.0.39 间接依赖 npm
org.codehaus.woodstox:stax2-api 4.2.1 间接依赖 maven
isbinaryfile 4.0.10 间接依赖 npm
org.tukaani:xz 1.8 间接依赖 maven
org.jetbrains.compose.ui:ui-tooling-preview-desktop 1.0.1 间接依赖 maven
toidentifier 1.0.1 间接依赖 npm
socket.io 4.6.1 间接依赖 npm
org.jetbrains.compose.ui:ui-util 1.5.2 间接依赖 maven
process-nextick-args 2.0.1 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-bom 1.6.4 直接依赖 maven
uk.co.caprica:vlcj 4.7.0 直接依赖 maven
chalk 4.1.2 间接依赖 npm
org.jetbrains.compose.animation:animation-core-desktop 1.0.0 间接依赖 maven
org.jetbrains.compose.runtime:runtime-saveable-desktop 1.5.2 间接依赖 maven
org.apache.sis.core:sis-metadata 1.0 间接依赖 maven
p-finally 1.0.0 间接依赖 npm
@webassemblyjs/utf8 1.11.1 间接依赖 npm
handle-thing 2.0.1 间接依赖 npm
org.jetbrains.compose.ui:ui-graphics-desktop 1.0.0-alpha1 间接依赖 maven
@babel/code-frame 7.22.5 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
io.ktor:ktor-client-okhttp 1.6.4 直接依赖 maven
xerces:xercesImpl 2.12.0 间接依赖 maven
cross-spawn 7.0.3 间接依赖 npm
acorn-import-assertions 1.8.0 间接依赖 npm
es-module-lexer 0.9.3 间接依赖 npm
setprototypeof 1.2.0 间接依赖 npm
androidx.camera:camera-view 1.2.3 直接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm 1.0.0 间接依赖 maven
org.jetbrains.compose.ui:ui-unit-desktop 1.0.1 间接依赖 maven
com.google.guava:listenablefuture 9999.0-empty-to-avoid-conflict-with-guava 间接依赖 maven
org.jetbrains.compose.ui:ui-tooling-preview-desktop 1.0.0 间接依赖 maven
ms 2.1.2 间接依赖 npm
org.jetbrains.skiko:skiko-jvm-runtime-macos-x64 0.6.6 间接依赖 maven
org.jetbrains.kotlinx:kotlinx-coroutines-core 1.7.1 直接依赖 maven
ws 8.13.0 间接依赖 npm
com.github.junrar:junrar 4.0.0 间接依赖 maven
ansi-regex 6.0.1 间接依赖 npm
@webpack-cli/serve 1.7.0 间接依赖 npm
resolve-cwd 3.0.0 间接依赖 npm
org.ccil.cowan.tagsoup:tagsoup 1.2.1 间接依赖 maven
com.google.code.findbugs:jsr305 3.0.2 间接依赖 maven
edu.ucar:netcdf4 4.5.5 间接依赖 maven
p-limit 3.1.0 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk8 1.5.31 直接依赖 maven
org.jetbrains.compose.animation:animation 1.0.1 间接依赖 maven
regexp.prototype.flags 1.4.3 间接依赖 npm
fastq 1.15.0 间接依赖 npm
@types/estree 1.0.0 间接依赖 npm
minimatch 5.0.1 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
org.jetbrains.compose.ui:ui-unit 1.5.2 间接依赖 maven
which 2.0.2 间接依赖 npm
http-errors 2.0.0 间接依赖 npm
org.glassfish.jaxb:txw2 2.3.2 间接依赖 maven
@webassemblyjs/helper-wasm-bytecode 1.11.1 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk8 1.9.0 直接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-jdk7 1.5.21 间接依赖 maven
org.jetbrains.compose.ui:ui-tooling-preview 1.0.1 间接依赖 maven
strip-final-newline 2.0.0 间接依赖 npm
org.jsoup:jsoup 1.14.3 直接依赖 maven
is-path-inside 3.0.3 间接依赖 npm
org.apache.poi:poi-ooxml 4.1.2 间接依赖 maven
side-channel 1.0.4 间接依赖 npm
org.jetbrains.compose.animation:animation-core 1.5.2 间接依赖 maven
clone-deep 4.0.1 间接依赖 npm
is-builtin-module 3.2.1 间接依赖 npm
fs-monkey 1.0.3 间接依赖 npm
org.jetbrains.compose.ui:ui-graphics-desktop 1.0.1 间接依赖 maven
ajv 6.12.6 间接依赖 npm
get-stream 6.0.1 间接依赖 npm
org.apache.commons:commons-math3 3.6.1 间接依赖 maven
org.jetbrains.compose.runtime:runtime 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.foundation:foundation-layout 1.0.0 间接依赖 maven
org.jetbrains.compose.material:material 1.5.2 间接依赖 maven
@jridgewell/set-array 1.1.2 间接依赖 npm
org.jetbrains.compose.material:material 1.0.0-alpha1 间接依赖 maven
ms 2.0.0 间接依赖 npm
org.lwjgl:lwjgl 3.2.3 直接依赖 maven
@webassemblyjs/wasm-parser 1.11.1 间接依赖 npm
locate-path 5.0.0 间接依赖 npm
glob 7.2.3 间接依赖 npm
on-finished 2.3.0 间接依赖 npm
jest-worker 27.5.1 间接依赖 npm
org.apache.pdfbox:fontbox 2.0.19 间接依赖 maven
com.google.j2objc:j2objc-annotations 1.3 间接依赖 maven
destroy 1.2.0 间接依赖 npm
org.jetbrains.skiko:skiko-awt-runtime-macos-x64 0.7.77 间接依赖 maven
uuid 8.3.2 间接依赖 npm
jest-worker 26.6.2 间接依赖 npm
colorette 2.0.19 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
org.jetbrains.compose.ui:ui-text-desktop 1.0.0-alpha1 间接依赖 maven
org.apache.james:apache-mime4j-core 0.8.3 间接依赖 maven
socket.io-parser 4.2.2 间接依赖 npm
org.jetbrains.compose.foundation:foundation 1.0.0-alpha1 间接依赖 maven
string_decoder 1.3.0 间接依赖 npm
org.jetbrains.compose.foundation:foundation-desktop 1.0.0 间接依赖 maven
com.google.maps.android:maps-compose 2.11.2 直接依赖 maven
jakarta.activation:jakarta.activation-api 1.2.1 间接依赖 maven
org.jetbrains.compose.ui:ui-geometry 1.0.0 间接依赖 maven
@xtuc/long 4.2.2 间接依赖 npm
com.adobe.xmp:xmpcore 6.1.10 间接依赖 maven
org.jetbrains.compose.ui:ui 1.0.0-alpha1 间接依赖 maven
string-width 4.2.3 间接依赖 npm
jakarta.xml.bind:jakarta.xml.bind-api 2.3.2 间接依赖 maven
org.bouncycastle:bcprov-jdk15on 1.65 间接依赖 maven
org.jetbrains.compose.animation:animation-core-desktop 1.5.2 间接依赖 maven
org.jetbrains.compose.foundation:foundation-desktop 1.0.0-alpha1 间接依赖 maven
path-exists 4.0.0 间接依赖 npm
anymatch 3.1.3 间接依赖 npm
void-elements 2.0.1 间接依赖 npm
loader-runner 4.3.0 间接依赖 npm
supports-color 8.1.1 间接依赖 npm
debug 3.2.7 间接依赖 npm
ip-regex 4.3.0 间接依赖 npm
estraverse 5.3.0 间接依赖 npm
events 3.3.0 间接依赖 npm
org.jetbrains.compose.ui:ui-geometry 1.0.0-alpha1 间接依赖 maven
highlight.js 10.7.2 直接依赖 npm
org.apache.commons:commons-lang3 3.10 间接依赖 maven
org.jetbrains.skiko:skiko-jvm-runtime-linux-arm64 0.6.6 直接依赖 maven
net.minidev:accessors-smart 1.2 直接依赖 maven
http-deceiver 1.2.7 间接依赖 npm
@types/node 18.15.11 间接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
io.github.microutils:kotlin-logging 2.0.3 间接依赖 maven
typescript 3.9.10 直接依赖 npm
hpack.js 2.1.6 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
escape-html 1.0.3 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-common 1.5.31 直接依赖 maven
body-parser 1.20.1 间接依赖 npm
electron-to-chromium 1.4.352 间接依赖 npm
com.google.protobuf:protobuf-java 3.11.4 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib 1.8.21 间接依赖 maven
org.jetbrains.kotlinx:atomicfu-jvm 0.17.0 间接依赖 maven
portfinder 1.0.32 间接依赖 npm
org.jetbrains.skiko:skiko-awt-runtime-linux-x64 0.7.77 直接依赖 maven
find-up 4.1.0 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
media-typer 0.3.0 间接依赖 npm
org.jetbrains.compose.foundation:foundation-layout 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.ui:ui-geometry-desktop 1.0.0 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-common 1.6.10 间接依赖 maven
object-assign 4.1.1 间接依赖 npm
@jridgewell/gen-mapping 0.3.2 间接依赖 npm
deep-equal 1.1.1 间接依赖 npm
source-map 0.6.1 间接依赖 npm
update-browserslist-db 1.0.10 间接依赖 npm
mime 1.6.0 间接依赖 npm
ansi-colors 4.1.1 间接依赖 npm
org.jetbrains.compose.runtime:runtime-desktop 1.0.1 间接依赖 maven
org.jetbrains.compose.material:material-ripple-desktop 1.0.0 间接依赖 maven
org.jetbrains.compose.foundation:foundation-layout 1.0.1 间接依赖 maven
is-extglob 2.1.1 间接依赖 npm
vary 1.1.2 间接依赖 npm
content-disposition 0.5.4 间接依赖 npm
flatted 3.2.7 间接依赖 npm
http-proxy-middleware 2.0.6 间接依赖 npm
js-yaml 4.1.0 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
org.apache.poi:poi-ooxml-schemas 4.1.2 间接依赖 maven
uri-js 4.4.1 间接依赖 npm
org.jetbrains.compose.desktop:desktop 1.0.1 直接依赖 maven
org.apache.pdfbox:pdfbox-tools 2.0.19 间接依赖 maven
isobject 3.0.1 间接依赖 npm
org.jetbrains.compose:preview-rpc project 直接依赖 maven
@jridgewell/trace-mapping 0.3.17 间接依赖 npm
inherits 2.0.4 间接依赖 npm
org.jetbrains.compose.ui:ui-util 1.0.1 间接依赖 maven
org.apache.sis.storage:sis-netcdf 1.0 间接依赖 maven
path-type 4.0.0 间接依赖 npm
org.jetbrains.compose.ui:ui-unit 1.0.0 间接依赖 maven
org.jetbrains:space-sdk-jvm 83821-beta 直接依赖 maven
io.ktor:ktor-client-core 1.6.4 间接依赖 maven
minimatch 3.1.2 间接依赖 npm
ip 1.1.8 间接依赖 npm
org.glassfish.jaxb:jaxb-runtime 2.3.2 间接依赖 maven
iconv-lite 0.6.3 间接依赖 npm
commander 7.2.0 间接依赖 npm
object-is 1.1.5 间接依赖 npm
yargs-parser 20.2.4 间接依赖 npm
mime-db 1.52.0 间接依赖 npm
com.rometools:rome-utils 1.12.2 间接依赖 maven
typescript 4.7.4 直接依赖 npm
webpack-merge 5.8.0 间接依赖 npm
require-from-string 2.0.2 间接依赖 npm
internal-ip 6.2.0 间接依赖 npm
com.fasterxml.jackson.core:jackson-core 2.12.5 间接依赖 maven
buffer-from 1.1.2 间接依赖 npm
strip-json-comments 3.1.1 间接依赖 npm
commons-logging:commons-logging 1.2 间接依赖 maven
lodash 4.17.21 间接依赖 npm
minimist 1.2.8 间接依赖 npm
com.fasterxml.jackson:jackson-bom 2.12.5 间接依赖 maven
yargs-parser 20.2.9 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
is-number 7.0.0 间接依赖 npm
commondir 1.0.1 间接依赖 npm
org.jetbrains.skiko:skiko-jvm-runtime-macos-arm64 0.6.6 间接依赖 maven
shebang-regex 3.0.0 间接依赖 npm
org.apache.cxf:cxf-core 3.3.6 间接依赖 maven
org.jetbrains.kotlinx:kotlinx.benchmark.runtime 0.3.0 直接依赖 maven
object-keys 1.1.1 间接依赖 npm
qjobs 1.2.0 间接依赖 npm
io.ktor:ktor-client-cio 2.2.1 直接依赖 maven
@webpack-cli/configtest 1.2.0 间接依赖 npm
org.tallison.xmp:xmpcore-shaded 6.1.10 间接依赖 maven
org.gagravarr:vorbis-java-tika 0.8 间接依赖 maven
is-module 1.0.0 间接依赖 npm
@jridgewell/resolve-uri 3.1.0 间接依赖 npm
raw-body 2.5.1 间接依赖 npm
isarray 1.0.0 间接依赖 npm
dom-serialize 2.2.1 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core 1.5.1 直接依赖 maven
org.lwjgl:lwjgl-opengl 3.2.3 直接依赖 maven
karma-firefox-launcher 2.1.2 直接依赖 npm
io.ktor:ktor-utils-jvm 1.6.4 间接依赖 maven
org.apache.pdfbox:xmpbox 2.0.19 间接依赖 maven
parseurl 1.3.3 间接依赖 npm
org.jetbrains.compose.foundation:foundation-desktop 1.0.1 间接依赖 maven
qs 6.11.0 间接依赖 npm
@webassemblyjs/ast 1.11.1 间接依赖 npm
com.mchange:c3p0 0.9.5.5 间接依赖 maven
browser-stdout 1.3.1 间接依赖 npm
edu.ucar:httpservices 4.5.5 间接依赖 maven
@jridgewell/source-map 0.3.5 间接依赖 npm
@types/json-schema 7.0.11 间接依赖 npm
yargs 16.2.0 间接依赖 npm
org.slf4j:slf4j-api 1.7.30 间接依赖 maven
has 1.0.3 间接依赖 npm
is-reference 1.2.1 间接依赖 npm
find-up 5.0.0 间接依赖 npm
com.mchange:mchange-commons-java 0.2.19 间接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm-linux-arm64 1.0.1 直接依赖 maven
com.google.accompanist:accompanist-permissions 0.29.2-rc 直接依赖 maven
balanced-match 1.0.2 间接依赖 npm
escalade 3.1.1 间接依赖 npm
locate-path 6.0.0 间接依赖 npm
org.jetbrains.compose.ui:ui-desktop 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.foundation:foundation-layout-desktop 1.0.1 间接依赖 maven
punycode 2.3.0 间接依赖 npm
human-signals 2.1.0 间接依赖 npm
org.jetbrains.compose.material:material 1.0.0 间接依赖 maven
rollup-plugin-sourcemaps 0.6.3 直接依赖 npm
webpack-dev-server 4.0.0 直接依赖 npm
path-to-regexp 0.1.7 间接依赖 npm
serialize-javascript 4.0.0 间接依赖 npm
com.epam:parso 2.0.11 间接依赖 maven
colorette 1.4.0 间接依赖 npm
org.jetbrains:space-sdk-runtime 0.1.16 直接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm-macos-arm64 1.0.1 直接依赖 maven
org.jetbrains.compose.ui:ui-text-desktop 1.0.1 间接依赖 maven
webpack 5.74.0 直接依赖 npm
graceful-fs 4.2.11 直接依赖 npm
org.jetbrains.skiko:skiko-jvm 0.3.9 间接依赖 maven
org.jetbrains.jcef:jcef-skiko 0.1 直接依赖 maven
org.jetbrains.kotlinx:kotlinx-serialization-json 1.5.1 直接依赖 maven
micromatch 4.0.5 间接依赖 npm
org.jetbrains.compose.material:material-ripple 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.ui:ui-geometry-desktop 1.0.1 间接依赖 maven
brace-expansion 2.0.1 间接依赖 npm
diff 5.0.0 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core 1.6.4 直接依赖 maven
terser-webpack-plugin 5.3.9 间接依赖 npm
p-event 4.2.0 间接依赖 npm
org.jetbrains.compose.desktop:desktop-jvm-linux-x64 1.0.0-alpha1 直接依赖 maven
statuses 1.5.0 间接依赖 npm
glob 7.2.0 间接依赖 npm
http-errors 1.6.3 间接依赖 npm
node-forge 0.10.0 间接依赖 npm
org.apache.poi:poi 4.1.2 间接依赖 maven
org.apache.sis.core:sis-referencing 1.0 间接依赖 maven
org.jetbrains.compose.ui:ui-tooling-preview-desktop 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.runtime:runtime-saveable 1.5.2 间接依赖 maven
com.google.guava:failureaccess 1.0.1 间接依赖 maven
kind-of 6.0.3 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core-jvm 1.5.0 间接依赖 maven
is-wsl 2.2.0 间接依赖 npm
@rollup/plugin-node-resolve 13.3.0 直接依赖 npm
tslib 2.6.0 直接依赖 npm
engine.io 6.4.1 间接依赖 npm
readable-stream 2.3.8 间接依赖 npm
xml-apis:xml-apis 1.4.01 间接依赖 maven
org.jetbrains.compose.foundation:foundation-layout-desktop 1.0.0 间接依赖 maven
@webassemblyjs/wast-printer 1.11.1 间接依赖 npm
org.jetbrains.compose.ui:ui-unit-desktop 1.5.2 间接依赖 maven
org.jetbrains.compose.ui:ui-text 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.ui:ui-unit-desktop 1.0.0 间接依赖 maven
he 1.2.0 间接依赖 npm
@types/cors 2.8.13 间接依赖 npm
p-retry 4.6.2 间接依赖 npm
execa 5.1.1 间接依赖 npm
source-map-resolve 0.6.0 间接依赖 npm
@jridgewell/sourcemap-codec 1.4.14 间接依赖 npm
webpack-dev-middleware 5.3.3 间接依赖 npm
org.jetbrains.compose.material:material-icons-core-desktop 1.0.0 间接依赖 maven
browserslist 4.21.5 间接依赖 npm
workerpool 6.2.1 间接依赖 npm
ent 2.2.0 间接依赖 npm
accepts 1.3.8 间接依赖 npm
p-timeout 3.2.0 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
inherits 2.0.3 间接依赖 npm
org.brotli:dec 0.1.2 间接依赖 maven
is-unicode-supported 0.1.0 间接依赖 npm
org.jetbrains.compose.material:material-icons-core-desktop 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm-linux-x64 1.0.0 直接依赖 maven
@webassemblyjs/wasm-opt 1.11.1 间接依赖 npm
inflight 1.0.6 间接依赖 npm
body-parser 1.20.2 间接依赖 npm
detect-node 2.1.0 间接依赖 npm
com.fasterxml.jackson.core:jackson-annotations 2.12.5 间接依赖 maven
org.apache.pdfbox:preflight 2.0.19 间接依赖 maven
net.java.dev.jna:jna 5.5.0 间接依赖 maven
org.jetbrains.compose.material:material-icons-core 1.0.0 间接依赖 maven
org.jetbrains.compose.ui:ui-graphics 1.0.1 间接依赖 maven
rollup 2.79.1 直接依赖 npm
org.apache.commons:commons-exec 1.3 间接依赖 maven
org.jetbrains.compose.material:material-ripple 1.0.1 间接依赖 maven
@types/eslint 8.37.0 间接依赖 npm
org.jetbrains.compose.runtime:runtime 1.0.0 间接依赖 maven
fastest-levenshtein 1.0.16 间接依赖 npm
org.jetbrains.compose.animation:animation-desktop 1.0.1 间接依赖 maven
wbuf 1.7.3 间接依赖 npm
io.ktor:ktor-client-core-jvm 1.6.4 间接依赖 maven
estraverse 4.3.0 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
org.jetbrains.skiko:skiko-jvm-runtime-linux-x64 0.3.9 直接依赖 maven
io.ktor:ktor-http-cio-jvm 1.6.4 间接依赖 maven
universalify 0.1.2 间接依赖 npm
negotiator 0.6.3 间接依赖 npm
org.apache.cxf:cxf-rt-rs-client 3.3.6 间接依赖 maven
dns-equal 1.0.0 间接依赖 npm
com.fasterxml.jackson.module:jackson-module-kotlin 2.12.5 直接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib 1.9.0 直接依赖 maven
eventemitter3 4.0.7 间接依赖 npm
log-symbols 4.1.0 间接依赖 npm
async 2.6.4 间接依赖 npm
@colors/colors 1.5.0 间接依赖 npm
schema-utils 3.1.1 间接依赖 npm
org.tallison:isoparser 1.9.41.2 间接依赖 maven
com.rometools:rome 1.12.2 间接依赖 maven
@webpack-cli/info 1.5.0 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib 1.5.21 间接依赖 maven
io.ktor:ktor-network-jvm 1.6.4 间接依赖 maven
ajv 8.12.0 间接依赖 npm
abab 2.0.6 间接依赖 npm
shallow-clone 3.0.1 间接依赖 npm
io.ktor:ktor-http 1.6.4 间接依赖 maven
raw-body 2.5.2 间接依赖 npm
org.jetbrains.compose.material:material-icons-extended 1.5.2 直接依赖 maven
org.jetbrains.compose.ui:ui-util 1.0.0-alpha1 间接依赖 maven
onetime 5.1.2 间接依赖 npm
batch 0.6.1 间接依赖 npm
androidx.annotation:annotation 1.2.0 间接依赖 maven
com.github.jai-imageio:jai-imageio-core 1.4.0 间接依赖 maven
org.jetbrains.compose.material:material-icons-core 1.0.1 间接依赖 maven
edu.ucar:grib 4.5.5 间接依赖 maven
io.ktor:ktor-http-jvm 1.6.4 间接依赖 maven
content-type 1.0.5 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-swing 1.5.2 间接依赖 maven
org.jetbrains.compose.ui:ui-text 1.5.2 间接依赖 maven
glob-to-regexp 0.4.1 间接依赖 npm
@rollup/plugin-typescript 8.5.0 直接依赖 npm
org.apache.opennlp:opennlp-tools 1.9.2 间接依赖 maven
org.jetbrains.skiko:skiko-jvm-runtime-windows-x64 0.6.6 间接依赖 maven
utils-merge 1.0.1 间接依赖 npm
org.jetbrains.compose.material:material-ripple-desktop 1.0.0-alpha1 间接依赖 maven
org.jetbrains.skiko:skiko-jvm-runtime-linux-x64 0.6.6 间接依赖 maven
methods 1.1.2 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
terser 5.19.1 间接依赖 npm
org.jetbrains.compose.desktop:desktop-jvm 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.runtime:runtime-saveable 1.0.0-alpha1 间接依赖 maven
decamelize 4.0.0 间接依赖 npm
fs-extra 8.1.0 间接依赖 npm
is-plain-obj 3.0.0 间接依赖 npm
npm-run-path 4.0.1 间接依赖 npm
ipaddr.js 2.0.1 间接依赖 npm
picocolors 1.0.0 间接依赖 npm
org.jetbrains.compose.desktop:desktop-jvm 1.5.2 间接依赖 maven
streamroller 3.1.5 间接依赖 npm
@xtuc/ieee754 1.2.0 间接依赖 npm
@discoveryjs/json-ext 0.5.7 间接依赖 npm
log4js 6.9.1 间接依赖 npm
dir-glob 3.0.1 间接依赖 npm
functions-have-names 1.2.3 间接依赖 npm
org.apache.cxf:cxf-rt-transports-http 3.3.6 间接依赖 maven
org.jetbrains.compose.ui:ui-unit 1.0.1 间接依赖 maven
org.jetbrains.compose.animation:animation-desktop 1.5.2 间接依赖 maven
@nodelib/fs.walk 1.2.8 间接依赖 npm
ajv-keywords 3.5.2 间接依赖 npm
estree-walker 1.0.1 间接依赖 npm
org.apache.james:apache-mime4j-dom 0.8.3 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-jdk7 1.6.10 间接依赖 maven
org.jetbrains.compose.material:material 1.0.1 间接依赖 maven
org.jetbrains.compose.material:material-icons-core-desktop 1.5.2 间接依赖 maven
com.squareup.okhttp3:okhttp 4.6.0 间接依赖 maven
org.jetbrains.compose.ui:ui-graphics 1.0.0-alpha1 间接依赖 maven
org.jetbrains.compose.foundation:foundation 1.5.2 间接依赖 maven
p-map 4.0.0 间接依赖 npm
unpipe 1.0.0 间接依赖 npm
io.github.microutils:kotlin-logging-jvm 2.0.3 间接依赖 maven
p-locate 4.1.0 间接依赖 npm
cliui 7.0.4 间接依赖 npm
org.jetbrains.compose.ui:ui-text 1.0.1 间接依赖 maven
org.jetbrains.compose.ui:ui-graphics-desktop 1.5.2 间接依赖 maven
org.jetbrains.compose.ui:ui-desktop 1.5.2 间接依赖 maven
org.jetbrains.kotlinx:kotlinx-coroutines-swing 1.5.0 间接依赖 maven
depd 2.0.0 间接依赖 npm
http-parser-js 0.5.8 间接依赖 npm
default-gateway 6.0.3 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
requires-port 1.0.0 间接依赖 npm
is-fullwidth-code-point 3.0.0 间接依赖 npm
type-is 1.6.18 间接依赖 npm
org.jetbrains:space-sdk-runtime-jvm 0.1.16 间接依赖 maven
com.github.openjson:openjson 1.0.12 间接依赖 maven
mocha 10.0.0 直接依赖 npm
ee-first 1.1.1 间接依赖 npm
edu.ucar:udunits 4.5.5 间接依赖 maven
array-union 2.1.0 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
forwarded 0.2.0 间接依赖 npm
array-flatten 2.1.2 间接依赖 npm
binary-extensions 2.2.0 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
@types/cookie 0.4.1 间接依赖 npm
org.jetbrains.compose.ui:ui-text-desktop 1.0.0 间接依赖 maven
@types/eslint-scope 3.7.4 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib 1.5.31 直接依赖 maven
memfs 3.4.13 间接依赖 npm
serialize-javascript 6.0.0 间接依赖 npm
org.jetbrains.compose.ui:ui 1.5.2 间接依赖 maven
is-arguments 1.1.1 间接依赖 npm
ignore 5.2.4 间接依赖 npm
org.jetbrains.skiko:skiko 0.6.6 间接依赖 maven
is-date-object 1.0.5 间接依赖 npm
org.jetbrains.compose.ui:ui-geometry-desktop 1.0.0-alpha1 间接依赖 maven
mime-types 2.1.35 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk7 1.5.31 间接依赖 maven
require-directory 2.1.1 间接依赖 npm
org.jetbrains.compose.ui:ui-util-desktop 1.0.0-alpha1 间接依赖 maven
multicast-dns-service-types 1.1.0 间接依赖 npm
multicast-dns 6.2.3 间接依赖 npm
deepmerge 4.3.1 间接依赖 npm
org.jetbrains.compose.ui:ui-util-desktop 1.0.1 间接依赖 maven
org.jetbrains.compose.ui:ui-text-desktop 1.5.2 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-common 1.9.10 间接依赖 maven
io.ktor:ktor-utils 1.6.4 间接依赖 maven
aggregate-error 3.1.0 间接依赖 npm
@types/http-proxy 1.17.10 间接依赖 npm
org.jetbrains.compose.desktop:desktop-jvm-linux-x64 1.5.2 直接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm-macos-x64 1.5.2 直接依赖 maven
org.jetbrains.compose.animation:animation-core 1.0.0-alpha1 间接依赖 maven
braces 3.0.2 间接依赖 npm
sourcemap-codec 1.4.8 间接依赖 npm
org.jvnet.staxex:stax-ex 1.8.1 间接依赖 maven
core-util-is 1.0.3 间接依赖 npm
com.google.errorprone:error 间接依赖 maven
karma-webpack 5.0.0 直接依赖 npm
color-convert 2.0.1 间接依赖 npm
com.sun.istack:istack-commons-runtime 3.0.8 间接依赖 maven
has-property-descriptors 1.0.0 间接依赖 npm
source-map-support 0.5.21 直接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core-jvm 1.5.2 间接依赖 maven
org.jetbrains:annotations 13.0 直接依赖 maven
esrecurse 4.3.0 间接依赖 npm
org.jetbrains.compose.animation:animation-core 1.0.0 间接依赖 maven
resolve 1.22.2 间接依赖 npm
serialize-javascript 6.0.1 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-common 1.8.21 间接依赖 maven
javax.measure:unit-api 1.0 间接依赖 maven
socket.io-adapter 2.5.2 间接依赖 npm
slash 3.0.0 间接依赖 npm
open 8.4.2 间接依赖 npm
caniuse-lite 1.0.30001474 间接依赖 npm
di 0.0.1 间接依赖 npm
minimalistic-assert 1.0.1 间接依赖 npm
org.jetbrains.skiko:skiko 0.7.77 间接依赖 maven
obuf 1.1.2 间接依赖 npm
com.sun.xml.fastinfoset:FastInfoset 1.2.16 间接依赖 maven
org.jetbrains.compose.animation:animation-core-desktop 1.0.1 间接依赖 maven
jsonfile 4.0.0 间接依赖 npm
resolve-from 5.0.0 间接依赖 npm
ansi-styles 4.3.0 间接依赖 npm
org.jetbrains.compose.animation:animation 1.5.2 间接依赖 maven
mkdirp 0.5.6 间接依赖 npm
pkg-dir 4.2.0 间接依赖 npm
org.slf4j:jul-to-slf4j 1.7.28 间接依赖 maven
io.ktor:ktor-io-jvm 1.6.4 间接依赖 maven
org.jetbrains.compose.material:material-ripple 1.0.0 间接依赖 maven
com.sun.activation:jakarta.activation 1.2.1 间接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm-macos-x64 1.0.1 直接依赖 maven
clean-stack 2.2.0 间接依赖 npm
etag 1.8.1 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
org.jetbrains.compose.foundation:foundation-desktop 1.5.2 间接依赖 maven
envinfo 7.8.1 间接依赖 npm
base64id 2.0.0 间接依赖 npm
org.jetbrains.compose.material:material-desktop 1.0.0-alpha1 间接依赖 maven
supports-color 5.5.0 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core-jvm 1.6.4 间接依赖 maven
readable-stream 3.6.2 间接依赖 npm
org.apache.pdfbox:pdfbox 2.0.19 间接依赖 maven
org.ocpsoft.prettytime:prettytime 4.0.4.Final 直接依赖 maven
glob-parent 5.1.2 间接依赖 npm
org.jetbrains.compose.material:material-icons-core 1.5.2 间接依赖 maven
connect 3.7.0 间接依赖 npm
is-core-module 2.11.0 间接依赖 npm
org.jetbrains.compose.runtime:runtime-desktop 1.0.0 间接依赖 maven
path-is-absolute 1.0.1 间接依赖 npm
org.jetbrains.compose.ui:ui-util-desktop 1.0.0 间接依赖 maven
p-locate 5.0.0 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk8 1.5.21 直接依赖 maven
com.fasterxml.jackson.module:jackson-module-jaxb-annotations 2.12.5 间接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm 1.0.1 间接依赖 maven
url 0.11.0 间接依赖 npm
org.slf4j:jcl-over-slf4j 1.7.28 间接依赖 maven
org.jetbrains.kotlin:kotlin-reflect 1.4.21 间接依赖 maven
:No dependencies 直接依赖 maven
interpret 2.2.0 间接依赖 npm
nanoid 3.3.3 间接依赖 npm
@ungap/promise-all-settled 1.1.2 间接依赖 npm
org.apache.httpcomponents:httpclient 4.5.12 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib-jdk8 1.6.10 间接依赖 maven
get-intrinsic 1.2.0 间接依赖 npm
is-docker 2.2.1 间接依赖 npm
com.googlecode.juniversalchardet:juniversalchardet 1.0.3 间接依赖 maven
normalize-path 3.0.0 间接依赖 npm
atob 2.1.2 间接依赖 npm
@types/estree 0.0.51 间接依赖 npm
ansi-html 0.0.7 间接依赖 npm
org.apache.httpcomponents:httpcore 4.4.13 间接依赖 maven
watchpack 2.4.0 间接依赖 npm
source-map-js 1.0.2 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-jdk7 1.9.0 直接依赖 maven
ws 8.11.0 间接依赖 npm
send 0.18.0 间接依赖 npm
org.jetbrains.compose.runtime:runtime-desktop 1.0.0-alpha1 间接依赖 maven
com.github.virtuald:curvesapi 1.06 间接依赖 maven
com.fasterxml.woodstox:woodstox-core 6.2.4 间接依赖 maven
ajv-keywords 5.1.0 间接依赖 npm
org.jetbrains.compose.ui:ui 1.0.1 间接依赖 maven
safe-buffer 5.2.1 间接依赖 npm
is-path-cwd 2.2.0 间接依赖 npm
org.apache.pdfbox:jempbox 1.8.16 间接依赖 maven
del 6.1.1 间接依赖 npm
io.ktor:ktor-http-cio 1.6.4 间接依赖 maven
com.google.android.gms:play-services-maps 18.1.0 直接依赖 maven
import-local 3.1.0 间接依赖 npm
org.jetbrains.compose.runtime:runtime 1.0.1 间接依赖 maven
org.jetbrains.compose.ui:ui-tooling-preview 1.0.0 间接依赖 maven
commander 2.20.3 间接依赖 npm
org.lwjgl:lwjgl-glfw 3.2.3 直接依赖 maven
strip-ansi 7.0.1 间接依赖 npm
org.jetbrains.compose.runtime:runtime-saveable-desktop 1.0.1 间接依赖 maven
connect-history-api-fallback 1.6.0 间接依赖 npm
com.fasterxml.jackson.dataformat:jackson-dataformat-xml 2.12.5 直接依赖 maven
com.fasterxml.jackson.core:jackson-databind 2.12.5 间接依赖 maven
@webassemblyjs/helper-wasm-section 1.11.1 间接依赖 npm
@types/retry 0.12.0 间接依赖 npm
org.jetbrains.compose.ui:ui-util 1.0.0 间接依赖 maven
karma-sourcemap-loader 0.3.8 直接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
cookie 0.4.2 间接依赖 npm
org.jetbrains.compose.foundation:foundation-layout 1.5.2 间接依赖 maven
com.pff:java-libpst 0.9.3 间接依赖 maven
org.jetbrains.kotlinx:atomicfu 0.17.0 间接依赖 maven
org.jetbrains.compose.material:material-ripple-desktop 1.0.1 间接依赖 maven
com.google.guava:guava 28.2-jre 间接依赖 maven
org.jetbrains.compose.desktop:desktop 1.5.2 直接依赖 maven
eslint-scope 5.1.1 间接依赖 npm
indent-string 4.0.0 间接依赖 npm
org.jdom:jdom2 2.0.6 间接依赖 maven
org.jetbrains.kotlinx:kotlinx-datetime 0.2.0 间接依赖 maven
org.jetbrains.compose.material:material-icons-extended-desktop 1.5.2 间接依赖 maven
node-releases 2.0.10 间接依赖 npm
is-stream 2.0.1 间接依赖 npm
org.jetbrains.compose.foundation:foundation-layout-desktop 1.5.2 间接依赖 maven
punycode 1.3.2 间接依赖 npm
format-util 1.0.5 直接依赖 npm
rimraf 3.0.2 间接依赖 npm
org.jetbrains.compose.material:material-icons-core-desktop 1.0.1 间接依赖 maven
finalhandler 1.2.0 间接依赖 npm
org.gagravarr:vorbis-java-core 0.8 间接依赖 maven
org.apache.pdfbox:jbig2-imageio 3.0.3 间接依赖 maven
com.google.android.gms:play-services-location 21.0.1 直接依赖 maven
org.apache.cxf:cxf-rt-security 3.3.6 间接依赖 maven
array-flatten 1.1.1 间接依赖 npm
ansi-regex 5.0.1 间接依赖 npm
fsevents 2.3.2 直接依赖 npm
bytes 3.0.0 间接依赖 npm
magic-string 0.25.9 间接依赖 npm
com.healthmarketscience.jackcess:jackcess 3.0.1 间接依赖 maven
signal-exit 3.0.7 间接依赖 npm
define-lazy-prop 2.0.0 间接依赖 npm
argparse 2.0.1 间接依赖 npm
webpack-merge 4.2.2 间接依赖 npm
which 1.3.1 间接依赖 npm
@babel/helper-validator-identifier 7.22.5 间接依赖 npm
org.jetbrains.compose.material:material-desktop 1.0.1 间接依赖 maven
compressible 2.0.18 间接依赖 npm
debug 2.6.9 间接依赖 npm
org.jetbrains.compose.ui:ui-graphics 1.5.2 间接依赖 maven
org.bouncycastle:bcpkix-jdk15on 1.65 间接依赖 maven
follow-redirects 1.15.2 间接依赖 npm
org.jetbrains.compose.ui:ui-desktop 1.0.1 间接依赖 maven
com.apollographql.apollo:apollo-runtime 2.3.0 直接依赖 maven
estree-walker 2.0.2 间接依赖 npm
fast-glob 3.2.12 间接依赖 npm
custom-event 1.0.1 间接依赖 npm
querystring 0.2.0 间接依赖 npm
source-map-loader 4.0.0 直接依赖 npm
org.jetbrains.compose.material:material-icons-core 1.0.0-alpha1 间接依赖 maven
org.jetbrains.skiko:skiko-jvm 0.6.6 间接依赖 maven
javax.annotation:javax.annotation-api 1.3.2 间接依赖 maven
org.jetbrains.compose.desktop:desktop 1.0.0-alpha1 直接依赖 maven
neo-async 2.6.2 间接依赖 npm
has-symbols 1.0.3 间接依赖 npm
org.jetbrains.kotlin:kotlin-stdlib-common 1.5.21 间接依赖 maven
has-flag 3.0.0 间接依赖 npm
websocket-extensions 0.1.4 间接依赖 npm
com.zaxxer:SparseBitSet 1.2 间接依赖 maven
isexe 2.0.0 间接依赖 npm
org.jetbrains.compose.runtime:runtime-desktop 1.5.2 间接依赖 maven
ajv-formats 2.1.1 间接依赖 npm
range-parser 1.2.1 间接依赖 npm
commons-io:commons-io 2.6 间接依赖 maven
is-plain-obj 2.1.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
supports-preserve-symlinks-flag 1.0.0 间接依赖 npm
chrome-trace-event 1.0.3 间接依赖 npm
compression 1.7.4 间接依赖 npm
io.ktor:ktor-io 1.6.4 间接依赖 maven
org.checkerframework:checker-qual 2.10.0 间接依赖 maven
serve-index 1.9.1 间接依赖 npm
net.sf.ehcache:ehcache-core 2.6.2 间接依赖 maven
dns-packet 1.3.4 间接依赖 npm
is-ip 3.1.0 间接依赖 npm
tapable 2.2.1 间接依赖 npm
enhanced-resolve 5.15.0 间接依赖 npm
extend 3.0.2 间接依赖 npm
org.jetbrains.compose.ui:ui-geometry-desktop 1.5.2 间接依赖 maven
karma 6.4.0 直接依赖 npm
@rollup/plugin-commonjs 21.1.0 直接依赖 npm
json-schema-traverse 1.0.0 间接依赖 npm
debug 4.3.4 间接依赖 npm
org.quartz-scheduler:quartz 2.3.2 间接依赖 maven
path-key 3.1.1 间接依赖 npm
de.l3s.boilerpipe:boilerpipe 1.1.0 间接依赖 maven
@socket.io/component-emitter 3.1.0 间接依赖 npm
wildcard 2.0.0 间接依赖 npm
cors 2.8.5 间接依赖 npm
@types/resolve 1.17.1 间接依赖 npm
object-inspect 1.12.3 间接依赖 npm
org.jetbrains.compose.ui:ui-util-desktop 1.5.2 间接依赖 maven
y18n 5.0.8 间接依赖 npm
strip-ansi 6.0.1 间接依赖 npm
chokidar 3.5.3 间接依赖 npm
on-headers 1.0.2 间接依赖 npm
org.apache.commons:commons-compress 1.20 间接依赖 maven
picomatch 2.3.1 间接依赖 npm
org.apache.tika:tika-core 1.24.1 间接依赖 maven
wrap-ansi 7.0.0 间接依赖 npm
org.jetbrains.compose.runtime:runtime 1.5.2 间接依赖 maven
color-name 1.1.4 间接依赖 npm
rechoir 0.7.1 间接依赖 npm
org.apache.commons:commons-collections4 4.4 间接依赖 maven
org.jetbrains.compose.desktop:desktop-jvm-linux-x64 1.0.1 直接依赖 maven
karma-chrome-launcher 3.1.1 直接依赖 npm
builtin-modules 3.3.0 间接依赖 npm
spdy-transport 3.0.0 间接依赖 npm
org.apache.xmlbeans:xmlbeans 3.1.0 间接依赖 maven
org.apache.poi:poi-scratchpad 4.1.2 间接依赖 maven
supports-color 7.2.0 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
org.jetbrains.compose.ui:ui-graphics 1.0.0 间接依赖 maven
encodeurl 1.0.2 间接依赖 npm
org.jetbrains.compose.desktop:desktop-jvm-windows-x64 1.0.1 直接依赖 maven
html-entities 2.3.3 间接依赖 npm
has-tostringtag 1.0.0 间接依赖 npm
@webassemblyjs/helper-api-error 1.11.1 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core-jvm 1.5.1 间接依赖 maven
org.jetbrains.compose.material:material-ripple 1.5.2 间接依赖 maven
cookie-signature 1.0.6 间接依赖 npm
org.apache.sis.core:sis-utility 1.0 间接依赖 maven
org.jetbrains.skiko:skiko-awt 0.7.77 直接依赖 maven
js-tokens 4.0.0 间接依赖 npm
org.jetbrains.compose.animation:animation-core 1.0.1 间接依赖 maven
org.jetbrains.kotlin:kotlin-stdlib 1.9.10 间接依赖 maven
org.bouncycastle:bcmail-jdk15on 1.65 间接依赖 maven
flat 5.0.2 间接依赖 npm
sockjs 0.3.24 间接依赖 npm
org.jetbrains.compose.ui:ui-text 1.0.0 间接依赖 maven
serve-static 1.15.0 间接依赖 npm
@webassemblyjs/wasm-edit 1.11.1 间接依赖 npm
androidx.camera:camera-camera2 1.2.3 直接依赖 maven
com.googlecode.json-simple:json-simple 1.1.1 间接依赖 maven
finalhandler 1.1.2 间接依赖 npm
ipaddr.js 1.9.1 间接依赖 npm
org.jetbrains.compose.ui:ui-tooling-preview 1.5.2 间接依赖 maven
acorn 8.10.0 间接依赖 npm
cookie 0.5.0 间接依赖 npm
edu.usc.ir:sentiment-analysis-parser 0.1 间接依赖 maven
function-bind 1.1.1 间接依赖 npm
selfsigned 1.10.14 间接依赖 npm
chalk 2.4.2 间接依赖 npm
karma-mocha 2.0.1 直接依赖 npm
org.opengis:geoapi 3.0.1 间接依赖 maven
org.jetbrains.compose.ui:ui-tooling-preview 1.0.0-alpha1 间接依赖 maven
@webassemblyjs/wasm-gen 1.11.1 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-datetime 0.4.0 直接依赖 maven
setprototypeof 1.1.0 间接依赖 npm
@rollup/pluginutils 3.1.0 间接依赖 npm
rfdc 1.3.0 间接依赖 npm
org.jetbrains.kotlinx:kotlinx-coroutines-core 直接依赖 maven
bonjour 3.5.0 间接依赖 npm
tmp 0.2.1 间接依赖 npm
org.jetbrains.compose.ui:ui-tooling-preview-desktop 1.5.2 间接依赖 maven
randombytes 2.1.0 间接依赖 npm
on-finished 2.4.1 间接依赖 npm
com.nimbusds:nimbus-jose-jwt 6.0 直接依赖 maven
ms 2.1.3 间接依赖 npm
spdy 4.0.2 间接依赖 npm
org.tallison:metadata-extractor 2.13.0 间接依赖 maven
merge2 1.4.1 间接依赖 npm
select-hose 2.0.0 间接依赖 npm
websocket-driver 0.7.4 间接依赖 npm
org.jetbrains.compose.material:material-desktop 1.5.2 间接依赖 maven
webpack-sources 3.2.3 间接依赖 npm
rollup-plugin-terser 7.0.2 直接依赖 npm
bytes 3.1.2 间接依赖 npm
com.healthmarketscience.jackcess:jackcess-encrypt 3.0.0 间接依赖 maven
org.jetbrains.compose.foundation:foundation 1.0.1 间接依赖 maven
merge-descriptors 1.0.1 间接依赖 npm
acorn 8.8.2 间接依赖 npm
depd 1.1.2 间接依赖 npm
org.apache.sis.core:sis-feature 1.0 间接依赖 maven
dns-txt 2.0.2 间接依赖 npm
retry 0.13.1 间接依赖 npm
org.jetbrains.compose.runtime:runtime-saveable 1.0.1 间接依赖 maven
org.jetbrains.compose.ui:ui-geometry 1.0.1 间接依赖 maven
@nodelib/fs.scandir 2.1.5 间接依赖 npm
org.jetbrains.compose.foundation:foundation-layout-desktop 1.0.0-alpha1 间接依赖 maven
yargs-unparser 2.0.0 间接依赖 npm
com.squareup.okio:okio 2.6.0 间接依赖 maven
(0)
上一篇 2023年10月31日
下一篇 2023年10月31日

相关推荐

  • cburmeister/flask-bones 软件分析报告

    基础信息 项目名称:cburmeister/flask-bones 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716594546259394560/1716594546326503424 此报告由Murphy…

    软件分析 2023年10月24日
    0
  • csxiaoyaojianxian/JavaScriptStudy 软件分析报告

    基础信息 项目名称:csxiaoyaojianxian/JavaScriptStudy 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721116607844974592/1725685056327864320 …

    软件分析 2023年11月18日
    0
  • awslabs/chalice 软件分析报告

    基础信息 项目名称:awslabs/chalice 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1730716748843274240/1730716748914577408 此报告由Murphysec提供 漏洞…

    软件分析 2023年12月2日
    0
  • znck/vuepack 软件分析报告

    基础信息 项目名称:znck/vuepack 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1724846038571245568/1724846038621577216 此报告由Murphysec提供 漏洞列表 …

    软件分析 2023年11月16日
    0
  • hathach/tinyusb 软件分析报告

    基础信息 项目名称:hathach/tinyusb 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718507821679116288/1718507821792362496 此报告由Murphysec提供 漏洞…

    软件分析 2023年10月29日
    0