jedireza/frame 软件分析报告

基础信息

项目名称:jedireza/frame

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1719048531754139648/1719048531921911808

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
mixin-deep 参数注入漏洞 参数注入或修改 MPS-2019-10507 CVE-2019-10746 严重
eslint-utils 代码注入 MPS-2019-10659 CVE-2019-15657 严重
handlebars 原型污染漏洞 原型污染 MPS-2019-16888 CVE-2019-19919 严重
kind-of 存在注入漏洞 将资源暴露给错误范围 MPS-2019-17164 CVE-2019-20149 高危
lodash 原型污染漏洞 拒绝服务 MPS-2019-8636 CVE-2019-10744 严重
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
handlebars 代码注入漏洞 代码注入 MPS-2020-13732 CVE-2019-20920 高危
handlebars 安全漏洞 不可达退出条件的循环(无限循环) MPS-2020-13734 CVE-2019-20922 高危
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
Nodemailer 注入 MPS-2020-15702 CVE-2020-7769 严重
dot-prop 原型污染漏洞 原型污染 MPS-2020-1734 CVE-2020-8116 高危
Yargs Y18n 输入原型污染漏洞 动态确定对象属性修改的控制不恰当 MPS-2020-17543 CVE-2020-7774 严重
Ini 拒绝服务 MPS-2020-17544 CVE-2020-7788 高危
undefsafe 注入漏洞 注入 MPS-2020-2617 CVE-2019-10795 中危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
yargs-parser 原型污染漏洞 特权定义了不安全动作 MPS-2020-4006 CVE-2020-7608 中危
BSON 序列化绕过漏洞 反序列化 MPS-2020-4726 CVE-2020-7610 严重
js-bson 反序列化 MPS-2020-4759 CVE-2019-2391 中危
bcrypt 加密问题漏洞 加密强度不足 MPS-2020-9756 CVE-2020-7689 高危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-11547 CVE-2021-32804 高危
node-tar 路径遍历漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-11548 CVE-2021-32803 高危
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28486 CVE-2021-37701 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28488 CVE-2021-37712 高危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-28489 CVE-2021-37713 高危
validator.js 拒绝服务漏洞 拒绝服务 MPS-2021-31021 CVE-2021-3765 高危
marked 存在拒绝服务漏洞 ReDoS MPS-2021-37038 CVE-2022-21680 高危
marked 存在拒绝服务漏洞 过度严格的正则表达式 MPS-2021-37039 CVE-2022-21681 高危
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
handlebars 远程代码执行 (RCE) 漏洞 代码注入 MPS-2021-4548 CVE-2021-23369 严重
handlebars 原型污染 MPS-2021-6180 CVE-2021-23383 严重
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
Nodemailer 注入漏洞 注入 MPS-2021-9219 CVE-2021-23400 高危
Moment.js 正则拒绝服务漏洞 拒绝服务 MPS-2022-11159 CVE-2022-31129 高危
acorn 存在拒绝服务漏洞 拒绝服务 MPS-2022-13525 高危
bcrypt 存在密码学问题漏洞 密码学问题 MPS-2022-13573 中危
confidence 存在原型污染漏洞 原型污染 MPS-2022-13606 低危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13732 高危
handlebars 存在代码注入漏洞 代码注入 MPS-2022-13733 高危
handlebars 存在拒绝服务漏洞 拒绝服务 MPS-2022-13734 严重
handlebars 拒绝服务 MPS-2022-13735 中危
@hapi/accept 存在拒绝服务漏洞 拒绝服务 MPS-2022-13739 高危
@hapi/ammo 存在拒绝服务漏洞 拒绝服务 MPS-2022-13740 高危
@hapi/hoek 存在原型污染漏洞 原型污染 MPS-2022-13742 中危
@hapi/statehood 存在ReDoS漏洞 ReDoS MPS-2022-13743 中危
@hapi/subtext 存在拒绝服务漏洞 拒绝服务 MPS-2022-13745 高危
@hapi/subtext 存在原型污染漏洞 原型污染 MPS-2022-13747 高危
@hapi/subtext 存在拒绝服务漏洞 拒绝服务 MPS-2022-13748 高危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
marked 存在拒绝服务漏洞 拒绝服务 MPS-2022-13862 中危
marked ReDoS MPS-2022-13864 中危
swagger-ui-dist 存在关键信息的UI错误表达漏洞 关键信息的UI错误表达 MPS-2022-14075 中危
tar 正则表达式拒绝服务漏洞 拒绝服务 MPS-2022-14081 低危
uglify-js ReDoS MPS-2022-14112 中危
validator 拒绝服务 MPS-2022-14122 中危
validator 拒绝服务 MPS-2022-14123 中危
validator 拒绝服务 MPS-2022-14124 中危
got 存在打开重定向漏洞 跨站重定向 MPS-2022-19247 CVE-2022-33987 中危
Moment.js 路径遍历漏洞 路径遍历 MPS-2022-3752 CVE-2022-24785 中危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
decode-uri-component 拒绝服务 MPS-2022-56259 CVE-2022-38900 高危
hoek 安全漏洞 原型污染 MPS-2022-57758 CVE-2020-36604 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
Swagger UI URL注入漏洞 注入 MPS-2022-6241 CVE-2018-25031 中危
swagger-ui-dist 安全漏洞 渲染 UI 层或帧的不当限制 MPS-2022-6243 CVE-2021-46708 中危
needle 存在Authorization请求头泄露漏洞 未授权敏感信息泄露 MPS-2022-7866 中危
fsevents 安全漏洞 代码注入 MPS-2ipy-muq0 CVE-2023-45311 严重

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
mixin-deep 1.3.1 1.3.2 间接依赖 建议修复
glob-parent 3.1.0 5.1.2 间接依赖 建议修复
@hapi/ammo 3.1.0 3.1.2 间接依赖 建议修复
@hapi/accept 3.2.2 3.2.4 间接依赖 建议修复
decode-uri-component 0.2.0 0.2.1 间接依赖 建议修复
swagger-ui-dist 3.22.3 4.1.3 间接依赖 建议修复
ini 1.3.5 1.3.6 间接依赖 建议修复
bson 1.1.1 1.1.4 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
@hapi/hoek 7.1.0 8.5.1 间接依赖 建议修复
acorn 6.1.1 6.4.1 间接依赖 建议修复
minimist 0.0.8 1.2.6 间接依赖 建议修复
lodash 4.17.11 4.17.21 间接依赖 建议修复
tar 4.4.10 4.4.18 间接依赖 建议修复
dot-prop 4.2.0 4.2.1 间接依赖 建议修复
bcrypt 3.0.6 5.0.0 直接依赖 建议修复
eslint-utils 1.3.1 1.4.1 间接依赖 建议修复
nodemailer 6.2.1 6.6.1 直接依赖 建议修复
handlebars 4.1.2 4.7.7 间接依赖 建议修复
y18n 4.0.0 4.0.1 间接依赖 建议修复
validator 10.11.0 13.7.0 间接依赖 建议修复
@hapi/subtext 6.1.0 6.1.3 间接依赖 建议修复
fsevents 1.2.9 1.2.11 间接依赖 可选修复
got 6.7.1 11.8.5 间接依赖 可选修复
ajv 6.10.0 6.12.3 间接依赖 可选修复
marked 0.6.2 4.0.10 间接依赖 可选修复
uglify-js 3.6.0 3.14.3 间接依赖 可选修复
confidence 4.0.2 5.0.1 直接依赖 可选修复
kind-of 6.0.2 6.0.3 间接依赖 可选修复
@hapi/statehood 6.1.0 7.0.4 间接依赖 可选修复
yargs-parser 13.1.1 13.1.2 间接依赖 可选修复
moment 2.24.0 2.29.4 间接依赖 可选修复
semver 5.7.0 7.5.2 间接依赖 可选修复
undefsafe 2.0.2 2.0.3 间接依赖 可选修复
needle 2.4.0 3.1.0 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 268
ISC 54
BSD-3-Clause 57
BSD-2-Clause 11
Apache-2.0 11
BSD 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
crypto-random-string 1.0.0 间接依赖 npm
registry-url 3.1.0 间接依赖 npm
fsevents 1.2.9 间接依赖 npm
require-main-filename 2.0.0 间接依赖 npm
boxen 1.3.0 间接依赖 npm
url-parse-lax 1.0.0 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
yallist 2.1.2 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
@hapi/teamwork 3.3.1 间接依赖 npm
uri-js 4.2.2 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
registry-auth-token 3.4.0 间接依赖 npm
inherits 2.0.3 间接依赖 npm
is-fullwidth-code-point 1.0.0 间接依赖 npm
array-uniq 1.0.3 间接依赖 npm
npm-packlist 1.4.1 间接依赖 npm
p-defer 1.0.0 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
code-point-at 1.1.0 间接依赖 npm
external-editor 3.0.3 间接依赖 npm
y18n 4.0.0 间接依赖 npm
wordwrap 0.0.3 间接依赖 npm
resolve-from 2.0.0 间接依赖 npm
stream-shift 1.0.0 间接依赖 npm
nice-try 1.0.5 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
pify 4.0.1 间接依赖 npm
expand-brackets 2.1.4 间接依赖 npm
is-obj 1.0.1 间接依赖 npm
astral-regex 1.0.0 间接依赖 npm
assign-symbols 1.0.0 间接依赖 npm
@hapi/rule-capitalize-modules 1.2.0 间接依赖 npm
@hapi/rule-scope-start 2.2.0 间接依赖 npm
rxjs 6.5.2 间接依赖 npm
promptly 3.0.3 直接依赖 npm
kind-of 6.0.2 间接依赖 npm
lowercase-keys 1.0.1 间接依赖 npm
swagger-ui-dist 3.22.3 间接依赖 npm
hapi-remote-address 1.0.0 直接依赖 npm
fast-glob 2.2.7 间接依赖 npm
@hapi/somever 2.1.0 间接依赖 npm
@types/node 12.0.8 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
@hapi/mimos 4.1.0 间接依赖 npm
configstore 3.1.2 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
mongo-models 3.0.1 直接依赖 npm
split-string 3.1.0 间接依赖 npm
@nodelib/fs.stat 1.1.3 间接依赖 npm
sax 1.2.4 间接依赖 npm
chownr 1.1.1 间接依赖 npm
@hapi/nigel 3.1.0 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
pumpify 1.5.1 间接依赖 npm
minimist 0.0.8 间接依赖 npm
mixin-deep 1.3.1 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
@types/events 3.0.0 间接依赖 npm
mem 4.3.0 间接依赖 npm
eslint 5.16.0 间接依赖 npm
hapi-mongo-models 8.0.1 直接依赖 npm
is-number 3.0.0 间接依赖 npm
commander 2.20.0 间接依赖 npm
@hapi/boom 7.4.2 间接依赖 npm
@hapi/wreck 15.0.1 间接依赖 npm
cross-spawn 6.0.5 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
component-emitter 1.3.0 间接依赖 npm
format-util 1.0.3 间接依赖 npm
swagger-methods 1.0.8 间接依赖 npm
@hapi/topo 3.1.0 间接依赖 npm
lodash.isequal 4.5.0 间接依赖 npm
handlebars 4.1.2 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
which-module 2.0.0 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
console-control-strings 1.1.0 间接依赖 npm
moment 2.24.0 间接依赖 npm
optimist 0.6.1 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
number-is-nan 1.0.1 间接依赖 npm
@hapi/good-console 8.1.0 直接依赖 npm
upath 1.1.2 间接依赖 npm
is-retry-allowed 1.1.0 间接依赖 npm
@hapi/iron 5.1.0 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
extglob 2.0.4 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
mime-db 1.40.0 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
is-descriptor 0.1.6 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
chardet 0.7.0 间接依赖 npm
timed-out 4.0.1 间接依赖 npm
@hapi/eslint-plugin-hapi 4.3.3 间接依赖 npm
needle 2.4.0 间接依赖 npm
lodash 4.17.11 间接依赖 npm
is-glob 4.0.1 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
is-promise 2.1.0 间接依赖 npm
source-map-support 0.5.12 间接依赖 npm
js-yaml 3.13.1 间接依赖 npm
braces 2.3.2 间接依赖 npm
rc 1.2.8 间接依赖 npm
base 0.11.2 间接依赖 npm
@hapi/bossy 4.1.1 间接依赖 npm
emoji-regex 7.0.3 直接依赖 npm
map-age-cleaner 0.1.3 间接依赖 npm
@hapi/bourne 1.3.2 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
espree 5.0.1 间接依赖 npm
@hapi/shot 4.1.0 间接依赖 npm
chokidar 2.1.6 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
p-limit 2.2.0 间接依赖 npm
@babel/code-frame 7.0.0 间接依赖 npm
abbrev 1.1.1 间接依赖 npm
wrap-ansi 5.1.0 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
cli-cursor 2.1.0 间接依赖 npm
glob-to-regexp 0.3.0 间接依赖 npm
find-rc 4.0.0 间接依赖 npm
node-pre-gyp 0.12.0 间接依赖 npm
callsites 3.1.0 间接依赖 npm
ret 0.1.15 间接依赖 npm
@hapi/ammo 3.1.0 间接依赖 npm
slash 2.0.0 间接依赖 npm
@hapi/glue 6.1.0 直接依赖 npm
acorn 6.1.1 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
touch 3.1.0 间接依赖 npm
term-size 1.2.0 间接依赖 npm
fast-deep-equal 2.0.1 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
is-installed-globally 0.1.0 间接依赖 npm
unique-string 1.0.0 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
require_optional 1.0.1 间接依赖 npm
locate-path 3.0.0 间接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
ono 4.0.11 间接依赖 npm
dir-glob 2.2.2 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
through 2.3.8 间接依赖 npm
type-check 0.3.2 间接依赖 npm
@hapi/vise 3.1.0 间接依赖 npm
diff 4.0.1 间接依赖 npm
mongodb 3.2.7 直接依赖 npm
is-ci 1.2.1 间接依赖 npm
@types/minimatch 3.0.3 间接依赖 npm
osenv 0.1.5 间接依赖 npm
is-npm 1.0.0 间接依赖 npm
write 1.0.3 间接依赖 npm
is-binary-path 1.0.1 间接依赖 npm
@hapi/hoek 7.1.0 间接依赖 npm
esrecurse 4.2.1 间接依赖 npm
path-key 2.0.1 间接依赖 npm
nodemailer 6.2.1 直接依赖 npm
semver-diff 2.1.0 间接依赖 npm
@hapi/inert 5.2.0 直接依赖 npm
fast-json-stable-stringify 2.0.0 间接依赖 npm
hapi-swagger 10.0.2 直接依赖 npm
cliui 5.0.0 间接依赖 npm
nodemon 1.19.1 直接依赖 npm
are-we-there-yet 1.1.5 间接依赖 npm
duplexify 3.7.1 间接依赖 npm
nodemailer-markdown 1.0.3 直接依赖 npm
will-call 1.0.1 间接依赖 npm
slice-ansi 2.1.0 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
snapdragon 0.8.2 间接依赖 npm
detect-libc 1.0.3 间接依赖 npm
eslint-scope 4.0.3 间接依赖 npm
lodash.get 4.4.2 间接依赖 npm
@hapi/rule-no-var 1.1.3 间接依赖 npm
write-file-atomic 2.4.3 间接依赖 npm
sparse-bitfield 3.0.3 间接依赖 npm
global-dirs 0.1.1 间接依赖 npm
inflight 1.0.6 间接依赖 npm
dot-prop 4.2.0 间接依赖 npm
npm-bundled 1.0.6 间接依赖 npm
optionator 0.8.2 间接依赖 npm
@types/glob 7.1.1 间接依赖 npm
ignore 4.0.6 间接依赖 npm
uuid 3.3.2 直接依赖 npm
nopt 4.0.1 间接依赖 npm
undefsafe 2.0.2 间接依赖 npm
text-table 0.2.0 间接依赖 npm
minizlib 1.2.1 间接依赖 npm
@hapi/heavy 6.2.0 间接依赖 npm
is-buffer 1.1.6 直接依赖 npm
call-me-maybe 1.0.1 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
pstree.remy 1.1.7 间接依赖 npm
os-locale 3.1.0 间接依赖 npm
unzip-response 2.0.1 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
strip-json-comments 2.0.1 间接依赖 npm
esquery 1.0.1 间接依赖 npm
string-width 1.0.2 间接依赖 npm
@hapi/bounce 1.3.0 间接依赖 npm
useragent 2.3.0 直接依赖 npm
resolve-url 0.2.1 间接依赖 npm
got 6.7.1 间接依赖 npm
execa 1.0.0 间接依赖 npm
@hapi/basic 5.1.0 直接依赖 npm
array-union 1.0.2 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
color-name 1.1.3 间接依赖 npm
has-unicode 2.0.1 间接依赖 npm
supports-color 6.1.0 间接依赖 npm
joistick 1.0.1 直接依赖 npm
find-up 3.0.0 间接依赖 npm
tslib 1.10.0 间接依赖 npm
file-entry-cache 5.0.1 间接依赖 npm
end-of-stream 1.4.1 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
urix 0.1.0 间接依赖 npm
esutils 2.0.2 间接依赖 npm
gauge 2.7.4 间接依赖 npm
pump 2.0.1 间接依赖 npm
doctrine 3.0.0 间接依赖 npm
repeat-string 1.6.1 间接依赖 npm
cli-boxes 1.0.0 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
marked 0.6.2 间接依赖 npm
source-map-url 0.4.0 间接依赖 npm
debug 3.2.6 间接依赖 npm
latest-version 3.1.0 间接依赖 npm
@hapi/code 5.3.1 直接依赖 npm
make-dir 1.3.0 间接依赖 npm
@hapi/rule-no-arrowception 1.1.1 间接依赖 npm
delegates 1.0.0 间接依赖 npm
create-error-class 3.0.2 间接依赖 npm
@hapi/accept 3.2.2 间接依赖 npm
nanomatch 1.2.13 间接依赖 npm
get-stream 4.1.0 间接依赖 npm
ci-info 1.6.0 间接依赖 npm
snapdragon-node 2.1.1 间接依赖 npm
flat-cache 2.0.1 间接依赖 npm
isobject 3.0.1 间接依赖 npm
typescript 3.5.2 间接依赖 npm
aproba 1.2.0 间接依赖 npm
p-is-promise 2.1.0 间接依赖 npm
globals 11.12.0 间接依赖 npm
semver 5.7.0 间接依赖 npm
@hapi/good-squeeze 5.2.0 直接依赖 npm
safe-regex 1.1.0 间接依赖 npm
@hapi/oppsy 2.1.1 间接依赖 npm
@babel/highlight 7.0.0 间接依赖 npm
snapdragon-util 3.0.1 间接依赖 npm
is-path-inside 1.0.1 间接依赖 npm
fs-minipass 1.2.6 间接依赖 npm
onetime 2.0.1 间接依赖 npm
@hapi/joi 15.0.3 间接依赖 npm
xdg-basedir 3.0.0 间接依赖 npm
readdirp 2.2.1 间接依赖 npm
ms 2.1.2 间接依赖 npm
fill-range 4.0.0 间接依赖 npm
alce 1.2.0 间接依赖 npm
@hapi/hapi 18.3.1 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
uglify-js 3.6.0 间接依赖 npm
camelcase 5.3.1 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
eslint-visitor-keys 1.0.0 间接依赖 npm
argparse 1.0.10 间接依赖 npm
ansi-escapes 3.2.0 间接依赖 npm
@hapi/good 8.2.0 直接依赖 npm
graceful-fs 4.1.15 间接依赖 npm
@hapi/lab 19.1.0 直接依赖 npm
tmp 0.0.33 间接依赖 npm
npm-run-path 2.0.2 间接依赖 npm
to-regex-range 2.1.1 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
atob 2.1.2 间接依赖 npm
tar 4.4.10 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
ansi-align 2.0.0 间接依赖 npm
z-schema 3.25.1 间接依赖 npm
@hapi/rule-for-loop 1.2.0 间接依赖 npm
async-each 1.0.3 间接依赖 npm
esprima 1.2.5 间接依赖 npm
package-json 4.0.1 间接依赖 npm
os-homedir 1.0.2 间接依赖 npm
duplexer3 0.1.4 间接依赖 npm
@hapi/b64 4.2.0 间接依赖 npm
estraverse 1.9.3 间接依赖 npm
bcrypt 3.0.6 直接依赖 npm
confidence 4.0.2 直接依赖 npm
@hapi/pez 4.1.0 间接依赖 npm
restore-cursor 2.0.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
@hapi/subtext 6.1.0 间接依赖 npm
glob-parent 3.1.0 间接依赖 npm
which 1.3.1 间接依赖 npm
is-redirect 1.0.0 间接依赖 npm
pascalcase 0.1.1 间接依赖 npm
binary-extensions 1.13.1 间接依赖 npm
mute-stream 0.0.7 间接依赖 npm
mongodb-core 3.2.7 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
figures 2.0.0 间接依赖 npm
deep-extend 0.6.0 间接依赖 npm
regexpp 2.0.1 间接依赖 npm
@mrmlnc/readdir-enhanced 2.2.1 间接依赖 npm
repeat-element 1.1.3 间接依赖 npm
@hapi/vision 5.5.2 直接依赖 npm
validator 10.11.0 间接依赖 npm
fast-safe-stringify 2.0.6 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
readable-stream 2.3.6 间接依赖 npm
array-unique 0.3.2 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
eslint-utils 1.3.1 间接依赖 npm
run-async 2.3.0 间接依赖 npm
@hapi/podium 3.4.0 间接依赖 npm
use 3.1.1 间接依赖 npm
deep-is 0.1.3 间接依赖 npm
wide-align 1.1.3 间接依赖 npm
@hapi/call 5.1.0 间接依赖 npm
isarray 1.0.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
p-locate 3.0.0 间接依赖 npm
unicode 11.0.1 间接依赖 npm
chalk 2.4.2 间接依赖 npm
path-dirname 1.0.2 间接依赖 npm
ajv 6.10.0 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
bson 1.1.1 间接依赖 npm
cache-base 1.0.1 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
@hapi/catbox 10.2.1 间接依赖 npm
process-nextick-args 2.0.0 间接依赖 npm
path-is-inside 1.0.2 间接依赖 npm
path-type 3.0.0 间接依赖 npm
acorn-jsx 5.0.1 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
isexe 2.0.0 间接依赖 npm
class-utils 0.3.6 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
@hapi/statehood 6.1.0 间接依赖 npm
table 5.4.1 间接依赖 npm
json-schema-ref-parser 6.1.0 间接依赖 npm
cli-width 2.2.0 间接依赖 npm
nan 2.13.2 间接依赖 npm
@hapi/content 4.1.0 间接依赖 npm
ignore-walk 3.0.1 间接依赖 npm
punycode 2.1.1 间接依赖 npm
import-lazy 2.1.0 间接依赖 npm
yargs 13.2.4 间接依赖 npm
remove-trailing-separator 1.1.0 直接依赖 npm
dotenv 8.0.0 直接依赖 npm
strip-eof 1.0.0 间接依赖 npm
rimraf 2.6.3 间接依赖 npm
neo-async 2.6.1 间接依赖 npm
saslprep 1.0.3 间接依赖 npm
swagger-parser 4.0.2 间接依赖 npm
npmlog 4.1.2 间接依赖 npm
is-extendable 0.1.1 间接依赖 npm
merge2 1.2.3 间接依赖 npm
inquirer 6.3.1 间接依赖 npm
source-map-resolve 0.5.2 间接依赖 npm
yargs-parser 13.1.1 间接依赖 npm
@hapi/cryptiles 4.2.0 间接依赖 npm
once 1.4.0 间接依赖 npm
map-cache 0.2.2 间接依赖 npm
seedrandom 2.4.4 间接依赖 npm
swagger-schema-official 2.0.0-bab6bed 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
update-notifier 2.5.0 间接依赖 npm
globby 9.2.0 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
@hapi/eslint-config-hapi 12.1.0 间接依赖 npm
slug 1.1.0 直接依赖 npm
ignore-by-default 1.0.1 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
decode-uri-component 0.2.0 间接依赖 npm
read 1.0.7 间接依赖 npm
flatted 2.0.0 间接依赖 npm
@hapi/catbox-memory 4.1.0 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
import-fresh 3.0.0 间接依赖 npm
@hapi/address 2.0.0 间接依赖 npm
define-property 2.0.2 间接依赖 npm
source-map 0.6.1 间接依赖 npm
progress 2.0.3 间接依赖 npm
minipass 2.3.5 间接依赖 npm
prelude-ls 1.1.2 间接依赖 npm
memory-pager 1.5.0 间接依赖 npm
glob 7.1.4 间接依赖 npm
levn 0.3.0 间接依赖 npm
http-status 1.3.2 间接依赖 npm
core-js 2.6.9 间接依赖 npm
lru-cache 4.1.5 间接依赖 npm
ini 1.3.5 间接依赖 npm
widest-line 2.0.1 间接依赖 npm
lcid 2.0.0 间接依赖 npm
invert-kv 2.0.0 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
(0)
上一篇 2023年10月31日
下一篇 2023年10月31日

相关推荐

  • yansongda/laravel-pay 软件分析报告

    基础信息 项目名称:yansongda/laravel-pay 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721643498042073088/1721643498079821824 此报告由Murphyse…

    软件分析 2023年11月7日
    0
  • wgzhao/Addax 软件分析报告

    基础信息 项目名称:wgzhao/Addax 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721370496345862144/1721370496408776704 此报告由Murphysec提供 漏洞列表 …

    软件分析 2023年11月6日
    0
  • iluuu1994/Pathbar 软件分析报告

    基础信息 项目名称:iluuu1994/Pathbar 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718793632580501504/1718793632689553408 此报告由Murphysec提供 …

    软件分析 2023年10月30日
    0
  • CrowdHailer/raxx 软件分析报告

    基础信息 项目名称:CrowdHailer/raxx 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721113459336220672/1729261143417380864 此报告由Murphysec提供 漏…

    软件分析 2023年11月28日
    0
  • IBM/IPFSfB 软件分析报告

    基础信息 项目名称:IBM/IPFSfB 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718755043535798272/1718755043594518528 此报告由Murphysec提供 漏洞列表 暂无…

    软件分析 2023年10月30日
    0