idealclover/Easy-to-RSS 软件分析报告

基础信息

项目名称:idealclover/Easy-to-RSS

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1718767028261224448/1718767028311556096

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
eslint-utils 代码注入 MPS-2019-10659 CVE-2019-15657 严重
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
acorn 存在拒绝服务漏洞 拒绝服务 MPS-2022-13525 高危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
acorn 6.0.4 6.4.1 间接依赖 建议修复
minimist 0.0.8 1.2.6 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
eslint-utils 1.3.1 1.4.1 间接依赖 建议修复
lodash 4.17.14 4.17.21 间接依赖 建议修复
ajv 6.6.2 6.12.3 间接依赖 可选修复
semver 5.6.0 7.5.2 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 86
BSD-2-Clause 7
ISC 15
Apache-2.0 4
BSD-3-Clause 3

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
ajv 6.6.2 间接依赖 npm
minimist 0.0.8 间接依赖 npm
resolve-from 1.0.1 间接依赖 npm
argparse 1.0.10 间接依赖 npm
cross-spawn 6.0.5 间接依赖 npm
strip-ansi 4.0.0 间接依赖 npm
eslint 5.10.0 直接依赖 npm
ansi-regex 4.0.0 间接依赖 npm
progress 2.0.3 间接依赖 npm
ansi-escapes 3.1.0 间接依赖 npm
color-name 1.1.3 间接依赖 npm
string-width 2.1.1 间接依赖 npm
esrecurse 4.2.1 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
estraverse 4.2.0 间接依赖 npm
mimic-fn 1.2.0 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
astral-regex 1.0.0 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
ms 2.1.1 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
levn 0.3.0 间接依赖 npm
esutils 2.0.2 间接依赖 npm
@babel/highlight 7.0.0 间接依赖 npm
slice-ansi 2.0.0 间接依赖 npm
file-entry-cache 2.0.0 间接依赖 npm
path-key 2.0.1 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
path-is-inside 1.0.2 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
rxjs 6.3.3 间接依赖 npm
semver 5.6.0 间接依赖 npm
mute-stream 0.0.7 间接依赖 npm
pluralize 7.0.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
graceful-fs 4.1.15 间接依赖 npm
acorn-jsx 5.0.1 间接依赖 npm
external-editor 3.0.3 间接依赖 npm
lodash 4.17.14 间接依赖 npm
fast-deep-equal 2.0.1 间接依赖 npm
strip-ansi 5.0.0 间接依赖 npm
once 1.4.0 间接依赖 npm
optionator 0.8.2 间接依赖 npm
wordwrap 1.0.0 间接依赖 npm
tslib 1.9.3 间接依赖 npm
table 5.1.1 间接依赖 npm
glob 7.1.3 间接依赖 npm
@babel/code-frame 7.0.0 间接依赖 npm
which 1.3.1 间接依赖 npm
chardet 0.7.0 间接依赖 npm
doctrine 2.1.0 间接依赖 npm
is-promise 2.1.0 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
run-async 2.3.0 间接依赖 npm
tmp 0.0.33 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
espree 5.0.0 间接依赖 npm
flat-cache 1.3.4 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
regexpp 2.0.1 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
circular-json 0.3.3 间接依赖 npm
ignore 4.0.6 间接依赖 npm
require-uncached 1.0.3 间接依赖 npm
inquirer 6.2.1 间接依赖 npm
write 0.2.1 间接依赖 npm
nice-try 1.0.5 间接依赖 npm
prelude-ls 1.1.2 间接依赖 npm
esquery 1.0.1 间接依赖 npm
rimraf 2.6.2 间接依赖 npm
esprima 4.0.1 间接依赖 npm
chalk 2.4.1 间接依赖 npm
type-check 0.3.2 间接依赖 npm
inherits 2.0.3 间接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
isexe 2.0.0 间接依赖 npm
caller-path 0.1.0 间接依赖 npm
punycode 2.1.1 间接依赖 npm
js-yaml 3.13.1 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
ansi-regex 3.0.0 间接依赖 npm
eslint-visitor-keys 1.0.0 间接依赖 npm
onetime 2.0.1 间接依赖 npm
inflight 1.0.6 间接依赖 npm
strip-json-comments 2.0.1 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
debug 4.1.0 间接依赖 npm
figures 2.0.0 间接依赖 npm
text-table 0.2.0 间接依赖 npm
callsites 0.2.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
through 2.3.8 间接依赖 npm
cli-cursor 2.1.0 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
acorn 6.0.4 间接依赖 npm
restore-cursor 2.0.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
globals 11.9.0 间接依赖 npm
fast-json-stable-stringify 2.0.0 间接依赖 npm
cli-width 2.2.0 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
eslint-scope 4.0.0 间接依赖 npm
uri-js 4.2.2 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
deep-is 0.1.3 间接依赖 npm
eslint-utils 1.3.1 间接依赖 npm
(0)
上一篇 2023年10月30日
下一篇 2023年10月30日

相关推荐

  • ivo-georgiev/ukfLib 软件分析报告

    基础信息 项目名称:ivo-georgiev/ukfLib 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718922704118923264/1718922704769040384 此报告由Murphysec提…

    软件分析 2023年10月30日
    0
  • CraryPrimitiveMan/awesome-php-zh_CN 软件分析报告

    基础信息 项目名称:CraryPrimitiveMan/awesome-php-zh_CN 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721109484381736960/173017816597419622…

    软件分析 2023年11月30日
    0
  • jhough10/centurion 软件分析报告

    基础信息 项目名称:jhough10/centurion 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721308052580761600/1729752079806713856 此报告由Murphysec提供…

    软件分析 2023年11月29日
    0
  • gztchan/awesome-design 软件分析报告

    基础信息 项目名称:gztchan/awesome-design 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718408235290771456/1718408235332714496 此报告由Murphys…

    软件分析 2023年10月29日
    0
  • ankurp/Dollar.swift 软件分析报告

    基础信息 项目名称:ankurp/Dollar.swift 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715847269207113728/1715847269618155520 此报告由Murphysec提…

    软件分析 2023年10月23日
    0