howdyai/botkit 软件分析报告

基础信息

项目名称:howdyai/botkit

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1718666155752472576/1718666155786027008

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
istanbul-reports 通过 window.opener 访问使用指向不受信任目标的 Web 链接 MPS-2022-13797 中危
parse-url跨站脚本漏洞 XSS MPS-2022-20044 CVE-2022-2217 中危
parse-url SSRF漏洞 SSRF MPS-2022-20045 CVE-2022-2216 严重
parse-url 跨站脚本漏洞 XSS MPS-2022-20046 CVE-2022-2218 中危
parse-url 未授权敏感信息泄露 MPS-2022-4780 CVE-2022-0722 高危
http-cache-semantics 安全漏洞 ReDoS MPS-2022-5164 CVE-2022-25881 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
parse-url SSRF MPS-2022-54120 CVE-2022-2900 严重
mocha ReDoS 漏洞 ReDoS MPS-2022-54598 高危
parse-url 安全漏洞 输入的错误解释 MPS-2022-57049 CVE-2022-3224 中危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
Tauri 原型污染漏洞 原型污染 MPS-2022-65568 CVE-2022-46175 高危
word-wrap 安全漏洞 ReDoS MPS-2023-5109 CVE-2023-26115 高危
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
Babel 插件任意代码执行漏洞漏洞【Poc公开】 不完整的黑名单 MPS-avb9-j50z CVE-2023-45133 严重

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
parse-url 6.0.0 8.1.0 间接依赖 建议修复
@babel/traverse 7.17.3 7.23.2 间接依赖 建议修复
mocha 9.2.2 直接依赖 建议修复
word-wrap 1.2.3 1.2.4 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
json5 2.2.0 2.2.2 间接依赖 建议修复
lodash.template 4.5.0 间接依赖 可选修复
request 2.88.2 间接依赖 可选修复
istanbul-reports 3.0.5 3.1.3 间接依赖 可选修复
semver 7.3.5 7.5.2 间接依赖 可选修复
http-cache-semantics 4.1.0 4.1.1 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 440
ISC 105
BSD-3-Clause 13
BSD 1
BSD-2-Clause 12
Apache-2.0 13
CC-BY-4.0 1
0BSD 1
CC-BY-3.0 1
CC0-1.0 1
Artistic-2.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
array-union 2.1.0 间接依赖 npm
spdx-expression-parse 3.0.1 间接依赖 npm
strip-bom 4.0.0 间接依赖 npm
@nodelib/fs.stat 2.0.5 间接依赖 npm
read-package-json 2.1.2 间接依赖 npm
dezalgo 1.0.3 间接依赖 npm
gensync 1.0.0-beta.2 间接依赖 npm
is-obj 2.0.0 间接依赖 npm
@lerna/query-graph 4.0.0 间接依赖 npm
@babel/traverse 7.17.3 间接依赖 npm
js-tokens 4.0.0 间接依赖 npm
duplexer 0.1.2 间接依赖 npm
byte-size 7.0.1 间接依赖 npm
fast-deep-equal 3.1.3 间接依赖 npm
minipass-json-stream 1.0.1 间接依赖 npm
load-json-file 6.2.0 间接依赖 npm
eslint-import-resolver-node 0.3.6 间接依赖 npm
@npmcli/node-gyp 1.0.3 间接依赖 npm
shebang-regex 3.0.0 间接依赖 npm
type-fest 0.20.2 间接依赖 npm
istanbul-lib-hook 3.0.0 间接依赖 npm
uuid 3.4.0 间接依赖 npm
@lerna/publish 4.0.0 间接依赖 npm
node-releases 2.0.2 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
@typescript-eslint/visitor-keys 5.16.0 间接依赖 npm
@octokit/plugin-paginate-rest 2.17.0 间接依赖 npm
console-control-strings 1.1.0 间接依赖 npm
delegates 1.0.0 间接依赖 npm
optionator 0.9.1 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
validate-npm-package-name 3.0.0 间接依赖 npm
readable-stream 2.3.7 间接依赖 npm
slash 3.0.0 间接依赖 npm
yargs-parser 20.2.9 间接依赖 npm
JSONStream 1.3.5 间接依赖 npm
npm-registry-fetch 11.0.0 间接依赖 npm
@typescript-eslint/scope-manager 5.16.0 间接依赖 npm
lines-and-columns 1.2.4 间接依赖 npm
@types/json-schema 7.0.10 间接依赖 npm
@npmcli/installed-package-contents 1.0.7 间接依赖 npm
mkdirp 0.5.5 间接依赖 npm
@lerna/npm-publish 4.0.0 间接依赖 npm
has-bigints 1.0.1 间接依赖 npm
ssri 8.0.1 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
tsutils 3.21.0 间接依赖 npm
@nodelib/fs.scandir 2.1.5 间接依赖 npm
foreground-child 2.0.0 间接依赖 npm
is-callable 1.2.4 间接依赖 npm
readdir-scoped-modules 1.1.0 间接依赖 npm
lru-cache 6.0.0 间接依赖 npm
minipass-collect 1.0.2 间接依赖 npm
@octokit/plugin-rest-endpoint-methods 5.13.0 间接依赖 npm
gitconfiglocal 1.0.0 间接依赖 npm
read-cmd-shim 2.0.0 间接依赖 npm
picomatch 2.3.0 间接依赖 npm
wcwidth 1.0.1 间接依赖 npm
log-symbols 4.1.0 间接依赖 npm
git-url-parse 11.6.0 间接依赖 npm
execa 5.1.1 间接依赖 npm
@lerna/filter-options 4.0.0 间接依赖 npm
get-intrinsic 1.1.1 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
cosmiconfig 7.0.1 间接依赖 npm
strip-final-newline 2.0.0 间接依赖 npm
esrecurse 4.3.0 间接依赖 npm
cross-spawn 7.0.3 间接依赖 npm
argparse 1.0.10 间接依赖 npm
@lerna/timer 4.0.0 间接依赖 npm
object.values 1.1.5 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
rxjs 6.6.7 间接依赖 npm
side-channel 1.0.4 间接依赖 npm
release-zalgo 1.0.0 间接依赖 npm
cli-cursor 3.1.0 间接依赖 npm
resolve 1.20.0 间接依赖 npm
micromatch 4.0.4 间接依赖 npm
node-preload 0.2.1 间接依赖 npm
eslint-module-utils 2.7.3 间接依赖 npm
read-package-json-fast 2.0.3 间接依赖 npm
mkdirp-infer-owner 2.0.0 间接依赖 npm
minimist-options 4.1.0 间接依赖 npm
is-core-module 2.8.0 间接依赖 npm
modify-values 1.0.1 间接依赖 npm
core-util-is 1.0.3 间接依赖 npm
@lerna/changed 4.0.0 间接依赖 npm
to-fast-properties 2.0.0 间接依赖 npm
object.assign 4.1.2 间接依赖 npm
minipass 2.9.0 间接依赖 npm
@babel/helper-module-imports 7.16.7 间接依赖 npm
@lerna/check-working-tree 4.0.0 间接依赖 npm
split 1.0.1 间接依赖 npm
@types/minimatch 3.0.5 间接依赖 npm
camelcase-keys 6.2.2 间接依赖 npm
slide 1.1.6 间接依赖 npm
wrap-ansi 7.0.0 间接依赖 npm
require-main-filename 2.0.0 直接依赖 npm
array-ify 1.0.0 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
@babel/helper-function-name 7.16.7 间接依赖 npm
@lerna/profiler 4.0.0 间接依赖 npm
@types/json5 0.0.29 间接依赖 npm
asap 2.0.6 间接依赖 npm
lodash.flattendeep 4.4.0 间接依赖 npm
arrify 2.0.1 间接依赖 npm
string-width 4.2.3 间接依赖 npm
caniuse-lite 1.0.30001319 间接依赖 npm
html-escaper 2.0.2 间接依赖 npm
webidl-conversions 6.1.0 间接依赖 npm
typedarray 0.0.6 间接依赖 npm
is-binary-path 2.1.0 间接依赖 npm
tmp 0.0.33 间接依赖 npm
yaml 1.10.2 间接依赖 npm
get-port 5.1.1 间接依赖 npm
globby 11.0.4 间接依赖 npm
nanoid 3.3.1 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
fromentries 1.3.2 间接依赖 npm
conventional-changelog-writer 5.0.0 间接依赖 npm
@lerna/prerelease-id-from-version 4.0.0 间接依赖 npm
http-cache-semantics 4.1.0 间接依赖 npm
acorn-jsx 5.3.2 间接依赖 npm
@octokit/types 6.34.0 间接依赖 npm
picocolors 1.0.0 间接依赖 npm
@babel/helper-get-function-arity 7.16.7 间接依赖 npm
flat 5.0.2 间接依赖 npm
istanbul-lib-coverage 3.2.0 间接依赖 npm
is-string 1.0.7 间接依赖 npm
regexpp 3.2.0 间接依赖 npm
istanbul-lib-instrument 4.0.3 间接依赖 npm
istanbul-lib-report 3.0.0 间接依赖 npm
@lerna/command 4.0.0 间接依赖 npm
@lerna/init 4.0.0 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
is-symbol 1.0.4 间接依赖 npm
@npmcli/fs 1.0.0 间接依赖 npm
@lerna/gitlab-client 4.0.0 间接依赖 npm
eslint-utils 3.0.0 间接依赖 npm
binary-extensions 2.2.0 间接依赖 npm
internal-slot 1.0.3 间接依赖 npm
@octokit/plugin-enterprise-rest 6.0.1 间接依赖 npm
is-regex 1.1.4 间接依赖 npm
@babel/compat-data 7.17.7 间接依赖 npm
dargs 7.0.0 间接依赖 npm
upath 2.0.1 间接依赖 npm
@lerna/diff 4.0.0 间接依赖 npm
figures 3.2.0 间接依赖 npm
p-reduce 2.1.0 间接依赖 npm
builtins 1.0.3 间接依赖 npm
redent 3.0.0 间接依赖 npm
fill-range 7.0.1 间接依赖 npm
@hutson/parse-repository-url 3.0.2 间接依赖 npm
@typescript-eslint/utils 5.16.0 间接依赖 npm
fast-glob 3.2.7 间接依赖 npm
tslib 1.14.1 间接依赖 npm
doctrine 3.0.0 间接依赖 npm
has-unicode 2.0.1 间接依赖 npm
glob 7.2.0 间接依赖 npm
libnpmaccess 4.0.3 间接依赖 npm
@types/normalize-package-data 2.4.1 直接依赖 npm
@lerna/import 4.0.0 间接依赖 npm
@babel/highlight 7.16.10 间接依赖 npm
byline 5.0.0 间接依赖 npm
@lerna/pack-directory 4.0.0 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
process-on-spawn 1.0.0 间接依赖 npm
p-map-series 2.1.0 间接依赖 npm
mute-stream 0.0.8 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
@octokit/graphql 4.8.0 间接依赖 npm
yallist 4.0.0 间接依赖 npm
cliui 7.0.4 间接依赖 npm
istanbul-lib-processinfo 2.0.2 间接依赖 npm
normalize-package-data 2.5.0 间接依赖 npm
@lerna/otplease 4.0.0 间接依赖 npm
json-parse-even-better-errors 2.3.1 间接依赖 npm
@humanwhocodes/object-schema 1.2.1 间接依赖 npm
@lerna/get-npm-exec-opts 4.0.0 间接依赖 npm
read-pkg-up 3.0.0 间接依赖 npm
meow 8.1.2 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
is-number 7.0.0 间接依赖 npm
@eslint/eslintrc 1.2.1 间接依赖 npm
espree 9.3.1 间接依赖 npm
shebang-command 2.0.0 间接依赖 npm
@typescript-eslint/typescript-estree 5.16.0 间接依赖 npm
at-least-node 1.0.0 间接依赖 npm
ansi-colors 4.1.1 间接依赖 npm
is-unicode-supported 0.1.0 间接依赖 npm
@babel/core 7.16.0 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
is-boolean-object 1.1.2 间接依赖 npm
cli-width 3.0.0 间接依赖 npm
eslint 8.11.0 直接依赖 npm
@lerna/global-options 4.0.0 间接依赖 npm
chardet 0.7.0 间接依赖 npm
color-name 1.1.3 间接依赖 npm
yocto-queue 0.1.0 直接依赖 npm
dir-glob 3.0.1 间接依赖 npm
conventional-changelog-preset-loader 2.3.4 间接依赖 npm
external-editor 3.1.0 间接依赖 npm
strip-ansi 6.0.1 间接依赖 npm
through2 4.0.2 间接依赖 npm
@typescript-eslint/parser 5.16.0 直接依赖 npm
get-stream 6.0.1 间接依赖 npm
eslint-plugin-import 2.25.4 直接依赖 npm
get-package-type 0.1.0 间接依赖 npm
minipass-sized 1.0.3 间接依赖 npm
@npmcli/ci-detect 1.4.0 直接依赖 npm
node-fetch 2.6.7 间接依赖 npm
columnify 1.5.4 间接依赖 npm
chownr 1.1.4 间接依赖 npm
init-package-json 2.0.5 间接依赖 npm
@typescript-eslint/eslint-plugin 5.16.0 直接依赖 npm
fs-extra 9.1.0 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
git-semver-tags 4.1.1 间接依赖 npm
electron-to-chromium 1.4.90 间接依赖 npm
@babel/template 7.16.7 间接依赖 npm
@npmcli/move-file 1.1.2 间接依赖 npm
path-key 3.1.1 间接依赖 npm
is-bigint 1.0.4 间接依赖 npm
@lerna/run-topologically 4.0.0 间接依赖 npm
@tootallnate/once 1.1.2 间接依赖 npm
prelude-ls 1.2.1 间接依赖 npm
commondir 1.0.1 间接依赖 npm
p-waterfall 2.1.1 间接依赖 npm
npm-run-path 4.0.1 间接依赖 npm
@lerna/collect-updates 4.0.0 间接依赖 npm
es-abstract 1.19.1 间接依赖 npm
write-json-file 4.3.0 间接依赖 npm
ansi-regex 5.0.1 间接依赖 npm
which 2.0.2 间接依赖 npm
@lerna/npm-install 4.0.0 间接依赖 npm
get-pkg-repo 4.2.1 间接依赖 npm
@npmcli/git 2.1.0 间接依赖 npm
@ungap/promise-all-settled 1.1.2 间接依赖 npm
path-exists 4.0.0 间接依赖 npm
string.prototype.trimend 1.0.4 间接依赖 npm
emoji-regex 8.0.0 间接依赖 npm
eventemitter3 4.0.7 间接依赖 npm
deprecation 2.3.1 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
is-fullwidth-code-point 3.0.0 间接依赖 npm
which-boxed-primitive 1.0.2 间接依赖 npm
@lerna/run-lifecycle 4.0.0 间接依赖 npm
minipass-flush 1.0.5 间接依赖 npm
lerna 4.0.0 直接依赖 npm
@lerna/exec 4.0.0 间接依赖 npm
has 1.0.3 间接依赖 npm
estraverse 4.3.0 间接依赖 npm
eslint-plugin-promise 5.2.0 直接依赖 npm
make-dir 2.1.0 间接依赖 npm
locate-path 5.0.0 间接依赖 npm
typedarray-to-buffer 3.1.5 直接依赖 npm
socks-proxy-agent 6.1.1 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
envinfo 7.8.1 间接依赖 npm
chalk 4.1.2 间接依赖 npm
strip-json-comments 3.1.1 间接依赖 npm
promzard 0.3.0 间接依赖 npm
json5 2.2.0 间接依赖 npm
conventional-commits-filter 2.0.7 间接依赖 npm
eslint-visitor-keys 3.3.0 间接依赖 npm
ci-info 2.0.0 间接依赖 npm
read 1.0.7 间接依赖 npm
@lerna/info 4.0.0 间接依赖 npm
escape-string-regexp 4.0.0 间接依赖 npm
@octokit/request 5.6.2 间接依赖 npm
eslint-config-standard 16.0.3 直接依赖 npm
compare-func 2.0.0 间接依赖 npm
has-symbols 1.0.2 间接依赖 npm
which-module 2.0.0 直接依赖 npm
jsonfile 6.1.0 间接依赖 npm
hard-rejection 2.1.0 间接依赖 npm
minipass-pipeline 1.2.4 间接依赖 npm
serialize-javascript 6.0.0 间接依赖 npm
hasha 5.2.2 间接依赖 npm
@babel/code-frame 7.16.7 间接依赖 npm
fsevents 2.3.2 间接依赖 npm
archy 1.0.0 间接依赖 npm
temp-dir 1.0.0 间接依赖 npm
package-hash 4.0.0 间接依赖 npm
@lerna/cli 4.0.0 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
git-up 4.0.5 间接依赖 npm
indent-string 4.0.0 间接依赖 npm
@lerna/pulse-till-done 4.0.0 间接依赖 npm
@babel/helper-validator-option 7.16.7 间接依赖 npm
@istanbuljs/schema 0.1.3 间接依赖 npm
unique-filename 1.1.1 间接依赖 npm
spdx-correct 3.1.1 间接依赖 npm
punycode 2.1.1 间接依赖 npm
https-proxy-agent 5.0.0 间接依赖 npm
uri-js 4.4.1 间接依赖 npm
@babel/helper-hoist-variables 7.16.7 间接依赖 npm
p-map 4.0.0 间接依赖 npm
browserslist 4.20.2 间接依赖 npm
code-point-at 1.1.0 直接依赖 npm
once 1.4.0 间接依赖 npm
@lerna/symlink-dependencies 4.0.0 间接依赖 npm
wide-align 1.1.5 间接依赖 npm
git-raw-commits 2.0.10 间接依赖 npm
unbox-primitive 1.0.1 间接依赖 npm
restore-cursor 3.1.0 间接依赖 npm
spdx-exceptions 2.3.0 间接依赖 npm
before-after-hook 2.2.2 间接依赖 npm
balanced-match 1.0.2 间接依赖 npm
@lerna/get-packed 4.0.0 间接依赖 npm
node-gyp 5.1.1 间接依赖 npm
escalade 3.1.1 间接依赖 npm
@babel/helper-simple-access 7.17.7 间接依赖 npm
@lerna/npm-conf 4.0.0 间接依赖 npm
@types/parse-json 4.0.0 间接依赖 npm
y18n 4.0.3 间接依赖 npm
@lerna/run 4.0.0 间接依赖 npm
split2 3.2.2 间接依赖 npm
@babel/helper-validator-identifier 7.16.7 间接依赖 npm
@lerna/github-client 4.0.0 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
p-limit 2.3.0 间接依赖 npm
es-to-primitive 1.2.1 间接依赖 npm
@nodelib/fs.walk 1.2.8 间接依赖 npm
word-wrap 1.2.3 间接依赖 npm
@babel/helper-split-export-declaration 7.16.7 间接依赖 npm
env-paths 2.2.1 间接依赖 npm
is-weakref 1.0.1 间接依赖 npm
find-up 4.1.0 间接依赖 npm
npm-packlist 2.2.2 间接依赖 npm
is-ci 2.0.0 间接依赖 npm
@octokit/auth-token 2.5.0 间接依赖 npm
is-negative-zero 2.0.1 间接依赖 npm
handlebars 4.7.7 间接依赖 npm
randombytes 2.1.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
@lerna/create-symlink 4.0.0 间接依赖 npm
lodash 4.17.21 间接依赖 npm
decamelize-keys 1.1.0 间接依赖 npm
camelcase 5.3.1 间接依赖 npm
@types/minimist 1.2.2 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
esquery 1.4.0 间接依赖 npm
@npmcli/run-script 1.8.6 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
temp-write 4.0.0 间接依赖 npm
to-regex-range 5.0.1 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
ansi-escapes 4.3.2 间接依赖 npm
conventional-commits-parser 3.2.3 间接依赖 npm
request 2.88.2 间接依赖 npm
p-try 2.2.0 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
yargs 16.2.0 间接依赖 npm
@lerna/bootstrap 4.0.0 间接依赖 npm
ini 1.3.8 间接依赖 npm
is-stream 2.0.1 间接依赖 npm
spdx-license-ids 3.0.11 间接依赖 npm
debug 4.3.3 间接依赖 npm
@lerna/project 4.0.0 间接依赖 npm
dateformat 3.0.3 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
deep-is 0.1.4 间接依赖 npm
sort-keys 2.0.0 间接依赖 npm
whatwg-url 8.7.0 间接依赖 npm
minizlib 1.3.3 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
text-table 0.2.0 间接依赖 npm
npm-pick-manifest 6.1.1 间接依赖 npm
buffer-from 1.1.2 间接依赖 npm
eslint-plugin-es 3.0.1 间接依赖 npm
@lerna/prompt 4.0.0 间接依赖 npm
graceful-fs 4.2.8 间接依赖 npm
is-glob 4.0.3 间接依赖 npm
resolve-from 4.0.0 间接依赖 npm
es6-error 4.1.1 间接依赖 npm
@lerna/listable 4.0.0 间接依赖 npm
array.prototype.flat 1.2.5 间接依赖 npm
read-package-tree 5.3.1 间接依赖 npm
concat-stream 2.0.0 间接依赖 npm
@lerna/log-packed 4.0.0 间接依赖 npm
inherits 2.0.4 间接依赖 npm
encoding 0.1.13 间接依赖 npm
hosted-git-info 4.0.2 间接依赖 npm
@lerna/npm-run-script 4.0.0 间接依赖 npm
find-cache-dir 3.3.2 间接依赖 npm
uid-number 0.0.6 间接依赖 npm
p-locate 4.1.0 间接依赖 npm
debuglog 1.0.1 间接依赖 npm
cmd-shim 4.1.0 间接依赖 npm
diff 5.0.0 间接依赖 npm
@lerna/add 4.0.0 间接依赖 npm
nopt 4.0.3 间接依赖 npm
isobject 3.0.1 间接依赖 npm
util-promisify 2.1.0 间接依赖 npm
braces 3.0.2 间接依赖 npm
object.getownpropertydescriptors 2.1.3 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
promise-inflight 1.0.1 间接依赖 npm
eslint-scope 5.1.1 间接依赖 npm
@babel/generator 7.17.7 间接依赖 npm
through 2.3.8 间接依赖 npm
lodash.templatesettings 4.2.0 间接依赖 npm
acorn 8.7.0 间接依赖 npm
is-lambda 1.0.1 间接依赖 npm
semver 7.3.5 间接依赖 npm
@lerna/clean 4.0.0 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
iconv-lite 0.6.3 间接依赖 npm
npmlog 4.1.2 间接依赖 npm
jsonparse 1.3.1 间接依赖 npm
parse-json 5.2.0 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
ignore-walk 3.0.4 间接依赖 npm
humanize-ms 1.2.1 间接依赖 npm
string.prototype.trimstart 1.0.4 间接依赖 npm
conventional-changelog-angular 5.0.13 间接依赖 npm
@octokit/plugin-request-log 1.0.4 间接依赖 npm
@lerna/package-graph 4.0.0 间接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
write-file-atomic 2.4.3 间接依赖 npm
conventional-recommended-bump 6.1.0 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
default-require-extensions 3.0.0 间接依赖 npm
q 1.5.1 间接依赖 npm
defaults 1.0.3 间接依赖 npm
@lerna/filter-packages 4.0.0 间接依赖 npm
parent-module 1.0.1 间接依赖 npm
eslint-plugin-node 11.1.0 直接依赖 npm
import-local 3.0.3 间接依赖 npm
@lerna/create 4.0.0 间接依赖 npm
agentkeepalive 4.1.4 间接依赖 npm
is-plain-obj 1.1.0 间接依赖 npm
ajv 6.12.6 间接依赖 npm
inflight 1.0.6 间接依赖 npm
mocha 9.2.2 直接依赖 npm
xtend 4.0.2 直接依赖 npm
@lerna/npm-dist-tag 4.0.0 间接依赖 npm
glob-parent 5.1.2 间接依赖 npm
@babel/parser 7.17.8 间接依赖 npm
object-inspect 1.11.0 间接依赖 npm
esutils 2.0.3 间接依赖 npm
tar 4.4.19 间接依赖 npm
he 1.2.0 间接依赖 npm
js-yaml 3.14.1 间接依赖 npm
caching-transform 4.0.0 间接依赖 npm
clone-deep 4.0.1 间接依赖 npm
clean-stack 2.2.0 间接依赖 npm
@octokit/request-error 2.1.0 间接依赖 npm
@lerna/package 4.0.0 间接依赖 npm
trim-newlines 3.0.1 间接依赖 npm
type-check 0.4.0 间接依赖 npm
fs-minipass 1.2.7 间接依赖 npm
lodash.template 4.5.0 间接依赖 npm
unique-slug 2.0.2 间接依赖 npm
npm-lifecycle 3.1.5 间接依赖 npm
@lerna/resolve-symlink 4.0.0 间接依赖 npm
gauge 2.7.4 间接依赖 npm
universal-user-agent 6.0.0 间接依赖 npm
get-symbol-description 1.0.0 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
shallow-clone 3.0.1 间接依赖 npm
depd 1.1.2 间接依赖 npm
p-pipe 3.1.0 间接依赖 npm
@lerna/rimraf-dir 4.0.0 间接依赖 npm
merge-stream 2.0.0 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
callsites 3.1.0 间接依赖 npm
human-signals 2.1.0 间接依赖 npm
@typescript-eslint/types 5.16.0 间接依赖 npm
@lerna/list 4.0.0 间接依赖 npm
aggregate-error 3.1.0 间接依赖 npm
is-ssh 1.3.3 间接依赖 npm
array-differ 3.0.0 间接依赖 npm
growl 1.10.5 间接依赖 npm
@babel/types 7.17.0 间接依赖 npm
is-date-object 1.0.5 间接依赖 npm
@lerna/validation-error 4.0.0 间接依赖 npm
jsesc 2.5.2 间接依赖 npm
config-chain 1.1.13 间接依赖 npm
proto-list 1.2.4 间接依赖 npm
parse-url 6.0.0 间接依赖 npm
typescript 3.9.10 直接依赖 npm
levn 0.4.1 间接依赖 npm
@babel/helper-compilation-targets 7.17.7 间接依赖 npm
minipass-fetch 1.4.1 间接依赖 npm
chokidar 3.5.3 间接依赖 npm
convert-source-map 1.8.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
promise-retry 2.0.1 间接依赖 npm
universalify 2.0.0 间接依赖 npm
resolve-cwd 3.0.0 间接依赖 npm
esprima 4.0.1 间接依赖 npm
is-number-object 1.0.6 间接依赖 npm
isexe 2.0.0 间接依赖 npm
rimraf 3.0.2 间接依赖 npm
detect-indent 5.0.0 间接依赖 npm
add-stream 1.0.0 间接依赖 npm
npm-normalize-package-bin 1.0.1 间接依赖 npm
is-shared-array-buffer 1.0.1 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
infer-owner 1.0.4 间接依赖 npm
@npmcli/promise-spawn 1.3.2 间接依赖 npm
@typescript-eslint/type-utils 5.16.0 间接依赖 npm
read-pkg 3.0.0 间接依赖 npm
conventional-changelog-core 4.2.4 间接依赖 npm
@lerna/conventional-commits 4.0.0 间接依赖 npm
@humanwhocodes/config-array 0.9.5 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
socks 2.6.1 间接依赖 npm
define-properties 1.1.3 间接依赖 npm
npm-install-checks 4.0.0 间接依赖 npm
@lerna/link 4.0.0 间接依赖 npm
@babel/helper-module-transforms 7.17.7 间接依赖 npm
istanbul-lib-source-maps 4.0.1 间接依赖 npm
flat-cache 3.0.4 间接依赖 npm
http-proxy-agent 4.0.1 间接依赖 npm
minimist 1.2.6 间接依赖 npm
@octokit/core 3.5.1 间接依赖 npm
source-map 0.5.7 间接依赖 npm
tsconfig-paths 3.14.1 间接依赖 npm
tr46 2.1.0 间接依赖 npm
agent-base 6.0.2 间接依赖 npm
@lerna/symlink-binary 4.0.0 间接依赖 npm
isarray 1.0.0 间接依赖 npm
p-queue 6.6.2 间接依赖 npm
is-text-path 1.0.1 间接依赖 npm
v8-compile-cache 2.3.0 间接依赖 npm
multimatch 5.0.0 间接依赖 npm
call-bind 1.0.2 间接依赖 npm
file-entry-cache 6.0.1 间接依赖 npm
workerpool 6.2.0 间接依赖 npm
number-is-nan 1.0.1 直接依赖 npm
spawn-wrap 2.0.0 间接依赖 npm
@istanbuljs/load-nyc-config 1.1.0 间接依赖 npm
@lerna/version 4.0.0 间接依赖 npm
npm-package-arg 8.1.5 间接依赖 npm
inquirer 7.3.3 间接依赖 npm
globals 13.13.0 间接依赖 npm
@babel/helpers 7.16.3 间接依赖 npm
@babel/helper-environment-visitor 7.16.7 间接依赖 npm
path-type 4.0.0 间接依赖 npm
signal-exit 3.0.6 间接依赖 npm
@octokit/rest 18.12.0 间接依赖 npm
write-pkg 4.0.0 间接依赖 npm
browser-stdout 1.3.1 间接依赖 npm
retry 0.12.0 间接依赖 npm
onetime 5.1.2 间接依赖 npm
lodash.ismatch 4.4.0 间接依赖 npm
umask 1.1.0 间接依赖 npm
anymatch 3.1.2 间接依赖 npm
strong-log-transformer 2.1.0 间接依赖 npm
yargs-unparser 2.0.0 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
merge2 1.4.1 间接依赖 npm
negotiator 0.6.3 间接依赖 npm
flatted 3.2.4 间接依赖 npm
ms 2.1.2 间接依赖 npm
@lerna/has-npm-version 4.0.0 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
@gar/promisify 1.1.2 间接依赖 npm
p-timeout 3.2.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
fastq 1.13.0 间接依赖 npm
json-parse-better-errors 1.0.2 直接依赖 npm
@lerna/collect-uncommitted 4.0.0 间接依赖 npm
pify 4.0.1 间接依赖 npm
git-remote-origin-url 2.0.0 间接依赖 npm
nyc 15.1.0 直接依赖 npm
dedent 0.7.0 间接依赖 npm
array-includes 3.1.4 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
make-fetch-happen 9.1.0 间接依赖 npm
import-fresh 3.3.0 间接依赖 npm
ignore 5.2.0 间接依赖 npm
dot-prop 6.0.1 间接依赖 npm
are-we-there-yet 1.1.7 间接依赖 npm
libnpmpublish 4.0.2 间接依赖 npm
path-parse 1.0.7 间接依赖 npm
lodash._reinterpolate 3.0.0 间接依赖 npm
test-exclude 6.0.0 间接依赖 npm
aproba 1.2.0 间接依赖 npm
has-tostringtag 1.0.0 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
@lerna/write-log-file 4.0.0 间接依赖 npm
@lerna/output 4.0.0 间接依赖 npm
@lerna/describe-ref 4.0.0 间接依赖 npm
run-async 2.4.1 间接依赖 npm
cacache 15.3.0 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
@lerna/child-process 4.0.0 间接依赖 npm
pkg-dir 4.2.0 间接依赖 npm
append-transform 2.0.0 间接依赖 npm
err-code 2.0.3 间接依赖 npm
readdirp 3.6.0 间接依赖 npm
istanbul-reports 3.0.5 间接依赖 npm
pacote 11.3.5 间接依赖 npm
safe-buffer 5.2.1 间接依赖 npm
npm-bundled 1.1.2 间接依赖 npm
(0)
上一篇 2023年10月30日
下一篇 2023年10月30日

相关推荐

  • JetBrains/intellij-plugins 软件分析报告

    基础信息 项目名称:JetBrains/intellij-plugins 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721305347011727360/1730492815909015552 此报告由Mur…

    软件分析 2023年12月1日
    0
  • EQuimper/youtubeMeetupAppReactNativeNode 软件分析报告

    基础信息 项目名称:EQuimper/youtubeMeetupAppReactNativeNode 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721166953774649344/1727923015112…

    软件分析 2023年11月24日
    0
  • xxczaki/styled-react-boilerplate 软件分析报告

    基础信息 项目名称:xxczaki/styled-react-boilerplate 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721599884597424128/1721599885205598208 此…

    软件分析 2023年11月7日
    0
  • google/classp 软件分析报告

    基础信息 项目名称:google/classp 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718211360521322496/1718211360982695936 此报告由Murphysec提供 漏洞列表…

    软件分析 2023年10月28日
    0
  • fengyuanchen/viewer 软件分析报告

    基础信息 项目名称:fengyuanchen/viewer 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717783014486441984/1717783014700351488 此报告由Murphysec提…

    软件分析 2023年10月27日
    0