getbase/base 软件分析报告

基础信息

项目名称:getbase/base

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1718083677044998144/1718083677586063360

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
LibSass 拒绝服务漏洞 空指针取消引用 MPS-2018-15348 CVE-2018-19797 中危
LibSass 拒绝服务漏洞 UAF MPS-2018-15372 CVE-2018-19827 高危
LibSass 拒绝服务漏洞 越界读取 MPS-2018-15397 CVE-2018-19839 中危
LibSass 拒绝服务漏洞 空指针取消引用 MPS-2018-15962 CVE-2018-20190 中危
LibSass 堆缓冲区错误漏洞 越界读取 MPS-2019-0502 CVE-2019-6283 中危
LibSass 堆缓冲区错误漏洞 越界读取 MPS-2019-0503 CVE-2019-6284 中危
LibSass 堆缓冲区错误漏洞 越界读取 MPS-2019-0505 CVE-2019-6286 中危
LibSass 越界读取 MPS-2019-14247 CVE-2019-18798 中危
LibSass 程序崩溃漏洞 空指针取消引用 MPS-2019-14248 CVE-2019-18799 中危
LibSass 资源管理错误漏洞 未经控制的递归 MPS-2019-4291 CVE-2018-20821 中危
node-sass 堆栈溢出漏洞 未经控制的递归 MPS-2019-4292 CVE-2018-20822 中危
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
ua-parser-js 拒绝服务 MPS-2020-13044 CVE-2020-7733 高危
object-path 安全漏洞 MAID MPS-2020-14597 CVE-2020-15256 严重
lodash 原型污染 MPS-2020-15679 CVE-2020-8203 高危
Axios 服务器端请求伪造漏洞 SSRF MPS-2020-16365 CVE-2020-28168 中危
ua-parser-js DOS漏洞 拒绝服务 MPS-2020-17428 CVE-2020-7793 高危
Yargs Y18n 输入原型污染漏洞 动态确定对象属性修改的控制不恰当 MPS-2020-17543 CVE-2020-7774 严重
Ini 拒绝服务 MPS-2020-17544 CVE-2020-7788 高危
Socketio Engineio 资源管理错误漏洞 拒绝服务 MPS-2021-0191 CVE-2020-36048 高危
Socketio Engineio 资源管理错误漏洞 拒绝服务 MPS-2021-0192 CVE-2020-36049 高危
Sass Node-sass 信任管理问题漏洞 证书验证不恰当 MPS-2021-0364 CVE-2020-24025 中危
Socketio Socket.io CORS漏洞 源验证错误 MPS-2021-0652 CVE-2020-28481 中危
object-path 原型污染漏洞 使用不兼容类型访问资源(类型混淆) MPS-2021-18322 CVE-2021-23434 高危
requests 代码注入漏洞 代码注入 MPS-2021-2418 CVE-2020-28502 高危
lodash 拒绝服务漏洞 拒绝服务 MPS-2021-2574 CVE-2020-28500 中危
lodash 命令注入漏洞 代码注入 MPS-2021-2638 CVE-2021-23337 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28486 CVE-2021-37701 高危
Npm Node-tar 后置链接漏洞 在文件访问前对链接解析不恰当(链接跟随) MPS-2021-28488 CVE-2021-37712 高危
node-tar 路径遍历漏洞 路径遍历 MPS-2021-28489 CVE-2021-37713 高危
Sindre Sorhus is-svg 拒绝服务漏洞 拒绝服务 MPS-2021-3031 CVE-2021-28092 高危
Axios 拒绝服务漏洞 拒绝服务 MPS-2021-30688 CVE-2021-3749 高危
nth-check 正则表达式拒绝服务漏洞 ReDoS MPS-2021-31847 CVE-2021-3803 高危
ua-parser-js 正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-3199 CVE-2021-27292 高危
Ruy Adorno hosted-git-info 正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-3400 CVE-2021-23362 中危
Takayuki Sato copy-props 安全漏洞 原型污染 MPS-2021-3446 CVE-2020-28503 严重
json-schema 安全漏洞 原型污染 MPS-2021-34478 CVE-2021-3918 严重
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
Andrey Sitnik postcss 拒绝服务漏洞 拒绝服务 MPS-2021-4549 CVE-2021-23368 中危
Dan DeFelippi node-XMLHttpRequest 信任管理问题漏洞 证书验证不恰当 MPS-2021-5338 CVE-2021-31597 严重
postcss 存在正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-5409 CVE-2021-23382 中危
browserslist 存在正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-5473 CVE-2021-23364 中危
npm path-parse 安全漏洞 拒绝服务 MPS-2021-6165 CVE-2021-23343 高危
ws 存在拒绝服务漏洞 拒绝服务 MPS-2021-7109 CVE-2021-32640 中危
trim-newlines 存在拒绝服务漏洞 拒绝服务 MPS-2021-7398 CVE-2021-33623 高危
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
Color-String 拒绝服务 MPS-2021-8683 CVE-2021-29060 中危
is-svg 存在正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-8684 CVE-2021-29059 高危
follow-redirects 侵犯隐私 MPS-2022-0815 CVE-2022-0155 中危
http-proxy 拒绝服务 MPS-2022-13767 中危
lodash 拒绝服务 MPS-2022-13841 高危
lodash 拒绝服务 MPS-2022-13842 高危
uglify-js ReDoS MPS-2022-14112 中危
follow-redirects 未授权敏感信息泄露 MPS-2022-3636 CVE-2022-0536 中危
Express 中的 qs 模块存在原型污染漏洞 原型污染 MPS-2022-3967 CVE-2022-24999 高危
scss-tokenizer 安全漏洞 ReDoS MPS-2022-5119 CVE-2022-25758 高危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
decode-uri-component 拒绝服务 MPS-2022-56259 CVE-2022-38900 高危
Socketio Engine.IO拒绝服务漏洞 未捕获的异常 MPS-2022-58577 CVE-2022-41940 中危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
tough-cookie 安全漏洞 原型污染 MPS-2023-5130 CVE-2023-26136 严重
request SSRF防御绕过漏洞 SSRF MPS-2023-7722 CVE-2023-28155 中危
tough-cookie 原型污染 MPS-esyq-56vx 中危
PostCSS 安全漏洞 注入 MPS-y3tx-jzms CVE-2023-44270 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
xmlhttprequest-ssl 1.5.5 1.6.2 间接依赖 强烈建议修复
glob-parent 3.1.0 5.1.2 间接依赖 建议修复
socket.io-parser 3.3.0 3.3.2 间接依赖 建议修复
object-path 0.9.2 0.11.8 间接依赖 建议修复
tough-cookie 2.5.0 4.1.3 间接依赖 建议修复
decode-uri-component 0.2.0 0.2.1 间接依赖 建议修复
qs 6.2.3 6.2.4 间接依赖 建议修复
minimist 1.2.5 1.2.6 间接依赖 建议修复
y18n 3.2.1 3.2.2 间接依赖 建议修复
ini 1.3.5 1.3.6 间接依赖 建议修复
path-parse 1.0.6 1.0.7 间接依赖 建议修复
engine.io 3.2.1 6.4.2 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
axios 0.19.0 0.21.3 间接依赖 建议修复
nth-check 1.0.2 2.0.1 间接依赖 建议修复
json-schema 0.2.3 0.4.0 间接依赖 建议修复
ua-parser-js 0.7.17 0.7.24 间接依赖 建议修复
tar 2.2.2 4.4.18 间接依赖 建议修复
scss-tokenizer 0.2.3 0.4.3 间接依赖 建议修复
copy-props 2.0.4 2.0.5 直接依赖 建议修复
is-svg 3.0.0 4.3.0 间接依赖 建议修复
node-sass 4.14.1 间接依赖 建议修复
lodash 4.17.15 4.17.21 间接依赖 建议修复
trim-newlines 1.0.0 3.0.1 间接依赖 建议修复
socket.io 2.1.1 2.4.0 间接依赖 可选修复
follow-redirects 1.5.10 1.14.8 间接依赖 可选修复
ws 6.1.4 6.2.2 间接依赖 可选修复
ajv 6.12.2 6.12.3 间接依赖 可选修复
postcss 7.0.29 8.4.31 间接依赖 可选修复
semver 5.7.1 7.5.2 间接依赖 可选修复
hosted-git-info 2.8.8 2.8.9 间接依赖 可选修复
request 2.88.2 间接依赖 可选修复
color-string 1.5.3 1.5.5 间接依赖 可选修复
uglify-js 2.8.29 3.14.3 间接依赖 可选修复
browserslist 4.12.0 4.16.5 间接依赖 可选修复
http-proxy 1.15.2 1.18.1 间接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 520
ISC 61
CC-BY-4.0 1
0BSD 1
BSD-3-Clause 7
Apache-2.0 14
CC0-1.0 1
BSD-2-Clause 8
Unlicense 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
callsites 2.0.0 间接依赖 npm
abbrev 1.1.1 间接依赖 npm
invert-kv 1.0.0 间接依赖 npm
range-parser 1.2.1 间接依赖 npm
cssesc 3.0.0 间接依赖 npm
color 3.1.2 间接依赖 npm
color-support 1.1.3 间接依赖 npm
vinyl-sourcemap 1.1.0 间接依赖 npm
is-buffer 1.1.6 间接依赖 npm
path-root 0.1.1 间接依赖 npm
plugin-error 0.1.2 间接依赖 npm
ext 1.4.0 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
hex-color-regex 1.1.0 间接依赖 npm
map-cache 0.2.2 间接依赖 npm
repeating 2.0.1 直接依赖 npm
indexof 0.0.1 间接依赖 npm
safe-regex 1.1.0 间接依赖 npm
async-each-series 0.1.1 间接依赖 npm
postcss-normalize-url 4.0.1 间接依赖 npm
isexe 2.0.0 间接依赖 npm
postcss-normalize-display-values 4.0.2 间接依赖 npm
caniuse-lite 1.0.30001053 间接依赖 npm
ee-first 1.1.1 间接依赖 npm
bach 1.2.0 间接依赖 npm
postcss-calc 7.0.2 间接依赖 npm
is-path-inside 3.0.2 间接依赖 npm
requires-port 1.0.0 间接依赖 npm
strip-bom 2.0.0 间接依赖 npm
copy-props 2.0.4 直接依赖 npm
util.promisify 1.0.1 间接依赖 npm
center-align 0.1.3 直接依赖 npm
load-json-file 1.1.0 间接依赖 npm
tslib 1.11.2 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
for-in 1.0.2 间接依赖 npm
is-relative 1.0.0 间接依赖 npm
dashdash 1.14.1 间接依赖 npm
css-color-names 0.0.4 间接依赖 npm
statuses 1.3.1 间接依赖 npm
last-run 1.1.1 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
expand-tilde 2.0.2 间接依赖 npm
read-pkg 1.1.0 间接依赖 npm
reusify 1.0.4 间接依赖 npm
async-settle 1.0.0 间接依赖 npm
batch 0.6.1 间接依赖 npm
caller-callsite 2.0.0 间接依赖 npm
stylehacks 4.0.3 间接依赖 npm
commander 2.20.3 间接依赖 npm
aproba 1.2.0 间接依赖 npm
array-union 2.1.0 间接依赖 npm
resolve-dir 1.0.1 间接依赖 npm
cssnano-util-get-arguments 4.0.0 间接依赖 npm
extend 3.0.2 间接依赖 npm
setprototypeof 1.1.1 间接依赖 npm
is-svg 3.0.0 间接依赖 npm
js-yaml 3.13.1 间接依赖 npm
browserslist 4.12.0 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
autoprefixer 9.7.6 直接依赖 npm
is-absolute-url 2.1.0 间接依赖 npm
clean-stack 2.2.0 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
glob-parent 3.1.0 间接依赖 npm
object.assign 4.1.0 间接依赖 npm
postcss-normalize-timing-functions 4.0.2 间接依赖 npm
decode-uri-component 0.2.0 间接依赖 npm
send 0.16.2 间接依赖 npm
negotiator 0.6.2 间接依赖 npm
postcss-svgo 4.0.2 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
lodash.merge 4.6.2 间接依赖 npm
postcss-normalize-string 4.0.2 间接依赖 npm
align-text 0.1.4 间接依赖 npm
pump 2.0.1 间接依赖 npm
source-map 0.6.1 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
getpass 0.1.7 间接依赖 npm
replace-ext 1.0.1 间接依赖 npm
pinkie 2.0.4 间接依赖 npm
cosmiconfig 5.2.1 间接依赖 npm
json-parse-better-errors 1.0.2 直接依赖 npm
get-caller-file 1.0.3 间接依赖 npm
stream-throttle 0.1.3 间接依赖 npm
sass-graph 2.2.5 间接依赖 npm
forever-agent 0.6.1 间接依赖 npm
detect-file 1.0.0 间接依赖 npm
portscanner 2.1.1 间接依赖 npm
isobject 3.0.1 间接依赖 npm
lodash.memoize 4.1.2 间接依赖 npm
replace-homedir 1.0.0 直接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
use 3.1.1 间接依赖 npm
snapdragon-node 2.1.1 间接依赖 npm
indent-string 4.0.0 间接依赖 npm
typedarray 0.0.6 间接依赖 npm
is-binary-path 1.0.1 间接依赖 npm
better-assert 1.0.2 间接依赖 npm
postcss-selector-parser 6.0.2 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
node-releases 1.1.55 间接依赖 npm
has-ansi 2.0.0 直接依赖 npm
dev-ip 1.0.1 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
object.getownpropertydescriptors 2.1.0 间接依赖 npm
boolbase 1.0.0 间接依赖 npm
json-stringify-safe 5.0.1 间接依赖 npm
resolve-from 3.0.0 间接依赖 npm
glogg 1.0.2 间接依赖 npm
read-pkg-up 1.0.1 间接依赖 npm
yeast 0.1.2 间接依赖 npm
next-tick 1.0.0 间接依赖 npm
each-props 1.3.2 间接依赖 npm
osenv 0.1.5 间接依赖 npm
array-initial 1.1.0 间接依赖 npm
dot-prop 5.2.0 直接依赖 npm
os-homedir 1.0.2 间接依赖 npm
import-fresh 2.0.0 间接依赖 npm
extglob 2.0.4 间接依赖 npm
run-parallel 1.1.9 间接依赖 npm
iconv-lite 0.4.24 间接依赖 npm
less 3.11.1 间接依赖 npm
chalk 2.4.2 间接依赖 npm
socket.io-parser 3.3.0 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
clone-buffer 1.0.0 间接依赖 npm
rx 4.1.0 间接依赖 npm
arr-union 3.1.0 间接依赖 npm
@nodelib/fs.walk 1.2.4 间接依赖 npm
postcss-load-config 2.1.0 间接依赖 npm
aws-sign2 0.7.0 间接依赖 npm
gulp-less 4.0.1 直接依赖 npm
mdn-data 2.0.4 间接依赖 npm
jsprim 1.4.1 间接依赖 npm
har-schema 2.0.0 间接依赖 npm
eventemitter3 1.2.0 间接依赖 npm
binary-extensions 1.13.1 间接依赖 npm
postcss-merge-rules 4.0.3 间接依赖 npm
postcss-unique-selectors 4.0.1 间接依赖 npm
stable 0.1.8 间接依赖 npm
assert-plus 1.0.0 间接依赖 npm
es6-symbol 3.1.3 间接依赖 npm
slash 3.0.0 间接依赖 npm
csso 4.0.3 间接依赖 npm
normalize-package-data 2.5.0 间接依赖 npm
localtunnel 1.9.2 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
cssnano-preset-default 4.0.7 间接依赖 npm
is-data-descriptor 0.1.4 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
nanomatch 1.2.13 间接依赖 npm
fsevents 1.2.13 间接依赖 npm
hsl-regex 1.0.0 间接依赖 npm
semver 5.7.1 间接依赖 npm
string-width 1.0.2 间接依赖 npm
is-glob 4.0.1 间接依赖 npm
socket.io-client 2.3.0 间接依赖 npm
node-sass 4.14.1 间接依赖 npm
raw-body 2.4.1 间接依赖 npm
default-resolution 2.0.0 间接依赖 npm
indexes-of 1.0.1 间接依赖 npm
to-regex-range 2.1.1 间接依赖 npm
destroy 1.0.4 间接依赖 npm
npmlog 4.1.2 间接依赖 npm
@types/q 1.5.2 间接依赖 npm
collection-visit 1.0.0 间接依赖 npm
alphanum-sort 1.0.2 间接依赖 npm
is-unc-path 1.0.0 间接依赖 npm
lodash.flatten 4.4.0 间接依赖 npm
inherits 2.0.4 间接依赖 npm
component-inherit 0.0.3 间接依赖 npm
asynckit 0.4.0 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
ms 2.1.2 间接依赖 npm
for-own 1.0.0 间接依赖 npm
after 0.8.2 间接依赖 npm
json-schema 0.2.3 间接依赖 npm
mixin-deep 1.3.2 间接依赖 npm
undertaker-registry 1.0.1 间接依赖 npm
openurl 1.1.1 间接依赖 npm
ultron 1.1.1 直接依赖 npm
serve-index 1.9.1 间接依赖 npm
fstream 1.0.12 间接依赖 npm
errno 0.1.7 间接依赖 npm
postcss-minify-selectors 4.0.2 间接依赖 npm
jsbn 0.1.1 间接依赖 npm
default-compare 1.0.0 间接依赖 npm
hsla-regex 1.0.0 间接依赖 npm
postcss-discard-overridden 4.0.1 间接依赖 npm
parseqs 0.0.5 间接依赖 npm
is-descriptor 0.1.6 间接依赖 npm
coa 2.0.2 间接依赖 npm
glob-watcher 5.0.3 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
array-unique 0.3.2 间接依赖 npm
bs-recipes 1.3.4 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
make-iterator 1.0.1 间接依赖 npm
set-value 2.0.1 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
remove-bom-buffer 3.0.0 间接依赖 npm
unquote 1.1.1 间接依赖 npm
lodash.isfinite 3.3.2 间接依赖 npm
is-extendable 0.1.1 间接依赖 npm
rgba-regex 1.0.0 间接依赖 npm
loud-rejection 1.6.0 间接依赖 npm
upath 1.2.0 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
readable-stream 2.3.7 间接依赖 npm
supports-color 5.5.0 间接依赖 npm
nopt 3.0.6 间接依赖 npm
lodash.pick 4.4.0 间接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
resp-modifier 6.0.2 间接依赖 npm
fancy-log 1.3.3 间接依赖 npm
define-properties 1.1.3 间接依赖 npm
minimist 1.2.5 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
cssnano 4.1.10 直接依赖 npm
import-from 2.1.0 间接依赖 npm
universalify 0.1.2 间接依赖 npm
domutils 1.7.0 间接依赖 npm
path-parse 1.0.6 间接依赖 npm
indx 0.2.3 间接依赖 npm
ansi-cyan 0.1.1 间接依赖 npm
to-absolute-glob 2.0.2 间接依赖 npm
fast-deep-equal 3.1.1 间接依赖 npm
is-number-like 1.0.8 间接依赖 npm
electron-to-chromium 1.3.430 间接依赖 npm
fastq 1.7.0 间接依赖 npm
lead 1.0.0 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
opn 5.3.0 间接依赖 npm
parse-node-version 1.0.1 间接依赖 npm
v8flags 3.1.3 直接依赖 npm
serve-static 1.13.2 间接依赖 npm
semver-greatest-satisfied-range 1.1.0 直接依赖 npm
just-debounce 1.0.0 间接依赖 npm
uniq 1.0.1 间接依赖 npm
http-proxy 1.15.2 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
rgb-regex 1.0.1 间接依赖 npm
wrap-ansi 2.1.0 间接依赖 npm
glob-stream 6.1.0 间接依赖 npm
is-path-cwd 2.2.0 间接依赖 npm
postcss-reduce-initial 4.0.3 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
vinyl-sourcemaps-apply 0.2.1 间接依赖 npm
unpipe 1.0.0 间接依赖 npm
socket.io 2.1.1 间接依赖 npm
lru-cache 4.1.5 间接依赖 npm
xmlhttprequest-ssl 1.5.5 间接依赖 npm
globule 1.3.1 间接依赖 npm
through2-filter 3.0.0 间接依赖 npm
engine.io-client 3.4.1 间接依赖 npm
postcss-minify-font-values 4.0.2 间接依赖 npm
os-locale 1.4.0 间接依赖 npm
postcss-normalize-unicode 4.0.1 间接依赖 npm
is-obj 2.0.0 间接依赖 npm
cross-spawn 3.0.1 间接依赖 npm
once 1.4.0 间接依赖 npm
graceful-fs 4.2.4 间接依赖 npm
are-we-there-yet 1.1.5 间接依赖 npm
is-finite 1.1.0 间接依赖 npm
which 1.3.1 间接依赖 npm
homedir-polyfill 1.0.3 间接依赖 npm
ajv 6.12.2 间接依赖 npm
bindings 1.5.0 间接依赖 npm
now-and-later 2.0.1 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
camelcase 3.0.0 间接依赖 npm
tunnel-agent 0.6.0 间接依赖 npm
verror 1.10.0 间接依赖 npm
path-type 1.1.0 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
cookie 0.3.1 间接依赖 npm
ordered-read-streams 1.0.1 间接依赖 npm
json-schema-traverse 0.4.1 间接依赖 npm
pretty-hrtime 1.0.3 直接依赖 npm
type 1.2.0 间接依赖 npm
unique-stream 2.3.1 间接依赖 npm
parse-filepath 1.0.2 间接依赖 npm
globby 10.0.2 间接依赖 npm
window-size 0.2.0 间接依赖 npm
postcss-discard-empty 4.0.1 间接依赖 npm
css-select-base-adapter 0.1.1 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
accepts 1.3.7 间接依赖 npm
postcss-normalize-repeat-style 4.0.2 间接依赖 npm
wide-align 1.1.3 间接依赖 npm
meow 3.7.0 间接依赖 npm
jsonfile 3.0.1 间接依赖 npm
object.reduce 1.0.1 间接依赖 npm
accord 0.29.0 间接依赖 npm
uglify-to-browserify 1.0.2 间接依赖 npm
chokidar 2.1.8 间接依赖 npm
redent 1.0.0 间接依赖 npm
locate-path 2.0.0 间接依赖 npm
postcss-discard-comments 4.0.2 间接依赖 npm
bcrypt-pbkdf 1.0.2 间接依赖 npm
timsort 0.3.0 间接依赖 npm
cssnano-util-raw-cache 4.0.1 间接依赖 npm
sver-compat 1.5.0 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
lcid 1.0.0 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
esprima 4.0.1 间接依赖 npm
node-gyp 3.8.0 间接依赖 npm
mkdirp 0.5.5 间接依赖 npm
nth-check 1.0.2 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
ansi-red 0.1.1 间接依赖 npm
css-tree 1.0.0-alpha.37 间接依赖 npm
is-directory 0.3.1 间接依赖 npm
is-color-stop 1.1.0 间接依赖 npm
gulp-sass 4.1.0 直接依赖 npm
fill-range 4.0.0 间接依赖 npm
aggregate-error 3.0.1 间接依赖 npm
is-absolute 1.0.0 间接依赖 npm
is-number 3.0.0 间接依赖 npm
array-last 1.3.0 间接依赖 npm
mime-db 1.44.0 间接依赖 npm
strip-indent 1.0.1 间接依赖 npm
lodash.uniq 4.5.0 间接依赖 npm
js-base64 2.5.2 间接依赖 npm
braces 2.3.2 间接依赖 npm
combined-stream 1.0.8 间接依赖 npm
yallist 2.1.2 间接依赖 npm
color-name 1.1.3 间接依赖 npm
base 0.11.2 间接依赖 npm
resolve-url 0.2.1 间接依赖 npm
tough-cookie 2.5.0 间接依赖 npm
ret 0.1.15 间接依赖 npm
pumpify 1.5.1 间接依赖 npm
etag 1.8.1 间接依赖 npm
has 1.0.3 间接依赖 npm
postcss-merge-longhand 4.0.11 间接依赖 npm
right-align 0.1.3 直接依赖 npm
color-string 1.5.3 间接依赖 npm
cssnano-util-same-parent 4.0.1 间接依赖 npm
nan 2.14.1 间接依赖 npm
array-each 1.0.1 间接依赖 npm
ws 6.1.4 间接依赖 npm
isarray 2.0.1 间接依赖 npm
unset-value 1.0.0 间接依赖 npm
depd 1.1.2 间接依赖 npm
fs-mkdirp-stream 1.0.0 间接依赖 npm
arr-filter 1.1.2 间接依赖 npm
cssnano-util-get-match 4.0.0 间接依赖 npm
snapdragon 0.8.2 间接依赖 npm
oauth-sign 0.9.0 间接依赖 npm
cliui 3.2.0 间接依赖 npm
flush-write-stream 1.1.1 间接依赖 npm
true-case-path 1.0.3 间接依赖 npm
through2 2.0.5 间接依赖 npm
vinyl 2.2.0 间接依赖 npm
caniuse-api 3.0.0 间接依赖 npm
es-abstract 1.17.5 间接依赖 npm
caller-path 2.0.0 间接依赖 npm
on-finished 2.3.0 间接依赖 npm
define-property 2.0.2 间接依赖 npm
static-extend 0.1.2 间接依赖 npm
union-value 1.0.1 间接依赖 npm
has-value 1.0.0 间接依赖 npm
get-stdin 4.0.1 间接依赖 npm
flagged-respawn 1.0.1 间接依赖 npm
find-up 2.1.0 间接依赖 npm
signal-exit 3.0.3 间接依赖 npm
value-or-function 3.0.0 间接依赖 npm
stream-shift 1.0.1 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
es6-weak-map 2.0.3 间接依赖 npm
scss-tokenizer 0.2.3 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
es5-ext 0.10.53 间接依赖 npm
is-wsl 1.1.0 间接依赖 npm
repeat-string 1.6.1 间接依赖 npm
num2fraction 1.2.2 间接依赖 npm
component-bind 1.0.0 间接依赖 npm
connect-history-api-fallback 1.6.0 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
has-cors 1.1.0 间接依赖 npm
del 5.1.0 直接依赖 npm
y18n 3.2.1 间接依赖 npm
mime 1.4.1 间接依赖 npm
callsite 1.0.0 间接依赖 npm
aws4 1.9.1 间接依赖 npm
postcss 7.0.29 间接依赖 npm
postcss-convert-values 4.0.1 间接依赖 npm
has-symbols 1.0.1 间接依赖 npm
gulp-postcss 8.0.0 直接依赖 npm
assign-symbols 1.0.0 间接依赖 npm
postcss-reduce-transforms 4.0.2 间接依赖 npm
is-typedarray 1.0.0 间接依赖 npm
inflight 1.0.6 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
ansi-gray 0.1.1 间接依赖 npm
server-destroy 1.0.1 间接依赖 npm
browser-sync 2.26.7 直接依赖 npm
uri-js 4.2.2 间接依赖 npm
http-signature 1.2.0 间接依赖 npm
easy-extender 2.3.4 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
component-emitter 1.2.1 间接依赖 npm
console-control-strings 1.1.0 间接依赖 npm
object.defaults 1.1.0 间接依赖 npm
http-errors 1.7.3 间接依赖 npm
remove-bom-stream 1.2.0 间接依赖 npm
class-utils 0.3.6 间接依赖 npm
code-point-at 1.1.0 间接依赖 npm
ansi-colors 1.1.0 直接依赖 npm
mime-types 2.1.27 间接依赖 npm
currently-unhandled 0.4.1 间接依赖 npm
postcss-normalize-whitespace 4.0.2 间接依赖 npm
tweetnacl 0.14.5 间接依赖 npm
ini 1.3.5 间接依赖 npm
@nodelib/fs.scandir 2.1.3 间接依赖 npm
merge2 1.3.0 间接依赖 npm
is-accessor-descriptor 0.1.6 间接依赖 npm
end-of-stream 1.4.4 间接依赖 npm
camelcase-keys 2.1.0 间接依赖 npm
buffer-equal 1.0.0 间接依赖 npm
array-find-index 1.0.2 间接依赖 npm
array-sort 1.0.0 直接依赖 npm
clone 2.1.2 间接依赖 npm
path-root-regex 0.1.2 间接依赖 npm
qs 6.2.3 间接依赖 npm
urix 0.1.0 间接依赖 npm
gauge 2.7.4 间接依赖 npm
escape-html 1.0.3 间接依赖 npm
debug 4.1.1 间接依赖 npm
rechoir 0.6.2 间接依赖 npm
uglify-js 2.8.29 间接依赖 npm
@types/events 3.0.0 间接依赖 npm
p-map 3.0.0 间接依赖 npm
postcss-minify-gradients 4.0.2 间接依赖 npm
resolve-options 1.1.0 间接依赖 npm
d 1.0.1 间接依赖 npm
prr 1.0.1 间接依赖 npm
css-declaration-sorter 4.0.1 间接依赖 npm
tfunk 3.1.0 间接依赖 npm
require-main-filename 1.0.1 间接依赖 npm
file-uri-to-path 1.0.0 间接依赖 npm
to-object-path 0.3.0 间接依赖 npm
postcss-colormin 4.0.3 间接依赖 npm
longest 1.0.1 间接依赖 npm
is-utf8 0.2.1 间接依赖 npm
unc-path-regex 0.1.2 间接依赖 npm
has-binary2 1.0.3 间接依赖 npm
har-validator 5.1.3 间接依赖 npm
yargs 6.4.0 间接依赖 npm
base64-arraybuffer 0.1.5 间接依赖 npm
asap 2.0.6 间接依赖 npm
path-dirname 1.0.2 间接依赖 npm
stack-trace 0.0.10 间接依赖 npm
duplexify 3.7.1 间接依赖 npm
performance-now 2.1.0 间接依赖 npm
snapdragon-util 3.0.1 间接依赖 npm
split-string 3.1.0 间接依赖 npm
glob 7.1.6 间接依赖 npm
postcss-ordered-values 4.1.2 间接依赖 npm
immutable 3.8.2 间接依赖 npm
async-each 1.0.3 间接依赖 npm
pascalcase 0.1.1 间接依赖 npm
cloneable-readable 1.1.3 间接依赖 npm
which-module 1.0.0 间接依赖 npm
expand-brackets 2.1.4 间接依赖 npm
svgo 1.3.2 间接依赖 npm
postcss-discard-duplicates 4.0.2 间接依赖 npm
@types/minimatch 3.0.3 间接依赖 npm
trim-newlines 1.0.0 间接依赖 npm
engine.io-parser 2.2.0 间接依赖 npm
xtend 4.0.2 间接依赖 npm
sax 1.2.4 间接依赖 npm
simple-swizzle 0.2.2 间接依赖 npm
resolve 1.17.0 间接依赖 npm
q 1.5.1 间接依赖 npm
posix-character-classes 0.1.1 间接依赖 npm
parseuri 0.0.5 间接依赖 npm
argparse 1.0.10 间接依赖 npm
parseurl 1.3.3 间接依赖 npm
global-prefix 1.0.2 间接依赖 npm
gaze 1.1.3 间接依赖 npm
arr-map 2.0.2 间接依赖 npm
convert-source-map 1.7.0 间接依赖 npm
rimraf 3.0.2 间接依赖 npm
map-obj 1.0.1 间接依赖 npm
is-extglob 2.1.1 间接依赖 npm
is-resolvable 1.1.0 间接依赖 npm
arraybuffer.slice 0.0.7 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
spdx-expression-parse 3.0.0 间接依赖 npm
pify 2.3.0 间接依赖 npm
number-is-nan 1.0.1 间接依赖 npm
fresh 0.5.2 间接依赖 npm
liftoff 3.1.0 直接依赖 npm
time-stamp 1.1.0 间接依赖 npm
normalize-url 3.3.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
delayed-stream 1.0.0 间接依赖 npm
normalize-path 3.0.0 间接依赖 npm
mute-stdout 1.0.1 直接依赖 npm
block-stream 0.0.9 间接依赖 npm
amdefine 1.0.1 直接依赖 npm
encodeurl 1.0.2 间接依赖 npm
backo2 1.0.2 间接依赖 npm
object-path 0.9.2 间接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
@types/node 13.13.5 间接依赖 npm
connect 3.6.6 间接依赖 npm
emoji-regex 7.0.3 直接依赖 npm
findup-sync 3.0.0 间接依赖 npm
follow-redirects 1.5.10 间接依赖 npm
socket.io-adapter 1.1.2 间接依赖 npm
vinyl-fs 3.0.3 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
symbol-observable 1.0.1 间接依赖 npm
archy 1.0.0 直接依赖 npm
finalhandler 1.1.0 间接依赖 npm
blob 0.0.5 间接依赖 npm
postcss-value-parser 4.1.0 间接依赖 npm
image-size 0.5.5 间接依赖 npm
postcss-normalize-charset 4.0.1 间接依赖 npm
bs-snippet-injector 2.0.1 间接依赖 npm
isstream 0.1.2 间接依赖 npm
lodash.partialright 4.2.1 间接依赖 npm
lodash.defaults 4.2.0 间接依赖 npm
readdirp 2.2.1 间接依赖 npm
uniqs 2.0.0 间接依赖 npm
caseless 0.12.0 间接依赖 npm
hosted-git-info 2.8.8 间接依赖 npm
cache-base 1.0.1 间接依赖 npm
delegates 1.0.0 间接依赖 npm
object.values 1.1.1 间接依赖 npm
async-done 1.3.2 间接依赖 npm
object.map 1.0.1 间接依赖 npm
when 3.7.8 间接依赖 npm
request 2.88.2 间接依赖 npm
es6-iterator 2.0.3 间接依赖 npm
css-what 3.2.1 间接依赖 npm
matchdep 2.0.0 直接依赖 npm
html-comment-regex 1.1.2 间接依赖 npm
psl 1.8.0 间接依赖 npm
has-unicode 2.0.1 间接依赖 npm
punycode 2.1.1 间接依赖 npm
fast-json-stable-stringify 2.1.0 间接依赖 npm
interpret 1.2.0 直接依赖 npm
stream-exhaust 1.0.2 间接依赖 npm
postcss-normalize-positions 4.0.2 间接依赖 npm
fs-extra 3.0.1 间接依赖 npm
ua-parser-js 0.7.17 间接依赖 npm
lazystream 1.0.0 间接依赖 npm
postcss-minify-params 4.0.2 间接依赖 npm
extsprintf 1.3.0 间接依赖 npm
is-valid-glob 1.0.0 间接依赖 npm
undertaker 1.2.1 间接依赖 npm
tar 2.2.2 间接依赖 npm
collection-map 1.0.0 间接依赖 npm
to-array 0.1.4 间接依赖 npm
form-data 2.3.3 间接依赖 npm
stdout-stream 1.4.1 间接依赖 npm
promise 7.3.1 间接依赖 npm
async-limiter 1.0.1 间接依赖 npm
import-cwd 2.1.0 间接依赖 npm
spdx-correct 3.1.0 间接依赖 npm
ignore 5.1.4 间接依赖 npm
@types/glob 7.1.1 间接依赖 npm
utils-merge 1.0.1 间接依赖 npm
pkg-up 2.0.0 间接依赖 npm
dir-glob 3.0.1 间接依赖 npm
p-locate 2.0.0 间接依赖 npm
eazy-logger 3.0.2 间接依赖 npm
is-fullwidth-code-point 1.0.0 间接依赖 npm
get-value 2.0.6 间接依赖 npm
css-select 2.1.0 间接依赖 npm
is-negated-glob 1.0.0 间接依赖 npm
normalize-range 0.1.2 间接依赖 npm
asn1 0.2.4 间接依赖 npm
gulplog 1.0.0 直接依赖 npm
object-component 0.0.3 间接依赖 npm
fast-glob 3.2.2 间接依赖 npm
sshpk 1.16.1 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
vendors 1.0.4 间接依赖 npm
uuid 3.4.0 间接依赖 npm
wordwrap 0.0.2 直接依赖 npm
@nodelib/fs.stat 2.0.3 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
yargs-parser 4.2.1 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
async-foreach 0.1.3 间接依赖 npm
axios 0.19.0 间接依赖 npm
parse-passwd 1.0.0 间接依赖 npm
ecc-jsbn 0.1.2 间接依赖 npm
source-map-url 0.4.0 间接依赖 npm
ansi-wrap 0.1.0 间接依赖 npm
sparkles 1.0.1 间接依赖 npm
async 1.5.2 间接依赖 npm
toidentifier 1.0.0 间接依赖 npm
color-convert 1.9.3 间接依赖 npm
concat-stream 1.6.2 直接依赖 npm
picomatch 2.2.2 间接依赖 npm
mitt 1.2.0 间接依赖 npm
array-slice 1.1.0 间接依赖 npm
rxjs 5.5.12 间接依赖 npm
append-buffer 1.0.2 间接依赖 npm
browser-sync-client 2.26.6 间接依赖 npm
engine.io 3.2.1 间接依赖 npm
browser-sync-ui 2.26.4 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
bytes 3.1.0 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
base64id 1.0.0 间接依赖 npm
repeat-element 1.1.3 间接依赖 npm
lodash 4.17.15 间接依赖 npm
to-through 2.0.0 间接依赖 npm
fined 1.2.0 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
parse-json 2.2.0 间接依赖 npm
lodash.clone 4.5.0 间接依赖 npm
in-publish 2.0.1 间接依赖 npm
atob 2.1.2 间接依赖 npm
source-map-resolve 0.5.3 间接依赖 npm
lazy-cache 1.0.4 间接依赖 npm
global-modules 1.0.0 间接依赖 npm
clone-stats 1.0.0 间接依赖 npm
limiter 1.1.5 间接依赖 npm
gulp 4.0.2 直接依赖 npm
(0)
上一篇 2023年10月28日
下一篇 2023年10月28日

相关推荐

  • EQuimper/nodejs-api-boilerplate 软件分析报告

    基础信息 项目名称:EQuimper/nodejs-api-boilerplate 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721166910208413696/1722998960053768192 此报…

    软件分析 2023年11月10日
    0
  • huxingyi/dust3d 软件分析报告

    基础信息 项目名称:huxingyi/dust3d 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1718726436822237184/1718726437010980864 此报告由Murphysec提供 漏洞…

    软件分析 2023年10月30日
    0
  • Jermolene/TiddlyWiki5 软件分析报告

    基础信息 项目名称:Jermolene/TiddlyWiki5 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721304212565741568/1726763609033760768 此报告由Murphyse…

    软件分析 2023年11月21日
    0
  • fbernardo/WishlistAnimation 软件分析报告

    基础信息 项目名称:fbernardo/WishlistAnimation 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721189579909828608/1726117101659181056 此报告由Mu…

    软件分析 2023年11月19日
    0
  • ManimCommunity/manim 软件分析报告

    基础信息 项目名称:ManimCommunity/manim 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1755966310236663808/1755966310278606848 此报告由Murphysec…

    软件分析 2024年2月9日
    0