gauravsoni119/ng2-tel-input 软件分析报告

基础信息

项目名称:gauravsoni119/ng2-tel-input

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1718038670232829952/1718038670274772992

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
kind-of 存在注入漏洞 将资源暴露给错误范围 MPS-2019-17164 CVE-2019-20149 高危
Yargs Y18n 输入原型污染漏洞 动态确定对象属性修改的控制不恰当 MPS-2020-17543 CVE-2020-7774 严重
Ini 拒绝服务 MPS-2020-17544 CVE-2020-7788 高危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
yargs-parser 原型污染漏洞 特权定义了不安全动作 MPS-2020-4006 CVE-2020-7608 中危
Ruy Adorno hosted-git-info 正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-3400 CVE-2021-23362 中危
Takayuki Sato copy-props 安全漏洞 原型污染 MPS-2021-3446 CVE-2020-28503 严重
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
npm path-parse 安全漏洞 拒绝服务 MPS-2021-6165 CVE-2021-23343 高危
glob-parent 拒绝服务 MPS-2021-7827 CVE-2020-28469 高危
Angular 跨站脚本漏洞 XSS MPS-2022-12764 CVE-2021-4231 中危
@angular/core 存在跨站脚本漏洞 XSS MPS-2022-13545 低危
uglify-js ReDoS MPS-2022-14112 中危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
decode-uri-component 拒绝服务 MPS-2022-56259 CVE-2022-38900 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
fsevents 安全漏洞 代码注入 MPS-2ipy-muq0 CVE-2023-45311 严重

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
y18n 4.0.0 4.0.1 间接依赖 建议修复
decode-uri-component 0.2.0 0.2.1 间接依赖 建议修复
y18n 3.2.1 3.2.2 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
minimist 1.2.0 1.2.6 间接依赖 建议修复
copy-props 2.0.4 2.0.5 直接依赖 建议修复
ini 1.3.5 1.3.6 间接依赖 建议修复
glob-parent 3.1.0 5.1.2 间接依赖 建议修复
path-parse 1.0.6 1.0.7 间接依赖 建议修复
fsevents 1.2.9 1.2.11 间接依赖 可选修复
semver 5.7.0 7.5.2 间接依赖 可选修复
uglify-js 3.8.0 3.14.3 直接依赖 可选修复
hosted-git-info 2.7.1 2.8.9 间接依赖 可选修复
yargs-parser 13.1.1 13.1.2 间接依赖 可选修复
semver 5.7.1 7.5.2 间接依赖 可选修复
kind-of 6.0.2 6.0.3 间接依赖 可选修复
yargs-parser 5.0.0 5.0.1 间接依赖 可选修复
@angular/core 8.2.14 11.0.5 直接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 321
ISC 45
CC-BY-3.0 1
Apache-2.0 8
BSD-2-Clause 2
BSD-3-Clause 2
CC0-1.0 1

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
util-deprecate 1.0.2 间接依赖 npm
path-parse 1.0.6 间接依赖 npm
sver-compat 1.5.0 间接依赖 npm
vinyl 2.2.0 间接依赖 npm
es6-weak-map 2.0.3 间接依赖 npm
strip-ansi 5.2.0 间接依赖 npm
ordered-read-streams 1.0.1 间接依赖 npm
yargs 13.1.0 间接依赖 npm
cloneable-readable 1.1.3 间接依赖 npm
resolve-dir 1.0.1 间接依赖 npm
require-main-filename 1.0.1 间接依赖 npm
kind-of 6.0.3 间接依赖 npm
yargs 7.1.0 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
vinyl-fs 3.0.3 间接依赖 npm
es5-ext 0.10.53 间接依赖 npm
code-point-at 1.1.0 直接依赖 npm
union-value 1.0.1 间接依赖 npm
stream-shift 1.0.0 间接依赖 npm
parse-passwd 1.0.0 间接依赖 npm
nice-try 1.0.5 间接依赖 npm
ansi-colors 1.1.0 直接依赖 npm
read-pkg 1.1.0 间接依赖 npm
clone-buffer 1.0.0 间接依赖 npm
intl-tel-input 16.0.11 直接依赖 npm
array-initial 1.1.0 间接依赖 npm
type 1.2.0 间接依赖 npm
arr-filter 1.1.2 间接依赖 npm
minimist 1.2.0 间接依赖 npm
@angular/compiler-cli 8.2.14 直接依赖 npm
fragment-cache 0.2.1 间接依赖 npm
normalize-path 2.1.1 间接依赖 npm
each-props 1.3.2 间接依赖 npm
mixin-deep 1.3.2 间接依赖 npm
inherits 2.0.3 间接依赖 npm
is-glob 4.0.1 间接依赖 npm
wrap-ansi 2.1.0 间接依赖 npm
hosted-git-info 2.7.1 间接依赖 npm
nan 2.14.0 间接依赖 npm
binary-extensions 1.11.0 间接依赖 npm
lcid 2.0.0 间接依赖 npm
ansi-gray 0.1.1 间接依赖 npm
plugin-error 0.1.2 间接依赖 npm
p-defer 1.0.0 间接依赖 npm
fill-range 4.0.0 间接依赖 npm
copy-props 2.0.4 直接依赖 npm
arr-union 2.1.0 间接依赖 npm
chokidar 2.1.8 间接依赖 npm
es5-ext 0.10.50 间接依赖 npm
os-locale 3.1.0 间接依赖 npm
xtend 4.0.1 间接依赖 npm
invert-kv 1.0.0 间接依赖 npm
is-descriptor 1.0.2 间接依赖 npm
readable-stream 2.3.5 间接依赖 npm
archy 1.0.0 直接依赖 npm
bach 1.2.0 间接依赖 npm
pump 2.0.1 间接依赖 npm
es6-shim 0.35.5 直接依赖 npm
is-extendable 0.1.1 间接依赖 npm
type 2.0.0 间接依赖 npm
d 1.0.1 间接依赖 npm
posix-character-classes 0.1.1 间接依赖 npm
is-windows 1.0.2 间接依赖 npm
snapdragon-node 2.1.1 间接依赖 npm
pify 2.3.0 间接依赖 npm
spdx-exceptions 2.2.0 间接依赖 npm
set-value 2.0.1 间接依赖 npm
ansi-wrap 0.1.0 间接依赖 npm
readable-stream 2.3.6 间接依赖 npm
through2-filter 3.0.0 间接依赖 npm
object.pick 1.3.0 间接依赖 npm
default-resolution 2.0.0 间接依赖 npm
glob 7.1.4 间接依赖 npm
kind-of 6.0.2 间接依赖 npm
clone-stats 1.0.0 间接依赖 npm
stream-exhaust 1.0.2 间接依赖 npm
inflight 1.0.6 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
object.map 1.0.1 间接依赖 npm
gulp-clean 0.4.0 直接依赖 npm
safe-regex 1.1.0 间接依赖 npm
isobject 3.0.1 间接依赖 npm
kind-of 5.1.0 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
yargs-parser 5.0.0 间接依赖 npm
extend-shallow 1.1.4 间接依赖 npm
semver 5.7.1 间接依赖 npm
load-json-file 1.1.0 间接依赖 npm
path-dirname 1.0.2 间接依赖 npm
spdx-correct 3.1.0 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
snapdragon 0.8.2 间接依赖 npm
arr-map 2.0.2 间接依赖 npm
object.defaults 1.1.0 间接依赖 npm
is-buffer 1.1.6 间接依赖 npm
path-root 0.1.1 间接依赖 npm
isarray 1.0.0 间接依赖 npm
cache-base 1.0.1 间接依赖 npm
cliui 4.1.0 间接依赖 npm
has-value 1.0.0 间接依赖 npm
set-blocking 2.0.0 间接依赖 npm
fsevents 2.1.2 直接依赖 npm
pretty-hrtime 1.0.3 直接依赖 npm
bindings 1.5.0 间接依赖 npm
process-nextick-args 2.0.0 间接依赖 npm
string_decoder 1.0.3 间接依赖 npm
lazystream 1.0.0 间接依赖 npm
fancy-log 1.3.3 间接依赖 npm
get-value 2.0.6 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
fined 1.2.0 间接依赖 npm
replace-homedir 1.0.0 直接依赖 npm
define-property 1.0.0 间接依赖 npm
buffer-from 1.1.1 间接依赖 npm
fsevents 1.2.11 直接依赖 npm
component-emitter 1.3.0 间接依赖 npm
cliui 3.2.0 间接依赖 npm
map-cache 0.2.2 间接依赖 npm
is-data-descriptor 0.1.4 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
just-debounce 1.0.0 间接依赖 npm
type 1.0.1 间接依赖 npm
npm-run-path 2.0.2 间接依赖 npm
last-run 1.1.1 间接依赖 npm
is-relative 1.0.0 间接依赖 npm
gulp 4.0.2 直接依赖 npm
urix 0.1.0 间接依赖 npm
@angular/core 8.2.14 直接依赖 npm
normalize-path 3.0.0 间接依赖 npm
canonical-path 1.0.0 间接依赖 npm
ini 1.3.5 间接依赖 npm
resolve 1.11.1 间接依赖 npm
clone 2.1.2 间接依赖 npm
has-symbols 1.0.1 间接依赖 npm
normalize-package-data 2.5.0 间接依赖 npm
array-slice 1.1.0 间接依赖 npm
stream-shift 1.0.1 间接依赖 npm
stack-trace 0.0.10 间接依赖 npm
get-caller-file 2.0.5 间接依赖 npm
fsevents 1.2.9 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
dependency-graph 0.7.2 间接依赖 npm
tsickle 0.38.1 直接依赖 npm
source-map 0.6.1 间接依赖 npm
flagged-respawn 1.0.1 间接依赖 npm
readable-stream 2.3.7 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
extend-shallow 2.0.1 间接依赖 npm
to-absolute-glob 2.0.2 间接依赖 npm
is-arrayish 0.2.1 间接依赖 npm
emoji-regex 7.0.3 间接依赖 npm
decamelize 1.2.0 间接依赖 npm
regex-not 1.0.2 间接依赖 npm
cross-spawn 6.0.5 间接依赖 npm
parse-filepath 1.0.2 间接依赖 npm
ms 2.0.0 直接依赖 npm
is-extglob 2.1.1 间接依赖 npm
is-accessor-descriptor 0.1.6 间接依赖 npm
remove-trailing-separator 1.1.0 间接依赖 npm
convert-source-map 1.7.0 间接依赖 npm
glob 7.1.6 间接依赖 npm
color-support 1.1.3 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
sourcemap-codec 1.4.8 间接依赖 npm
global-prefix 1.0.2 间接依赖 npm
braces 2.3.2 间接依赖 npm
magic-string 0.25.6 间接依赖 npm
commander 2.20.3 间接依赖 npm
readdirp 2.2.1 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
source-map-resolve 0.5.3 间接依赖 npm
parse-json 2.2.0 间接依赖 npm
lead 1.0.0 间接依赖 npm
is-utf8 0.2.1 间接依赖 npm
ansi-red 0.1.1 间接依赖 npm
replace-ext 1.0.0 间接依赖 npm
is-valid-glob 1.0.0 间接依赖 npm
yargs-parser 13.1.1 间接依赖 npm
matchdep 2.0.0 直接依赖 npm
homedir-polyfill 1.0.3 间接依赖 npm
camelcase 5.3.1 间接依赖 npm
unc-path-regex 0.1.2 间接依赖 npm
invert-kv 2.0.0 间接依赖 npm
semver 5.7.0 间接依赖 npm
base 0.11.2 间接依赖 npm
validate-npm-package-license 3.0.4 间接依赖 npm
ext 1.4.0 间接依赖 npm
debug 2.6.9 间接依赖 npm
expand-brackets 2.1.4 间接依赖 npm
uglify-js 3.8.0 直接依赖 npm
mem 4.3.0 间接依赖 npm
define-property 0.2.5 间接依赖 npm
graceful-fs 4.2.3 间接依赖 npm
string-width 2.1.1 间接依赖 npm
nanomatch 1.2.13 间接依赖 npm
convert-source-map 1.6.0 间接依赖 npm
glob-parent 3.1.0 间接依赖 npm
fs-mkdirp-stream 1.0.0 间接依赖 npm
unset-value 1.0.0 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
y18n 4.0.0 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
v8flags 3.1.3 直接依赖 npm
rimraf 2.6.3 间接依赖 npm
has-symbols 1.0.0 间接依赖 npm
vinyl-sourcemap 1.1.0 间接依赖 npm
define-properties 1.1.3 间接依赖 npm
which-module 2.0.0 间接依赖 npm
glogg 1.0.2 间接依赖 npm
number-is-nan 1.0.1 直接依赖 npm
pascalcase 0.1.1 间接依赖 npm
value-or-function 3.0.0 间接依赖 npm
split-string 3.1.0 间接依赖 npm
ansi-regex 3.0.0 间接依赖 npm
xtend 4.0.2 间接依赖 npm
reflect-metadata 0.1.10 间接依赖 npm
gulplog 1.0.0 直接依赖 npm
to-regex-range 2.1.1 间接依赖 npm
concat-stream 1.6.2 直接依赖 npm
resolve 1.15.1 间接依赖 npm
append-buffer 1.0.2 间接依赖 npm
make-iterator 1.0.1 间接依赖 npm
path-key 2.0.1 间接依赖 npm
async-done 1.3.2 间接依赖 npm
upath 1.2.0 间接依赖 npm
arr-diff 1.1.0 间接依赖 npm
graceful-fs 4.2.0 间接依赖 npm
object-keys 1.1.1 间接依赖 npm
collection-visit 1.0.0 间接依赖 npm
micromatch 3.1.10 间接依赖 npm
source-map 0.5.7 间接依赖 npm
rimraf 2.7.1 间接依赖 npm
extend 3.0.2 间接依赖 npm
get-stream 4.1.0 间接依赖 npm
pumpify 1.5.1 间接依赖 npm
repeat-element 1.1.2 间接依赖 npm
next-tick 1.0.0 间接依赖 npm
to-through 2.0.0 间接依赖 npm
undertaker-registry 1.0.1 间接依赖 npm
is-binary-path 1.0.1 间接依赖 npm
strip-ansi 4.0.0 间接依赖 npm
execa 1.0.0 间接依赖 npm
expand-tilde 2.0.2 间接依赖 npm
upath 1.1.2 间接依赖 npm
read-pkg-up 1.0.1 直接依赖 npm
map-age-cleaner 0.1.3 间接依赖 npm
string-width 3.1.0 间接依赖 npm
resolve-url 0.2.1 间接依赖 npm
repeat-string 1.6.1 间接依赖 npm
use 3.1.1 间接依赖 npm
p-finally 1.0.0 间接依赖 npm
lcid 1.0.0 间接依赖 npm
extend-shallow 3.0.2 间接依赖 npm
async-settle 1.0.0 间接依赖 npm
class-utils 0.3.6 间接依赖 npm
duplexify 3.7.1 间接依赖 npm
ansi-cyan 0.1.1 间接依赖 npm
es6-symbol 3.1.3 间接依赖 npm
array-sort 1.0.0 直接依赖 npm
detect-file 1.0.0 间接依赖 npm
find-up 3.0.0 间接依赖 npm
p-is-promise 2.1.0 间接依赖 npm
array-slice 0.2.3 间接依赖 npm
decode-uri-component 0.2.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
glob-watcher 5.0.3 间接依赖 npm
source-map-resolve 0.5.2 间接依赖 npm
snapdragon-util 3.0.1 间接依赖 npm
path-exists 2.1.0 间接依赖 npm
arr-union 3.1.0 间接依赖 npm
remove-bom-buffer 3.0.0 间接依赖 npm
intl-tel-input 16.0.1 直接依赖 npm
gulp-cli 2.2.0 间接依赖 npm
rechoir 0.6.2 间接依赖 npm
require-directory 2.1.1 间接依赖 npm
path-type 1.1.0 间接依赖 npm
once 1.4.0 间接依赖 npm
findup-sync 3.0.0 间接依赖 npm
safe-buffer 5.2.0 间接依赖 npm
ansi-regex 4.1.0 间接依赖 npm
anymatch 2.0.0 间接依赖 npm
is-fullwidth-code-point 2.0.0 间接依赖 npm
rxjs 6.5.4 直接依赖 npm
array-each 1.0.1 间接依赖 npm
buffer-equal 1.0.0 间接依赖 npm
y18n 3.2.1 间接依赖 npm
is-number 4.0.0 间接依赖 npm
array-last 1.3.0 间接依赖 npm
@angular/common 8.2.14 直接依赖 npm
pump 3.0.0 间接依赖 npm
sparkles 1.0.1 间接依赖 npm
which-module 1.0.0 间接依赖 npm
path-root-regex 0.1.2 间接依赖 npm
global-modules 1.0.0 间接依赖 npm
rollup 2.0.2 直接依赖 npm
error-ex 1.3.2 间接依赖 npm
zone.js 0.9.1 直接依赖 npm
flush-write-stream 1.1.1 间接依赖 npm
strip-bom 2.0.0 间接依赖 npm
@angular/compiler 8.2.14 直接依赖 npm
is-descriptor 0.1.6 间接依赖 npm
es6-iterator 2.0.3 间接依赖 npm
to-object-path 0.3.0 间接依赖 npm
atob 2.1.2 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
locate-path 3.0.0 间接依赖 npm
typedarray 0.0.6 间接依赖 npm
kind-of 3.2.2 间接依赖 npm
define-property 2.0.2 间接依赖 npm
end-of-stream 1.4.1 间接依赖 npm
for-in 1.0.2 间接依赖 npm
interpret 1.2.0 直接依赖 npm
collection-map 1.0.0 间接依赖 npm
semver-greatest-satisfied-range 1.1.0 直接依赖 npm
is-glob 3.1.0 间接依赖 npm
typescript 3.4.5 直接依赖 npm
static-extend 0.1.2 间接依赖 npm
p-locate 3.0.0 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
unique-stream 2.3.1 间接依赖 npm
process-nextick-args 2.0.1 间接依赖 npm
source-map-url 0.4.0 间接依赖 npm
string-width 1.0.2 间接依赖 npm
undertaker 1.2.1 间接依赖 npm
binary-extensions 1.13.1 间接依赖 npm
async-each 1.0.3 间接依赖 npm
spdx-license-ids 3.0.4 间接依赖 npm
get-caller-file 1.0.3 间接依赖 npm
p-limit 2.2.2 间接依赖 npm
extglob 2.0.4 间接依赖 npm
inherits 2.0.4 间接依赖 npm
safe-buffer 5.1.1 间接依赖 npm
parse-node-version 1.0.1 间接依赖 npm
mimic-fn 2.1.0 间接依赖 npm
spdx-expression-parse 3.0.0 间接依赖 npm
findup-sync 2.0.0 间接依赖 npm
object.reduce 1.0.1 间接依赖 npm
end-of-stream 1.4.4 间接依赖 npm
now-and-later 2.0.1 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
is-number 3.0.0 间接依赖 npm
glob-stream 6.1.0 间接依赖 npm
is-extendable 1.0.1 间接依赖 npm
require-main-filename 2.0.0 间接依赖 npm
to-regex 3.0.2 间接依赖 npm
kind-of 1.1.0 间接依赖 npm
path-exists 3.0.0 间接依赖 npm
which 1.3.1 间接依赖 npm
mute-stdout 1.0.1 直接依赖 npm
es6-symbol 3.1.1 间接依赖 npm
pinkie 2.0.4 间接依赖 npm
liftoff 3.1.0 直接依赖 npm
strip-eof 1.0.0 间接依赖 npm
is-unc-path 1.0.0 间接依赖 npm
array-unique 0.3.2 间接依赖 npm
remove-bom-stream 1.2.0 间接依赖 npm
tslib 1.11.0 间接依赖 npm
arr-flatten 1.1.0 间接依赖 npm
resolve-options 1.1.0 间接依赖 npm
tslib 1.9.3 间接依赖 npm
chokidar 2.1.6 间接依赖 npm
arr-diff 4.0.0 间接依赖 npm
reflect-metadata 0.1.13 直接依赖 npm
object.assign 4.1.0 间接依赖 npm
file-uri-to-path 1.0.0 间接依赖 npm
default-compare 1.0.0 间接依赖 npm
time-stamp 1.1.0 间接依赖 npm
shebang-command 1.2.0 间接依赖 npm
for-own 1.0.0 间接依赖 npm
ret 0.1.15 间接依赖 npm
camelcase 3.0.0 间接依赖 npm
p-try 2.2.0 间接依赖 npm
is-absolute 1.0.0 间接依赖 npm
through2 2.0.5 间接依赖 npm
is-plain-object 2.0.4 间接依赖 npm
os-locale 1.4.0 间接依赖 npm
repeat-element 1.1.3 间接依赖 npm
is-fullwidth-code-point 1.0.0 间接依赖 npm
is-negated-glob 1.0.0 间接依赖 npm
assign-symbols 1.0.0 间接依赖 npm
find-up 1.1.2 间接依赖 npm
(0)
上一篇 2023年10月28日
下一篇 2023年10月28日

相关推荐

  • forms-angular/forms-angular 软件分析报告

    基础信息 项目名称:forms-angular/forms-angular 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1717940013043941376/1717940013312376833 此报告由Mu…

    软件分析 2023年10月28日
    0
  • kilianc/rtail 软件分析报告

    基础信息 项目名称:kilianc/rtail 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719461782447849472/1719461787367768064 此报告由Murphysec提供 漏洞列表…

    软件分析 2023年11月1日
    0
  • matomo-org/matomo 软件分析报告

    基础信息 项目名称:matomo-org/matomo 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1744132431440031744/1744132431477780480 此报告由Murphysec提供 …

    软件分析 2024年1月8日
    0
  • anaglik/PeriscopyPullToRefresh 软件分析报告

    基础信息 项目名称:anaglik/PeriscopyPullToRefresh 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715778459497447424/1715778459677802496 此报告…

    软件分析 2023年10月23日
    0
  • alextarrago/QZCircleSegue 软件分析报告

    基础信息 项目名称:alextarrago/QZCircleSegue 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1715643785861185536/1715643786280615936 此报告由Murp…

    软件分析 2023年10月23日
    0