delfrrr/npm-consider 软件分析报告

基础信息

项目名称:delfrrr/npm-consider

项目徽章:

Security Status

仓库地址:https://github.com/pterodactyl/panel

检测报告地址:https://www.murphysec.com/console/report/1717113809713020928/1717113810853871616

此报告由Murphysec提供

漏洞列表

漏洞名称 漏洞类型 MPS编号 CVE编号 漏洞等级
Ajv v6.12.2 输入验证错误漏洞 MAID MPS-2020-10525 CVE-2020-15366 中危
npm node-fetch 不加限制的资源分配漏洞 不加限制或调节的资源分配 MPS-2020-12719 CVE-2020-15168 中危
Ini 拒绝服务 MPS-2020-17544 CVE-2020-7788 高危
minimist 原型污染漏洞 原型污染 MPS-2020-3516 CVE-2020-7598 中危
Ruy Adorno hosted-git-info 正则表达式拒绝服务漏洞 拒绝服务 MPS-2021-3400 CVE-2021-23362 中危
minimist 安全漏洞 原型污染 MPS-2021-38405 CVE-2021-44906 严重
npm path-parse 安全漏洞 拒绝服务 MPS-2021-6165 CVE-2021-23343 高危
Moment.js 正则拒绝服务漏洞 拒绝服务 MPS-2022-11159 CVE-2022-31129 高危
acorn 存在拒绝服务漏洞 拒绝服务 MPS-2022-13525 高危
js-yaml 存在拒绝服务漏洞 拒绝服务 MPS-2022-13820 中危
js-yaml 代码注入 MPS-2022-13822 高危
node-fetch 信息泄露漏洞 未授权敏感信息泄露 MPS-2022-1461 CVE-2022-0235 中危
Moment.js 路径遍历漏洞 路径遍历 MPS-2022-3752 CVE-2022-24785 中危
node-semver 安全漏洞 ReDoS MPS-2022-5166 CVE-2022-25883 高危
minimatch 资源管理错误漏洞 拒绝服务 MPS-2022-59845 CVE-2022-3517 高危
cross-fetch 安全漏洞 授权检查错误 MPS-2022-8877 CVE-2022-1365 中危

缺陷组件

组件名称 版本 最小修复版本 依赖关系 修复建议
minimist 1.2.0 1.2.6 间接依赖 建议修复
ini 1.3.5 1.3.6 间接依赖 建议修复
minimatch 3.0.4 3.0.5 间接依赖 建议修复
js-yaml 3.12.0 3.13.1 间接依赖 建议修复
path-parse 1.0.5 1.0.7 间接依赖 建议修复
acorn 5.7.1 5.7.4 间接依赖 建议修复
node-fetch 1.7.3 2.6.7 直接依赖 可选修复
hosted-git-info 2.6.1 2.8.9 间接依赖 可选修复
ajv 5.5.2 6.12.3 间接依赖 可选修复
semver 5.5.0 7.5.2 间接依赖 可选修复
moment 2.22.2 2.29.4 直接依赖 可选修复

许可证风险

许可证类型 相关组件 许可证风险
MIT 136
Apache-2.0 4
ISC 20
BSD-2-Clause 7
BSD-3-Clause 4
CC0-1.0 1
CC-BY-3.0 2

SBOM清单

组件名称 组件版本 是否直接依赖 仓库
find-up 1.1.2 间接依赖 npm
brace-expansion 1.1.11 间接依赖 npm
is-promise 2.1.0 间接依赖 npm
argparse 1.0.10 间接依赖 npm
validate-npm-package-license 3.0.3 间接依赖 npm
once 1.4.0 间接依赖 npm
callsites 0.2.0 间接依赖 npm
eslint-config-airbnb-base 11.3.2 直接依赖 npm
ini 1.3.5 间接依赖 npm
balanced-match 1.0.0 间接依赖 npm
hosted-git-info 2.6.1 间接依赖 npm
inherits 2.0.3 间接依赖 npm
json-schema-traverse 0.3.1 间接依赖 npm
ajv 5.5.2 间接依赖 npm
normalize-package-data 2.4.0 间接依赖 npm
mimic-fn 1.2.0 间接依赖 npm
colors 1.3.0 间接依赖 npm
wordwrap 1.0.0 间接依赖 npm
which 1.3.1 间接依赖 npm
sprintf-js 1.0.3 间接依赖 npm
eslint-visitor-keys 1.0.0 间接依赖 npm
acorn-jsx 3.0.1 间接依赖 npm
promise-queue 2.2.5 直接依赖 npm
p-limit 1.3.0 间接依赖 npm
arrify 1.0.1 间接依赖 npm
minimatch 3.0.4 间接依赖 npm
is-path-in-cwd 1.0.1 间接依赖 npm
cli-cursor 2.1.0 间接依赖 npm
esquery 1.0.1 间接依赖 npm
contains-path 0.1.0 间接依赖 npm
spdx-compare 0.1.2 间接依赖 npm
util-deprecate 1.0.2 间接依赖 npm
rc 1.2.8 直接依赖 npm
deep-is 0.1.3 间接依赖 npm
table 4.0.2 间接依赖 npm
p-locate 2.0.0 间接依赖 npm
is-path-inside 1.0.1 间接依赖 npm
natural-compare 1.4.0 间接依赖 npm
figures 2.0.0 间接依赖 npm
error-ex 1.3.2 间接依赖 npm
pkg-dir 1.0.0 间接依赖 npm
graceful-fs 4.1.11 间接依赖 npm
type-check 0.3.2 间接依赖 npm
fs.realpath 1.0.0 间接依赖 npm
core-util-is 1.0.2 间接依赖 npm
onetime 2.0.1 间接依赖 npm
ansi-escapes 3.1.0 间接依赖 npm
circular-json 0.3.3 间接依赖 npm
safer-buffer 2.1.2 间接依赖 npm
espree 3.5.4 间接依赖 npm
isexe 2.0.0 间接依赖 npm
resolve-from 1.0.1 间接依赖 npm
eslint-scope 3.7.1 间接依赖 npm
regexpp 1.1.0 间接依赖 npm
ms 2.0.0 间接依赖 npm
acorn 5.7.1 间接依赖 npm
estraverse 4.2.0 间接依赖 npm
optionator 0.8.2 间接依赖 npm
run-async 2.3.0 间接依赖 npm
flat-cache 1.3.0 间接依赖 npm
load-json-file 2.0.0 间接依赖 npm
eslint 4.19.1 直接依赖 npm
esprima 4.0.0 间接依赖 npm
levn 0.3.0 间接依赖 npm
os-tmpdir 1.0.2 间接依赖 npm
commander 2.16.0 直接依赖 npm
chardet 0.4.2 间接依赖 npm
escape-string-regexp 1.0.5 间接依赖 npm
pluralize 7.0.0 间接依赖 npm
rx-lite 4.0.8 间接依赖 npm
has 1.0.3 间接依赖 npm
locate-path 2.0.0 直接依赖 npm
resolve 1.8.1 间接依赖 npm
strip-bom 3.0.0 间接依赖 npm
globals 11.7.0 间接依赖 npm
has-ansi 2.0.0 直接依赖 npm
typedarray 0.0.6 间接依赖 npm
builtin-modules 1.1.1 间接依赖 npm
rimraf 2.6.2 间接依赖 npm
color-name 1.1.1 间接依赖 npm
fast-levenshtein 2.0.6 间接依赖 npm
file-entry-cache 2.0.0 间接依赖 npm
rx-lite-aggregates 4.0.8 间接依赖 npm
path-type 2.0.0 间接依赖 npm
supports-color 5.4.0 间接依赖 npm
text-table 0.2.0 间接依赖 npm
spdx-license-ids 2.0.1 间接依赖 npm
buffer-from 1.1.0 间接依赖 npm
js-tokens 3.0.2 间接依赖 npm
path-parse 1.0.5 间接依赖 npm
string_decoder 1.1.1 间接依赖 npm
cross-spawn 5.1.0 间接依赖 npm
array-union 1.0.2 间接依赖 npm
tmp 0.0.33 间接依赖 npm
chalk 2.4.1 间接依赖 npm
function-bind 1.1.1 间接依赖 npm
path-is-inside 1.0.2 间接依赖 npm
js-yaml 3.12.0 间接依赖 npm
through 2.3.8 间接依赖 npm
pinkie-promise 2.0.1 间接依赖 npm
glob 7.1.2 间接依赖 npm
pify 2.3.0 间接依赖 npm
semver 5.5.0 间接依赖 npm
iconv-lite 0.4.23 间接依赖 npm
object-assign 4.1.1 间接依赖 npm
encoding 0.1.12 间接依赖 npm
spdx-exceptions 2.1.0 间接依赖 npm
lru-cache 4.1.3 间接依赖 npm
wrappy 1.0.2 间接依赖 npm
minimist 1.2.0 间接依赖 npm
pseudomap 1.0.2 间接依赖 npm
strip-json-comments 2.0.1 间接依赖 npm
write 0.2.1 间接依赖 npm
is-builtin-module 1.0.0 间接依赖 npm
inquirer 3.3.0 间接依赖 npm
safe-buffer 5.1.2 间接依赖 npm
require-uncached 1.0.3 间接依赖 npm
slice-ansi 1.0.0 间接依赖 npm
color-convert 1.9.2 间接依赖 npm
eslint-restricted-globals 0.1.1 间接依赖 npm
json-stable-stringify-without-jsonify 1.0.1 间接依赖 npm
del 2.2.2 间接依赖 npm
parse-json 2.2.0 间接依赖 npm
readable-stream 2.3.6 间接依赖 npm
path-exists 2.1.0 间接依赖 npm
deep-extend 0.6.0 间接依赖 npm
ajv-keywords 2.1.1 间接依赖 npm
signal-exit 3.0.2 间接依赖 npm
co 4.6.0 间接依赖 npm
path-is-absolute 1.0.1 间接依赖 npm
spdx-expression-parse 2.0.2 间接依赖 npm
is-stream 1.1.0 间接依赖 npm
concat-map 0.0.1 间接依赖 npm
mkdirp 0.5.1 间接依赖 npm
spdx-correct 2.0.4 间接依赖 npm
caller-path 0.1.0 间接依赖 npm
mute-stream 0.0.7 间接依赖 npm
isarray 1.0.0 间接依赖 npm
cli-width 2.2.0 间接依赖 npm
functional-red-black-tree 1.0.1 间接依赖 npm
strip-ansi 3.0.1 间接依赖 npm
is-path-cwd 1.0.0 间接依赖 npm
eslint-plugin-import 2.13.0 直接依赖 npm
shebang-regex 1.0.0 间接依赖 npm
concat-stream 1.6.2 间接依赖 npm
babel-code-frame 6.26.0 间接依赖 npm
filesize 3.6.1 直接依赖 npm
shebang-command 1.2.0 间接依赖 npm
fast-deep-equal 1.1.0 间接依赖 npm
esutils 2.0.2 间接依赖 npm
ansi-styles 3.2.1 间接依赖 npm
pinkie 2.0.4 间接依赖 npm
globby 5.0.0 间接依赖 npm
spdx-satisfies 0.1.3 直接依赖 npm
read-pkg 2.0.0 间接依赖 npm
spdx-ranges 1.0.1 间接依赖 npm
ansi-regex 2.1.1 间接依赖 npm
esrecurse 4.2.1 间接依赖 npm
eslint-import-resolver-node 0.3.2 间接依赖 npm
yallist 2.1.2 间接依赖 npm
prelude-ls 1.1.2 间接依赖 npm
process-nextick-args 2.0.0 间接依赖 npm
fast-json-stable-stringify 2.0.0 间接依赖 npm
read-pkg-up 2.0.0 间接依赖 npm
moment 2.22.2 直接依赖 npm
inflight 1.0.6 间接依赖 npm
debug 3.1.0 间接依赖 npm
has-flag 3.0.0 间接依赖 npm
restore-cursor 2.0.0 间接依赖 npm
cli-table3 0.5.0 直接依赖 npm
imurmurhash 0.1.4 间接依赖 npm
progress 2.0.0 间接依赖 npm
node-fetch 1.7.3 直接依赖 npm
external-editor 2.2.0 间接依赖 npm
doctrine 2.1.0 间接依赖 npm
ignore 3.3.10 间接依赖 npm
eslint-module-utils 2.2.0 间接依赖 npm
is-resolvable 1.1.0 间接依赖 npm
p-try 1.0.0 间接依赖 npm
(0)
上一篇 2023年10月25日
下一篇 2023年10月25日

相关推荐

  • ddnlink/ddn 软件分析报告

    基础信息 项目名称:ddnlink/ddn 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721127969283444736/1725722931064950784 此报告由Murphysec提供 漏洞列表 漏…

    软件分析 2023年11月18日
    0
  • jaywcjlove/translater.js 软件分析报告

    基础信息 项目名称:jaywcjlove/translater.js 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719013522306367488/1719013522507694080 此报告由Murph…

    软件分析 2023年10月30日
    0
  • coderofsalvation/powscript 软件分析报告

    基础信息 项目名称:coderofsalvation/powscript 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1721098662062395392/1722407804373405696 此报告由Mur…

    软件分析 2023年11月9日
    0
  • kadalu/kadalu 软件分析报告

    基础信息 项目名称:kadalu/kadalu 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1719358875550662656/1719358875877818368 此报告由Murphysec提供 漏洞列表…

    软件分析 2023年10月31日
    0
  • berty/berty 软件分析报告

    基础信息 项目名称:berty/berty 项目徽章: 仓库地址:https://github.com/pterodactyl/panel 检测报告地址:https://www.murphysec.com/console/report/1716303408049995776/1716303413615837184 此报告由Murphysec提供 漏洞列表 漏…

    软件分析 2023年10月23日
    0